Ubuntu

load dvb-usb-dib0700 driver for asus my cinema U3000 mini

Reported by Sergio Cambra on 2007-03-24
28
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
linux (Ubuntu)
Medium
Tim Gardner
Hardy
Undecided
Unassigned
Intrepid
Medium
Tim Gardner
linux-restricted-modules-2.6.20 (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
linux-restricted-modules-2.6.24 (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

Binary package hint: linux-source-2.6.20

I have a dvb device (ASUS My Cinema U3000 Mini) which is not detected. Adding Vendor ID and Product ID to driver and putting the firmware in /lib/firmware/`uname -r` the driver is loaded and the device is working.

Vendor ID: 0b05
Product ID: 171f

Tim Gardner (timg-tpi) on 2007-03-26
Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed

This firmware file is also needed for the following USB dongle (purchased in Paris - FRANCE today for 39.50 EUR TTC):

[ 353.743457] dvb-usb: found a 'Leadtek Winfast DTV Dongle (STK7700P based)' in cold state, will try to load a firmware
[ 353.783236] dvb-usb: downloading firmware from file 'dvb-usb-dib0700-01.fw'

Everything works once dvb-usb-dib0700-01.fw from http://www.omskakas.se/wp-content/uploads/2007/01/linuxtv-firmwaretar.bz2 is put there:

/lib/firmware/2.6.20-15-generic/dvb-usb-dib0700-01.fw

Without it, it doesn''t work (no line "downloading firmware and /dev/dvb not created).

Please consider adding this firmware file.

Baptiste (baptiste2050) wrote :

Adding the firmware doesn't change anything for me. I have the same piece of hardware and it doesn't work.

I did :

sudo modprobe dvb-usb-dib0700

Here is what dmesg shows:

[ 885.524000] usbcore: registered new interface driver dvb_usb_dib0700
[ 1085.536000] usb 2-4: USB disconnect, address 7
[ 1087.544000] usb 2-4: new high speed USB device using ehci_hcd and address 8
[ 1087.680000] usb 2-4: configuration #1 chosen from 1 choice

Here is what lsusb shows :

Bus 002 Device 008: ID 0b05:171f ASUSTek Computer, Inc.

Steve (stephen-rowles) wrote :

Firmware also required for the following devices:

Hauppauge Nova-T stick: http://www.hauppauge.co.uk/pages/products/data_novatstick.html
Hauppauge Nova-T 500: http://www.hauppauge.co.uk/pages/products/data_novat500.html
AVerMedia AVerTV DVB-T Volar
Compro Videomate U500

Info from: http://www.linuxtv.org/wiki/index.php/DVB_USB#DiBcom_USB2.0_DVB-T_devices_.28based_on_the_DiB0700.29

Please consider including this firmware, I wanted to use the liveCD to check out my media centre before upgrading to ubuntu (which I've put on hold for the moment as it runs our TV and I don't want to risk breaking it), frustratingly it detects the card but cannot load the firmware, and of course being a liveCD I don't have write access to allow me to download and save the firmware in the right place to make this work :)

thank you

Baptiste, did you patch the kernel to add vendor ID and product ID to the driver? When you patch the kernel try to load the firmware, and then the DVB device is detected.

Baptiste (baptiste2050) wrote :

Sorry! I didn't patch it. Now it seems to work fine, thanks for all!

I haven't been able to tune channels yet, and with my last searchs in google now I think this device (0b05:171f) has a MT2266 tuner. There is no driver for that tuner in linux and that may be the reason I don't get tuning channels.

Baptiste (baptiste2050) wrote :

The driver should be integrated in gutsy too. I would be great to get the support for ubuntu 7.10.

rookie (ockie-irawan) wrote :

Sorry for the novice question. I had the same USB DVB tuner. I want to know how to execute the tv application in ubuntu. I try to load the device following baptiste comment before . <i>sudo modprobe dvb-usb-dib0700</i>
lsusb shown:

<i>Bus 002 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 0b05:171f ASUSTek Computer, Inc.
Bus 001 Device 003: ID 05e3:0605 Genesys Logic, Inc. USB 2.0 Hub [ednet]
Bus 001 Device 001: ID 0000:0000 </i>

dmesg shown:
<i>[ 316.504000] dib0700: loaded with support for 2 different device-types
[ 316.504000] usbcore: registered new interface driver dvb_usb_dib0700</i>

Please give a direction for me so that i can watch tv over my ubuntu system.

Thanks in advances.

Chase (fletch-techemail) wrote :

Hi,

I'm really lost but that's ok i'll get there.

I've installed v4l on my ubuntu 7.10.

I've put the dib0700-01.fw in the firmware folder.

I don't know how to run the patch nor do i know how to change the PID's which i think might be because i don't actually have a file called "dib0700_devices.c" to patch, could this be right?

If i su and then modprobe dvb-usb-dib0700 i get:
[ 2857.548000] usbcore: registered new interface driver dvb_usb_dib0700

Anyone know what part i'm doing wrong or how to do the part i don't know how to do?

If you help me you'll probably be helping a whole lot of other people too as i can't find anything solid on this anywhere on google.

Thanks to anyone who can help.

Chase.

Baptiste (baptiste2050) wrote :

Well, I have been waiting for a solution on this post for 6 months. It would be pleasant if any mantainer would tell us if it possible or not to use this dvb device on linux.

I get loaded the driver but tunning failed. I modified dib0700_devices.c to point to mt2266 (stk7700d_tuner_attach) tuner without luck...

Dylan Prava (af632) wrote :

Sorry to be asking such a noob question, but I have been unable to figure out how I can copy the firmware file dvb-usb-dib0700-01.fw to the lib/firmware/2.6.20-15-generic folder. I keep getting told that I don't have permission to copy to a root folder? Obviously need to do this so that Ubuntu Feisty will recognise my Winfast DTV Dongle. Would somebody mind taking me through the steps I need to take? Thanks.

nevelis (nevelis) wrote :

Try using sudo:

sudo cp dvd-usb-dib0700-01.fw /lib/firmware/$(uname -r)/

Dylan Prava (af632) wrote :

Thanks, I think I've almost got my head around command line basics now, but I'm still struggling a little. I have the firmware folder (containing dvb-usb-dib0700-01.fw) on my desktop.I've tried the sudo command mentioned but I still can't copy to lib/firmware/2.6.20-15-generic folder. Not sure what I'm doing wrong. Again, I'm really sorry for asking, but I need help! Thanks a million.
P.S. does anyone know whether the new version of Ubuntu about to be released will have a fix for this firmware issue?

ThePar (papeleo) wrote :

 Hello,

 I have the ASUS Cinema U3000. I patched de driver like Sergio Cambra explains. But when I plug the devices don't apear the directory /dev/dvb/
 dmesg tells that the device are detected and firmware are loaded but the directory doesn't appear.
 Then I tried with other firmwares: dvb-usb-dib0700-03-pre1.fw and and dvb-usb-dib0700-1-10.fw with the first the directory appear but the device doesn't work properly.
 Somebody have the same problem, know another firmware that I can try or know a solution?
 Thanks.

Dylan, for copy a file to this directory you need administration rights. If your user don't have administration rights you can not use the command sudo. You need an user with administration rights. Maybe this is your problem.
In Ubuntu, the first user you created should have administration rights.
There are a lot of places explaining it, for example:
http://www.freesoftwaremagazine.com/articles/users_in_ubuntu
http://ubuntuforums.org/showthread.php?t=586398

cheesemp (phil-cheesemp) wrote :

Can I also add a request to get this sorted. Its look like this device is now readily avaible from several companies and it would be nice if it just worked.

Thanks!

Baptiste (baptiste2050) wrote :

The 22/11/2007 asus released linux drivers for the u3000 mini and the u3100 mini tuners. Moreover, they release a DVBT linux player. I don't know if the driver and the software work well, but I will try it. You can download the driver and the software on the asus website.

http://dlsvr01.asus.com/pub/ASUS/vga/tvtuner/EeePC_TVAP_15712.zip (driver)

http://dlsvr01.asus.com/pub/ASUS/vga/tvtuner/EeePC_TVAP_15711.zip (the player)

Baptiste (baptiste2050) wrote :

Asus released the code source of the player and the driver. There me be found here :

http://dlsvr01.asus.com/pub/ASUS/vga/tvtuner/EeePC_TVDrv_Src_11.zip (the driver)
http://dlsvr02.asus.com/pub/ASUS/vga/tvtuner/EeePC_TVAP_Src_15711.zip (the software)

ThePar (papeleo) wrote :

 I can't compile the source code for the driver released by Asus. But I download the last version of v4l from linuxtv.org and changed the code using some lines from the Asus driver. Then I used the firmware from the Asus driver:
http://dlsvr01.asus.com/pub/ASUS/vga/tvtuner/EeePC_TVDrv_12.zip
and I used the player that Asus released. Finally my U3000 mini works with Ubuntu Gutsy.
I attach the changes I made in the linuxtv.org driver.

Baptiste (baptiste2050) wrote :

Sorry. I've written a little howto to install the driver and the firmware (it is in French). To compile the asus driver, yous must make executable all the files of the folder "scripts" (v4ldvbpb-1.1-src -> v4l -> scripts). Then, make all and sudo make install should work.

Here is the howto : http://forum.ubuntu-fr.org/viewtopic.php?pid=1396500

However, the linux player of asus is a bit too simple. Kaffeine seems to be a good alternative since I didn't found a working gtk alternative (vlc and tv-me aren't user-friendly and zapping doesn't work).

ThePar (papeleo) wrote :

Thanks for the help!

Chuck Short (zulcss) wrote :

This patch would be alot better if it was sent to the linux-video folks who can get the patch included upstream.

Thanks
chuck

Changed in linux-source-2.6.20:
assignee: ubuntu-kernel-team → zulcss
Timo Aaltonen (tjaalton) wrote :

Closing for feisty.

Changed in linux-restricted-modules-2.6.20:
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-restricted-modules-2.6.24 - 2.6.24.8-7.18

---------------
linux-restricted-modules-2.6.24 (2.6.24.8-7.18) hardy; urgency=low

  * Update nvidia -> 96.43.05, nvidia-legacy -> 71.86.04.
  * nvidia*: Add the desktop file and png for nvidia-settings.
    (LP: #44897)
  * Added DVB firmware files:
    - dvb-usb-wt220u-fc03.fw (LP: #91415)
    - dvb-usb-wt220u-zl0353-01.fw (LP: #61181)
    - dvb-usb-dib0700-1.10.fw (LP: #179626, #95277)
  * Add atieventsd -initscript to xorg-driver-fglrx. (LP: #58785)

 -- Timo Aaltonen <email address hidden> Fri, 08 Feb 2008 13:42:42 +0200

Changed in linux-restricted-modules-2.6.24:
status: New → Fix Released
Baptiste (baptiste2050) wrote :

The dvb tuner still doesn't work in hardy with the kernel 2.6.24-10-generic

closing 'linux' task as this is against linux-restricted-modules.

Baptiste, do you have the linux-restricted-modules package installed?

Changed in linux:
status: Confirmed → Invalid
Baptiste (baptiste2050) wrote :

Yes, I have installed the linux-restricted-modules maybe I've done something wrong. Well, I should try it with the alpha 6.

manu (manu-linux) wrote :

I also have troubles trying to make this device work on Hardy. With the default kernel the U3000 was not recognized.

I've compiled the source code from linuxtv, downloaded the firmware and now I can see the tuner when I insert it in the usb port:

[ 218.897833] usb 5-6: new high speed USB device using ehci_hcd and address 4
[ 219.030596] usb 5-6: configuration #1 chosen from 1 choice
[ 219.235721] dib0700: loaded with support for 6 different device-types
[ 219.236487] dvb-usb: found a 'ASUS My Cinema U3000 Mini DVBT Tuner' in cold state, will try to load a firmware
[ 219.311805] dvb-usb: downloading firmware from file 'dvb-usb-dib0700-1.10.fw'
[ 219.527187] dib0700: firmware started successfully.
[ 220.027444] dvb-usb: found a 'ASUS My Cinema U3000 Mini DVBT Tuner' in warm state.
[ 220.027522] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 220.028356] DVB: registering new adapter (ASUS My Cinema U3000 Mini DVBT Tuner)
[ 220.288589] DVB: registering frontend 0 (DiBcom 7000PC)...
[ 220.351515] MT2266: successfully identified
[ 220.513095] dvb-usb: ASUS My Cinema U3000 Mini DVBT Tuner successfully initialized and connected.
[ 220.513538] usbcore: registered new interface driver dvb_usb_dib0700

So everything looks "fine", but I've got no /dev/video* so now I'm stuck here...

Baptiste (baptiste2050) wrote :

Yes, it still doesn't work on hardy (kernel 2.6.24-12-generic). When you plug it, ubuntu doesn't recognize it :

lsusb:

Bus 001 Device 005: ID 0b05:171f ASUSTek Computer, Inc.

dmesg :

[ 1378.210758] usb 1-2: new high speed USB device using ehci_hcd and address 6
[ 1378.277308] usb 1-2: configuration #1 chosen from 1 choice

So, what have we to do? The linux restricted modules are installed and everything works fine.

Changed in linux-source-2.6.20:
status: New → Invalid
Changed in linux-restricted-modules-2.6.24:
status: Fix Released → Incomplete
Ahmed EL Zein (zein) wrote :

I have the same problem.

I just installed fresh copy of 8.04 alpha 6, did an upgrade and installed linux-restricted-modules.
All I get from dmesg is:
[ 95.968462] usb 5-3: new high speed USB device using ehci_hcd and address 2
[ 96.006529] usb 5-3: configuration #1 chosen from 1 choice

lsusb:
Bus 005 Device 002: ID 0b05:171f ASUSTek Computer, Inc.

uname -r:
2.6.24-12-generic

Re-openning linux task to include missing vendor and device id's. Thanks.

Changed in linux:
assignee: zulcss → ubuntu-kernel-team
importance: Wishlist → Medium
status: Invalid → Triaged

Tried with linux-image-2.6.24-16-generic, did not find device, asus ids not in source with i look in source package
Installed v4l mercurial repos as of today, device is found and works great.

Device ids seams to be in linus tree now:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=132c3188433bcb149ee764be1ca9a69f6d719dfe

Tim Gardner (timg-tpi) wrote :

SRU Justification:

Impact: Several ASUS My Cinema U3000 Mini DVBT Tuners are not supported

Fix Description: Add device ID and quirk support for these devices. Affects only these devices.

Patch: http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-hardy.git;a=commit;h=075b1ce5586cbb9526e9bb04468925109bc00673

TEST CASE: These USB devices are not detected.

Tim Gardner (timg-tpi) wrote :
Changed in linux:
assignee: ubuntu-kernel-team → timg-tpi
milestone: none → ubuntu-8.04.1
status: Triaged → Fix Committed
kibbl (ryan-ryanheise) wrote :

Hi Tim - Does the above post mean it's now fixed? And if so, how can I try it?

Martin Pitt (pitti) on 2008-06-04
Changed in linux-restricted-modules-2.6.20:
status: New → Invalid
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in linux:
status: New → Fix Committed
Changed in linux-restricted-modules-2.6.24:
status: New → Fix Committed
Steve Langasek (vorlon) on 2008-06-05
Changed in linux:
milestone: ubuntu-8.04.1 → none
Martin Pitt (pitti) wrote :

Copied to hardy-updates. The new kernel was tested extensively by many people, who reported back in other bug reports. Due to lack of feedback, this particular bug was not confirmed to be tested, though. Please report back here if the bug still occurs for you with the new kernel packages, then we will reopen this bug.

Changed in linux:
status: Fix Committed → Fix Released
Changed in linux-restricted-modules-2.6.24:
status: Fix Committed → Fix Released
tenguzori (tenguzori) wrote :

Guys no expert on this stuff, but the following may help a few.

- driver included with Hardy does not work even if you have the correct firmware.
- downloading driver from ASUS did not work (for me) as it is compiled for x86 not amd.

following is a French site detailing how to patch the v4l driver - also note the u3000-mini.sh script which does the work for you.

http://forum.hardware.fr/hfr/OSAlternatifs/Hardware-2/cinema-u3000-debian-sujet_66769_1.htm

It worked for me, I now have a U3100 tuner working under hardy and with mythtv - able to pickup channels

larry (larry1chan) wrote :

hi
i have a ASUS My Cinema-U3100Mini/DMB-TH, the device id is 0x1721, which is different from the value USB_PID_ASUS_U3100 as defined in dvb-usb-ids.h, i changed the value, recompile, and install. the stick can now be recognized but i received the following error:

[ 5405.409957] usb 5-6: new high speed USB device using ehci_hcd and address 14
[ 5405.542324] usb 5-6: configuration #1 chosen from 1 choice
[ 5410.538662] dvb-usb: found a 'ASUS My Cinema U3100 Mini DVBT Tuner' in cold state, will try to load a firmware
[ 5410.540180] dvb-usb: downloading firmware from file 'dvb-usb-dib0700-1.10.fw'
[ 5410.540184] dib0700: firmware download failed at 7 with -22

i m using the firmware dvb-usb-dib0700-1.10.fw

asus releases a firmware which could be downloaded here: http://dlcdnet.asus.com/pub/ASUS/vga/tvtuner/asus-dmbth-20080528_tar.zip

please help.

Martin,

Thanks for your ongoing support and assistance. Greatly appreciated.

Regards,

Dylan.

----- Original Message ----
From: Martin Pitt <email address hidden>
To: <email address hidden>
Sent: Thursday, 5 June, 2008 12:57:44 AM
Subject: [Bug 95277] Re: load dvb-usb-dib0700 driver for asus my cinema U3000 mini

Accepted into -proposed, please test and give feedback here

** Changed in: linux (Ubuntu Hardy)
       Status: New => Fix Committed

** Changed in: linux-restricted-modules-2.6.24 (Ubuntu Hardy)
       Status: New => Fix Committed

--
load dvb-usb-dib0700 driver for asus my cinema U3000 mini
https://bugs.launchpad.net/bugs/95277
You received this bug notification because you are a direct subscriber
of the bug.

      Win a MacBook Air or iPod touch with Yahoo!7. http://au.docs.yahoo.com/homepageset

This is "Fix Released" for Intrepid. For those who are still experiencing issues or require slightly different fixes than what was needed here it would be better to open a new bug report. Thanks.

Changed in linux:
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

marking invalid for 'linux-restricted-modules-2.6.24' in intrepid, as this package no longer exists. If this is still an issue for lrm in intrepid, please open a task for the linux-restricted-modules package - but judging by Leann's last comment, it sounds like this is already resolved.

Changed in linux-restricted-modules-2.6.24:
status: Incomplete → Invalid
Steven Yu (yueh) wrote :

Hi All

I have a similar problem with my build in tv tuner on my Asus M51Sn laptop.

  idVendor 0x1164 YUAN High-Tech Development Co., Ltd
  idProduct 0x1f08
  bcdDevice 1.00
  iManufacturer 1 YUANRD
  iProduct 2 STK7700D
  iSerial 3 0000000001

The STK7700D use the dib0700 firmware, however I can't find /dev/dvb in my system, and no dmesg regarding to the dvb device at all.

By manual loading the dib0700 firmware via modprobe, I get the following message

dmesg
[ 117.476200] dib0700: loaded with support for 7 different device-types
[ 117.476296] usbcore: registered new interface driver dvb_usb_dib0700

$lsmod | grep dvb
dvb_usb_dib0700 37128 0
dib7000p 25224 1 dvb_usb_dib0700
dib7000m 23940 1 dvb_usb_dib0700
dvb_usb 24588 1 dvb_usb_dib0700
dvb_core 86016 1 dvb_usb
dib3000mc 20616 1 dvb_usb_dib0700
dib0070 15876 1 dvb_usb_dib0700
i2c_core 31892 8 dvb_usb_dib0700,dib7000p,dib7000m,dvb_usb,dib3000mc,dibx000_common,dib0070,nvidia
usbcore 149360 7 dvb_usb_dib0700,dvb_usb,uvcvideo,btusb,ehci_hcd,uhci_hcd

But still no /dev/dvb??? What is going on?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers