package linux-image-3.2.0-17-generic 3.2.0-17.27 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 2

Bug #946100 reported by Mike Kupfer on 2012-03-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Upgrading from 11.10 to 12.04 Beta 1, I got a pop-up saying

  Could not install 'linux-image-3.2.0-17-generic'

  subprocess installed post-installation script returned error exit status 2

I was unable to retrieve any additional information from the log window.

This was in a 32-bit VirtualBox VM, running on an amd64 host (also running 11.10).

I looked in /boot/grub, and it looked like the new kernel was registered with grub, so I chanced a restart. Booting the new kernel gave me a blank screen. After waiting a bit, I shut down the VM and booted the 3.0.0-16 kernel from Oneiric, which is what's being used to submit this bug report.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-17-generic 3.2.0-17.27
ProcVersionSignature: Ubuntu 3.0.0-16.28-generic 3.0.17
Uname: Linux 3.0.0-16-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: I82801AAICH [Intel 82801AA-ICH], device 0: Intel ICH [Intel 82801AA-ICH]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.94-0ubuntu1
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: kupfer 1727 F.... pulseaudio
                      kupfer 1730 F.... xfce4-volumed
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'I82801AAICH'/'Intel 82801AA-ICH with STAC9700,83,84 at irq 5'
   Mixer name : 'SigmaTel STAC9700,83,84'
   Components : 'AC97a:83847600'
   Controls : 34
   Simple ctrls : 24
CurrentDmesg:
 [ 22.067035] ip_tables: (C) 2000-2006 Netfilter Core Team
 [ 22.638603] init: plymouth-upstart-bridge main process (775) killed by TERM signal
 [ 23.636998] init: plymouth-stop pre-start process (1250) terminated with status 1
 [ 28.088035] eth0: no IPv6 routers present
Date: Sat Mar 3 21:12:03 2012
ErrorMessage: ErrorMessage: subprocess installed post-installation script returned error exit status 2
HibernationDevice: RESUME=UUID=68b07294-e7c0-47f1-8fd7-2d47dd3e49fc
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: innotek GmbH VirtualBox
ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-16-generic root=UUID=3420f158-e7e9-44b8-b33e-6580a5fe33a1 ro quiet splash vt.handoff=7
PulseSinks: Error: command ['pacmd', 'list-sinks'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
PulseSources: Error: command ['pacmd', 'list-sources'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions: grub-pc 1.99-14ubuntu2
RfKill:

SourcePackage: linux
Title: package linux-image-3.2.0-17-generic 3.2.0-17.27 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 2
UpgradeStatus: Upgraded to precise on 2012-03-04 (0 days ago)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH

Mike Kupfer (mkupfer37) wrote :
Brad Figg (brad-figg) on 2012-03-04
Changed in linux (Ubuntu):
status: New → Confirmed
Mike Kupfer (mkupfer37) wrote :
Download full text (3.5 KiB)

Trying to reinstall linux-image-3.2.0-17-generic with Synaptic fails.

I get a pop-up with

E: linux-image-3.2.0-17-generic: subprocess installed post-installation script returned error exit status 2
E: linux-image-generic: dependency problems - leaving unconfigured
E: linux-generic: dependency problems - leaving unconfigured

Here's the log:

(Reading database ... 253074 files and directories currently installed.)
Removing xubuntu-desktop ...
Removing update-notifier ...
Removing update-manager ...
Processing triggers for gconf2 ...
Processing triggers for libglib2.0-0 ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for man-db ...
debconf: unable to initialize frontend: Gnome
debconf: (Unable to load Gtk -- is libgtk2-perl installed?)
debconf: falling back to frontend: Dialog
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Setting up linux-image-3.2.0-17-generic (3.2.0-17.27) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
cp: cannot stat `/boot/initrd.img-3.2.0-17-generic': No such file or directory
Failed to copy /boot/initrd.img-3.2.0-17-generic to /initrd.img .
dpkg: error processing linux-image-3.2.0-17-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of linux-image-generic:
 linux-image-generic depends on linux-image-3.2.0-17-generic; however:
  Package linux-image-3.2.0-17-generic is not configured yet.
dpkg: error processing linux-image-generic (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of linux-generic:
 linux-generic depends on linux-image-generic (= 3.2.0.17.17); however:
  Package linux-image-generic is not configured yet.
dpkg: error processing linux-generic (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 linux-image-3.2.0-17-generic
 linux-image-generic
 linux-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up linux-image-3.2.0-17-generic (3.2.0-17.27) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
cp: cannot stat `/boot/initrd.img-3.2.0-17-generic': No such file or directory
Failed to copy /boot/initrd.img-3.2.0-17-generic to /initrd.img .
dpkg: error processing linux-image-3.2.0-17-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-image-generic:
 linux-image-generic depends on linux-image-3.2.0-17-generic; however:
  Package linux-image-3.2.0-17-generic is not configured yet.
dpkg: error processing linux-image-generic (--configure):
 depen...

Read more...

ray (arkibott) wrote :

is there a newer kernel version available already?

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-18.28
Joseph Salisbury (jsalisbury) wrote :

You may need to run the following:

sudo apt-get install -f
sudo apt-get clean
sudo apt-get update

Then re-install the package.

If that does not resolve your issue, please mark the bug as "Confirmed"

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Mike Kupfer (mkupfer37) wrote :

Unable to reinstall the -17 kernel, as it has been replaced by the -18 kernel.

Unable to upgrade to the -18 kernel, because "apt-get upgrade" bails out because of 946113.

Now apt-get and Synaptic both bail out with "E: Internal Error, No file name for libselinux1". I don't see how to proceed here.

Joseph Salisbury (jsalisbury) wrote :

@Mike

Did you first try running the following from a terminal window:

sudo apt-get install -f
sudo apt-get clean
sudo apt-get update

Mike Kupfer (mkupfer37) wrote :

@Joseph

I did. IIRC, the "apt-get install -f" failed (see 946113), the "apt-get clean" finished okay, and the "apt-get update" failed partway through with complaints that it couldn't download files that it needed. I may have a typescript file saved in the VM, if you'd like details. At this point I started getting errors about / being read-only, so I rebooted and redid the "apt-get update", which succeeded. I then tried the reinstall, which failed, as described in comment #6.

In hindsight, I think I should have uninstalled update-manager and update-manager-core after the failure of "apt-get install -f", and then retried the "install -f", but I didn't think of that until much later.

Mike Kupfer (mkupfer37) wrote :

By the way, I suspect that this VM is sufficiently hosed that I'm not concerned about trying to recover from the current problems. If there's value to Ubuntu in doing further troubleshooting, I'm happy to help with that. Otherwise, I'm willing to revert to my last 11.10 snapshot and redo the upgrade when I get some time.

Mike Kupfer (mkupfer37) wrote :

Okay, I took another stab at doing an upgrade in my VM. It still fails in the same was as before.

I've attached 2 logs.

reinstall-20120311.log has the results from the steps listed in comment #5.

configure-20120311.log has some debugging output from "dpkg --configure". The first set of output is from

  /usr/bin/sudo dpkg --configure --debug=2 linux-image-3.2.0-18-generic

The second set of output is from the same command, but after I hacked the postinstall script (set $DEBUG=1).

Changed in linux (Ubuntu):
status: Invalid → Confirmed
Mike Kupfer (mkupfer37) wrote :
Mike Kupfer (mkupfer37) wrote :

In comment #10, that should have been "same way as before".

I don't understand kernel packaging/installation, but Googling suggests the following is useful information:

ubuntu-vb$ df -h /
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 15G 5.3G 8.8G 38% /
ubuntu-vb$ df -h /boot
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 15G 5.3G 8.8G 38% /

Ah. Google also suggested

$ sudo update-initramfs -k 3.2.0-18-generic -c -v

and that fixed things.

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-18.29
Mike Kupfer (mkupfer37) on 2012-03-12
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → Incomplete
Mike Kupfer (mkupfer37) wrote :

While updating to the latest bits (including a kernel update from 3.2.0-18.28 to 3.2.0-18.29), I noticed the following messages. Could the vboxguest problem be related to the failure to generate the initrd.img file on the upgrade from 11.10?

Setting up linux-image-3.2.0-18-generic (3.2.0-18.29) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Not updating initrd symbolic links since we are being updated/reinstalled
(3.2.0-18.28 was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled
(3.2.0-18.28 was configured last, according to dpkg)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 3.2.0-18-generic /boot/vmlinuz-3.2.0-18-generic
ERROR (dkms apport): binary package for vboxguest: 4.1.2 not found
Error! Bad return status for module build on kernel: 3.2.0-18-generic (i686)
Consult /var/lib/dkms/vboxguest/4.1.2/build/make.log for more information.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-18-generic /boot/vmlinuz-3.2.0-18-generic
update-initramfs: Generating /boot/initrd.img-3.2.0-18-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.2.0-18-generic /boot/vmlinuz-3.2.0-18-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.2.0-18-generic /boot/vmlinuz-3.2.0-18-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.2.0-18-generic /boot/vmlinuz-3.2.0-18-generic
Generating grub.cfg ...
[...]
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.2.0-18-generic /boot/vmlinuz-3.2.0-18-generic
ERROR (dkms apport): binary package for vboxguest: 4.1.2 not found
Error! Bad return status for module build on kernel: 3.2.0-18-generic (i686)
Consult /var/lib/dkms/vboxguest/4.1.2/build/make.log for more information.

Mike Kupfer (mkupfer37) wrote :

To clarify my question in comment #14, I'm wondering if there was problem with vboxguest that was hidden in the original upgrade logs, and whether as a result update-initramfs was not executed.

Mike Kupfer (mkupfer37) wrote :

Still a problem with the -18.29 kernel.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
Mike Kupfer (mkupfer37) wrote :

I uninstalled the VirtualBox Guest Additions using /opt/VBoxGuestAdditions-4.1.2/uninstall.sh and then attempted an upgrade. Alas, the problem is still present (3.2.0-19 kernel).

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-19.30
Mike Kupfer (mkupfer37) on 2012-03-18
tags: added: bot-stop-nagging
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.