Ubuntu

PC display will not turn on with Llano APUs connected to the VGA port

Reported by Robert Roth on 2012-02-29
78
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

The PC has a Llano A6-3650 APU with a display connected to the VGA port, but the display turns off when plymouth should appear, thus making installation from liveCD/USB impossible. Ubuntu starts up, as I can hear the login sound, but nothing is visible.

Filed separately, as requested in bug #825777, as this one is about a PC, and the other one is about laptops.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-16-generic-pae 3.0.0-16.28
ProcVersionSignature: Ubuntu 3.0.0-16.28-generic-pae 3.0.17
Uname: Linux 3.0.0-16-generic-pae i686
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: evfool 1592 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Generic'/'HD-Audio Generic at 0xfe01c000 irq 52'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card1.Amixer.info:
 Card hw:1 'Generic_1'/'HD-Audio Generic at 0xfe020000 irq 16'
   Mixer name : 'Realtek ALC889'
   Components : 'HDA:10ec0889,1458a132,00100004'
   Controls : 37
   Simple ctrls : 22
CheckboxSubmission: 589b7562703a9b18f8c7bdabc7186c59
CheckboxSystem: 4ed15c40009aa6f7770f606350a390a2
Date: Wed Feb 29 15:48:11 2012
HibernationDevice: RESUME=UUID=1b7f7f1a-53b1-4d7a-95df-6862c754e92e
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: Gigabyte Technology Co., Ltd. GA-A75M-UD2H
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-16-generic-pae root=UUID=9cafb3fa-9832-4949-bf09-039fbc4a9df6 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-16-generic-pae N/A
 linux-backports-modules-3.0.0-16-generic-pae N/A
 linux-firmware 1.60
RfKill:

SourcePackage: linux
UpgradeStatus: Upgraded to oneiric on 2011-11-21 (100 days ago)
WifiSyslog:

dmi.bios.date: 11/03/2011
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F5
dmi.board.name: GA-A75M-UD2H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF5:bd11/03/2011:svnGigabyteTechnologyCo.,Ltd.:pnGA-A75M-UD2H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-A75M-UD2H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-A75M-UD2H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Created attachment 53026
dmesg log of radeon errors

I have an ASRock A75M motherboard with an A8-3850.

Booting a 3.1 kernel (also tried 3.06), my screen goes blank with modesetting enabled. If I disable modesetting, I am able to boot fine but then X won't work because the X11 driver requires modesetting.

Created attachment 53027
vga bios

Download full text (4.9 KiB)

Nov 01 12:06:55 [kernel] [ 1.445489] [drm] Initialized drm 1.1.0 20060810
Nov 01 12:06:55 [kernel] [ 1.445828] [drm] radeon defaulting to kernel modesetting.
Nov 01 12:06:55 [kernel] [ 1.445934] [drm] radeon kernel modesetting enabled.
Nov 01 12:06:55 [kernel] [ 1.446077] radeon 0000:00:01.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
Nov 01 12:06:55 [kernel] [ 1.446675] [drm] initializing kernel modesetting (SUMO 0x1002:0x9640 0x1849:0x9640).
Nov 01 12:06:55 [kernel] [ 1.446922] [drm] register mmio base: 0xFEF00000
Nov 01 12:06:55 [kernel] [ 1.447024] [drm] register mmio size: 262144
Nov 01 12:06:55 [kernel] [ 1.447234] ATOM BIOS: General
Nov 01 12:06:55 [kernel] [ 1.447361] radeon 0000:00:01.0: VRAM: 256M 0x0000000000000000 - 0x000000000FFFFFFF (256M used)
Nov 01 12:06:55 [kernel] [ 1.447538] radeon 0000:00:01.0: GTT: 512M 0x0000000010000000 - 0x000000002FFFFFFF
Nov 01 12:06:55 [kernel] [ 1.447719] mtrr: type mismatch for c0000000,10000000 old: write-back new: write-combining
Nov 01 12:06:55 [kernel] [ 1.447886] [drm] Detected VRAM RAM=256M, BAR=256M
Nov 01 12:06:55 [kernel] [ 1.447974] [drm] RAM width 32bits DDR
Nov 01 12:06:55 [kernel] [ 1.448195] [TTM] Zone kernel: Available graphics memory: 3950106 kiB.
Nov 01 12:06:55 [kernel] [ 1.448289] [TTM] Zone dma32: Available graphics memory: 2097152 kiB.
Nov 01 12:06:55 [kernel] [ 1.448379] [TTM] Initializing pool allocator.
Nov 01 12:06:55 [kernel] [ 1.448493] [drm] radeon: 256M of VRAM memory ready
Nov 01 12:06:55 [kernel] [ 1.448584] [drm] radeon: 512M of GTT memory ready.
Nov 01 12:06:55 [kernel] [ 1.448685] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
Nov 01 12:06:55 [kernel] [ 1.448775] [drm] Driver supports precise vblank timestamp query.
Nov 01 12:06:55 [kernel] [ 1.448897] radeon 0000:00:01.0: radeon: using MSI.
Nov 01 12:06:55 [kernel] [ 1.449013] [drm] radeon: irq initialized.
Nov 01 12:06:55 [kernel] [ 1.449104] [drm] GART: num cpu pages 131072, num gpu pages 131072
Nov 01 12:06:55 [kernel] [ 1.450154] [drm] Loading SUMO Microcode
Nov 01 12:06:55 [kernel] [ 1.458789] radeon 0000:00:01.0: WB enabled
Nov 01 12:06:55 [kernel] [ 1.474954] [drm] ring test succeeded in 2 usecs
Nov 01 12:06:55 [kernel] [ 1.475122] [drm] radeon: ib pool ready.
Nov 01 12:06:55 [kernel] [ 1.475276] [drm] ib test succeeded in 0 usecs
Nov 01 12:06:55 [kernel] [ 1.477539] [drm] Radeon Display Connectors
Nov 01 12:06:55 [kernel] [ 1.477645] [drm] Connector 0:
Nov 01 12:06:55 [kernel] [ 1.477746] [drm] HDMI-A
Nov 01 12:06:55 [kernel] [ 1.477846] [drm] HPD2
Nov 01 12:06:55 [kernel] [ 1.477947] [drm] DDC: 0x6440 0x6440 0x6444 0x6444 0x6448 0x6448 0x644c 0x644c
Nov 01 12:06:55 [kernel] [ 1.478122] [drm] Encoders:
Nov 01 12:06:55 [kernel] [ 1.478223] [drm] DFP1: INTERNAL_UNIPHY2
Nov 01 12:06:55 [kernel] [ 1.478325] [drm] Connector 1:
Nov 01 12:06:55 [kernel] [ 1.478426] [drm] VGA
Nov 01 12:06:55 [kernel] [ 1.478525] [drm] HPD1
Nov 01 12:06:55 [kernel] [ 1.478626] [drm] DDC: 0x6430 0x6430 0x6434 0x6434 0x6438 0x6438 0x643c 0x643c
Nov 01 12:06:55 [kernel] [ 1.478779]...

Read more...

Please attach your xorg log. Which connector(s) are you using?

The problem is happening right at boot. With DRM_RADEON_KMS enabled in my kernel config, the screen goes black immediately after exiting the bootloader. The machines is not wedged because <ctrl-alt-delete> still works.

If recompile with DRM_RADEON_KMS=n, the screen goes black (for longer than I'm used to) but then I see the kernel printks and then a login prompt. When I try to run X with xf86-video-ati I get an error message telling me that SUMO requires KMS. So I'm currently working around by running with the VESA X drivers.

This is a brand new machine which I just brought up yesterday. Windows seems to work fine so I don't think its a hardware issue.

The motherboard comes with a VGA and an HDMI connector. I'm currently using the VGA connector.

I probably should have assigned this to Product:DRI instead Product:xorg since the problem I'm seeing is in the kernel driver and not in the xorg driver.

The DP to VGA bridge chips on a llano APUs are problematic in a lot of cases. You might try a newer kernel or use a digital port (HDMI, DP, DVI) in the meantime.

I've tried 3.0.6, 3.1 and the drm-core-next branch from: git://people.freedesktop.org/~airlied/linux

Is there a radeon linux kernel tree I could test? I'm also happy to test any patches against any tree.

I've ordered an HDMI-DVI cable so I'll give that a shot in a few days.

(In reply to comment #7)
> I've tried 3.0.6, 3.1 and the drm-core-next branch from:
> git://people.freedesktop.org/~airlied/linux
>
> Is there a radeon linux kernel tree I could test? I'm also happy to test any
> patches against any tree.

You can try drm-fixes-staging, but I doubt you'll see any change. I'll be sure to update this bug as I make progress with the NUTMEG chip.

Tested with drm-fixes-staging. Same behavior.

Woot! HDMI works fine.

Robert Roth (evfool) wrote :
Brad Figg (brad-figg) on 2012-02-29
Changed in linux (Ubuntu):
status: New → Confirmed
A8-3800 (a8-3800) wrote :

I tested the daily build of Ubuntu 12.04 for AMD64 from 2012-03-02 and Ubuntu 12.04 for AMD64 beta 1 with an A8-3800 and a MSI-Mainboard. It doesn't work. When the Display is connected on the VGA-Port the display will not turn on. When both ports (VGA and HDMI) connected , the display on the VGA-Port will not turn on, the display on the HDMI-Port will turn on.

summary: - PC display will not turn on in Oneiric with Llano APUs connected to the
- VGA port
+ PC display will not turn on with Llano APUs connected to the VGA port
Anthony Wong (anthonywong) wrote :

Can you help us to test the latest mainline kernel to verify whether it's already fixed in upstream? You can do that by following these steps:

1. Install 12.04 daily build or beta
2. Download the latest mainline kernel packages from http://kernel.ubuntu.com/~kernel-ppa/mainline/, by the time of this writing, the latest is v3.3-rc6 (http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc6-precise/), remember to choose the correct kernel flavour (i386, i386-pae or amd64)
3. Install them by running 'sudo dpkg -i <downloaded packages>'
4. Reboot and test VGA output

Thanks!

Anthony Wong (anthonywong) wrote :

It may also help to enable drm debug messages before testing the kernel:

Run 'sudo xdiagnose', then tick the first checkbox, apply, wait for grub to rebuild, then reboot the machine, reproduce the issue, and collect /var/log/dmesg.

Robert Roth (evfool) wrote :

@Anthony Wong: can't help with that, as it fails at step 1.: can not install 12.04 as the screen turns off after GRUB.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Jesse Sung (wenchien) wrote :

Robert,

Does booting with "nomodeset" help?

Robert Roth (evfool) wrote :

I haven't tried with recent daily builds, but when I have tried with Oneiric final, it did not help.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

A8-3800 (a8-3800) wrote :

Results of test with ubuntu 12.04 beta1 and kernel-image 3.3.0-030300rc6-generic #201203032235:
- using VGA-port only: Display stay blank
- using two displays; one with HDMI-port , one with VGA-Port: Display connected to HDMI works fine, Display connected on VGA-Port stay blank
No change with kernel v3.3-rc6

A8-3800 (a8-3800) wrote :

new try with activated xdiagnose from comment #4. The test ist with two monitors, one on VGA-Port, and one on HDMI-Port. The monitor on VGA-Port stay black (goes into the powersave-mode). dmesg-file see attachment.

*** Bug 47064 has been marked as a duplicate of this bug. ***

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
A8-3800 (a8-3800) wrote :

The same results with kernel-image 3.3.0-030300rc7-generic (effects like comment #8 and #9). see dmesg-file attached. At the end of the file are some more errors. maybe interesting.

Tomas Cassidy (tomas-cassidy) wrote :

I've got the same problem. Running A8-3850 APU on an ASRock A75M-HVS. Tested with the mainline kernel 3.3-rc7. The HDMI port works fine. The VGA port fails to work unless I boot with "nomodeset". I'm running this with Ubuntu Server 11.10, so there is no Xorg installed.

tags: added: amd64 precise
peterzay (peterzay) wrote :

Duplicate Bug #959890 testing has shown that Ubuntu 11.04 Natty Narwhal AMD64 does NOT have this bug.

Changed in linux (Ubuntu):
importance: Undecided → Medium
peterzay (peterzay) wrote :

The boot success with liveCD Ubuntu 11.04 Natty Narwhal AMD64 gave a gnome 2 classic desktop.

Given the processing power, I would have expected booting into Unity.

That power is: The APU is AMD A6-3600 CPU combined with AMD Radeon HD 6530D GPU.

Same problem with Asus F1A75-M and A8-3870, running stock Oneiric amd64:
monitor went blank almost immediately after boot.
I don't have non-VGA monitor on site so don't know if DVI/HDMI would work.

But disabling modeset like this made text console work:
echo options radeon modeset=0 > /etc/modprobe.d/radeon-kms.conf
(No need for X there at present, so this is sufficient workaround for now.)

Seeing this here on an Acer Aspire am3470g-uw10p with Radeon HD 6530D. The vga output dies as soon as radeon with KMS is loaded. In process of acquiring HDMI cable to test with HDMI output.

I have tried with 3.3.1 and 3.3.2 and same problem. Using xorg 1.12.1, xf86-video-ati 6.14.4, ati-dri/mesa 8.0.2 on brand new Arch Linux. Also tried Ubuntu 11.10 Live CD and same results.

Adding vga=775 radeon.modeset=0 to kernel boot line gives me a usable console interface and Xorg will actually start that way, but Xorg display is highly corrupted with bands of bright green and red lines.

Ubuntu 12.04 beta 2 gives same result except that it can successfully start a non-corrupted (but incorrect resolution) Xorg server with the kernel boot line above.

I have an identical snippet in my dmesg as the one posted by Mandeep Baines above.

This bug is marked fixed for Ubuntu in Launchpad ( https://bugs.launchpad.net/ubuntu/+source/linux/+bug/825777 ) but it doesn't work with a fully up-to-date Arch Linux. I haven't had occasion to try the specific Ubuntu kernel build (3.0.0-17.30) cited as resolving the problem (and it seems to be based on one positive result) and I don't seem to see a patch that would be applicable to a mainline kernel.

lspci:
VGA compatible controller: Advanced Micro Devices [AMD] nee ATI BeaverCreek [Radeon HD 6530D]

So it turns out the monitor didn't have an HDMI input.

The only way I could get it working without an HDMI-DVI cable was to downgrade to Xorg 1.11 and install Catalyst. I'm looking forward to the arrival of an HDMI-capable monitor at that station so I can test the open-source driver more thoroughly (get some quite annoying crashes with Catalyst).

kompir (eorg) wrote :

Just wanted you to know that i tried Xubuntu 12.04 daily AMD64 from 2012-04-16 on Asus F1A55-M LE motherboard and my VGA connected monitor still went to power save after booting from flash drive. Unfortunately i can't test the HDMI workaround as i don't have HDMI cable and monitor here.

Created attachment 60707
possible fix

This patch fixes things for me.

Doesn't change anything for me.
I tried patching a kernel 3.3.2 and a 3.4.0_rc4 ... should I try with a next-drm or drm-fixes-staging ?

This does not fix the problem for me, either...

Created attachment 60730
dmesg with proposed patch and drm.debug=4

(In reply to comment #16)
> This does not fix the problem for me, either...

(In reply to comment #17)
> Created attachment 60730 [details]
> dmesg with proposed patch and drm.debug=4

Your system doesn't use a NUTMEG chip. It uses TRAVIS for both VGA and LVDS. Please attach a copy of your vbios:

(as root)
(use lspci to get the bus id)
cd /sys/bus/pci/devices/<pci bus id>
echo 1 > rom
cat rom > /tmp/vbios.rom
echo 0 > rom

Created attachment 60758
dmesg with proposed patch and drm.debug=4

Mine is and the patch doesn't correct the problem.

(please ignore the nouveau stuff this is because I want a dual screen so I put a second card in the machine if not for this problem with the VGA I wouldn't have it)

At least here, I now can boot, however I can't get through a dpms as link training fails.

so one step forward.

Created attachment 60760
vbios

(In reply to comment #19)
> Created attachment 60758 [details]
> dmesg with proposed patch and drm.debug=4
>
> Mine is and the patch doesn't correct the problem.

Does it work if you boot without VGA attached and then enable it later? How about if you disable VGA with xrandr and then re-enable it? E.g.:
xrandr --output VGA-0 --off
xrandr --output VGA-0 --auto

Created attachment 60765
possible fix

Please try this patch in addition to the one in attachment 60707.

Created attachment 60773
dmesg with second patch and drm.debug=4

without the second patch doing

xrandr --output VGA-0 --off
xrandr --output VGA-0 --auto

logs errors in dmesg

[drm:radeon_dp_link_train_cr] *ERROR* clock recovery reached max voltage
[drm:radeon_dp_link_train_cr] *ERROR* clock recovery failed

---

with the second patch I have exactly the same error...

Created attachment 60774
dmesg booting with monitor unplugged and letting X enabling it (2nd patch applied)

oh sorry the previous log was with monitor connected since boot... with the patch and booting with the monitor unplugged and then plugging it and letting X enable it, it works !

Oh fun. Seeing how the driver seems to mess up things (with your previous comment) with the connectors when booting with both plugged, I tried to boot without the nvidia card and both monitors plugged and the unplugging the VGA monitor during the boot (before X starts) and both screens when off, the VGA one with "no connection" and the DVI with "no signal".

Once X is started both monitors are detected correctly.

Is it somehow linked to the mirror mode the EFI does ?

Well at least I have a hook to get my dual screen working. Just unplug the VGA boot and plug it during boot.

A patch referencing this bug report has been merged in Linux v3.4-rc5:

commit 700698e7c303f5095107c62a81872c2c3dad1702
Author: Alex Deucher <email address hidden>
Date: Fri Apr 27 17:18:59 2012 -0400

    drm/radeon/kms: need to set up ss on DP bridges as well

madbiologist (me-again) wrote :

There is a fix in the upstream kernel 3.4-rc5 which references the freedesktop bug linked to this bug report. This fix has also been cc'd to stable.

A PPA of kernel 3.4-rc5 is available at http://kernel.ubuntu.com/~kernel-ppa/mainline/

Changed in linux (Ubuntu):
status: Confirmed → Triaged
A8-3800 (a8-3800) wrote :

I tried the new Ubuntu 12.04 LTS with kernel 3.4-rc5 with different monitor-configurations. When only a VGA connected monitor is used, everything works fine. The monitor doesn't go to power save after booting. This kernel seems to solve the problem of this bugreport.

But when I connect two monitors, one on the HDMI- and one on the VGA-Interface at boottime only the monitor connected to HDMI works. I can't activate the monitor on VGA-interface. The monitor an VGA-monitor stays in power save.

Then I tried an other idea: When I connect the monitor on the VGA-interface at boottime the monitor works correct like descripted above, and afterwards I connect the second monitor with the HDMI-interface, both monitors works fine and show the same content (mirrored screens). Then I want to expand the display to both monitors (two independent screens). A strange effect appears: Depending on the Screen for the starter-band, the mouse can only move on one of the monitors. I can move windows from one monitor to the other monitor, but I can't get them back, because of the limitation of the mousepointer. That's amazing.

I appended the dmesg-file for the case with two monitors connected via VGA and HDMI at boottime.

Does people here have better luck with the patch mentioned previously:

drm/radeon/kms: need to set up ss on DP bridges as well

Well considering the commit pointed is exactly the patch proposed in comment 14 ( https://bugs.freedesktop.org/attachment.cgi?id=60707 ) it is pretty clear that it doesn't do anything for me.

That's why I didn't react at all when the inclusion was advertised.

Jesse Sung (wenchien) wrote :

The fix in 3.4-rc5 that referenced to the freedesktop bug is 700698e7c303f5095107c62a81872c2c3dad1702
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commit;h=700698e7c303f5095107c62a81872c2c3dad1702

This one is already in stable kernel 3.2.17, so precise will get this commit after 3.2.17 merged. But as A8-3800 pointed out in #31, it may not help people who has both VGA and digital output, which is found on many laptops, though.

madbiologist (me-again) wrote :

This fix is now included in Ubuntu Precise kernel 3.2.0-25.40 which is currently in precise-proposed. Please test and report here. For instructions on how to enable and use -proposed, see https://wiki.ubuntu.com/Testing/EnableProposed

Changed in linux (Ubuntu):
status: Triaged → Fix Committed
Tomas Cassidy (tomas-cassidy) wrote :

I just upgraded to linux-server 3.2.0.25.27 from precise-proposed. I can confirm that VGA is now working without the "nomodeset" option on the grub commandline.

Tomas Cassidy (tomas-cassidy) wrote :

It appears that the bug is not entirely fixed. If I leave the computer for a while and come back to it, the screen is now blank and unresponsive, while the numlock/capslock keys on the keyboard still toggle so I'm guessing it's only the display that is still not working. If I then force-reboot the pc (Alt+SysRq+REISUB) then the display re-appears, but then disappears after leaving it again for a short while. I haven't waited around to see how long it takes for the screen to become unresponsive, but my guess would be after the display is put to sleep by power management stuff in the kernel.

madbiologist (me-again) wrote :

@Thomas - Thanks for your feedback - the upstream kernel developers did add the following comment to this patch:

"radeon: initial fix for VGA on LLano system, 3 or 4 of us have spent time debugging this, and Jerome finally figured out the magic bit the BIOS/fglrx set that we didn't. This at least should get things working, there may be future reliability fixes."

I've checked the kernel DRM-next tree but there is nothing there yet. Let's wait and see what is included in the drm pull request for kernel 3.5.

Can you confirm that disabling DPMS (power management for the display) keeps the display visible?

Tomas Cassidy (tomas-cassidy) wrote :

Do you know where I can find out how to disable DPMS from Ubuntu Server? I read a how-to guide on DPMS that mentioned using "xset", but I don't have X11 installed on this server (at least not that I know of).

madbiologist (me-again) wrote :

If Xorg is not installed then you might not be using DPMS. I found a report which states that screen blanking on Ubuntu server can be disabled by adding the consoleblank=0 parameter to your kernel boot options on the GRUB command line.

Tomas Cassidy (tomas-cassidy) wrote :

I can confirm that setting consoleblank=0 stops the screen from becoming unresponsive. I set the consoleblank parameter in grub and left the computer for 30 minutes. After coming back to it, the console login screen was still visible and I could interact with the computer as normal.

This suggests that the problem on this new kernel from proposed repo is now with DPMS.

a6vision (batteryshipment999) wrote :

Ubuntu 12.04 Desktop
AMD A6-3600 APU.
HDMI/VGA video outputs.

VGA output from cpu blanks out after booting live cd.
No HDMI Monitor to test.

Has this issue been solved yet?

Still forced to use vga output to old lcd monitor.

12.04 desktop build works find under virtualbox/w*ndows 7, though understand the system is using
w*ndows video drivers through emulation.

Can confirm this problem on both desktop & laptop from gateway (acer/asus?) both with A6-3600 APU's and
HDMI/VGA output.

Laptop screen blacks out - when trying to boot from live cd loaded from either usb or micro sd.
Will burn cd & test that also...

madbiologist (me-again) wrote :

a6vision - This bug has been mostly fixed in Precise - see above for a couple of related bugs which are probably best addressed in separate, new bug reports. As far as the LiveCD goes, you will have to wait for Ubuntu Ubuntu 12.04.1 which is scheduled for release on 23rd August 2012. Or you can use the Ubuntu 12.10 "Quantal Quetzal" alpha 2 LiveCD.

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Russ Herman (russ-herman) wrote :

Irreversible screen blank after inactivity even with current FOSS driver installed. Another workaround seems to be using nomodeset. No idea what the net difference is between that and consoleblank=0.

Download full text (3.7 KiB)

I have a similar problem: right after boot, my screen works (displays kernel messages) until maybe drm module is loaded (I guess by udev), then it becomes immediately blank and monitor is blinking, and then works again some time after fbcon and radeon modules are manually loaded in boot scripts (before starting X).
It depends on modeset=1; if I use modeset=0 this behaviour doesn't appear, bua X cannot run without KMS.

I have an AMD A4-3300 APU and using a (vanilla) linux kernel 3.5.3 (on Slackware64)

The real problem is that some time (a couple of minutes or so) after video adapter is in idle mode (e.g. if I am not using the PC), monitor blinks (as in low power mode) screen is blank and system is no longer recoverable (unless I use e.g. ssh just to power it off).
I don't know if the two problems are really related or not. Voltage problems?

I have these messages in dmesg, too, when it happens:
"""
[ 2405.888198] [drm:radeon_atom_encoder_dpms], encoder dpms 33 to mode 0, devices 00000001, active_devices 00000001
[ 2405.892352] [drm:radeon_dp_get_link_status], link status 44 44 01 00 44 44
[ 2405.892360] [drm:dp_get_adjust_train], requested signal parameters: lane 0 voltage 0.4V pre_emph 3.5dB
[ 2405.892365] [drm:dp_get_adjust_train], using signal parameters: voltage 0.4V pre_emph 3.5dB
[ 2405.893921] [drm:radeon_dp_get_link_status], link status 44 44 01 00 48 44
[ 2405.893926] [drm:dp_get_adjust_train], requested signal parameters: lane 0 voltage 0.4V pre_emph 6dB
[ 2405.893931] [drm:dp_get_adjust_train], using signal parameters: voltage 0.4V pre_emph 6dB
[ 2405.895508] [drm:radeon_dp_get_link_status], link status 44 44 01 00 4c 44
[ 2405.895514] [drm:dp_get_adjust_train], requested signal parameters: lane 0 voltage 0.4V pre_emph 9.5dB
[ 2405.895518] [drm:dp_get_adjust_train], using signal parameters: voltage 0.4V pre_emph 9.5dB
[ 2405.897079] [drm:radeon_dp_get_link_status], link status 44 44 01 00 41 44
[ 2405.897085] [drm:dp_get_adjust_train], requested signal parameters: lane 0 voltage 0.6V pre_emph 0dB
[ 2405.897089] [drm:dp_get_adjust_train], using signal parameters: voltage 0.6V pre_emph 0dB
[ 2405.898632] [drm:radeon_dp_get_link_status], link status 44 44 01 00 45 44
[ 2405.898634] [drm:dp_get_adjust_train], requested signal parameters: lane 0 voltage 0.6V pre_emph 3.5dB
[ 2405.898636] [drm:dp_get_adjust_train], using signal parameters: voltage 0.6V pre_emph 3.5dB
[ 2405.900152] [drm:radeon_dp_get_link_status], link status 44 44 01 00 49 44
[ 2405.900155] [drm:dp_get_adjust_train], requested signal parameters: lane 0 voltage 0.6V pre_emph 6dB
[ 2405.900156] [drm:dp_get_adjust_train], using signal parameters: voltage 0.6V pre_emph 6dB
[ 2405.901674] [drm:radeon_dp_get_link_status], link status 44 44 01 00 42 44
[ 2405.901676] [drm:dp_get_adjust_train], requested signal parameters: lane 0 voltage 0.8V pre_emph 0dB
[ 2405.901677] [drm:dp_get_adjust_train], using signal parameters: voltage 0.8V pre_emph 0dB
[ 2405.903194] [drm:radeon_dp_get_link_status], link status 44 44 01 00 46 44
[ 2405.903196] [drm:dp_get_adjust_train], requested signal parameters: lane 0 voltage 0.8V pre_emph 3.5dB
[ 2405.903197] [drm:dp_get_adjust_train], using si...

Read more...

Please try my 3.6 fixes tree (should show up in 3.6.0rc4+ and eventually stable kernels).
http://cgit.freedesktop.org/~agd5f/linux/log/?h=drm-fixes-3.6

Created attachment 66808
dmesg booting with 2 monitors plugged drm.debug=4

This drm-fixes-3.6 branch just gives me two black screens when I have them both plugged during the boot. And when X starts I get a 100% processor usage from the X process and nothing displayed. The Xorg.0.log shows nothing out of the ordinary. But I think there is something really wrong because my X server never starts accepting connection from my login manager.

When I boot with only the DVI screen plugged, no problem it boots fine.
After having booted with only the DVI plugging the VGA one works just like before.

When X puts my screens into DPMS off and I try to wake them up, the VGA goes back on correctly with this branch whereas it didn't with vanilla kernel.

So there are some good points and some bad points.

Attached is dmesg | grep -e drm -e radeon when both screens are connected, after X is "started".

Created attachment 66817
dmesg booting with 2 monitors plugged patch applyed on top of drm-fixes-3.6 drm.debug=4

With the additional patch, I get the DVI screen displaying things when both a plugged-in but the VGA one now says there is no signal (instead of staying black). So the behavior is somewhat similar to the vanilla kernel in that regard.

Booting with the VGA unplugged and plugging it later gives the same behavior as without that patch (i.e. better than the vanilla kernel).

Attached is the dmesg | grep -e drm -e radeon when the 2 screens are plugged and the VGA says no signal.

Comment on attachment 66817
dmesg booting with 2 monitors plugged patch applyed on top of drm-fixes-3.6 drm.debug=4

Sorry wrong auto-detect of the type...

Created attachment 66819
dmesg booting with 2 monitors plugged patch applyed on top of drm-fixes-3.6 drm.debug=4

Sorry... I appended the new log to the last one instead of overwriting it...
Now there is only the new dmesg information.

Created attachment 66822
dmesg booting with 2 monitors plugged patch applyed on top of drm-fixes-3.6 drm.debug=4

Ok.... I need sleep...
This time is the right dmesg. With both screens plugged during the boot and the patch, but mysteriously this time the DVI screen stayed black and the VGA had no link. And X started to take 100% CPU. So exactly the same behavior as without the patch.

I tried rebooting and then both screens lit up and were black. X using 100% CPU.

the new attachment shows dmesg | grep -e drm -e radeon after both attempts.

You're getting a GPU hang for some reason which may be causing the modeset failure. Can you try with acceleration disabled to take the out of the equation? Try adding:
Option "NoAccel" "TRUE"
to the device section of your xorg.conf

Created attachment 66828
dmesg booting with 2 monitors plugged patch applyed on top of drm-fixes-3.6 drm.debug=4 (X with NoAccel)

I tested a few things and found out that with the patch over drm-fixes-3.6 I generally get the DVI screen working but the VGA has no signal if it is plugged during the boot. The generally is there because sometimes I just get a black screen on the DVI and then X causes a GPU Hangup (The NoAccel suppresses the Hangup). This situation is rare and If the GPU hangup pressing the reset switch (instead of letting the machine off during some time and doing a cold boot) causes it to happen more often.

A "quick" way to do it is booting without the patch starting X without NoAccel and then pressing the reset button and booting with the patch.

Seems the firmware doesn't reset the state of the card properly during POST or something. Last night the problem happened "by itself", so it might happen without trying to provoke it. This morning I tried rebooting a few times but didn't get it to happen without provoking it.

The attachment is dmesg | grep -e drm -e radeon when the DVI screen stays black (VGA saying no signal) and without hangup (provoking it on the previous boot). The last part is X turning the screens off and trying to wake them up. The situation didn't change.

Does your OEM have a newer bios available for your board? It might be worth trying a newer (or maybe older) bios image.

Oh yes there was and now even without the patch my machine displays something on the DVI screen when both screens are plugged and the GPU doesn't hang anymore even without NoAccel (but only from a cold boot, if I reboot/reset I get a black screen and the GPU hangup). So part of the problem was really a firmware issue.

With the patch I can't seem to provoke the GPU hangup anymore.

But my VGA screen continues to be stubbornly off when booting with both screens plugged. Continues to work if I plug my VGA screen after booting.

So now I can start X safely without NoAccel that's one good thing.

BTW my motherboad is an Asus F1A75-M now my firmware is the latest version (2004) upgraded from 1903.

Oh BTW I am booting in uEFI mode using grub-2.00 I don't know if this might change something.

I take back what I said before...
I just did a *very* cold boot (the machine was not connected to the electricity network during the night). I got the black DVI screen and GPU hangup with the patch. So the firmware change didn't do anything in facts...

Sorry for the delay.
The 2nd problem I've reported in comment #30 (when video adapter is in idle, screen blanks and becomes inoperable, error in clock recovery) seems to be resolved here using linux 3.6.0-rc4. BTW I've just one monitor on VGA port.

The 1st problem (at boot, for about 30-40 seconds screen is blanking and monitor LED is blinking; after that, messages appear again in console, before starting X [init 3 mode]) seems to be still present, though.
I will test last drm-fixes-3.6 patches ASAP.

Thank you.

Sorry, I've managed to resolve my first problem (screen blanking after boot for about 30-40 seconds): it is not related to drm, but it depends on fbcon loaded as a module (instead of it being compiled statically).

As explained in /usr/src/linux/Documentation/fb/fbcon.txt if fbcon is compiled as a module (CONFIG_FRAMEBUFFER_CONSOLE=m) it can produce blanking and/or garbage on display if it is not loaded immediately.
If "Framebuffer Console support" is compiled statically (CONFIG_FRAMEBUFFER_CONSOLE=y) there is no blanking here.
"Works for me"
HTH.

*** Bug 51652 has been marked as a duplicate of this bug. ***

I can confirm that this bug is still present in Linux 3.8.0, using X Server 7.7 and driver 7.1.0. As graphics are initialized screen just goes black.

To post a comment you must log in.