Ubuntu

[REGRESSION] Xorg Intel GMA 3600 driver does not work (Atom N2600 onboard graphics)

Reported by Gerold Jens Wucherpfennig on 2012-02-18
118
This bug affects 21 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

ubuntu-12.04-beta1-desktop-amd64.iso

Unable to install, unable to use,
because of the INTEL graphics driver
for the onboard Intel GMA 3600
graphics does not work.

The display stays black when the
X-Server has been started. No installation
of ubuntu-12.04-beta1-desktop-amd64
possible.

THIS BUG HAS TO BE RESOLVED BEFORE
UBUNTU 12.04 final !!!

----
OLD description:

I use the oneiric AMD64 version with latest BIOS.
Hardware: A brand-new ATOM N2600 netbook.

Everything worked fine, but not 3D required for
Unity/GNOME3. So i tried some bleeding edge
packages. They do not work!
(xorg-edgers PPA for oniric.)

AND EVEN WORSE:
Ubuntu 12.04 Precise Pangolin (daily-live ISO)
from today (2012-02-18)
does not even boot at all.

Ubuntu does only show a grey screen
on system startup and Ctrl+Alt+F2 etc. do not work.
A complete SYSTEM FREEZE happens!

There is something wrong with the
"xserver-xorg-video-intel"
driver when you have Intel GMA 3600
(Atom N2600 onboard graphics).

This is a regression, because on
ubuntu "oneiric" 2D graphics works
and on "precise" you can not even boot!
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gerold 1667 F.... pulseaudio
CRDA: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x86100000 irq 45'
   Mixer name : 'Realtek ALC269VB'
   Components : 'HDA:80862880,80860101,00100000 HDA:10ec0269,10250590,00100100'
   Controls : 17
   Simple ctrls : 11
DistroRelease: Ubuntu 11.10
HibernationDevice: RESUME=UUID=d8220339-8649-478f-afda-f13462612e84
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Acer AOD270
NonfreeKernelModules: wl
Package: linux (not installed)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-16-generic root=UUID=8e6def4c-3189-448c-b129-658c1ccd3f0e ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-16.28-generic 3.0.17
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-16-generic N/A
 linux-backports-modules-3.0.0-16-generic N/A
 linux-firmware 1.60
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
StagingDrivers: brcmsmac rts_pstor brcmutil
Tags: oneiric staging
Uname: Linux 3.0.0-16-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 01/12/2012
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: V1.04
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: JE01_CT
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvrV1.04:bd01/12/2012:svnAcer:pnAOD270:pvrV1.04:rvnAcer:rnJE01_CT:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: AOD270
dmi.product.version: V1.04
dmi.sys.vendor: Acer

Robert Hooker (sarvatt) wrote :

Reassigning to linux, there are no X drivers for this GPU and never have been, failures would be with the psb_gfx kernel module.

affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 934956

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

So I cannot do a "apport-collect 934956"
on ONEIRIC with "xorg-edgers PPA" packages.
Because then the system will not boot any more
in graphical mode.

Shall I do a "apport-collect 934956" without
"xorg-edgers PPA" packages?

Starting the PRECISE installation does not work at all,
because daily-live images will not boot at all
(because of graphic driver issues)!!!

apport information

tags: added: apport-collected oneiric staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

OK, that was the apport information without
the new defunctional X driver...

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

THIS BUG HAS TO BE RESOLVED BEFORE
UBUNTU 12.04 final !!!
Because ubuntu-12.04-beta1-desktop-amd64
cannot be installed.

description: updated
Fernando Sancho (toptnc) wrote :

I have a MSI Wind U180 with Atom N2600. Oneiric works, but in vesa mode and 800x600 resolution. No way to get 1024x600.

Precise live cd boots up, but screen goes black and nothing works to get a console (Ctrl-Alt-F1). The system isn't freezed because Ctrl-Alt-Supr or Power Button shuts down the machine but there is no way to get a console.

Fernando Sancho (toptnc) wrote :

AFAIK this GPU is similar to GMA500 and intel doesn't offer support. Is PowerVR who makes the drivers, and i don't know how to get it.

This could be a start point
MeeGo Quietly Releases a Cedar Trail Update
http://www.netbooknews.com/45135/meego-quietly-releases-a-cedar-trail-update/
http://lists.freedesktop.org/archives/intel-gfx/2012-February/015240.html

Fernando Sancho wrote:
>I have a MSI Wind U180 with Atom N2600.
>Oneiric works, but in vesa mode and 800x600 resolution.
>No way to get 1024x600

I have a Acer Aspire One D270 with Atom N2600.
Oneric x86_64 works, with driver vesa and 1024x600 resolution.
(I did a BIOS update to get 64bit support).
With glxgears I get 100 FPS.

Fedora 16 also works and Fedora 17 Alpha too.
If this bug does not get resolved in
Ubuntu 12.04 I will say good bye and use
Fedora 17 instead wich uses a 3.3 Linux kernel
which has a GMA 3600 DRI driver and the latest
Xorg-packages.

I was able to work around this, this might provide some clues.
I installed ubuntu-12.04-beta1-desktop-amd64.iso to a USB drive with unetbootin. At unetbootin boot time, I changed the boot parameters to add "vga=789", this had it display in 800x600x24 mode. With this I installed 12.04 Beta alongside the Windows 7 Starter.
When I boot the machine I get the purple Grub 1.99 menu with Ubuntu and Windows. I select Ubuntu.
For 2 minutes and 20 seconds I get a blank purple screen, then 10 seconds of a blank black screen, then the Unity desktop comes up in 1024x600 resolution, the resolution of the screen, and the machine is in Unity 2D mode.
The brightness control doesn't work.
I have it set to have the screen turn off after 10 minutes of inactivity, that is not working, I have a black screen but it is still on.

Robert Hooker (sarvatt) wrote :

CDV support has been disabled from psb_gfx in 3.2 for precise, workarounds to use vesa shouldn't be required anymore

Robert Hooker (sarvatt) wrote :

as of 3.2.0-19.31

Robert Hooker (sarvatt) wrote :

Also if you *really* want to try it out, the beginnings of cdv support from the proprietary drivers is available here https://launchpad.net/~sarvatt/+archive/cedarview

Fernando Sancho (toptnc) wrote :

linux-3.3 has GMA3600 support. It's experimental but it works. I have built a linux-3.3 kernel on Oneiric and it finally works. It would be nice to pull gma500_gfx driver from linux-3.3 to dkms system in order to have it updated more often without compiling the entire kernel.

Robert Hooker (sarvatt) wrote :

We looked into that and backporting the fixes required to make it work change drm too much, that's not going to be done in 3.2 for precise. I'm closing this bug since the regression was addressed, psb_gfx wasn't used in 11.10, and now its not used in 12.04.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released

I tested (K)Ubuntu 12.04 Precise Pangolin Beta 2 on my Netbook
and it finally works! The vesa driver works again.

Kaffeine with DVB-S is not working that well.
I do not know if that can be fixed with
better video acceleration, but I do not care
right now...

I will stay with Ubuntu and NOT use Fedora.
Fedora is dogslow at system boot because too
many services are started... but that should
only be an issue for Fedora's bugtracker...

Marc (corralesmarc) wrote :

Hi! What do you men with it works? do you manage to get the proper screen resolution? (more than the awful 800x600), ive managed to install the unity 12.04 beta 2 but i cant chose more than 800x600... have u installed manually the vea driver? Thanks a lot

>Do you manage to get the proper screen resolution?
I always got the right screen resolution. 1024x600.

The only thing I did with my netbook when
it was new, was to do a BIOS update to get
64-bit CPU - support.

Marc (corralesmarc) wrote :

Oh! I've got the same processor and integrated graphic card as you have, and ubuntu dosn't seam to recognize the monitor. Do you had t install some 3rd partu driver or something? I don't understand... Thank u

> Do you had t install some 3rd partu driver or something?

No it worked out-of-the-box.

andrew (andy-jjcftv6w) wrote :

By upgrading the bios to 64 bit and installing 12.04 beta. This will resolve the 1024 x 600 resolution problem.

Is my understanding correct?

> By upgrading the bios to 64 bit and installing 12.04 beta.

Installing 12.04 beta 1 did not work for me.
I only got a black screen, that is the reason
for this bug report.

Installing 12.04 beta 2 works flawlessly.

> This will resolve the 1024 x 600 resolution problem.

I do not know that. You could try a BIOS upgrade
and report us if this fixes your problems.

I needed the BIOS upgrade, because I wanted
to install a 64bit Linux.

I have not used the netbook without the BIOS
upgrade...

andrew (andy-jjcftv6w) wrote :

thanks for the clarification, will download and test.

Ubuntu 12.04 Beta2 i386 as well as amd64 did not work for me.
I have only 800x600 on my Samsung NC110-P05, Intel n2600 Cedar Trail-M based netbook with GMA 3600 with latest BIOS.

Fabio (mr-fabio90-g) wrote :

Please help
i've the same problem..on Ubuntu 11.10 i tried to install the emgd drivers for the gma 500(v 1.10)
but the netbook freezes on boot.

is there an existing driver?! or i should wait for 12.04 release?

thnx all!!

Kashyap (kashyapkopparam) wrote :

I have an ASUS 1015CX. i have updated the BIOS to the latest version. now the live desktop of 12.04 Beta 2 has only the 800x600 resolution. do i need a full install to have the 1024x600?

summary: - [REGRESSION] Xorg Intel GMA 3600 driver does not work (Atom N2600
+ [REGRESSION] Xorg Intel GMA 3600 driver does not work (Atom N2600
onboard graphics)
Fabio (mr-fabio90-g) wrote :

http://ubuntuforums.org/showthread.php?s=529605f2224e83e9388c17985debd2af&t=1953734&page=2

To solve the problem you've to compile kernel 3.3.2 as in this forum, now i'm able to run ubuntu 11.10 at 1024x600 but with VESA driver only..better then nothing.
You've to control your wireless card before the installation, but it's all described in the post.
I think the 3d support will come with an ubuntu 12.04's update, not so late.

Sorry for my english!

Hello.

I was able to compile kernel 3.4-rc5 with GMA3600 support.
The classmate netbook now works with full 1024x600 resolutions, but still does not support S3 resume operation.

If the computer enters Suspend Mode, it cannot resume correctly, and the graphic signal gets "corrupted", as documented in the provided attachment!

The lsmod is as following:

PC:~$ lsmod|grep -i gma
gma500_gfx 139228 2
drm_kms_helper 45321 1 gma500_gfx
drm 215594 2 gma500_gfx,drm_kms_helper
i2c_algo_bit 13197 1 gma500_gfx

PC:~$ sudo modinfo gma500_gfx
[sudo] password for agostinho:
filename: /lib/modules/3.4.0-rc5/kernel/drivers/gpu/drm/gma500/gma500_gfx.ko
license: GPL
description: DRM driver for the Intel GMA500
author: Alan Cox <email address hidden> and others
srcversion: AE5A0D7498638989EA81B04
alias: pci:v00008086d00000BE7sv*sd*bc*sc*i*
alias: pci:v00008086d00000BE6sv*sd*bc*sc*i*
alias: pci:v00008086d00000BE5sv*sd*bc*sc*i*
alias: pci:v00008086d00000BE4sv*sd*bc*sc*i*
alias: pci:v00008086d00000BE3sv*sd*bc*sc*i*
alias: pci:v00008086d00000BE2sv*sd*bc*sc*i*
alias: pci:v00008086d00000BE1sv*sd*bc*sc*i*
alias: pci:v00008086d00000BE0sv*sd*bc*sc*i*
alias: pci:v00008086d00004108sv*sd*bc*sc*i*
alias: pci:v00008086d00004107sv*sd*bc*sc*i*
alias: pci:v00008086d00004106sv*sd*bc*sc*i*
alias: pci:v00008086d00004105sv*sd*bc*sc*i*
alias: pci:v00008086d00004104sv*sd*bc*sc*i*
alias: pci:v00008086d00004103sv*sd*bc*sc*i*
alias: pci:v00008086d00004102sv*sd*bc*sc*i*
alias: pci:v00008086d00004101sv*sd*bc*sc*i*
alias: pci:v00008086d00004100sv*sd*bc*sc*i*
alias: pci:v00008086d00008109sv*sd*bc*sc*i*
alias: pci:v00008086d00008108sv*sd*bc*sc*i*
depends: drm,drm_kms_helper,i2c-algo-bit
intree: Y
vermagic: 3.4.0-rc5 SMP mod_unload modversions 686
parm: trap_pagefaults:Error and reset on MMU pagefaults (int)

Thank you

Forgot to mention I'm using Ubuntu 11.10!
Thank you
Agostinho

Kashyap (kashyapkopparam) wrote :

Even in Ubuntu 12.04, compiling 3.3 or 3.4 kernel with GMA 3600 support will give 1024 x 600 res. But resume from suspend and WiFi will not work.

Dmitry Pavlov (ringill) wrote :

WiFi works with the latest 3.4-rc6 kernel, but resume from suspend does not work indeed. So I think the bug should be reopened.

Hello.

Regarding the resume from S3 problem...

What happens if you remove the file:
/usr/lib/pm-utils/sleep.d/99video

Does it help?

I tried your suggestion (removing 99video) on a 3.5 kernel and it doesn't help. Still no resume

armo (r-mo) wrote :

I'm surprised there's been no mention of the cedartrail drivers which are now in the main repositories. Worked a charm for me. Just use the standard i386 kernel and the GMA3600 should be detected as additional drivers. If not (or you're getting the black screen issue which I never saw) just drop to a terminal and install:

cedarview-drm
cedarview-graphics-drivers
libva-cedarview-vaapi-driver

How do I drop to a terminal? After choosing to run or install Ubuntu from the USB, it goes dark (flashing cursor) and ctrl-alt-f1 does nothing.
It can sleep, shut down, but not even display a terminal.

nordicnurse (nordicnurse) wrote :

If you installed 12.10, you should check out this bug: https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1069031
Try to install the 12.0.4.1 lts version and afterwards install either closed source driver from 'restricted drivers' (the dkms one only) or try 3.4.1 kernel (haven't tested kernel option personally though)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers