Ubuntu

intel gma3600: X unable to start

Reported by Guy Coates on 2012-10-20
270
This bug affects 55 people
Affects Status Importance Assigned to Milestone
X.Org X server
New
Undecided
Unassigned
xorg-server (Ubuntu)
Medium
Matthias Klumpp
Quantal
Medium
Unassigned

Bug Description

X is unable to start on a Acer AOD270 intel atom netbook with a gma3600 chipset when the gma500_gfx kernel driver is loaded.

(xorg.0.log)

[ 41.352] (EE) intel(0): [drm] Failed to detect GEM. Kernel 2.6.28 required.
[ 41.352] (EE) intel(0): Failed to become DRM master.
[ 41.352] (II) UnloadModule: "intel"
[ 41.353] (EE) Screen(s) found, but none have a usable configuration.
[ 41.353] Fatal server error:

Workaround is to blacklist the gma500_glx module, which allows X to start by falling back to the vesa FB driver.

Applying the patch described here fixes the problem without the need to blacklist.

http://bugzillafiles.novell.org/attachment.cgi?id=499509

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xserver-xorg-video-intel 2:2.20.9-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic i686
NonfreeKernelModules: wl
ApportVersion: 2.6.1-0ubuntu3
Architecture: i386
Date: Sat Oct 20 11:35:10 2012
InstallationMedia: Xubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: Upgraded to quantal on 2012-10-19 (1 days ago)

Guy Coates (guy-coates) wrote :
Guy Coates (guy-coates) wrote :
Guy Coates (guy-coates) wrote :
Guy Coates (guy-coates) wrote :
Guy Coates (guy-coates) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
nordicnurse (nordicnurse) wrote :

Same issue on eeepc 1025c with gma3600. Blacklisting gma500_glx allows X to load. Otherwise system just hangs trying to start X.

minnigaliev-r (minnigaliev-r) wrote :

Don't starting live session on my Intel Atom N2800 (gma3650).
I tried Ubuntu 12.10 (amd64/+mac & i386), also Lubuntu 12.10 (i386).

Same problem as Guy on my Acer Aspire One D270 after Upgrade from Lubuntu 12.04 to 12.10.
Blacklisting the module alone did not suffice for me.
Did also need to update my initramfs with update-initramfs -u

Timur Melnikov (timur) wrote :

Don't starting live session on my Intel Atom N2600 (gma3600).
I tried Ubuntu 12.10 (i386), also Lubuntu 12.10 (i386) and Xubuntu 12.10 (i360).

description: updated
Timo Aaltonen (tjaalton) wrote :

and why the heck isn't that patch upstream..

affects: xserver-xorg-video-intel (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
nordicnurse (nordicnurse) wrote :

It's noteworthy that with 12.04 gma500_gfx allowed my netbook to run resolutions other than 800x600. Although blacklisting it allowed X to start it naturally reverted back to previous 800x600 state.

JACKasz (jackasz) wrote :

nordicnurse is right. Just disabling driver does not solve problem. Sure - it's better than nothing but running 800x600 is not really an option, then it's better to revert to 12.04 + 3.4.2 Kernel. How comes that live demo works just fine?

nordicnurse (nordicnurse) wrote :

For me, both installed 12.10 and live-usb froze when starting X. I reverted back to 12.04.1 which now seems to offer under 'restricted drivers' cedar trail driver as dkms. Either that or 3.4. kernel. I would prefer open alternative though.

nordicnurse (nordicnurse) wrote :

A random observations: when 12.10 is run from a live-usb with ubiquity-only option, gmas3600_gfx gets loaded and installer launches (and completes) with proper resolution. However, triyng to load complete DE results in failure. Lightdm, gdm, xdm all die, but with slightly differing results. Lightdm freezes and gdm/xdm end to terminal with a login prompt.

bugbot (bugbot) on 2012-10-25
tags: added: xubuntu
Christos (m1dg) wrote :

i also confirm this problem in ubuntu - xubuntu - lubuntu 12.10

Christos (m1dg) wrote :

my board is Ashrock AD2700-ITX (gma3600 vga)

Live session:
1. On boot push F5 and add to kernel option: text
2. Boot to TTY1
3. Creat /etc/X11/xorg.conf which contains:

Section "Device"
   Identifier "Intel GMA3600"
   Driver "fbdev"
EndSection

4. Save configs
5. Start the LightDM whith command:
sudo service lightdm start
6. Enjoy!

minnigaliev-r (minnigaliev-r) wrote :

Козинцев Егор (ekozincew)
>> fbdev

And get poor performance with slow interface?

Giles Howard (gilesahoward) wrote :

Is the patch upstream yet?

>>> Козинцев Егор (ekozincew)
>>> >> fbdev
>>>
>>> And get poor performance with slow interface?

Or this, or nothing!
(rus: "Или так, или никак!" )

I created the xorg.conf as described in #18. Now the screen remains black and I have to switch to tty7 manually. I can login there and things work, but the screen is very dark (in all ttys) and brightness control does not change anything.

Any idea how long it will take for a real fix to be delivered? I think about switching back to 12.04 in the meantime.

xubuntu 12.10, acer aspire one D270

Matthias Klumpp (ximion) wrote :

I will apply the patch mentioned above and submit a fixed package for review.
Please wait some more time :)

Changed in xorg-server (Ubuntu):
assignee: nobody → Matthias Klumpp (ximion)
status: Triaged → In Progress
Matthias Klumpp (ximion) wrote :

Here is a patch to apply this on Ubuntu.
I compiles and does not cause any misbehaviour, but I still need to test it on the actual hardware. I will report back if it worked.

Changed in xorg-server (Ubuntu):
status: In Progress → Fix Committed
Matthias Klumpp (ximion) wrote :

The attachment "Fix gma3600 issue on Ubuntu's Xserver" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Matthias Klumpp (ximion) wrote :

Tested and working fine! (Definitely resolves the issue)

Diego Carreño (diegoecp) wrote :

How I can apply that file debdiff? Can you tell me the steps to apply the patch and resolve the problem?

Matthias Klumpp (ximion) wrote :

There is an easier way: Just fetch the patches DEB packages from my Experimental PPA: https://launchpad.net/~ximion/+archive/ppa/+sourcepub/2784157/+listing-archive-extra and install them.
You then just need to be careful when updating your Xserver: The debdiff here needs to have been applied, if not, X will stop working again.
(That's why I hope someone from the X team will take this patch soon)

Diego Carreño (diegoecp) wrote :

Sorry, but can you tell me how to add this repository and which packages I have to install?

Matthias Klumpp (ximion) wrote :

Better install the package manually - the PPA is for my experimental stuff, so it's not safe to use on productive machines. (this package could have gone to my testing PPA, however...)
You might want to install the packages
    xserver-common
    xserver-xfbdev
    xserver-xorg-core
    xvfb
Just put them into one new directory, open a Terminal, cd to it and run "sudo dpkg -i *.deb".

David Guerrero (daguerreroa) wrote :

I installed the packages and can report that it works.

Changed in xorg-server (Ubuntu Quantal):
importance: Undecided → Medium
status: New → Triaged
Bryce Harrington (bryce) wrote :

Thanks; uploaded the patch for raring. Please also send the patch upstream to X.org for inclusion there.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.13.0-0ubuntu7

---------------
xorg-server (2:1.13.0-0ubuntu7) raring; urgency=low

  [ Maarten Lankhorst ]
  * Add 233-xf86events-valgrind.patch to fix a xserver corruption
    when acpid is stopped before Xorg is.
    (LP: #1070481)
  * Add 235-composite-tracking.patch to fix exa corruption.
    (LP: #1010794)

  [ Bryce Harrington ]
  * Add 236-use-fbdev-for-poulsbo-oaktrail-medfield.patch: Never use Intel
    driver on Poulsbo/Oaktrail/Medfield. Thanks to Matthias Klumpp.
    (LP: #1069031)
  * Add 237-dix-set-the-device-transformation-matrix.patch: Fix pointer
    jumping with absolute pointing device. Initializes device
    transformation matrix to an identity matrix. Thanks to a7x.
    (LP: #1041063)

  [ Tim Lunn ]
  * 500_pointer_barrier_thresholds.diff: Update to fix gaps above
    barriers at edge of screen
    (LP: #1073724)
 -- Bryce Harrington <email address hidden> Fri, 16 Nov 2012 11:37:26 -0800

Changed in xorg-server (Ubuntu):
status: Fix Committed → Fix Released
Bryce Harrington (bryce) wrote :

Fix is uploaded to quantal-proposed as well. Unsubscribing sponsors.

Changed in xorg-server (Ubuntu Quantal):
status: Triaged → Fix Committed

Hello Guy, or anyone else affected,

Accepted xorg-server into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xorg-server/2:1.13.0-0ubuntu6.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Guy Coates (guy-coates) wrote :

The updated package fixes the bug for me.

Cheers,

Guy

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.13.0-0ubuntu6.1

---------------
xorg-server (2:1.13.0-0ubuntu6.1) quantal-proposed; urgency=low

  [ Maarten Lankhorst ]
  * add 233-xf86events-valgrind.patch to fix a xserver corruption
    when acpid is stopped before Xorg is. (LP: #1070481)
  * add 235-composite-tracking.diff to fix exa corruption. (LP: #1010794)

  [ Bryce Harrington ]
  * Add 236-use-fbdev-for-poulsbo-oaktrail-medfield.patch: Never use Intel
    driver on Poulsbo/Oaktrail/Medfield. Thanks to Matthias Klumpp.
    (LP: #1069031)
  * Add 237-dix-set-the-device-transformation-matrix.patch: Fix pointer
    jumping with absolute pointing device. Initializes device
    transformation matrix to an identity matrix. Thanks to a7x.
    (LP: #1041063)
 -- Timo Aaltonen <email address hidden> Tue, 27 Nov 2012 08:09:59 +0200

Changed in xorg-server (Ubuntu Quantal):
status: Fix Committed → Fix Released

I must be missing something about the released fix. My Quantal system doesn't seem to have an xorg-server package at all, but it does have xorg-1:7.7+1ubuntu4. It seems like xorg-server might be a Raring-only package?

In any case, a fresh install of Quantal with all updates applied on an Acer Aspire One D270 still results in un-startable X server. :-( Xorg.0.log matches the initial comment in this bug.

Correction: the package is available for Quantal. However, I had xserver-xorg-core 2:1.13.0-0ubuntu6 installed, and ...ubuntu6.1 was not installed automatically as an update. Once I manually ran "apt-get install xserver-xorg-core", it installed the update and X worked.

cyklista (pkaplon) wrote :

Hi!
Could somebody explain step by step, how to solve this problem. Only upgrading the package xserver-xorg-core don' solve the problem in my case.
I have a HP Mini 200-4200sw netbook with Intel GMA3600 graphics.
I installed Xubuntu 12.10 (386) on the way described in #18 , but to start the graphic mode i have to choose the rescue mode and choose the "resume" option. When I delete the "xorg.conf" file wit the content as described in #18, the system starts "normally" , but the screen is very dark and I can't make it brighter.

Christian Weiske (cweiske) wrote :

xserver-xorg-core 1.13.0-0ubuntu6.1 fixes the issue for me on a Clevo W210CUQ ("Intellibook").

gaitapi (gaitapi) wrote :

#18 fix problem for me on a Toshiba NB515 (Mint 14)
Later I manually ran "apt-get install xserver-xorg-core" and all work fine!

Jordy (mydarksideevil) wrote :

I found a website with linux drivers downloads, but i couldn't compile it
(there's not deb packages, only rpm and tgz)
I don't know how this will helps to fix problems.

http://www.imgtec.com/powervr/insider/powervr-drivers.asp
PD: SFMBE

Maik Wagner (mtwagner) wrote :

#47: These drivers look fairly old to me. Mandrake 9.0 had a 2.4-Linux-kernel and a lot has changed since then.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers