Ubuntu

Gateway M520, no sound

Reported by Benjamin Carlson on 2012-02-12
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Daniel T Chen

Bug Description

I recently installed ubuntu 10.04 on a gateway M520S with a ICH4 southbridge AC97 audio card integrated into the motherboard. The default driver that is being used at the moment is "snd-intel8x0". I have no sound. I never did. I'm new to linux systems so I am having a hard time finding anything that can help. I found some trouble shooting guides and everything passed, but I still have no sound.
I had a similar problem with my wi-fi card, but for that I ended up re-installing the default driver and now that works, but when I tried to re-install the "snd-intel8x0" driver the terminal said it couldn't find the package. The command I used was "sudo apt-get install". (This worked for my wi-fi driver.) I don't know what else to do, please help.

-Ben
---
AlsaVersion:
 Advanced Linux Sound Architecture Driver Version 1.0.25.
 Compiled on Feb 11 2012 for kernel 3.0.0-15-generic (SMP).
ApportVersion: 1.23-0ubuntu4
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bcpostman2007 1453 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'I82801DBICH4'/'Intel 82801DB-ICH4 with Cx20468-31 at irq 17'
   Mixer name : 'Conexant Cx20468-31'
   Components : 'AC97a:43585430'
   Controls : 23
   Simple ctrls : 16
DistroRelease: Ubuntu 11.10
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
Package: alsa-driver (not installed)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.0.0-15.26-generic 3.0.13
Tags: oneiric running-unity
Uname: Linux 3.0.0-15-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin audio cdrom dialout lpadmin plugdev pulse pulse-access sambashare video
dmi.bios.date: 07/19/2004
dmi.bios.vendor: AMI
dmi.bios.version: NOTE BIOS Version /52.00.12
dmi.board.name: Gateway M520
dmi.board.vendor: Gateway
dmi.board.version: KBC K52.00.06
dmi.chassis.type: 10
dmi.chassis.vendor: Gateway
dmi.chassis.version: Rev 1.0
dmi.modalias: dmi:bvnAMI:bvrNOTEBIOSVersion/52.00.12:bd07/19/2004:svnGateway:pnGatewayM520:pvr52.00.12:rvnGateway:rnGatewayM520:rvrKBCK52.00.06:cvnGateway:ct10:cvrRev1.0:
dmi.product.name: Gateway M520
dmi.product.version: 52.00.12
dmi.sys.vendor: Gateway

Daniel Letzeisen (dtl131) wrote :

Please use this command to collect relevant audio information:
apport-collect 930842

Changed in alsa-driver (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected oneiric running-unity
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in alsa-driver (Ubuntu):
status: Incomplete → New

I saw a post here from an M520 owner that suggests an inverted amp setting: http://www.ubuntux.org/centrino-sound-problem

Run alsamixer with this command:
alsamixer

Turn off the 'External Amp' setting. and see if you get sound.

Thanks got it. :)

If anyone else has this problem, with AlsaMixer v1.0.24.2 you need to arrow over to external amplifier and hit the "m" key to turn it off. Then the sound will come on.

Ben, please use `apport-collect 930842' so we can generate a fix for your
hardware.

Daniel T Chen (crimsun) on 2012-02-13
Changed in alsa-driver (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
importance: Undecided → Low
status: New → Triaged
summary: - I have no sound
+ Gateway M520, no sound
madbiologist (me-again) wrote :

The default setting has been fixed upstream in kernel 3.3-rc4. From the changelog:

author Daniel T Chen
Tue, 14 Feb 2012 04:44:22 +0000 (23:44 -0500)
committer Takashi Iwai
Tue, 14 Feb 2012 08:33:47 +0000 (09:33 +0100)
commit 27c3afe6e1cf129faac90405121203962da08ff4
tree f8a5cf6ad004cb83ca5f2224aeb1f39195750a63
parent 675c67afb6a05907d9683ef176f41852bb1b5b9d
ALSA: intel8x0: Fix default inaudible sound on Gateway M520

BugLink: https://bugs.launchpad.net/bugs/930842

The reporter states that audio is inaudible by default without muting
'External Amplifier'. Add a quirk to handle his SSID so that changing
the control is not necessary.

Reported-and-tested-by: Benjamin Carlson
Cc: <email address hidden>
Signed-off-by: Daniel T Chen
Signed-off-by: Takashi Iwai

A PPA of this kernel can be found at http://kernel.ubuntu.com/~kernel-ppa/mainline/

Changed in alsa-driver (Ubuntu):
status: Triaged → Fix Committed
Andy Whitcroft (apw) on 2012-03-05
affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Oneiric in -proposed solves the problem ( 3.0.0-17.30). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-oneiric' to 'verification-done-oneiric'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-oneiric
Herton R. Krzesinski (herton) wrote :

The commit for this issue came in through 3.0.22 upstream stable update, so we can mark this as verified.

tags: added: verification-done-oneiric
removed: verification-needed-oneiric
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers