Ubuntu

vt.handoff 7 breaks psb_gfx driver

Reported by Lucazade on 2012-01-10
110
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Undecided
Unassigned
grub-gfxpayload-lists (Ubuntu)
High
Andy Whitcroft
linux (Ubuntu)
High
Andy Whitcroft

Bug Description

When using a gma500 based netbook with psb_gfx driver (shipped by default with kernel => 3.x)
if the option "vt.handoff=7" is enabled (by default) the psb_gfx driver cannot initialize itself correctly ending up in a blank screen instead of X.

I believe the KMS part of psb_gfx is not able to create the framebuffer and use it on VT7 with the fbdev xorg driver.

+ tried nightly iso image and already tried mainline kernels.

WORKAROUND: Removing vt.handoff=7 settings from grub (temporary or by editing /etc/grub.d/10_linux) the system load correctly.

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: MID [HDA Intel MID], device 0: ALC272X Analog [ALC272X Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.23-0ubuntu4
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: MID [HDA Intel MID], device 0: ALC272X Analog [ALC272X Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: luca 1329 F.... pulseaudio
CRDA: Error: [Errno 2] File o directory non esistente
Card0.Amixer.info:
 Card hw:0 'MID'/'HDA Intel MID at 0xb0050000 irq 22'
   Mixer name : 'Realtek ALC272X'
   Components : 'HDA:10ec0272,10250244,00100001'
   Controls : 15
   Simple ctrls : 9
DistroRelease: Ubuntu 11.10
HibernationDevice: RESUME=UUID=b158bd99-9809-40eb-9707-a9f5ab2ec4b7
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
MachineType: Acer AO751h
Package: linux (not installed)
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-8-generic root=UUID=9cbf9d42-d9e8-417e-9fc3-253fd8622f4c ro acpi_backlight=vendor quiet splash
ProcVersionSignature: Ubuntu 3.2.0-8.14-generic 3.2.0
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-8-generic N/A
 linux-backports-modules-3.2.0-8-generic N/A
 linux-firmware 1.60
StagingDrivers: psb_gfx
Tags: oneiric running-unity staging
Uname: Linux 3.2.0-8-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 02/26/2010
dmi.bios.vendor: Acer
dmi.bios.version: V0.3212
dmi.board.name: JV11-ML
dmi.board.vendor: Acer
dmi.board.version: Not Applicable
dmi.chassis.type: 1
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrV0.3212:bd02/26/2010:svnAcer:pnAO751h:pvrNotApplicable:rvnAcer:rnJV11-ML:rvrNotApplicable:cvnAcer:ct1:cvrN/A:
dmi.product.name: AO751h
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer

Phillip Susi (psusi) on 2012-01-10
affects: grub (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 914311

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected oneiric running-unity staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

Lucazade (lucazade) wrote : Lspci.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Lucazade (lucazade) on 2012-01-11
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: gma500
tags: added: rls-mgr-p-tracking
bodhi.zazen (bodhi.zazen) wrote :

Any update on this bug ?

Lucazade, thank you for reporting this and helping make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Lucazade (lucazade) wrote :

already pushed the necessary logs.. bug is confirmed, it affects a lot of people.. I'd say all the gma500 owners.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Lucazade (lucazade) wrote :

@penalvch
I've already provided logs for the kernel, already tried nightly iso image and already tried mainline kernels.
There are 11 other persons affected (and other hundred affected present in the gma500 megathread in the ubuntu forum).

Jus tell me what else I need to do instead of changing the bug status.

description: updated

Lucazade, thank you for testing both Precise and Mainline. Could you please attach a faulty boot up log with vt.handoff=7 enabled following https://wiki.ubuntu.com/DebuggingKernelBoot ?

Changed in linux (Ubuntu):
importance: Undecided → Low
status: Incomplete → Triaged
status: Triaged → Incomplete
tags: added: precise
tags: added: i386
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
importance: Low → High
tags: added: kernel-key

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-20.33
tags: added: bot-stop-nagging
Lucazade (lucazade) wrote :

@penalvch
attached my /var/log directory with vt.handoff enabled.. I haven't found any clear evidence of the issue in the logs.
that's why i've attached the whole dir.

Marking Invalid for upstream task only as vt.handoff is a downstream only kernel parameter.

Changed in linux (Ubuntu):
status: Incomplete → Triaged
tags: removed: kernel-request-3.2.0-20.33
Changed in linux:
status: New → Invalid
Andy Whitcroft (apw) wrote :

We believe that the recent grub2 changes will have allowed this not to be specified when the card is marked as blacklisted. As PSB does not work with that we should get it added to the grub blacklist. For that you will need the PCI IDs for all of the affected cards.

Lucazade (lucazade) wrote :

list of PCI IDs for psb_gfx module:

$ modinfo psb_gfx
filename: /lib/modules/3.0.0-19-generic-pae/kernel/drivers/staging/gma500/psb_gfx.ko
license: GPL
description: drm driver for the Intel GMA500
author: Intel Corporation
srcversion: C313C6C303ECDA07557A56D
alias: pci:v00008086d00004107sv*sd*bc*sc*i*
alias: pci:v00008086d00004106sv*sd*bc*sc*i*
alias: pci:v00008086d00004105sv*sd*bc*sc*i*
alias: pci:v00008086d00004104sv*sd*bc*sc*i*
alias: pci:v00008086d00004103sv*sd*bc*sc*i*
alias: pci:v00008086d00004102sv*sd*bc*sc*i*
alias: pci:v00008086d00004101sv*sd*bc*sc*i*
alias: pci:v00008086d00004100sv*sd*bc*sc*i*
alias: pci:v00008086d00008109sv*sd*bc*sc*i*
alias: pci:v00008086d00008108sv*sd*bc*sc*i*
depends: drm,drm_kms_helper,video,i2c-algo-bit
staging: Y
vermagic: 3.0.0-19-generic-pae SMP mod_unload modversions 686
parm: debug:Enable debug output (int)
parm: no_fb:Disable FBdev (int)
parm: trap_pagefaults:Error and reset on MMU pagefaults (int)

I believe the most common are btw 8086:8108 and 8109 because are employed in the Intel GMA500 netbooks.

tags: added: blocks-hwcert-enablement
Andy Whitcroft (apw) wrote :

Ok in the latest precise kernels this flag will be removed automatically for any blacklisted device. As pulsbough cannot handle handoff this will need adding to the blacklists. Can someone supply a list of affected PCI ids so we can get this added.

Andy Whitcroft (apw) wrote :

Ahh didn't see the previous list. Can we confirm all of those are affected, or should we start with just the 8108 and 8109.

Andy Whitcroft (apw) on 2012-05-22
Changed in grub-gfxpayload-lists (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
importance: Undecided → Medium
importance: Medium → High
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Triaged → Invalid
Changed in grub-gfxpayload-lists (Ubuntu):
status: New → In Progress
bodhi.zazen (bodhi.zazen) wrote :

Andy - Thank you for following through on this. Please note that this may well be resolved on kernel 3.4 (it is for me and many others).

Andy Whitcroft (apw) wrote :

Ok. I have put together a test package to disable vt handoff by default for the Pulsbough based systems. If those of you who are affected by this could reinstate the normal grub configuration and install the packages at the URL below and see if they correctly disable vt handoff for you. Please report any testing here:

    http://people.canonical.com/~apw/lp914311-precise/

Thanks!

Andy Whitcroft (apw) wrote :

@bodhi -- interesting ... i will make sure we only do this for precise then, assuming the testing is positive.

Lucazade (lucazade) wrote :

@Andy Whitcroft (apw)
thanks for the testing package.. going to try it as soon as I go back home on my Acer751h.

Yes, I believe 8108 and 8109 are enough for the poulsbo chipsets out there.. they are for the gma500, the others are for gma600 and Medfield variants (usually not netbook but embedded devices).

I don't know if kernel 3.4 might solve the issue without blacklisting the pci ids, I'll try it more in depth because I've already installed it via xorg-edgers ppa (along side new xorg-mesa bits). Alan Cox, the gma500_gfx author, is aware of the vt.handoff and plymouth issue so he had probably solved in the latest kernel builds.

I'll let you know soon :)

Andy Whitcroft (apw) wrote :

@lucazade -- sounds great thanks ...

James M. Leddy (jm-leddy) wrote :

Additionally, these PCIIDs should be added to cover cedarview machines:

v8086d0bef.*
v8086d0bee.*
v8086d0bed.*
v8086d0bec.*
v8086d0beb.*
v8086d0bea.*
v8086d0be9.*
v8086d0be8.*
v8086d0be7.*
v8086d0be6.*
v8086d0be5.*
v8086d0be4.*
v8086d0be3.*
v8086d0be2.*
v8086d0be1.*
v8086d0be0.*

Andy Whitcroft (apw) wrote :

@lucazade -- any luck with testing this?

Lucazade (lucazade) wrote :

@apw

going to try it today.. I was really busy this period!

Lucazade (lucazade) wrote :

@apw
reinstalled kubuntu 12.04 from scratch and then, after first bootup, I've applied your package.
It fixes completely the startup process and there is no need of manual tuning like in the past..

really thanks...

btw I don't know if gma500_gfx, included in kernel 3.4, will work well with vt.handoff or it will require
this fix as well.. we'll see in ubu 12.10 :)

Lucazade (lucazade) wrote :

any eta for integration in ubuntu repositories?

nicklasb (nicklasb) wrote :

I tried the package on an existing installation, and it seems to have solved my problems as well.

Lucazade (lucazade) wrote :

this fix is no more needed in Quantal.. it is necessary to install xserver-xorg-video-modesetting and there are no more conflicts with vt.handoff and plymouth.

Is it possible to include this package in the default installation?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers