Ubuntu

Intel HD Graphics "No Device Detected"

Reported by Gustavo Spadari on 2012-01-05
54
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

Intel HD Graphics is not recognized by kernel 3.0.0.14. Other kernels I've tried on Ubuntu 11.10:
2.6.39
3.0.0.12
3.1.4
3.1.6

All of them must be started with "nomodeset". If this is not done, I get a black screen. With nomodeset the display can run at 1280x1024, with vesa driver. It's a full HD display and is supposed to run at 1920x1080.
With "nomodeset" and with a xorg.conf using "intel" driver, when X starts I get "no device detected" error, falling back to console.

I've tried lastest version of other distros with the same result: OpenSUSE 12.1, Fedora 16, Bodhi 1.3, Ubuntu Precise 12.04 alpha,
CentOS 6.2, Extix 9, and i don't remember if anyone else.

I've tried too the 3.2 rc4 and rc7 kernel on Ubuntu 11.10, and those works better: nomodeset is not needed and I get full 1920x1080 resolution, but it's very unstable because the video turns off and on constantly (or turns into black), about 5 seconds each.

I've read in a lot of forums that the Intel HD Graphics are supported since 2.6.3x kernel, and must work ok too with 3.x, but it is failing with this specification.

Even I tried the http://ppa.launchpad.net/glasen/intel-driver as suggested in several forums.

cat /proc/version_signature ---> Ubuntu 3.0.0-14.23-generic 3.0.9

sudo lspci -vk
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
 Subsystem: Dell Device 0511
 Flags: bus master, fast devsel, latency 0, IRQ 46
 Memory at fe000000 (64-bit, non-prefetchable) [size=4M]
 Memory at d0000000 (64-bit, prefetchable) [size=256M]
 I/O ports at f000 [size=64]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
 Capabilities: [d0] Power Management version 2
 Capabilities: [a4] PCI Advanced Features
 Kernel modules: i915

sudo lshw -C video
  *-display UNCLAIMED
       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:fe000000-fe3fffff memory:d0000000-dfffffff ioport:f000(size=64)

The machine is a DELL INSPIRON ALL IN ONE 2320 i3 2100 CPU

One post to have a read is: http://www.grputland.com/2011/12/ubuntu-1204-alpha-1-sandy-bridge.html
It is the same problem as I describe it here.

Thanks

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-14-generic 3.0.0-14.23
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
Uname: Linux 3.0.0-14-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gspadari 1751 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xfe500000 irq 47'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,10280511,00100202'
   Controls : 14
   Simple ctrls : 10
Date: Thu Jan 5 13:42:39 2012
HibernationDevice: RESUME=UUID=d472e32e-08ee-4a81-a4d6-d546e293ca74
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Dell Inc. Inspiron One 2320
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-14-generic root=UUID=27b16ee7-81be-4a30-9fe2-4b0ebaeb379d ro quiet splash i915.i915_enable_rc6=1 nomodeset acpi_osi=Linux vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-14-generic N/A
 linux-backports-modules-3.0.0-14-generic N/A
 linux-firmware 1.60
SourcePackage: linux
StagingDrivers: rts5139 mei
UpgradeStatus: No upgrade log present (probably fresh install)
WifiSyslog:

dmi.bios.date: 12/22/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: 03KPVW
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 13
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 20147321890_1
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd12/22/2011:svnDellInc.:pnInspironOne2320:pvr00:rvnDellInc.:rn03KPVW:rvrA00:cvnDellInc.:ct13:cvr20147321890_1:
dmi.product.name: Inspiron One 2320
dmi.product.version: 00
dmi.sys.vendor: Dell Inc.

Gustavo Spadari (gspadari) wrote :
affects: linux-meta (Ubuntu) → linux (Ubuntu)
Brad Figg (brad-figg) on 2012-01-05
Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: oneiric
Joseph Salisbury (jsalisbury) wrote :

Can you post the last kernel version where you didn't have this issue?

Changed in linux (Ubuntu):
importance: Undecided → Medium
Gustavo Spadari (gspadari) wrote :

Joseph,
It was 3.2.0-030200rc4 downloaded from:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-rc4-oneiric/

With this kernel, Ubuntu boots in HD resolution (without nomodeset) and I reach to login screen also with 1920x1080. The drawback, besides it's a no stable kernel, is that the screen starts to flash. I mean, it turns completly off or black, and then it's back to Ubuntu 11.10 splash display with the dots changing from white to red, and after a few seconds, it turns off again, and a few more seconds gets back to the display, maybe the login screen or the splash Ubuntu I mention before. If I log in, this behaivior continues, even in a console mode (ctrl+alt+f1 for ex.).
I hope I have explained it well. If not, please tell me and I try to explain it again. If someone of your team speaks spanish, I can describe it more precisely in that language.

Thanks.

Gustavo Spadari (gspadari) wrote :

Today I've tested 3.0.0.15 and the problem persists.
Thanks.

Gustavo Spadari (gspadari) wrote :

Today I've tested the beta 1 Live CD, and the behavior was the same as described in comment #3. Another issue that happened was that the mouse was moving really slow.

Problem persists in 3.0.0-16 x86_64 version.

Gustavo Spadari (gspadari) wrote :

Maybe it helps to developers: I've tested also Fedora-17-Alpha-x86_64-Live-Desktop.iso and the behaivor is te same as comment #5.

Gustavo Spadari (gspadari) wrote :

I've tested the Live DVD "Sabayon_Linux_8_amd64_G.iso" and I get the same behaivor as comment #5.

Is this a kernel problem or an Intel video driver problem?

Anyone out there with similar architecture / features has the system working without issues?

Any other thing I can do to help solve this out?

Thanks

Looks like this is a driver bug. The release of Feb-23-2012 fixed many related issues. Looks like the driver was built on linux 3.2.x version.

Probably just a matter of packaging with the proper driver version. Meanwhile Linux 3.2.9 seems to have been released on released on 2012-03-02. I couldn't find which version of driver they are shipping with due to my limited knowledge about c programming.

http://intellinuxgraphics.org/2012.02.html

Thanks

Gustavo Spadari (gspadari) wrote :

Problem persists on "ubuntu-12.04-beta2-dvd-amd64.iso", but only "blinking screen"; the mouse seems to move normally.

Gustavo Spadari (gspadari) wrote :

I've upgraded to 12.04 rc, and the problem persists.
- Blinking seems to be more stable, like 10 sec or 20 sec.
- Mouse moves really slow

Have tried some kernel params with no luck.

Anyone out there is running Ubuntu without problems in HD resolution using an embedded Sandy Bridge video?

Thanks!

Gustavo Spadari (gspadari) wrote :

Problem is present on archlinux-2012.04.12_16-00-01-testing-core-x86_64.iso too.

I've also tried this:
http://www.kubuntuforums.net/showthread.php?56790-HOW-TO-Install-experimental-X-Org-and-the-latest-graphics-drivers
no luck.

Here is a very usefull information:
http://www.debianuserforums.org/viewtopic.php?f=56&t=1586&start=20

Other things I've tried without luck:
http://ubuntuforums.org/showthread.php?t=1817374

A workarround in some environments (not mine):
http://cquirke.blogspot.com.ar/2011/10/mintlinux-sandy-bridge-blank-screen.html
Maybe it's usefull to someone out there...

Some Kernel params I've tried:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1 i915.i915_enable_rc6=1 i915.semaphores=1 i915.panel_ignore_lid=1 i915.i915_enable_fbc=1 acpi_osi=linux pci=noacpi acpi=off"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1 video=LVDS-1:e acpi_osi=\"Linux\""
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1 i915.fbpercrtc=0 i915.panel_ignore_lid=0 i915.i915_enable_fbc=-1 i915.lvds_downclock=0 i915.lvds_use_ssc=-1 i915.vdt_sdvo_panel_type=-1 i915.i915_enable_rc6=-1 i915.powersave=1 i915.semaphores=1"
Of course... none of them worked.

In all these tests I've notice that the mouse oves really slow.

I'm going to download:
- http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-fixes/current/
and
- http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-experimental/current/
And try them.

tags: added: precise sandybridge
Gustavo Spadari (gspadari) wrote :

Tested:
- http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-fixes/current/
Didn't work. Black screen with some flashes on boot. But at login only black screen.
- http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-experimental/current/
Didn't work. Black screen with some flashes.
- linuxmint-12-gnome-cd-nocodecs-64bit.iso
Boot on main text mode selection, and after that, only black screen.

Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Gustavo Spadari (gspadari) wrote :

Thanks Joseph. I did a little search and found this:
https://bugzilla.kernel.org/show_bug.cgi?id=39532

I believe that the origin of the issue is the same as my report.

How can I link this bug to the BZ report? (can I do it?)

Low resolution problem persists with 12.04 LTS on ASUS U46E. Haven't tested with nomodeset removed.

Gustavo Spadari (gspadari) wrote :

Hi venkat, have you tried without nomodeset? Can you confirm if it works for you or not with the new LTS?

Gustavo Spadari (gspadari) wrote :

Joseph: I've created a new bug report on BZ Kernel: https://bugzilla.kernel.org/show_bug.cgi?id=43181
(The other one (39532) was not precise)
Thanks.

Gustavo

             I removed both nomodeset and nolapic, I am able to bootup, set highest resolution and use dual monitors right now. I am using Kubuntu 12.04 LTS with Linux 3.2.0-24-generic.

I still seem to need noapic. If I remove the noapic boot option, screen freezes on a grey screen after selecting which OS to launch different from what I saw previously. This time there is not blinking cursor with a black backround. Not sure if this is related to this bug, but I thought I'll just record it here.

I have kubuntu LTS installed on ASUS U456E all by itself, no other operating systems along with it.

Thanks
Venkat

1guess (ubuntu1-1guess) wrote :

I have Dell Vostro 460 with i7-2600 and NVIDIA GeForce GT 530 and experience the same issue of blinking cursor.
As an example I tried a number of GParted live disks and only 0.9.0-6 would display but the others I tried 0.10.0-3, 0.11.0-10, 0.12.0-2, 0.12.0-5 failed to provide a display.

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Gustavo Spadari (gspadari) wrote :

It's working if I turn on the PC (I mean no reboot) and start with only
"drm_kms_help.poll=0".
If I reboot, the screen starts to turn on and off.

I'll be doing more tests on next days.

Gustavo Spadari (gspadari) wrote :

Sorry: the param is "drm_kms_helper.poll=0"

Changed in linux:
status: Confirmed → Incomplete
Marin (siderov-m) wrote :
Download full text (8.0 KiB)

I can confirm the same issue with Ubuntu 12.04 LTS

marin@blackbox:~$ uname -a
Linux blackbox 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
marin@blackbox:~$ sudo lspci -vk
[sudo] password for marin:
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
 Subsystem: Hewlett-Packard Company Device 166f
 Flags: bus master, fast devsel, latency 0
 Capabilities: [e0] Vendor Specific Information: Len=0c <?>
 Kernel driver in use: agpgart-intel

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
 Subsystem: Hewlett-Packard Company Device 166f
 Flags: bus master, fast devsel, latency 0, IRQ 43
 Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
 Memory at b0000000 (64-bit, prefetchable) [size=256M]
 I/O ports at 4000 [size=64]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
 Capabilities: [d0] Power Management version 2
 Capabilities: [a4] PCI Advanced Features
 Kernel modules: i915

00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
 Subsystem: Hewlett-Packard Company Device 166f
 Flags: bus master, fast devsel, latency 0, IRQ 42
 Memory at c2604000 (64-bit, non-prefetchable) [size=16]
 Capabilities: [50] Power Management version 3
 Capabilities: [8c] MSI: Enable+ Count=1/1 Maskable- 64bit+
 Kernel driver in use: mei
 Kernel modules: mei

00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05) (prog-if 20 [EHCI])
 Subsystem: Hewlett-Packard Company Device 166f
 Flags: bus master, medium devsel, latency 0, IRQ 16
 Memory at c2609000 (32-bit, non-prefetchable) [size=1K]
 Capabilities: [50] Power Management version 2
 Capabilities: [58] Debug port: BAR=1 offset=00a0
 Capabilities: [98] PCI Advanced Features
 Kernel driver in use: ehci_hcd

00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
 Subsystem: Hewlett-Packard Company Device 166f
 Flags: bus master, fast devsel, latency 0, IRQ 44
 Memory at c2600000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: [50] Power Management version 2
 Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
 Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
 Capabilities: [100] Virtual Channel
 Capabilities: [130] Root Complex Link
 Kernel driver in use: snd_hda_intel
 Kernel modules: snd-hda-intel

00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5) (prog-if 00 [Normal decode])
 Flags: bus master, fast devsel, latency 0
 Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
 Memory behind bridge: c2500000-c25fffff
 Capabilities: [40] Express Root Port (Slot+), MSI 00
 Capabilities: [80] MSI: Enable- Count=1/1 Maskable- 64bit-
 Capabilities: [90] Subsystem: Hewlett-Packard Company Device 166f
 Capabilities: [a0] Power Management version 2
 Kernel driver in use: pcieport
 Kernel modules...

Read more...

Gustavo Spadari (gspadari) wrote :

I've upgraded to 12.10 and now it works OK. There is no need for using drm_kms_helper.poll=0.
Thanks!
(PD: Do I have to close the bug reports?)

Changed in linux:
status: Incomplete → Fix Released

Gustavo Spadari, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/912397/comments/24 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

tags: added: bios-outdated-a10
removed: i915 intel kernel sandybridge vesa
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.