Ubuntu

Ubuntu 11.10 USB problem on Msi u270

Reported by Rajabi on 2011-11-06
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

hi
i have an msi u270
config:
AMD E-450 (APU)
ram 4g
hard 500g

I installed the ubuntu 11.10 on it.

Sometimes i get a problem that my laptop can't recognize usb disk(dont detect Cooldisk or have I/O error) . i think it's a bug in new version.

I updated kernel to 3.0.0.13-22 , So i updated all package . but no solve

Please report this bug

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: SB [HDA ATI SB], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 3437 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Generic'/'HD-Audio Generic at 0xfeb44000 irq 45'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card1.Amixer.info:
 Card hw:1 'SB'/'HDA ATI SB at 0xfeb40000 irq 16'
   Mixer name : 'Realtek ALC269VB'
   Components : 'HDA:10ec0269,14621096,00100100'
   Controls : 16
   Simple ctrls : 10
CasperVersion: 1.287
DistroRelease: Ubuntu 11.10
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Micro-Star International Co., Ltd. U270 series
Package: linux (not installed)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-12-generic N/A
 linux-backports-modules-3.0.0-12-generic N/A
 linux-firmware 1.60
StagingDrivers: rts5139
Tags: oneiric running-unity staging
Uname: Linux 3.0.0-12-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 06/24/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: E1245AMS.10J
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: MS-1245
dmi.board.vendor: Micro-Star International Co., Ltd.
dmi.board.version: Ver 1.000
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 10
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrE1245AMS.10J:bd06/24/2011:svnMicro-StarInternationalCo.,Ltd.:pnU270series:pvrE1245AMS.10J:rvnMicro-StarInternationalCo.,Ltd.:rnMS-1245:rvrVer1.000:cvnToBeFilledByO.E.M.:ct10:cvrToBeFilledByO.E.M.:
dmi.product.name: U270 series
dmi.product.version: E1245AMS.10J
dmi.sys.vendor: Micro-Star International Co., Ltd.

affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 886845

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: oneiric

apport information

tags: added: apport-collected running-unity staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Rajabi (rajabi048) wrote : Lspci.txt

apport information

Rajabi (rajabi048) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Rajabi (rajabi048) wrote :

I installed ubuntu 11.04 after this bug,
i run " apport-collect 886845 " on ubuntu 11.10 live-cd .

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Yes, this problem had appeared on my U270 too. Device '/dev/sdb' disables randomly when i am trying to mount it or copy something on it. It happened after updating from 2.6.xx to 3.xx kernel. There was no problem in Ubuntu 11.04.

Joseph Salisbury (jsalisbury) wrote :

Are you seeing kernel panics when this issue happens? If so, this could be a dup of bug 844957

If your issue is similar to bug 844957, can you try the test kernel listed in comment #20 of that bug?

Rajabi (rajabi048) wrote :

how to fix this bug?

Rajabi (rajabi048) wrote :

:((

It seems to me that i have solved this bug by installing one of the lattest version of kernel ( 3.1.0 - 030100 ) from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1-oneiric/ . See what will happen next ...

Rajabi (rajabi048) wrote :

hello, how to install kernel 3.1.0 on ubuntu 11.10?

Hello,

to workaround this bug on already installed system you can install
kernel 3.1 (as Alex wrote) or 2.6.38-12 (from natty) and remove 3.0.0
(it helps - I wrote it earlier in bug description). Point is lots of
users still can't install ubuntu 11.10 on netbooks (it requires the
inst. process to be carried from usb stick) unless they upgrading
previous version 11.04. It's because installation process hangs
somewhere in the middle caused by disconnected usb stick - in install
image there is still 3.0.0-X kernel....

greetings,
Jacek Siutkowski

On Wed, 2011-11-09 at 17:13 +0000, Александр Стручков wrote:
> It seems to me that i have solved this bug by installing one of the
> lattest version of kernel ( 3.1.0 - 030100 ) from
> http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1-oneiric/ . See what
> will happen next ...
>

Rajabi (rajabi048) wrote :

when ubuntu fix this bug on kernel 3.0.x?
i thing fix bug with ubuntu updater , it is better.

valdi (informatyk74) wrote :

On my u270 blacklist module rts5139 (card reader) solved the problem with USB. There is not module rts5139 on kernel 2.6.38.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Rajabi (rajabi048) on 2012-06-17
Changed in linux (Ubuntu):
status: Fix Released → Confirmed

Rajabi, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete

Hi all ! This bug is still affects me. But i noticed, that when i use Fedora with any kernel versions, it works well without 'rts5139.blacklist = yes' option. Maybe it depends on some distro-specified kernel patches or other components, such us upstart/systemd.
P. S. I also tried OpenSUSE and Sabayon - they have the same issue with USB. And they both don't use systemd.

Sorry, i wrote that openSUSE don't use systemd, but it does.

Alexander Struchkov, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette

When opening up the new report, please feel free to subscribe me to it. Thank you for your understanding.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions