Ubuntu

Comment 5 for bug 886521

Boris Derzhavets (bderzhavets) wrote :

> We have noted that there is a newer version of the development kernel than the
>one you last tested when this
> issue was found.
> Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

I did all testing with the the most recent 3.1 Ubuntu's kernel in Dom0 and HVM DomU as well.
I am just saying that CONFIG_XEN_PLATFORM_PCI should be equal "y" as on Fedora 16 for instance.
Please , see how RH's development tuned mainstream kernel for Fedora 16. That's an excellent sample.

You might loose option loading Precise in PVHVM domain, because not every customer can rebuild
kernel in Ubuntu style, e.g. reproduce :-
http://blog.avirtualhome.com/2011/10/28/how-to-compile-a-new-ubuntu-11-10-oneiric-kernel/
what I did to load PV-on-HVM. I will attach dmesg report for PVHVM domain loaded with 3.1 Ubuntu's
kernel having hard linked xen-platform-pci driver for better understanding what i am talking about.
Extract from dmesg report at PVHVM DomU :-

[ 0.000000] DMI: Xen HVM domU, BIOS 4.1.2 10/23/2011
[ 0.000000] Hypervisor detected: Xen HVM
[ 0.000000] Xen version 4.1.
[ 0.000000] Xen Platform PCI: I/O protocol version 1
[ 0.000000] Netfront and the Xen platform PCI driver have been compiled for this kernel: unplug emulated NICs.
[ 0.000000] Blkfront and the Xen platform PCI driver have been compiled for this kernel: unplug emulated disks.
[ 0.000000] You might have to change the root device
[ 0.000000] from /dev/hd[a-d] to /dev/xvd[a-d]
[ 0.000000] in your root= kernel command line option