8086:0885 Intel 6150 does not work in Oneiric

Bug #886231 reported by TonyLudwick on 2011-11-04
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

ASUS U56E BBL6 w/Ubuntu 11.10 64 bit.
Intel Corporation Centrino Wireless-N + WiMAX 6150 [8086:0885] (rev 67)

Wireless scans, does not connect.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-12-generic 3.0.0-12.20
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: guestuser 1780 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xdfc00000 irq 52'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10ec0269,10431bd3,00100100 HDA:80862805,80860101,00100000'
   Controls : 18
   Simple ctrls : 10
Date: Fri Nov 4 11:56:05 2011
HibernationDevice: RESUME=UUID=3a8f509f-4399-41f6-87d5-72a11c89816e
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: ASUSTeK Computer Inc. U56E
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=4378dac9-b7d4-4446-bac0-8a68c1878716 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-12-generic N/A
 linux-backports-modules-3.0.0-12-generic N/A
 linux-firmware 1.60
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/26/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: U56E.208
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: U56E
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrU56E.208:bd07/26/2011:svnASUSTeKComputerInc.:pnU56E:pvr1.0:rvnASUSTeKComputerInc.:rnU56E:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: U56E
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

TonyLudwick (tonyludwick) wrote :
komputes (komputes) on 2011-11-04
summary: - 6150
+ Intel 6150 does not work in Oneiric
description: updated

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed
Charles Profitt (cprofitt) wrote :

I had the same issue on a Lenovo V570:

I entered the following command to test:

sudo rmmod -f acer-wmi

after running the command wireless worked.

If that works blacklist the acer-wmi

sudo su
echo "blacklist acer-wmi" >> /etc/modprobe.d/blacklist.conf
exit

Johannes Berg (johannes-berg) wrote :

I don't think this is a duplicate. If acer-wmi helps, then maybe this is rfkill related...

Johannes Berg (johannes-berg) wrote :

Hm, ok the rfkill info doesn't show that rfkill is messing with it, but I have no explanation for the acer-wmi issue thing otherwise (though of course that's not from the original submitter...)

So, Charles's issue could be rfkill, which would make it different.

geoffm (geoffm-companionway) wrote :

Dec 21 2011 - affects me too - I can "see" all the wifi signals but can't connect. Tried all rfkill changes, done all the updates possible - even in 12.04 - everything I read says it is a kernel problem with 3.x. If anyone comes across a solution let us know. The bug here shows that it is still "unassigned".

summary: - Intel 6150 does not work in Oneiric
+ 8086:0885 Intel 6150 does not work in Oneiric
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers