vga_switcheroo makes system freeze

Bug #881132 reported by Wim Goeman on 2011-10-24
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
High
linux (Ubuntu)
Medium
Unassigned

Bug Description

I am working with a new HP PC (dv7) which supports Hybrid Graphics in terms of the intel graphics and radeon graphics (as can bee found in lspci).

Currently I am only working with the Intel integrated graphics, and both adapters are powered on.

My goal was to deactivate the intel graphics and activate the radeon graphics, as the machine is plugged in to the power supply most of the time. To achieve this I tried the following:

cat /sys/kernel/debug/vga_switcheroo/switch
--> shows both cards are powered on and IGD is in use (the intel card)
echo DIS > /sys/kernel/debug/vga_switcheroo/switch
--> gives an error message because X is still running
I kill the X session
echo DIS > /sys/kernel/debug/vga_switcheroo/switch
After this command the system freezes completely. No warning or error, no blinking cursor, nothing. I have to power off using the power button.

Any suggestions on how to fix this are welcome. Is this a bug in the kernel?

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-12-generic 3.0.0-12.20
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: wim 1617 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xc7500000 irq 51'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:111d7605,103c1659,00100105 HDA:80862805,80860101,00100000'
   Controls : 18
   Simple ctrls : 10
Date: Mon Oct 24 23:55:59 2011
HibernationDevice: RESUME=/dev/sda3
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Hewlett-Packard HP Pavilion dv7 Notebook PC
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=71fb680e-ac18-42aa-86fb-4618d70b3895 ro quiet splash modeset=1 hybridopts=ON,DIS,OFF vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-12-generic N/A
 linux-backports-modules-3.0.0-12-generic N/A
 linux-firmware 1.60
SourcePackage: linux
StagingDrivers: rts_pstor mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/20/2011
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.1A
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1659
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 10.31
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.1A:bd07/20/2011:svnHewlett-Packard:pnHPPaviliondv7NotebookPC:pvr058F110000244610000620100:rvnHewlett-Packard:rn1659:rvr10.31:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Pavilion dv7 Notebook PC
dmi.product.version: 058F110000244610000620100
dmi.sys.vendor: Hewlett-Packard

Wim Goeman (wimgoeman) wrote :
Brad Figg (brad-figg) on 2011-10-24
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . If possible, please test the latest release candidate kernel (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the others). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.1-rc9 fixed and issue, the tag would be: 'kernel-fixed-upstream-v3.1-rc9'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Thanks in advance.

tags: added: needs-upstream-testing
ubik (m-beigert) wrote :

I've got the same problem on Lenovo G-770. It has also integrated Intel 3000 HD and discrete AMD Raden HD 6650M. When i do

echo DIS > /sys/kernel/debug/vga_switcheroo/switch

system freezes.

When I try:

echo DDIS > /sys/kernel/debug/vga_switcheroo/switch

and restart X, then the system also freezes.

I've tried Kernel v3.1-rc10-oneiric from your

ubik (m-beigert) wrote :

Additional comment:

Xorg.log doesn't show anything, it's empty.

Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Wim Goeman (wimgoeman) wrote :

I also tested v3.1-rc10-oneiric just for the record. Same result.

bugzilla.kernel.org seems to be down though. So I guess we need to wait until they are back online? Once they are back I will open a bug report there, and link back.

Joseph Salisbury (jsalisbury) wrote :

Yes, it appears that bugzilla.kernel.org is still unavailable. One alternative would be to report this directly to the subsystem maintainer or to the Linux Kernel Mailing List - <email address hidden>

Changed in linux (Ubuntu):
importance: Undecided → Medium
ubik (m-beigert) wrote :

Wim Goeman, could you do that? It's very tricky for me to go through this mailing list.

Wim Goeman (wimgoeman) wrote :

I have reported this bug on the <email address hidden> mailing list just now, and referred to this bug. So we will see what happens next.

Wim Goeman (wimgoeman) wrote :

Seems like the bufzill

Wim Goeman (wimgoeman) wrote :

Seems like the bugzilla of kernel.org is back online. This issue has been reported:
https://bugzilla.kernel.org/show_bug.cgi?id=42824

Maarten Bezemer (veger) wrote :

Thanks for taking the time to report this bug in the upstream bug tracking system this is a tremendous help. Launchpad has the ability to watch lots of upstream bug trackers and this can be done by following the procedure documented at https://wiki.ubuntu.com/Bugs/Watches. I've added the bug watch for this bug report.

Changed in linux:
importance: Unknown → High
status: Unknown → Confirmed

Wim Goeman, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc1

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: needs-full-computer-model needs-upstream-testing
Changed in linux (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.