[Regression]Mic doesn't work on Compaq Presario CQ60

Bug #880399 reported by Ricardo Almeida on 2011-10-23
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Linux
Unknown
Unknown
linux (Fedora)
New
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

The microphone doesn't work on kernel 3.0 that is shipped with Ubuntu 11.10.

Installing kernel linux-image-2.6.39-02063904-generic_2.6.39-02063904.201108040905_i386 from http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.39.4-oneiric/ solves the microphone bug (altough nvidia graphic drivers don't work :( so not really a good work-around).

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: alsa-base 1.0.24+dfsg-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu3
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: NVidia [HDA NVidia], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ralmeida 1654 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xc0000000 irq 20'
   Mixer name : 'Nvidia MCP77/78 HDMI'
   Components : 'HDA:14f15051,103c360a,00100000 HDA:10de0002,10de0101,00100000'
   Controls : 15
   Simple ctrls : 11
Date: Sun Oct 23 15:54:51 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaRecordingTest: ALSA recording test through plughw:NVidia failed
Symptom_Card: Internal Audio - HDA NVidia
Symptom_DevicesInUse:
 1654/dev/snd/controlC0: ralmeida F.... pulseaudio
 AND
Symptom_Jack: Mic, Internal
Symptom_Type: No sound at all
Title: [Compaq Presario CQ60 Notebook PC, Conexant CX20561 (Hermosa), Mic, Internal] No sound at all
UpgradeStatus: Upgraded to oneiric on 2011-10-15 (7 days ago)
dmi.bios.date: 10/17/2008
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.31
dmi.board.name: 303C
dmi.board.vendor: Wistron
dmi.board.version: 08.47
dmi.chassis.type: 10
dmi.chassis.vendor: Wistron
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.31:bd10/17/2008:svnHewlett-Packard:pnCompaqPresarioCQ60NotebookPC:pvrF.31:rvnWistron:rn303C:rvr08.47:cvnWistron:ct10:cvrN/A:
dmi.product.name: Compaq Presario CQ60 Notebook PC
dmi.product.version: F.31
dmi.sys.vendor: Hewlett-Packard

Ricardo Almeida (ric-almeida) wrote :
affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . If possible, please test the latest release candidate kernel (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the others). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.1-rc9 fixed and issue, the tag would be: 'kernel-fixed-upstream-v3.1-rc9'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Thanks in advance.

tags: added: needs-upstream-testing
Ricardo Almeida (ric-almeida) wrote :
tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
tags: added: regression-release
Matt Sturgeon (mattsturgeon) wrote :

I can also confirm this bug on the Compaq Presario CQ60.

Booting with kernal 2.6.39.4-oneiric fixes the microphone bug, I would be interested to see if it also fixed the same issue I'm having on my sister's Samsung N110...

summary: - Mic doesn't work on Compaq Presario CQ60
+ [Regression]Mic doesn't work on Compaq Presario CQ60
Daniel (danhab2000) wrote :

Don't know how to post full log as OP, but I have same issue with HP G60-445DX. Only posting here because its the same Nvidia MCP77/78 HDMI, so didn't feel that it needs its own thread.

Matt Sturgeon (mattsturgeon) wrote :
tags: added: kernel-sound
removed: i386 running-unity
Daniel (danhab2000) wrote :

@Matt Sturgeon thanks for the link. Will update shortly. Would also like to add that mic was working fine before the upgrade (was using 11.04, then upgraded to 11.10). I *do* remember though, that when first running ubuntu (11.04), i had to run alsamixer (in terminal), and raise volume of mic-input. That trick doesn't do the job with ubuntu 11.10 (and i also see it gets reset after each reboot).

Matt Sturgeon (mattsturgeon) wrote :

This bug appears to be *partially* fixed in the latest precise updates (kernel 3.2.0-16-generic).

External microphones (using internal ALSA card) work, however the built in microphone (same card) continues not to work.

David Wood (davidwood-x) wrote :

Microphone worked in 11.04 but not 11.10.

Mezgrman (mezgrman-o) wrote :

Are there any updates on this bug? I'm still using the 2.6.38-13 kernel to keep my microphone working.

tags: added: needs-full-computer-model needs-upstream-testing

Ricardo Almeida, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder, but the one all the way at the bottom) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.12

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Triaged → Incomplete

apport information

tags: added: apport-collected qiana
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Ricardo Almeida (ric-almeida) wrote :

I tried to install kernel 3.16 from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.16-utopic/ but the nvidia kernel module didn't compile against it. Attached make.log...

Ricardo Almeida, please do not apport-collect with linuxmint (which is not Ubuntu, nor the scope of this report).

tags: removed: apport-collected qiana
description: updated
Ricardo Almeida (ric-almeida) wrote :

Sorry, I installed Mint on the laptop... Since it's Ubuntu-based and it's a kernel issue, I thought there wasn't any problem.. I can confirm that installing kernel 2.6.39-02063904-generic fixes the issue with the Mic.

Raymond (superquad-vortex2) wrote :

https://git.kernel.org/cgit/linux/kernel/git/tiwai/sound.git/commit/sound/pci/hda?id=1812e67c7410c8d0d57f14a3dc81a99bd5b30e3e

even cxt_5051_hp model work but still cannot confirm which node is internal Mic and external Mic since unsol event were enabled on two nodes

you have to find out the external mic by hda-jack-sense-test or hda analyzer

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.