[Thinkpad T420s] MMC Reader has issues with SDHC (SD and MMC are OK)

Bug #877598 reported by Jeff Lane on 2011-10-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Testing the T420s with Oneiric. The MMC reader appears to have problems with SDHC cards. I tried two known working SDHC cards and both, on this machine, had trouble. I had to insert/remove several times for each before they were mounted. There are lots of weird errors in dmesg/syslog when inserting these SDHC cards.

I also tried SD and MMC cards and both of those were just fine. So this reader only has issues with SDHC.

For the record, both SDHC cards I tried are Kingston Class 4 4GB SDHC cards.

I tried BOTH cards in a Thinkpad X201 and they mounted and unmounted without issue at all.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-12-generic-pae 3.0.0-12.20
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.23-0ubuntu3
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1524 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf2a20000 irq 50'
   Mixer name : 'Conexant CX20590'
   Components : 'HDA:14f1506e,17aa21d2,00100000'
   Controls : 8
   Simple ctrls : 5
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Tue Oct 18 13:01:07 2011
HibernationDevice: RESUME=UUID=6bc921d0-7cac-431f-9846-3d0aba2cc88a
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
MachineType: LENOVO 417024U
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic-pae root=UUID=8091c6fd-1036-47b4-8198-8c15474e7fad ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-12-generic-pae N/A
 linux-backports-modules-3.0.0-12-generic-pae N/A
 linux-firmware 1.60
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/04/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8CET30WW (1.07 )
dmi.board.asset.tag: Not Available
dmi.board.name: 417024U
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8CET30WW(1.07):bd03/04/2011:svnLENOVO:pn417024U:pvrThinkPadT420s:rvnLENOVO:rn417024U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 417024U
dmi.product.version: ThinkPad T420s
dmi.sys.vendor: LENOVO

Jeff Lane (bladernr) wrote :
Brad Figg (brad-figg) on 2011-10-18
Changed in linux (Ubuntu):
status: New → Confirmed
Guilherme Salgado (salgado) wrote :

This seems to be a dupe of bug 773524; the hardware is the same (Ricoh e823). Also note that there's a workaround on that bug, but it's marked as fix released when it doesn't seem to be.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers