Broken X login screen after kernel security update (10/2011)

Bug #873130 reported by Agesp Anonymous on 2011-10-13
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Seth Forshee

Bug Description

SRU Justification

Impact: A regression in the 2.6.32-34 kernel is causing graphics corruption on the Asus A7V-E with nvidia graphics.

Fix: Backport of upstream bug fix for range-restricted allocations in DRM.

Test case: Verified to fix corruption by reporter on LP #873130.

---

The X login screen breaks up in Xubuntu 10.04.3 LTS, after i have upgraded my kernel.

kernel 2.6.32-33-generic worked fine, 2.6.32-34-generic garbled the login screen: No buttons, only the login screen background and panel below, copies of the mouse cursor and some garbage. No text.

I *can* log in by guessing what happens in the screen (no text shown...) - the Xubuntu desktop opens, with background and the panels, but most of the panel widgets are "missing" and I must only guess what should be on screen: something should appear, but nothing can be seen. The terminals (Ctrl+F1...F6) works nicely though.

Possibly affected packages (my guess): linux, xorg, gdm, xfwm4

Temporary fix: By choosing kernel 2.6.32-33 in boot time

Can be reproductable: By choosing kernel 2.6.32-34 in boot time

What changed:
(here is a part of the diff against the new(<) and old(>) version):
(most suspectable diff parts, selected from /var/log: dmesg, messages, debug, daemon.log, syslog, kern.log):

< [TIMESTAMP] Linux version 2.6.32-34-generic (buildd@vernadsky)
 (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #77-Ubuntu SMP
 Tue Sep 13 19:40:53 UTC 2011 (Ubuntu 2.6.32-34.77-generic 2.6.32.44+drm33.19)
---
> [TIMESTAMP] Linux version 2.6.32-33-generic (buildd@zirconium)
 (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #72-Ubuntu SMP
 Fri Jul 29 21:08:37 UTC 2011 (Ubuntu 2.6.32-33.72-generic 2.6.32.41+drm33.18)

< [TIMESTAMP] Kernel command line: BOOT_IMAGE=/vmlinuz-2.6.32-34-generic
 root=UUID=b68f5eec-3aa8-4780-a47e-c3bd1e26389c ro quiet splash
---
> [TIMESTAMP] Kernel command line: BOOT_IMAGE=/vmlinuz-2.6.32-33-generic
 root=UUID=b68f5eec-3aa8-4780-a47e-c3bd1e26389c ro quiet splash

< [TIMESTAMP] [drm] nouveau 0000:01:00.0:
 allocated 1280x1024 fb: 0x45000, bo dfbb9c00
---
> [TIMESTAMP] [drm] nouveau 0000:01:00.0:
 allocated 1280x1024 fb: 0x45000, bo df015800

...
< [TIME] wader kernel: [TIMESTAMP] [drm] nouveau 0000:01:00.0: validate: -12
< [TIME] wader kernel: [TIMESTAMP] [drm] nouveau 0000:01:00.0: validate: -12
< [TIME] wader acpid: client 920[0:0] has disconnected
< [TIME] wader acpid: client connected from 920[0:0]
< [TIME] wader acpid: 1 client rule loaded
< [TIME] wader kernel: [TIMESTAMP] [drm] nouveau 0000:01:00.0: validate: -12
< [TIME] wader kernel: [TIMESTAMP] [drm] nouveau 0000:01:00.0: validate: -12
< [TIME] wader kernel: [TIMESTAMP] [drm] nouveau 0000:01:00.0: validate: -12
< [TIME] wader kernel: [TIMESTAMP] [drm] nouveau 0000:01:00.0: validate: -12
...

(...and continues with ~100 more validate messages...)

The differences in /var/log/Xorg.0.log (and /var/log/gdm/:0.log) between new and old kernel versions:

< Current Operating System: Linux wader 2.6.32-34-generic #77-Ubuntu SMP
 Tue Sep 13 19:40:53 UTC 2011 i686
> Current Operating System: Linux wader 2.6.32-33-generic #72-Ubuntu SMP
 Fri Jul 29 21:08:37 UTC 2011 i686

< Kernel command line: BOOT_IMAGE=/vmlinuz-2.6.32-34-generic
 root=UUID=b68f5eec-3aa8-4780-a47e-c3bd1e26389c ro quiet splash
> Kernel command line: BOOT_IMAGE=/vmlinuz-2.6.32-33-generic
 root=UUID=b68f5eec-3aa8-4780-a47e-c3bd1e26389c ro quiet splash

< (II) NOUVEAU(0): Opened GPU channel 1
< (II) NOUVEAU(0): [DRI2] Setup complete
< (II) NOUVEAU(0): GART: 32MiB available
< (II) NOUVEAU(0): GART: Allocated 16MiB as a scratch buffer

> (II) NOUVEAU(0): Opened GPU channel 1
> (II) NOUVEAU(0): [DRI2] Setup complete
> (II) NOUVEAU(0): GART: 32MiB available
> (EE) NOUVEAU(0): Unable to allocate GART memory

So it looks like, the (currently running) old kernel 2.6.32-33 didn't allocate GART. My best guess is that GART thing was somewhat enabled in new kernel update. It haven't been enabled before, with Xubuntu 10.4 installed, according to previous logs.

And yet, it could be something with my Nvidia RIVA TNT2 graphics card and nouveau kernel driver..?

I'm pretty sure it is the kernel package that causes this problem. I can try uploading /var/log/apt/history.log if needed for more suspects.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-34-generic 2.6.32-34.77
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-33.72-generic 2.6.32.41+drm33.18
Uname: Linux 2.6.32-33-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: AudioPCI [Ensoniq AudioPCI], device 0: ES1371/1 [ES1371 DAC2/ADC]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: agemixer 1269 F.... xfce4-mixer-plu
                      agemixer 1276 F.... pulseaudio
                      agemixer 1304 F.... xfce4-volumed
CRDA: Error: [Errno 2] Tiedostoa tai hakemistoa ei ole
Card0.Amixer.info:
 Card hw:0 'AudioPCI'/'Ensoniq AudioPCI ENS1371 at 0xa000, irq 10'
   Mixer name : 'SigmaTel STAC9721,23'
   Components : 'AC97a:83847609'
   Controls : 36
   Simple ctrls : 23
CurrentDmesg:
 [ 24.276438] [drm] nouveau 0000:01:00.0: Allocating FIFO number 1
 [ 24.278696] [drm] nouveau 0000:01:00.0: nouveau_channel_alloc: initialised FIFO 1
 [ 29.340108] eth0: no IPv6 routers present
Date: Thu Oct 13 02:09:17 2011
HibernationDevice: RESUME=UUID=3fa1b2f0-2ad1-4f9d-83e7-5ec49ee84288
InstallationMedia: Xubuntu 10.04 "Lucid Lynx" - Release i386 (20100429)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Lsusb:
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: System Manufacturer System Name
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.32-33-generic root=UUID=b68f5eec-3aa8-4780-a47e-c3bd1e26389c ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=fi_FI.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34.7
RfKill:

SourcePackage: linux
dmi.bios.date: 03/08/2001
dmi.bios.vendor: Award Software, Inc.
dmi.bios.version: ASUS A7V-E ACPI BIOS Revision 1002D
dmi.board.name: <A7V-E>
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: REV 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 7
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAwardSoftware,Inc.:bvrASUSA7V-EACPIBIOSRevision1002D:bd03/08/2001:svnSystemManufacturer:pnSystemName:pvrSystemVersion:rvnASUSTeKComputerINC.:rn<A7V-E>:rvrREV1.xx:cvnChassisManufacture:ct7:cvrChassisVersion:
dmi.product.name: System Name
dmi.product.version: System Version
dmi.sys.vendor: System Manufacturer

Agesp Anonymous (agespam) wrote :
Brad Figg (brad-figg) on 2011-10-13
Changed in linux (Ubuntu):
status: New → Confirmed
Seth Forshee (sforshee) on 2011-10-13
Changed in linux (Ubuntu):
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → High
Seth Forshee (sforshee) wrote :

I have a suspicion about what's causing your issue. Could you please test the build at the following link and check whether or not it fixes your issue?

  http://people.canonical.com/~sforshee/lp873130/linux-2.6.32-34.77~lp873130v201110131511/

You'll need to download the *_all.deb file and either the *_i386.deb or *_amd64.deb files based on your installation (it looks like you need the i386 files based on the information collected by apport).

Thanks!

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Agesp Anonymous (agespam) wrote :

Yes, this seems to fix the issue. Currently running and as for now everything looks & sounds nice.
I thought that removal of linux-generic and linux-image-generic packages was needed to remove and replace with the test kernel. Was that Ok?

Thanks a lot and keep up the good work!

Seth Forshee (sforshee) on 2011-10-14
Changed in linux (Ubuntu):
status: Incomplete → In Progress
Seth Forshee (sforshee) wrote :

Agesp: No, removal of those packages was not necessary, you just needed to install the ones I provided. I'd suggest reinstalling the packages you removed.

Seth Forshee (sforshee) on 2011-10-14
description: updated
Tim Gardner (timg-tpi) on 2011-10-15
Changed in linux (Ubuntu Lucid):
assignee: nobody → Seth Forshee (sforshee)
status: New → Fix Committed
Changed in linux (Ubuntu):
status: In Progress → Invalid
assignee: Seth Forshee (sforshee) → nobody
importance: High → Undecided
Herton R. Krzesinski (herton) wrote :

This bug is awaiting verification that the kernel in -proposed (2.6.32-36.79) solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-lucid' to 'verification-done-lucid'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-lucid
Piotr Janas (piotr-janas) wrote :

My computer was also affected with this bug, and it's fixed in 2.6.36.79 for me.

uname --all
Linux janosik 2.6.32-36-386 #79-Ubuntu SMP Wed Nov 9 00:23:04 UTC 2011 i686 GNU/Linux

Please don't drop the fix from the source code. Thank you!

tags: added: verification-done-lucid
removed: verification-needed-lucid
Agesp Anonymous (agespam) wrote :

This bug also seems to appear in 2.6.32-35.78 kernel update, similiar to 2.6.32-34.77.

Now running linux-image-2.6.32-36.79 (from proposed) - and seems to work fine. No other bugs recognized yet after some testing. Logs are fine.

Could someone set the tags appropriately if required. (I have no idea of the logic - I'm more like an "end user", really, and English is far off my native language, but i try my best, and spent a lot of hours for all this already.)

Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.32-36.79

---------------
linux (2.6.32-36.79) lucid-proposed; urgency=low

  [Herton R. Krzesinski]

  * Release Tracking Bug
    - LP: #887727

  [ Upstream Kernel Changes ]

  * net_sched: Fix qdisc_notify() - CVE-2011-2525
    - LP: #869250
    - CVE-2011-2525
  * ipv6: restore correct ECN handling on TCP xmit
    - LP: #872179
  * nl80211: fix overflow in ssid_len - CVE-2011-2517
    - LP: #869245
    - CVE-2011-2517
  * vm: fix vm_pgoff wrap in stack expansion - CVE-2011-2496
    - LP: #869243
    - CVE-2011-2496
  * vm: fix vm_pgoff wrap in upward expansion - CVE-2011-2496
    - LP: #869243
    - CVE-2011-2496
  * drm: mm: fix range restricted allocations
    - LP: #873130
  * NLM: Don't hang forever on NLM unlock requests - CVE-2011-2491
    - LP: #869237
    - CVE-2011-2491
 -- Herton Ronaldo Krzesinski <email address hidden> Tue, 08 Nov 2011 17:20:39 -0200

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers