Ubuntu

Toshiba L640 Battery Issue - Ubuntu 11.10 not recognizing the batteries

Reported by Rajkumar on 2011-10-10
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

I have Toshiba Satellite L640 and Ubuntu 11.10 installed on it.

But Ubuntu is not recognizing the batteries. I have 6 batteries installed. Even Ubuntu 11.04 did not recognize the batteries.

Please help me resolve this problem.

Because of this problem, I am not able to work on the laptop using battery. It does not hibernate on low batteries. Instead abruptly switches off.

Rajkumar B
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu1
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: rajkumar 1533 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x96400000 irq 42'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:14f15069,1179fdd0,00100302 HDA:80862804,1179fdd0,00100000'
   Controls : 12
   Simple ctrls : 6
DistroRelease: Ubuntu 11.10
HibernationDevice: RESUME=UUID=f325b960-78e8-4d94-9681-b7ab517f814e
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 003: ID 04f2:b1d6 Chicony Electronics Co., Ltd
MachineType: TOSHIBA Satellite L640
NonfreeKernelModules: wl
Package: linux (not installed)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_IN
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=69544331-8f47-4aa2-8acb-e192df8c1754 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-11-generic N/A
 linux-backports-modules-3.0.0-11-generic N/A
 linux-firmware 1.60
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
StagingDrivers: brcmutil mei brcmsmac
Tags: oneiric running-unity staging
Uname: Linux 3.0.0-11-generic i686
UpgradeStatus: Upgraded to oneiric on 2011-09-24 (18 days ago)
UserGroups: adm admin cdrom dialout dip fax floppy fuse plugdev tape video
dmi.bios.date: 06/03/2010
dmi.bios.vendor: INSYDE
dmi.bios.version: 1.40
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Base Board Product Name
dmi.board.vendor: Intel Corp.
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: OEM Chassis Manufacturer
dmi.chassis.version: OEM Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvr1.40:bd06/03/2010:svnTOSHIBA:pnSatelliteL640:pvrPSK0JG-00L003:rvnIntelCorp.:rnBaseBoardProductName:rvrBaseBoardVersion:cvnOEMChassisManufacturer:ct10:cvrOEMChassisVersion:
dmi.product.name: Satellite L640
dmi.product.version: PSK0JG-00L003
dmi.sys.vendor: TOSHIBA

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Benjamin Plain (bplainia) wrote :

I have a Toshiba Satellite L655 with Ubuntu 11.10. I have had this problem since I had this lapop.

I have been able to fix it manually by compiling the kernel from source, editing the DSDT file. (See http://techinterplay.com/fix-toshiba-battery-issue-linux.html. Unfortunately, I cannot get to this website because of my school's proxy.)

This problem is very annoying because you have to do this every time a new kernel comes out.

-Benjamin

@Rajkumar
Please run this command on the affected machine:
apport-collect 871594
After doing so, please verify that information was automatically attached to this bug report and that the "apport-collected" tag was automatically added (please do *not* manually add it yourself). If this is the case, then you can go ahead and change this bug's status back from Incomplete to Confirmed. The automatically attached information should hopefully make this report complete enough to be worked on by a developer.

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: oneiric

apport information

tags: added: apport-collected running-unity staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20
Rajkumar (brajkumar) wrote :

Hi,

Can you please give me a quick way to update the Kernel in my laptop?

I actually installed 10.04 and then upgraded to 11.04 and again upgraded to 11.10.

Regards,
Rajkumar B

Use the Update Manager to update everything. Then reboot, to put the new kernel into use. After rebooting, you can run "uname -r" to check the kernel version in use, and compare it to the latest version listed at https://launchpad.net/ubuntu/+source/linux (scroll down to The Oneiric Ocelot).

Benjamin Plain (bplainia) wrote :

I updated to 3.0.0-12.20. It still doesn't work for me.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the release candidate kernel versus the daily build. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: needs-upstream-testing
Benjamin Plain (bplainia) wrote :

Still doesn't work. the top few lines of 'acpitool -e' says:

Kernel version : 3.1.0-999-generic - ACPI version : 20110623
Battery #1 : slot empty
AC adapter : on-line

This is using the daily kernel made at 12:43 today.
Is there any other information I need to add?

tags: removed: needs-upstream-testing
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Benjamin Plain (bplainia) wrote :

I cannot get to bugzilla.kernel.org. I think it is still down from the time it was hacked.

I am also unable to load http://bugzilla.kernel.org/. Hopefully it will be back up soon.

Rajkumar (brajkumar) wrote :

When will the bug status change to In-Progress from Triage?

This will happen once one or more developers indicate that they are actively working on the bug. Since this has been found to be an upstream problem, it will almost certainly not happen until the bug is reported upstream (or until a report is found upstream for it), which cannot happen until bugzilla.kernel.org is back up.

Benjamin Plain (bplainia) wrote :

Update:
A new kernel just came out yesterday. (3.0.0-13) I have installed it
I noticed that support for my wired network is included (this was not really a problem for me).
It still cannot detect my battery.
Bugzilla is still down.

Benjamin Plain (bplainia) wrote :

Bugzilla.kernel.org is up!!!
The bug number is 42628.
https://bugzilla.kernel.org/show_bug.cgi?id=42628

Benjamin Plain (bplainia) wrote :
Maarten Bezemer (veger) wrote :

Thanks for taking the time to report this bug in the upstream bug tracking system this is a tremendous help. Launchpad has the ability to watch lots of upstream bug trackers and this can be done by following the procedure documented at https://wiki.ubuntu.com/Bugs/Watches. I've added the bug watch for this bug report.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → Incomplete
Changed in linux:
status: Incomplete → Fix Released
Changed in linux:
status: Fix Released → Confirmed
Changed in linux:
status: Confirmed → In Progress
Changed in linux:
status: In Progress → Fix Released
Scott (massstash) on 2013-05-24
Changed in linux (Ubuntu):
status: Triaged → New

Rajkumar, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: needs-full-computer-model needs-upstream-etsting
tags: added: needs-upstream-testing
removed: kernel-request-3.0.0-12.20 needs-upstream-etsting
Changed in linux (Ubuntu):
status: New → Incomplete
Benjamin Plain (bplainia) wrote :

I tested the daily image on my laptop last week and it detected the battery.
Rajkumar, can you confirm this? You have a different model than me.

Benjamin Plain, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documention in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.