Realtek RTL8111/8168B: Wrong driver module is loaded

Bug #864196 reported by Christof Löwe on 2011-10-01
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

On AsRock Z68 Pro3 Motherboard with Realtek RTL8111/8168B Ethernet controller rev 06 the wrong driver module r8169 is loaded and connectivity is very bad and slow and interrupted. Correct driver module is r8168. If installed manually from Realteks website the device is working well. - But on reboot Ubuntu loads r8169 again - without huge effort to avoid this.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-generic 3.0.0.12.13
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: l3onidas 1666 F.... pulseaudio
CRDA: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
Card0.Amixer.info:
 Card hw:0 'Audigy2'/'SB Audigy 4 [SB0610] (rev.0, serial:0x10211102) at 0xe000, irq 16'
   Mixer name : 'SigmaTel STAC9750,51'
   Components : 'AC97a:83847650'
   Controls : 202
   Simple ctrls : 37
Date: Sat Oct 1 19:35:17 2011
HibernationDevice: RESUME=UUID=6f7daebb-ad81-4e63-aa3c-e9e286b34150
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcEnviron:
 LANGUAGE=
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=acb49775-c080-4c1c-b03a-1f23fac9b84c ro
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-12-generic N/A
 linux-backports-modules-3.0.0-12-generic N/A
 linux-firmware 1.60
RfKill:

SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/21/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.40
dmi.board.name: Z68 Pro3
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.40:bd06/21/2011:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnZ68Pro3:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.

Christof Löwe (christof-loewe) wrote :
Christof Löwe (christof-loewe) wrote :

Seems to be older issue, see e.g.
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/699761

But no solution except manual install?

Tested here in oneiric with mainline 3.1 Kernel, too. No change.

Eero Pajarre (epajarre) wrote :

Here on Asus P8P67.
Had to install from Realtek site on 11.04 Ubuntu, worked fine after that.

Now updated to 11.10 Ubuntu (beta 2, version available 30 September),
and booted up with no network connection!
(luckily had another system for network browsing).

The Realtek compile/install script needed some patching, because of the
kernel version number change, but after that seems to work.

I would consider this issue serious.

Christof Löwe (christof-loewe) wrote :

This is very serious.

But i think it is not a specific Ubuntu issue but a kernel one.

It's everywhere the same. I also tried Debian Testing (Linux MInt Debian Edition). The problem is that there is no module r8168 anywhere. Now, with this mentioned need to get the Ralink drivers makefile patched for linux 3.x this might be the end of linux contact for many people if they own the "right" hardware.

Christof Löwe (christof-loewe) wrote :

Sorry, not Ralink drivers - Realtek of course.

Mats Lorentzson (mats-tzs) wrote :

Today (2011-10-05) I installed daily oneiric-desktop-amd64 and my RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06) works like it should with modules r8169. But with my up to date stable Ubuntu 11.04 this driver don't work, its like the bug descriptions.

Mats Lorentzson (mats-tzs) wrote :

It did work even after reboot to 11.04, but after I booted win7, r8169 did not bee stable again. So the problem is still here.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-meta (Ubuntu):
status: New → Confirmed
b3nn0 (agib) wrote :

Just as a reference, this is probably the same issue as described here:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/853671

pinus (pinus) wrote :

This bug also affects the ASRock AOD790GX/128M main board claiming to have a RTL8111C-VCO-GR (from the manual). Not being able to access the net to get an update is a blocker for me.

germulvey (gpmulvey-iol) wrote :

affects ASUS M5A97 PRO with RTL8111E/8168B
connection is very slow usually sub 150kb/s and eventually stalls forcing skiping of language packs during system install

germulvey (gpmulvey-iol) wrote :

as a foot note to above post
opensuse loads the r8169 driver which works fine

Tim Gardner (timg-tpi) on 2011-12-06
affects: linux-meta (Ubuntu) → linux (Ubuntu)
Joseph Salisbury (jsalisbury) wrote :

This may be a duplicate of bug 896575

Changed in linux (Ubuntu):
importance: Undecided → Medium
Nelson Minar (g-nelson) wrote :

This bug has a long and sad history; see Ubuntu bug 141343 from 2007 for instance. This bug is also reported in every other Linux system I've looked for; the problem seems to be in the Linux kernel, not any specific distribution. My understanding is that the right driver is being installed, in that the r8169 driver is all that's in the Linux sources. But that driver has problems with this card. In my case, the bug I see is that eth0 doesn't come up until 10-200 seconds after system boot. Other people report packet loss, slow network, etc.

One frequently proposed solution is to try Realtek's r8168 driver from their site. I just tried that without success, but others say it works for them (I tried Realtek version 8.027.00, Linux 3.0.0-15-server). Another proposed solution is to enable Wake-on-LAN via Windows, which somehow keeps the card active on reboot. I don't have Windows to try it, but enabling WOL via ethtool did not solve my problem.

My conclusion is this card is cursed and if the bugs bother me, I need to get a different ethernet adapter. It's a shame because it's a very common motherboard Ethernet chip. And Realtek contributes to driver development; it seems like it should be a solvable problem.

Links:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/141343
http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false
http://nelsonslog.wordpress.com/2012/01/22/realtek-ethernet-drivers-r8169-vs-r8168/

Nelson Minar (g-nelson) wrote :

I should add that 148 systems using this Realtek ethernet controller are listed as Ubuntu Certified Hardware. Either those systems have something special that makes them work, or the certification process missed this driver problem.

http://www.ubuntu.com/certification/catalog/component/pci:8168:10EC-NETWORK

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers