[Oneiric regression] [RTL8111/8168B] Occasional network problems

Bug #853671 reported by David Henningsson on 2011-09-19
92
This bug affects 17 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Since I upgraded to Oneiric, occasionally, I'm having network problems - very slow connections often ending in "Connection timed out" or "Interrupted connection".
Shutting down the system and then powering it up again (not just rebooting) seems to help when this happens. As the machine cannot send reports to launchpad in this state, I'm attaching a saved report from when the machine was in this broken state.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-11-generic 3.0.0-11.18
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: david 1638 F.... pulseaudio
 /dev/snd/controlC3: david 1638 F.... pulseaudio
 /dev/snd/controlC1: david 1638 F.... pulseaudio
 /dev/snd/controlC0: david 1638 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfe024000 irq 16'
   Mixer name : 'Realtek ALC888'
   Components : 'HDA:10ec0888,1458e601,00100001'
   Controls : 40
   Simple ctrls : 22
Card1.Amixer.info:
 Card hw:1 'Juli'/'ESI Juli@ at 0xcf00, irq 21'
   Mixer name : 'ICE1724 - multitrack'
   Components : ''
   Controls : 36
   Simple ctrls : 14
Card2.Amixer.info:
 Card hw:2 'NVidia'/'HDA NVidia at 0xfcffc000 irq 19'
   Mixer name : 'Nvidia GPU 14 HDMI/DP'
   Components : 'HDA:10de0014,10de0101,00100100'
   Controls : 16
   Simple ctrls : 4
Card3.Amixer.info:
 Card hw:3 'Headset'/'Logitech Logitech USB Headset at usb-0000:00:12.0-1, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0a0c'
   Controls : 6
   Simple ctrls : 2
Date: Mon Sep 19 08:31:37 2011
HibernationDevice: RESUME=UUID=bb4f6961-6d62-4f7d-9402-a451881cd3b1
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110802.1)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: Gigabyte Technology Co., Ltd. GA-MA770T-UD3P
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=20d7bd2d-3fb5-4a38-b8fd-781d352fbe4e ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-11-generic N/A
 linux-backports-modules-3.0.0-11-generic N/A
 linux-firmware 1.60
RfKill:

SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/24/2009
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F2
dmi.board.name: GA-MA770T-UD3P
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF2:bd06/24/2009:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA770T-UD3P:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA770T-UD3P:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-MA770T-UD3P
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

David Henningsson (diwic) wrote :
David Henningsson (diwic) wrote :
summary: - [Oneiric regression] Occasional network problems
+ [Oneiric regression] [RTL8111/8168B] Occasional network problems
Brad Figg (brad-figg) on 2011-09-19
Changed in linux (Ubuntu):
status: New → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.19
b3nn0 (agib) wrote :

I can confirm this bug with the following kernel version:
linux-image-3.0.0-12-generic
However, I'm pretty sure that this is not only kernel related (firmware?).
I've been using the oneiric kernels on Natty for a while now and networking worked much better (not perfect, but better).
However, with Oneiric, it fails completely. The Interface is available, but even getting an IP address via DHCP sometimes takes ages or fails completely. If it works, it is very slow.

JimmyL (jrlangston11) wrote :

I can confirm this bug with RTL811 latest kernel & system updates as of 1st Oct. Basically "some" internet connectivity may occur at very low speeds, but mostly it doesnt work at all. Device is seen in lspci. I have windows on same box and ethernet works fine in it. i also installed natty and it worked fine.

JimmyL (jrlangston11) wrote :

Also I am on kubuntu and manually running dhclient does not even seem to work.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20
b3nn0 (agib) wrote :

Still nothing changed with the new kernel 3.0.0-12.20.
Manually installing the realtek-driver from realtek.com helps. But the driver has to be patched in order to work with kernel 3.0.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: needs-upstream-testing
tags: added: regression-release
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
b3nn0 (agib) wrote :

Seems to work better indeed.
I could not test it with the same setup, but was able to transfer a few gigabytes of files over the network (but with fixed IP. could not test DHCP).
I think this commit could be the cause of the improvement (but I'm not sure. never touched the network stack before).
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=70090424e59652c4b2e777b533cc23134b176b83

b3nn0 (agib) on 2011-10-11
tags: removed: kernel-request-3.0.0-12.19 kernel-request-3.0.0-12.20 needs-upstream-testing
Brad Figg (brad-figg) wrote :

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20
b3nn0 (agib) on 2011-10-11
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
b3nn0 (agib) wrote :

Sorry, accidently removed too many tags.
I also found these patches about the RTL8168B/8111B while looking through the 3.1 changelog which seem to improve support for it:
http://patchwork.ozlabs.org/patch/115115/
+ the 4 follow-up patches.
As mentioned, I'm missing the knowledge to name the correct patch, but one of those got to be it.

tags: added: patch-available-upstream
tags: added: cherry-pick
removed: patch-available-upstream
tags: added: kernel-fixed-upstream
removed: cherry-pick
tags: removed: kernel-fixed-upstream

Bug 839393 is likely the same issue being experienced here. That being said, for bug 839393 I provided a newer version of the r8169 driver from the latest upstream v3.1 kernel. For anyone interested in testing, I've provided it via the linux-backports-modules-3.0.0 package which I've uploaded to my PPA:

https://launchpad.net/~leannogasawara/+archive/ppa/

After adding the PPA to your system, you will want to install linux-backports-modules-net-3.0.0-12-generic which will provide the newer r8169 driver. Please note that you need to be using the linux-image-3.0.0-12-generic kernel when you install and you will also need to reboot after installing.

So, for anyone who is still experiencing issues, please let me know your results after having tested the newer driver.

Changed in linux (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
mose (ozmose) wrote :

Thanks Leann !

I had same symptoms with that card (messy connectivity, intermittent cuts) and linux-backports-modules-net-3.0.0-12-generic from your PPA fixed it perfectly.

Bill Gurley (bgurley) wrote :

This morning I applied updates via the flashing Software Center. Since some of them were Unity updates, I rebooted. Then I lost my onboard Realtek ethernet! I have an ASUS M4A89GTD Pro motherboard, with Realtek RTL8111/8168B ethernet controller. Googling the issue, I found this bug thread. It was working fine for me until today. I had updated last weekend from 11.04 to 11.10. No previous problems with this driver. Help!!

Thanks.

Bill Gurley (bgurley) wrote :

Sorry, but please disregard comment #15. It was not my NIC driver. Instead it was an issue with NetworkManager not populating my /etc/resolv.conf file. This is a problem that has been reported elsewhere. I installed the resolvconf package so that I could manually specify my dns servers.

psyopper (bfranks) wrote :

In regards to the network controller dropping the connection every few seconds while connected for Internet Connection Sharing...

Open the network connection being used for sharing. In the IPV6 Settings set the Method to "None" to disable IPV6. You shouldn't need IPv6 to directly connect two computers and by disabling it I was able to stabilize my connection to work correctly.

To post a comment you must log in.