Log spamming by verbose rtl8192 driver

Bug #859702 reported by gcc on 2011-09-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Tim Gardner

Bug Description

admin@classmate:~/matchbox-desktop-2.0$ sudo grep 'pwrdown, 0x6(BIT6)=f1' /var/log/syslog | wc -l
11897

Also seen:

Sep 26 16:57:21 classmate kernel: [ 4950.259147] LPS leave: notify AP we are awaked ++++++++++ SendNullFunctionData
Sep 26 16:57:21 classmate kernel: [ 4950.259305] ===>rtl8192se_link_change():ieee->iw_mode is 2

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-33-generic 2.6.32-33.72
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-33.72-generic 2.6.32.41+drm33.18
Uname: Linux 2.6.32-33-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: admin 1544 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x40a00000 irq 22'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,101990c9,00100004'
   Controls : 13
   Simple ctrls : 8
Date: Mon Sep 26 16:51:17 2011
HibernationDevice: RESUME=UUID=c3d84223-0ae8-424c-9f18-05149455a5be
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
MachineType: Intel Corporation Intel powered classmate PC
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-33-generic root=UUID=9cb259d2-8b3a-4f9c-90e5-464a455d5bd0 ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34.7
RfKill:

SourcePackage: linux
dmi.bios.date: 12/06/2010
dmi.bios.vendor: Phoenix
dmi.bios.version: BPPNV10A.86A.0014.2010.1206.1336
dmi.board.asset.tag: PTL Nanjing
dmi.board.name: Intel powered classmate PC
dmi.board.vendor: Intel Corporation
dmi.board.version: MP PV
dmi.chassis.type: 10
dmi.chassis.vendor: Intel
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenix:bvrBPPNV10A.86A.0014.2010.1206.1336:bd12/06/2010:svnIntelCorporation:pnIntelpoweredclassmatePC:pvrBPPV:rvnIntelCorporation:rnIntelpoweredclassmatePC:rvrMPPV:cvnIntel:ct10:cvrN/A:
dmi.product.name: Intel powered classmate PC
dmi.product.version: BP PV
dmi.sys.vendor: Intel Corporation

gcc (chris+ubuntu-qwirx) wrote :
Brad Figg (brad-figg) on 2011-09-26
Changed in linux (Ubuntu):
status: New → Confirmed
Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact: Excessive log spam

Patch Description: Use dev_dbg() for elective driver output

Changed in linux (Ubuntu):
status: Confirmed → Invalid
Changed in linux (Ubuntu Lucid):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Lucid):
status: In Progress → Fix Committed
Herton R. Krzesinski (herton) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-lucid' to 'verification-done-lucid'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-lucid
Herton R. Krzesinski (herton) wrote :

@gcc: any news on verifying if the bug is now solved with the -proposed kernel? If the change is not verified to be working, it'll be reverted by the end of this week.

gcc (chris+ubuntu-qwirx) wrote :

Verified that 2.6.32-35 fixes the problem, thanks :)

How do I change tags? I can't see any option for that.

Herton R. Krzesinski (herton) wrote :

Just click the pen icon in the "Tags:" field right after the description. No problem, I'm setting the correct tag now.

tags: added: verification-done-lucid
removed: verification-needed-lucid
Launchpad Janitor (janitor) wrote :
Download full text (5.2 KiB)

This bug was fixed in the package linux - 2.6.32-35.78

---------------
linux (2.6.32-35.78) lucid-proposed; urgency=low

  [Herton R. Krzesinski]

  * Release Tracking Bug
    - LP: #871899

  [ Andrew Dickinson ]

  * SAUCE: sched: Prevent divide by zero when cpu_power is 0
    - LP: #614853

  [ Stefan Bader ]

  * [Config] Force perf to use libiberty for demangling
    - LP: #783660

  [ Tim Gardner ]

  * [Config] Simplify binary-udebs dependencies
    - LP: #832352
  * [Config] kernel preparation cannot be parallelized
    - LP: #832352
  * [Config] Linearize module/abi checks
    - LP: #832352
  * [Config] Linearize and simplify tree preparation rules
    - LP: #832352
  * [Config] Build kernel image in parallel with modules
    - LP: #832352
  * [Config] Set concurrency for kmake invocations
    - LP: #832352
  * [Config] Improve install-arch-headers speed
    - LP: #832352
  * [Config] Fix binary-perarch dependencies
    - LP: #832352
  * [Config] Removed stamp-flavours target
    - LP: #832352
  * [Config] Serialize binary indep targets
    - LP: #832352
  * [Config] Use build stamp directly
    - LP: #832352
  * [Config] Restore prepare-% target
    - LP: #832352
  * [Config] Fix binary-% build target
  * [Config] Fix install-headers target
    - LP: #832352
  * SAUCE: igb: Protect stats update
    - LP: #829566
  * SAUCE: rtl8192se spams log
    - LP: #859702

  [ Upstream Kernel Changes ]

  * Add mount option to check uid of device being mounted = expect uid,
    CVE-2011-1833
    - LP: #732628
    - CVE-2011-1833
  * crypto: Move md5_transform to lib/md5.c
    - LP: #827462
  * net: Compute protocol sequence numbers and fragment IDs using MD5.
    - LP: #827462
  * ALSA: timer - Fix Oops at closing slave timer
    - LP: #827462
  * ALSA: snd-usb-caiaq: Fix keymap for RigKontrol3
    - LP: #827462
  * powerpc: Fix device tree claim code
    - LP: #827462
  * powerpc: pseries: Fix kexec on machines with more than 4TB of RAM
    - LP: #827462
  * Linux 2.6.32.45+drm33.19
    - LP: #827462
  * ipv6: make fragment identifications less predictable, CVE-2011-2699
    - LP: #827685
    - CVE-2011-2699
  * tunnels: fix netns vs proto registration ordering
    - LP: #823296
  * Fix broken backport for IPv6 tunnels in 2.6.32-longterm kernels.
  * USB: xhci: fix OS want to own HC
    - LP: #837669
  * USB: assign instead of equal in usbtmc.c
    - LP: #837669
  * USB: usb-storage: unusual_devs entry for ARM V2M motherboard.
    - LP: #837669
  * USB: Serial: Added device ID for Qualcomm Modem in Sagemcom's HiLo3G
    - LP: #837669
  * atm: br2864: sent packets truncated in VC routed mode
    - LP: #837669
  * hwmon: (ibmaem) add missing kfree
    - LP: #837669
  * ALSA: snd-usb-caiaq: Correct offset fields of outbound iso_frame_desc
    - LP: #837669
  * mm: fix wrong vmap address calculations with odd NR_CPUS values
    - LP: #837669
  * perf tools: do not look at ./config for configuration
    - LP: #837669
  * fs/partitions/efi.c: corrupted GUID partition tables can cause kernel
    oops
    - LP: #837669
  * befs: Validate length of long symbolic links.
    - LP: #837669
  * ALSA: snd_usb_caiaq: track submitted output urbs
    - LP: #8...

Read more...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers