[i915] DVI monitor via adapter to DisplayPort is reported as HDMI.

Bug #859389 reported by Daniel van Vugt on 2011-09-26
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

I have a DisplayPort with a passive DVI adapter plugged into it to run my DVI monitor. However the i915 module seems to want to call this connection "HDMI1".

Call it DisplayPort or DVI. Either would be correct. But HDMI is wrong.

This occurs on Ubuntu 11.04 and 11.10beta2.

$ grep conn /sys/class/drm/*/status
/sys/class/drm/card0-DP-1/status:disconnected
/sys/class/drm/card0-HDMI-A-1/status:connected
/sys/class/drm/card0-VGA-1/status:disconnected

$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 8192 x 8192
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 519mm x 324mm
   1920x1200 60.0*+
   1600x1200 60.0
   1680x1050 60.0
   1280x1024 75.0 60.0
   1152x864 75.0
   1024x768 75.1 60.0
   800x600 75.0 60.3
   640x480 75.0 60.0
   720x400 70.1
DP1 disconnected (normal left inverted right x axis y axis)

This is probably because the DisplayPort is running in DVI/HDMI mode [http://en.wikipedia.org/wiki/DisplayPort#Compatibility_with_HDMI.2FDVI]

But it's still wrong to call a DVI connection through DisplayPort "HDMI".

This bug might be caused by the fix for bug 702125.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-generic 2.6.38.11.26
ProcVersionSignature: Ubuntu 2.6.38-11.50-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dan 1747 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xe1a60000 irq 45'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10ec0269,1028047e,00100100 HDA:80862805,80860101,00100000'
   Controls : 22
   Simple ctrls : 13
Date: Mon Sep 26 13:46:15 2011
HibernationDevice: RESUME=UUID=645f2665-86aa-445c-9bbc-0c7a6883336b
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
IwConfig:
 lo no wireless extensions.

 eth1 no wireless extensions.

 vboxnet0 no wireless extensions.
MachineType: Dell Inc. OptiPlex 990
ProcEnviron:
 LANGUAGE=en_AU:en
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-11-generic root=UUID=e79b78d3-ed94-4285-8af0-4c7803ef2097 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-11-generic N/A
 linux-backports-modules-2.6.38-11-generic N/A
 linux-firmware 1.52
RfKill:

SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/28/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A05
dmi.board.name: 0D6H9T
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 15
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA05:bd05/28/2011:svnDellInc.:pnOptiPlex990:pvr01:rvnDellInc.:rn0D6H9T:rvrA00:cvnDellInc.:ct15:cvr:
dmi.product.name: OptiPlex 990
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

Daniel van Vugt (vanvugt) wrote :
Brad Figg (brad-figg) on 2011-09-26
Changed in linux (Ubuntu):
status: New → Confirmed
affects: xserver-xorg-video-intel → xserver-xorg-video-intel (Ubuntu)
Daniel van Vugt (vanvugt) wrote :

I've now tested mainline kernels 3.1 and 3.2-rc1. This but is still not fixed in either.

Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

The bugzilla.kernel.org site may still be unavailable due to the recent break-in. If that is the case, please add the tag: kernel-needs-upstream-bug-report

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged
tags: added: kernel-needs-upstream-bug-report
Bryce Harrington (bryce) wrote :

Hey vanvugt,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Daniel van Vugt (vanvugt) wrote :

Yes it's still a problem in Ubuntu 11.10 with the standard kernel 3.0 and even with mainline kernels 3.1 and 3.2-rc1.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Chris Wilson (ickle) wrote :

It's not technically an issue as there is no separate DVI encoder on the GPU - as DVI is merely a subset of HDMI there is no point.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Invalid
tags: added: bios-outdated-a18 needs-upstream-testing
no longer affects: xserver-xorg-video-intel (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Triaged → Incomplete
Daniel van Vugt (vanvugt) wrote :

I can confirm the bug is still present in Ubuntu 13.10 at least, but unfortunately can't easily test trusty due to bug 1212977.

tags: added: saucy
Daniel van Vugt (vanvugt) wrote :

I have been using BIOS A18 for over a month already...

$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
A18
09/24/2013

tags: added: latest-bios-a18
removed: bios-outdated-a18
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
summary: - [i915] DVI monitor via adapter to DisplayPort is reported as HDMI.
+ 8086:0102 [i915] [OptiPlex 990] DVI monitor via adapter to DisplayPort
+ is reported as HDMI.
Daniel van Vugt (vanvugt) wrote :

This bug is not specific to 8086:0102 or "Optiplex 990". It is a general intel graphics kernel issue.

summary: - 8086:0102 [i915] [OptiPlex 990] DVI monitor via adapter to DisplayPort
- is reported as HDMI.
+ [i915] DVI monitor via adapter to DisplayPort is reported as HDMI.
趙惟倫 (chaoweilun) wrote :

Confirmed this bug still in 14.04 and 14.10

趙惟倫, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
https://wiki.ubuntu.com/Kernel/Policies/DuplicateBugs
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

As well, please do not announce in this report you created a new bug report.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers