Ubuntu

Motherboard AMD 990FX/SB950 usb don't work

Reported by Gustavo on 2011-09-25
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

USB don't work on a ASUS Crosshair V Formula motherboard.
If I connect any device to USB 2 printer or flash drive are not recognized. Also USB mouse and keyboard are not recognized on USB 2 connectors.
Fortunately if I connect mouse and keyboard to USB 3 connectors they works constantly.
If I connect printer or flash drive or external drive box to usb 3 connection fail after some seconds.
If I use the USB hub of my Logitech G11 keyboard also the keyboard stop working.
I test Ubuntu Oneiric beta1 and all updates since now but the problem it's always present.
Also Natty, Maverick and Lucid are effected with this USB malfunction.
I test also other distributions such as Fedora 15 and Sabayon 6 and the USB malfunction it's present.
I test puppy live cd and USB 2 works but not USB 3.
If I use dmesg | tail I have:
[ 3603.750117] usb 7-1: device descriptor read/64, error -32
[ 3604.010107] usb 7-1: device descriptor read/64, error -32
[ 3604.270108] usb 7-1: new full speed USB device number 3 using ohci_hcd
[ 3604.420123] usb 7-1: device descriptor read/64, error -32
[ 3604.680121] usb 7-1: device descriptor read/64, error -32
[ 3604.940129] usb 7-1: new full speed USB device number 4 using ohci_hcd
[ 3605.360112] usb 7-1: device not accepting address 4, error -32
[ 3605.530122] usb 7-1: new full speed USB device number 5 using ohci_hcd
[ 3605.950115] usb 7-1: device not accepting address 5, error -32
[ 3605.950169] hub 7-0:1.0: unable to enumerate USB device on port 1
I think this problem it's specific for AMD 990FX/SB950 chipset.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-11-generic 3.0.0-11.18
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: paolo 2111 F.... pulseaudio
 /dev/snd/controlC0: paolo 2111 F.... pulseaudio
CRDA: Error: [Errno 2] File o directory non esistente
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfe600000 irq 16'
   Mixer name : 'Realtek ALC889'
   Components : 'HDA:10ec0889,1043846b,00100004'
   Controls : 39
   Simple ctrls : 23
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xfe080000 irq 25'
   Mixer name : 'Nvidia GPU 16 HDMI/DP'
   Components : 'HDA:10de0016,10de0101,00100100'
   Controls : 16
   Simple ctrls : 4
Date: Sun Sep 25 21:30:30 2011
HibernationDevice: RESUME=UUID=7480693f-559a-4a0e-a15d-efdf2771f0fb
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: To be filled by O.E.M. To be filled by O.E.M.
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.0.0-11-generic root=UUID=ed1fcb52-a56c-4538-b397-4d2b391b6f14 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-11-generic N/A
 linux-backports-modules-3.0.0-11-generic N/A
 linux-firmware 1.60
RfKill:

SourcePackage: linux
StagingDrivers: zram
UpgradeStatus: Upgraded to oneiric on 2011-09-23 (2 days ago)
dmi.bios.date: 06/22/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0506
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Crosshair V Formula
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0506:bd06/22/2011:svnTobefilledbyO.E.M.:pnTobefilledbyO.E.M.:pvrTobefilledbyO.E.M.:rvnASUSTeKComputerINC.:rnCrosshairVFormula:rvrRev1.xx:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To be filled by O.E.M.
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: To be filled by O.E.M.

Gustavo (paolo-nino) wrote :
Brad Figg (brad-figg) on 2011-09-25
Changed in linux (Ubuntu):
status: New → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.19
Gustavo (paolo-nino) wrote :

I installed the development kernel 3.1.0.
uname -r
3.1.0-0301rc4-generic

If I insert a sandisk flash drive on a USB 2 connection it is not recognized.
If i do

sudo dmesg | tail

that is the output

[ 192.180065] usb 7-1: device descriptor read/64, error -32
[ 192.440148] usb 7-1: device descriptor read/64, error -32
[ 192.720140] usb 7-1: new full speed USB device number 3 using ohci_hcd
[ 192.870154] usb 7-1: device descriptor read/64, error -32
[ 193.130138] usb 7-1: device descriptor read/64, error -32
[ 193.390150] usb 7-1: new full speed USB device number 4 using ohci_hcd
[ 193.810129] usb 7-1: device not accepting address 4, error -32
[ 193.960148] usb 7-1: new full speed USB device number 5 using ohci_hcd
[ 194.380163] usb 7-1: device not accepting address 5, error -32
[ 194.380212] hub 7-0:1.0: unable to enumerate USB device on port 1

Everything it's like the 3.0.0 kernel.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Gustavo (paolo-nino) wrote :

I discovered that changing a BIOS setting on my Crosshair V fotmula fix the USB problem.
I fresh reinstalled oneiric beta 1 and installed all upgrades available since now.
I'm currently running 3.0.0-12-generic kernel.
In the northbridge BIOS menu I have "IOMMU MODE" item. This enable MMIO support. That is what on line help say about "IOMMU MODE".
If I set "IOMMU MODE" to DISABLED and restart Oneiric than USB device connected to USB 2 or USB 3 start to work reliably.

Why this IOMMU MODE setting effect USB function?
Is this an hardware bug or a Linux bug?
Can I change this bug status to fixed?

I hope someone can give answer to this questions!

iLugo (isra) wrote :

I am also affected by this problem.

I am just finalizing a migration of my Ubuntu 11.04 to a Phenom II X6 1100T Processor mounted on an Asus Crosshair V Formula, with 8GB RAM. I have also found the hard way that if I enable the IOMMU MODE in the North Bridge Configuration screen, then I cannot even log on to my system because both my keyboard and mouse (USB) just don't work. Setting the "IMMU MODE" to DISABLED allows me to use my usb keyboard and usb wireless mouse.

From the perspective of an user who uses usb keyboard and mouse and has just enabled the IMMU mode, the Ubuntu system will be completely broken, completely irresponsive, where not even the Alt-SysRq R-E-I-S-U-B sequence could help because there is no keyboard.

iLugo (isra) wrote :

I have just confirmed :

You do NOT want to enable the IOMMU mode on the Asus Croshair V Formula motherboard (AMD 990FX/SB950 chipset) if you want to have your usb working on Ubuntu.

In particular, if you enable IOMMU and if your keyboard and mouse are usb, then you will NOT be able to log on to Ubuntu.

If you use PS2 keyboard and PS2 mouse, though, then they will work, but you will have no usb functionality.

Among other things, this is a pity, because the BIOS of this motherboard explains: "IOMMU is supported on Linux based systems to convert 32 bit I/O to 64 bit MMIO".

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20
kaefert (kaefert) wrote :

I can conform this bug with both Ubuntu 11.04 and Ubuntu 11.10 (upgraded from 11.04) and I can also confirm that setting this IOMMU setting to "disabled" instead of "64" in BIOS does workaround the issue

Gustavo (paolo-nino) on 2011-11-13
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
description: updated
Ralf-Peter (ralfpeter-rohbeck) wrote :

Reproduced with Debian squeeze on a 3.1.0-1-amd64 kernel.

Biell (snortt-gmail) wrote :

Hello all.

I don't know if it helps people working on this stuff, but I just bought a brand new MSI 990FXA-GD65 and a Phenom II X6 with 12GB RAM.
I tried to install Ubuntu 11.04 (x86_64) and it can't find USB devices. I gives the well known errors ("unable to enumerate device", "device descriptor read/64", "error -32", etc.). I also tried 10.04 (x86_64) with no success.

I just tried booting from Ubuntu 9.04 (i386) as the CD was lying on my desk and, for my surprise, it just worked fine! I could use my mouse and also my two external drives (one sata and the other IDE, but both from seagate). I looked inside the /var/log/kern.log file and it reported that "ehci_hcd" was successfully loaded! NOT a single error!

I tried taking the same kernel (but 64 bit version) from Ubuntu repo and installing it on a Debian 5.0, but the errors and messages appear again.

Good luck to us all.

Biell (snortt-gmail) wrote :

Debian 6.0.3 can't use EHCI_HCD either. If one tries to install it from an external USB CD-Drive will find that as soon as Debian starts looking for devices, the drive (used to boot it) vanishes and can't be found.

An upgrade to Testing didn't resolve.
An upgrade to SID didn't solve.
Taking kernel sources from kernel.org (3.1.2) and building it (using Debian's default config) didn't resolve either.

Daniel Llewellyn (diddledan) wrote :

This issue also affects MSI's 970A-G46 mainboard with a bulldozer 8-core cpu. On this system the Realtek RTL8111/RTL8168B NIC is also unresponsive along with the USB devices. Luckily I have a PS2 keyboard and was thus able to dig around the booted system a bit using the CLI. dmesg did not report anything untoward about the realtek nic, but the messages about USB devices are as others have already stated.

Ralf-Peter (ralfpeter-rohbeck) wrote :

The new Crosshair V BIOS (1102) resolved the issue for me.

Daniel Llewellyn (diddledan) wrote :

Re: #13

Ralf-Pete suggests an updated BIOS for his mainboard. I saw that MSI had also released a new BIOS (for my particular board), so I dutifuly updated. Unfortunately, this latest (version 1.50) BIOS for the MSI 970A-G46 Mainboard doesn't fix the issue with this board.

Changed in linux (Ubuntu):
importance: Undecided → Medium
Petros Tsantoulis (ptsant) wrote :

I can confirm the bug with the ASUS Formula V and Ubuntu 12.04, amd64 kernel 3.2.0-27. Upgrading the BIOS to 1503 solved the issue for me. Asus indicates that the BIOS "improves USB compatibility".

Note that upgrading the BIOS will require you to re-install grub-efi because NVRAM is erased.

Gustavo, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

tags: added: bot-stop-nagging
removed: kernel-request-3.0.0-12.19 kernel-request-3.0.0-12.20
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Gustavo (paolo-nino) wrote :

Last bios realise by Asus fix the problem.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
DustWolf (dustwolfy) wrote :

There is no fix released the problem still occurs on MSI boards.

DustWolf, if you have a bug in Ubuntu, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Kernel team article:
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports

the Ubuntu Bug Control team and Ubuntu Bug Squad team article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report may delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Download full text (4.8 KiB)

For my ASUS Crosshair V Formula a bios update fix the problem.

2012/12/13 DustWolf <email address hidden>

> There is no fix released the problem still occurs on MSI boards.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/859137
>
> Title:
> Motherboard AMD 990FX/SB950 usb don't work
>
> Status in “linux” package in Ubuntu:
> Fix Released
>
> Bug description:
> USB don't work on a ASUS Crosshair V Formula motherboard.
> If I connect any device to USB 2 printer or flash drive are not
> recognized. Also USB mouse and keyboard are not recognized on USB 2
> connectors.
> Fortunately if I connect mouse and keyboard to USB 3 connectors they
> works constantly.
> If I connect printer or flash drive or external drive box to usb 3
> connection fail after some seconds.
> If I use the USB hub of my Logitech G11 keyboard also the keyboard stop
> working.
> I test Ubuntu Oneiric beta1 and all updates since now but the problem
> it's always present.
> Also Natty, Maverick and Lucid are effected with this USB malfunction.
> I test also other distributions such as Fedora 15 and Sabayon 6 and the
> USB malfunction it's present.
> I test puppy live cd and USB 2 works but not USB 3.
> If I use dmesg | tail I have:
> [ 3603.750117] usb 7-1: device descriptor read/64, error -32
> [ 3604.010107] usb 7-1: device descriptor read/64, error -32
> [ 3604.270108] usb 7-1: new full speed USB device number 3 using ohci_hcd
> [ 3604.420123] usb 7-1: device descriptor read/64, error -32
> [ 3604.680121] usb 7-1: device descriptor read/64, error -32
> [ 3604.940129] usb 7-1: new full speed USB device number 4 using ohci_hcd
> [ 3605.360112] usb 7-1: device not accepting address 4, error -32
> [ 3605.530122] usb 7-1: new full speed USB device number 5 using ohci_hcd
> [ 3605.950115] usb 7-1: device not accepting address 5, error -32
> [ 3605.950169] hub 7-0:1.0: unable to enumerate USB device on port 1
> I think this problem it's specific for AMD 990FX/SB950 chipset.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: linux-image-3.0.0-11-generic 3.0.0-11.18
> ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
> Uname: Linux 3.0.0-11-generic x86_64
> NonfreeKernelModules: nvidia
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
> ApportVersion: 1.23-0ubuntu1
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC1: paolo 2111 F.... pulseaudio
> /dev/snd/controlC0: paolo 2111 F.... pulseaudio
> CRDA: Error: [Errno 2] File o directory non esistente
> Card0.Amixer.info:
> Card hw:0 'SB'/'HDA ATI SB at 0xfe600000 irq 16'
> Mixer name : 'Realtek ALC889'
> Components : 'HDA:10ec0889,1043846b,00100004'
> Controls : 39
> Simple ctrls : 23
> Card1.Amixer.info:
> Card hw:1 'NVidia'/'HDA NVidia at 0xfe080000 irq 25'
> Mixer name : 'Nvidia GPU 16 HDMI/DP'
> Components : 'HDA:10de0016,10de0101,00100100'
> Controls : 16
> Simple ctrls : 4
> Date: Sun Sep 25 21:30:30 2011
> HibernationD...

Read more...

dAgeCKo (dagecko) wrote :

For people who have the same issue. The bug is resolved on MSI cards too (at least on MSI 990XA-GD55) with the latest BIOS. This also resolve the bug with the network card, but does not resolve the bug with low frequency RAM.

dAgeCKo (dagecko) wrote :

Also, for the interested people, I wrote an article about my mainboard that depicts the bugs, provides some explanations (from MSI) and gives some solutions.

I had this issue with an GA-970A-D3P motherboard, chipset is AMD 970/AMD SB 950.

I set IOMMU controller = Enable on BIOS, now I can boot from my USB stick with no problems...

To post a comment you must log in.