vfat support=m: cannot flash an alternative kernel while removing the running one

Bug #853783 reported by Paolo Pisati on 2011-09-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Paolo Pisati
Oneiric
Undecided
Paolo Pisati
linux-ti-omap (Ubuntu)
Undecided
Paolo Pisati
Oneiric
Undecided
Paolo Pisati

Bug Description

SRU Justification:

Impact: Removing the running kernel (perhaps because we want to rollback to a previous one due to a regression) result in a system with no support for fat filesystem, and thus with the inability to flash/install the alternative kernel in the boot partition

How to reproduce: boot the beagle board, remove the running kernel and then run flash-kernel (see below)

Fix: Compile in support for v/fat and necessary nls modules (codepage 437 and iso8859-1) (see the attached patch)

=====

flag@beaglexm:~$ uname -a
Linux beaglexm 3.0.0-11-omap #18 Mon Sep 19 11:03:17 CEST 2011 armv7l armv7l armv7l GNU/Linux

# here we remove the running kernel
flag@beaglexm:~$ sudo dpkg -P linux-image-3.0.0-11-omap
[sudo] password for flag:
(Reading database ... 26609 files and directories currently installed.)
Removing linux-image-3.0.0-11-omap ...
WARN: Proceeding with removing running kernel image.
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.0.0-11-omap /boot/vmlinuz-3.0.0-11-omap
update-initramfs: Deleting /boot/initrd.img-3.0.0-11-omap
The link /vmlinuz is a damaged link
Removing symbolic link vmlinuz
 you may need to re-run your boot loader[grub]
The link /initrd.img is a damaged link
Removing symbolic link initrd.img
 you may need to re-run your boot loader[grub]
Purging configuration files for linux-image-3.0.0-11-omap ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.0.0-11-omap /boot/vmlinuz-3.0.0-11-omap

# ...but when we try to re-install the old kernel in the boot partition we suddenly find out
# that we don't have vfat support compiled-in
flag@beaglexm:~$ sudo flash-kernel
Using u-boot partition: /dev/mmcblk0p1
mount: unknown filesystem type 'vfat'

# ...and since the running kernel package has already been removed, we can't load the vfat module anymore
flag@beaglexm:~$ ls -la /lib/modules/

total 6
drwxr-xr-x 3 root root 1024 2011-09-19 12:36 .
drwxr-xr-x 17 root root 4096 2011-09-16 16:39 ..
drwxr-xr-x 4 root root 1024 2011-08-30 06:45 3.0.0-9-omap
flag@beaglexm:~$ lsmod
Module Size Used by
dm_crypt 16118 0
joydev 9588 0
smsc95xx 12679 0
usbnet 18565 1 smsc95xx
omap_wdt 4519 0
twl4030_pwrbutton 1369 0
omap2_mcspi 8120 0
gpio_keys 6500 0
leds_gpio 3633 0
usbhid 38987 0
hid 81145 1 usbhid
usb_storage 44426 0
uas 8222 0

by the way, vfat support is compiled-in in omap4 kernel.

Paolo Pisati (p-pisati) on 2011-09-19
Changed in linux-meta (Ubuntu):
assignee: nobody → Paolo Pisati (p-pisati)
Paolo Pisati (p-pisati) on 2011-09-19
Changed in linux-meta (Ubuntu):
status: New → Invalid
Changed in linux-ti-omap (Ubuntu):
assignee: nobody → Paolo Pisati (p-pisati)
Paolo Pisati (p-pisati) on 2011-09-19
summary: - vfat support=m: chicken egg situation while removing the running kernel
+ vfat support=m: cannot flash an alternative kernel while removing the
+ running one
Paolo Pisati (p-pisati) wrote :
description: updated
description: updated

The attachment "0001-UBUNTU-Config-Compile-in-vfat-support-for-armel.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Tim Gardner (timg-tpi) on 2011-09-19
affects: linux-meta (Ubuntu Oneiric) → linux (Ubuntu Oneiric)
Changed in linux (Ubuntu Oneiric):
status: Invalid → Fix Committed
Changed in linux-ti-omap (Ubuntu Oneiric):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.0.0-12.19

---------------
linux (3.0.0-12.19) oneiric; urgency=low

  [ Alex Bligh ]

  * SAUCE: (drop after v3.1) net/netfilter/nf_conntrack_netlink.c: fix Oops
    on container destroy
    - LP: #843892

  [ Andy Whitcroft ]

  * [Config] standardise on HZ=250
  * SAUCE: headers_install: fix #include "..." usage for userspace
    - LP: #824377
  * make module-inclusion selection retain the left overs
  * add a new linux-image-extras package for virtual

  [ edwin_rong ]

  * SAUCE: Staging: add driver for Realtek RTS5139 cardreader
    - LP: #824273

  [ Greg Kroah-Hartman ]

  * SAUCE: staging: rts5139: add vmalloc.h to some files to fix the build.
    - LP: #824273

  [ Jesse Sung ]

  * SAUCE: Unregister input device only if it is registered
    - LP: #839238

  [ Keng-Yu Lin ]

  * [Config] Enable CONFIG_RTS5139=m on i386/amd64
    - LP: #824273

  [ Leann Ogasawara ]

  * SAUCE: x86: reboot: Make Dell Optiplex 990 use reboot=pci
    - LP: #768039
  * SAUCE: x86: reboot: Make Dell Latitude E6220 use reboot=pci
    - LP: #838402

  [ Ming Lei ]

  * SAUCE: ata: make DVD drive recognisable on systems with Sandybridge CPT
    chipset
    - LP: #794642

  [ Paolo Pisati ]

  * [Config] Compile-in vfat support for armel
    - LP: #853783

  [ Randy Dunlap ]

  * SAUCE: staging: fix rts5139 depends & build
    - LP: #824273

  [ Tim Gardner ]

  * [Config] Fix binary-% build target
  * SAUCE: (drop after 3.0.0) OMAP3 and 4 hwmod I2C units only allow 16 bit
    access
    - LP: #852225

  [ Upstream Kernel Changes ]

  * hfsplus: Fix kfree of wrong pointers in hfsplus_fill_super() error path
    - LP: #854987
  * rt2x00: Serialize TX operations on a queue.
    - LP: #855239
 -- Leann Ogasawara <email address hidden> Wed, 14 Sep 2011 06:14:30 -0700

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers