Ubuntu

[HP EliteBook 8440p] sound control panel can't activate headphones

Reported by Glen Ditchfield on 2011-09-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
David Henningsson

Bug Description

While running through http://testcases.qa.ubuntu.com/Hardware/Sound/Headphones, I opened "Sound Settings..." in the volume control applet. Sound was coming out my headphones, but the "Connector" field in the control panel was set to "Analog Speakers".

I switched "Connector" to "Analog Headphones". The sound from the headphones stopped. The "mute" indicator on the keyboard lit up, but the "Mute" checkbox in the control panel remained unchecked, and the Volume Control applet did not switch to its "muted" state.

I tried pressing the keyboard "mute" and volume keys, toggling the control panel's "mute" checkbox, muting and unmuting with the volume control applet, and adjusting the volume sliders in the control panel and the volume control applet. The computer remained silent.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.1.91-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Thu Sep 8 20:59:55 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gjditchf 1701 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x94720000 irq 47'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:111d7603,103c172a,00100202 HDA:11c11040,103c3066,00100200 HDA:80862804,80860101,00100000'
   Controls : 19
   Simple ctrls : 11
DistroRelease: Ubuntu 11.10
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
Package: pulseaudio 1:0.99.3-0ubuntu4
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Tags: oneiric running-unity
Uname: Linux 3.0.0-11-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 12/22/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68CCU Ver. F.02
dmi.board.name: 172A
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 30.29
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68CCUVer.F.02:bd12/22/2009:svnHewlett-Packard:pnHPEliteBook8440p:pvr:rvnHewlett-Packard:rn172A:rvrKBCVersion30.29:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP EliteBook 8440p
dmi.sys.vendor: Hewlett-Packard

Glen Ditchfield (gjditchfield) wrote :
David Henningsson (diwic) wrote :

Hi Glen!
Could you please run "apport-collect 845275" to tell us more about your hardware? Thanks!

affects: gnome-control-center (Ubuntu) → pulseaudio (Ubuntu)
Changed in pulseaudio (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in pulseaudio (Ubuntu):
status: Incomplete → New

Thanks. I've investigated the problem a little bit further and writing down my notes about it:

Node 0x0f [Pin Complex] wcaps 0x400181: Stereo
  Pincap 0x00000014: OUT Detect
  Pin Default 0x0321101f: [Jack] HP Out at Ext Left
    Conn = 1/8, Color = Black
    DefAssociation = 0x1, Sequence = 0xf
  Pin-ctls: 0x00:
  Unsolicited: tag=02, enabled=1
  Connection: 3
     0x10* 0x11 0x17
     ^^^

This node should come from the 0x11 DAC instead of the 0x10 DAC. The problem is that the 0x11 DAC is already occupied by the docking station headphone, and so the algorithm falls back to using the 0x10 DAC instead.

The solution would probably be to do what is done in the autoparser for conexant, where it falls back to one of the same type first, then to the first DAC.

Changed in pulseaudio (Ubuntu):
status: New → Triaged
affects: pulseaudio (Ubuntu) → alsa-driver (Ubuntu)
summary: - sound control panel can't activate headphones
+ [HP EliteBook 8440p] sound control panel can't activate headphones
Changed in alsa-driver (Ubuntu):
importance: Undecided → Low
David Henningsson (diwic) wrote :

Patch sent upstream.

Changed in alsa-driver (Ubuntu):
status: Triaged → In Progress
assignee: nobody → David Henningsson (diwic)
affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Andy Whitcroft (apw) on 2012-01-16
Changed in linux (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers