Comment 18 for bug 836250

Wifi is very slow, but ethernet is OK.

Upload:
wifi: ~30 KiB/s
ethernet: ~400 KiB/s

Tried Kubuntu 10.04 Live CD - wifi speed is good.

I am ready to do any testing as this is my wife's laptop and she wants to switch back to slow Vista :)

$ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8400M GS] (rev a1)
02:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)
08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 01)
09:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
09:09.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
09:09.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
09:09.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)

$ uname -a
Linux nata 3.0.0-12-generic #19-Ubuntu SMP Fri Sep 23 21:23:39 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

syslog:
Oct 6 21:23:58 nata NetworkManager[1096]: <info> (eth0): carrier now OFF (device state 100, deferring action for 4 seconds)
Oct 6 21:24:03 nata NetworkManager[1096]: <info> (eth0): device state change: activated -> unavailable (reason 'carrier-changed') [100 20 40]
Oct 6 21:24:03 nata NetworkManager[1096]: <info> (eth0): deactivating device (reason 'carrier-changed') [40]
Oct 6 21:24:03 nata NetworkManager[1096]: <info> (eth0): canceled DHCP transaction, DHCP client pid 7928
Oct 6 21:24:03 nata avahi-daemon[1085]: Withdrawing address record for 192.168.1.105 on eth0.
Oct 6 21:24:03 nata avahi-daemon[1085]: Leaving mDNS multicast group on interface eth0.IPv4 with address 192.168.1.105.
Oct 6 21:24:03 nata avahi-daemon[1085]: Interface eth0.IPv4 no longer relevant for mDNS.
Oct 6 21:24:03 nata NetworkManager[1096]: <info> Policy set 'rnet' (wlan0) as default for IPv4 routing and DNS.
Oct 6 21:24:03 nata NetworkManager[1096]: <info> Policy set 'rnet' (wlan0) as default for IPv4 routing and DNS.
Oct 6 21:24:03 nata dbus[1037]: [system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
Oct 6 21:24:03 nata dbus[1037]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Oct 6 21:24:37 nata kernel: [16047.869583] iwl4965 0000:02:00.0: Aggregation not enabled for tid 0 because load = 1
Oct 6 21:25:03 nata kernel: [16074.744717] iwl4965 0000:02:00.0: Aggregation not enabled for tid 0 because load = 0
Oct 6 21:25:21 nata kernel: [16092.109599] iwl4965 0000:02:00.0: Aggregation not enabled for tid 0 because load = 0
Oct 6 21:25:59 nata kernel: [16130.274538] CPU1: Core temperature above threshold, cpu clock throttled (total events = 53377)
Oct 6 21:25:59 nata kernel: [16130.275513] CPU1: Core temperature/speed normal
Oct 6 21:26:03 nata kernel: [16133.812832] iwl4965 0000:02:00.0: Aggregation not enabled for tid 0 because load = 0
Oct 6 21:26:06 nata kernel: [16137.116073] iwl4965 0000:02:00.0: iwl4965_tx_agg_start on ra = bc:ae:c5:c3:6b:28 tid = 0
Oct 6 21:27:09 nata kernel: [16199.816095] [Hardware Error]: Machine check events logged