Error inserting ramzswap in Oneiric Desktop ISO 24th August

Bug #832694 reported by Gema Gomez on 2011-08-24
42
This bug affects 13 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Medium
Andy Whitcroft
linux (Ubuntu)
Medium
Andy Whitcroft

Bug Description

I had this problem when trying to boot a VM with 256 MB of RAM:
FATAL: Error inserting ramzswap (/lib/modules/3.0.0-9-generic/kernel/ubuntu/compcache/ramzswap.ko): Invalid module format

This sounded wrong as an error for such problem, so following apw advice tried booting with more memory and trying to insert the module manually, same issue:
root@ubuntu:~# modprobe ramzswap
FATAL: Error inserting ramzswap (/lib/modules/3.0.0-9-generic/kernel/ubuntu/compcache/ramzswap.ko): Invalid module format

This module failing to load is a common theme in many bugs in the database, I do not think they are duplicates, my feeling is that something is failing that is not being clearly reported, rather.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-9-generic 3.0.0-9.14
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: I82801AAICH [Intel 82801AA-ICH], device 0: Intel ICH [Intel 82801AA-ICH]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 2952 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'I82801AAICH'/'Intel 82801AA-ICH with STAC9700,83,84 at irq 5'
   Mixer name : 'SigmaTel STAC9700,83,84'
   Components : 'AC97a:83847600'
   Controls : 34
   Simple ctrls : 24
CasperVersion: 1.279
Date: Wed Aug 24 11:26:28 2011
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110824)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
MachineType: innotek GmbH VirtualBox
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
PulseSinks:
 Error: command ['pacmd', 'list-sinks'] failed with exit code 1: Home directory /home/ubuntu not ours.
 No PulseAudio daemon running, or not running as session daemon.
PulseSources:
 Error: command ['pacmd', 'list-sources'] failed with exit code 1: Home directory /home/ubuntu not ours.
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-9-generic N/A
 linux-backports-modules-3.0.0-9-generic N/A
 linux-firmware 1.60
RfKill:

SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH

Gema Gomez (gema) wrote :
Brad Figg (brad-figg) on 2011-08-24
Changed in linux (Ubuntu):
status: New → Confirmed
Andy Whitcroft (apw) on 2011-08-24
Changed in linux (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Andy Whitcroft (apw)
importance: Undecided → Medium
milestone: none → ubuntu-11.10-beta-2
Andy Whitcroft (apw) wrote :

I suspect that this is the real error:

    [ 135.395747] xvmalloc: exports duplicate symbol xv_create_pool (owned by kernel)

And indeed we seem to have two xvmalloc kernel modules now. A collission between a new staging driver and the ubuntu driver.

Andy Whitcroft (apw) wrote :

The new xvmalloc module has a complely different API to the one used by ramzswap so we are unable to move it trivially over to use the version in staging. We have two solutions available to us.

1) turn off zram and use ramzswap, or
2) turn off ramzswap and switch the live installer to use that.

The first should be the simplest as we _should_ already have the required installer support. The second is a longer term solution as zram represents the ongoing development of ramzswap.

However looking at the installer support (which is actually part of initramfs-tools) we find that the code there for using ramzswap is broken and will never correctly load the module as indeed is the code for compcache. The syntax of the generated udev rules files are broken and needs fundamental redesign. If we are going to redo the support there we may as well add zram support and transition over.

Therefore I am opening this up against initramfs-tools and the kernel. For the kernel this is to track removing ramzswap (which is broken anyhow). For initramfs-tools it is to track the updates to the udev support and adding zram support.

Changed in initramfs-tools (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Andy Whitcroft (apw)
milestone: none → ubuntu-11.10-beta-2
Andy Whitcroft (apw) on 2011-08-25
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
tags: added: iso-testing
Launchpad Janitor (janitor) wrote :
Download full text (4.9 KiB)

This bug was fixed in the package linux - 3.0.0-10.16

---------------
linux (3.0.0-10.16) oneiric; urgency=low

  [ Andy Whitcroft ]

  * Revert "ubuntu: compcache -- follow changes to bd_claim/bd_release"
    - LP: #832694
  * Revert "ubuntu: compcache -- version 0.5.3"
    - LP: #832694
  * [Config] dropping compcache configuration options

  [ David Henningsson ]

  * SAUCE: ALSA: HDA: hdmi: Emit pcm device index for jack input devices

  [ Kees Cook ]

  * [Config] enable and enforce SECCOMP_FILTER on x86

  [ Leann Ogasawara ]

  * [Config] Update CONFIG_EFI_VARS enforcer check
  * [Config] Enable CONFIG_ECHO=m on powerpc
  * [Config] Enable CONFIG_ET131X=m on powerpc
  * [Config] Set CONFIG_FB_MATROX=m
  * [Config] Enable CONFIG_FB_UDL=m on powerpc
  * [Config] Set CONFIG_FB_VIRTUAL=n
  * [Config] Enable CONFIG_FB_VGA16=m on powerpc
  * [Config] Enable CONFIG_GPIO_MAX732X=m on arm
  * [Config] Enable CONFIG_GPIO_PCF857X=m on arm
  * [Config] Set CONFIG_HOTPLUG_PCI_FAKE=m
  * [Config] Enable CONFIG_HOTPLUG_PCI=y on powerpc
  * [Config] Enable CONFIG_HOTPLUG_PCI_CPCI=y on powerpc
  * [Config] Enable CONFIG_HP_ILO=m on powerpc-smp
  * [Config] Enable CONFIG_I2C_PASEMI=m on powerpc
  * [Config] Enable CONFIG_IBM_BSR=m on powerpc
  * [Config] Enable CONFIG_IBMVETH=m on powerpc
  * [Config] Enable CONFIG_IDE_PHISON=m on powerpc
  * [Config] Enable CONFIG_IGB=m on powerpc
  * [Config] Enable CONFIG_IIO=m on powerpc
  * [Config] Enable CONFIG_INFINIBAND_NES=m
  * [Config] Enable CONFIG_IPMI_HANDLER=m on arm
  * [Config] Enable CONFIG_IWL3945=m on powerpc
  * [Config] Disable CONFIG_KVM_BOOK3S_64
  * [Config] Enable CONFIG_LAPBETHER=m on arm
  * [Config] Enable CONFIG_LEDS_GPIO=m on powerpc
  * [Config] Enable CONFIG_LEDS_CLEVO_MAIL=m all arch's
  * [Config] Enable CONFIG_LEDS_PCA9532=m on powerpc
  * [Config] Enable CONFIG_LEDS_PCA955X=m on powerpc
  * [Config] Enable CONFIG_LEDS_TRIGGER_DEFAULT_ON=m on powerpc
  * [Config] Set CONFIG_LEDS_TRIGGER_HEARTBEAT=m on arm and powerpc
  * [Config] Set CONFIG_LEDS_TRIGGER_TIMER=m on powerpc
  * [Config] Enable CONFIG_LINE6_USB=m on arm and powerpc
  * [Config] Enable CONFIG_MEMSTICK=m on arm
  * [Config] Enable CONFIG_MTD_AFS_PARTS=m on arm
  * [Config] Enable CONFIG_MTD_ALAUDA=m on arm
  * [Config] Enable CONFIG_MTD_AR7_PARTS=m on arm
  * [Config] Enable CONFIG_MTD_ARM_INTEGRATOR=m on arm
  * [Config] Enable CONFIG_MOXA_SMARTIO=m on powerpc
  * [Config] Enable CONFIG_MTD_DATAFLASH=m on arm
  * [Config] Enable CONFIG_MTD_GPIO_ADDR=m on arm
  * [Config] Enable CONFIG_MTD_IMPA7=m on arm
  * [Config] Enable CONFIG_MTD_NAND_GPIO=m on arm
  * [Config] Enable CONFIG_MTD_NAND_NANDSIM=m on arm
  * [Config] Enable CONFIG_MTD_NAND_PASEMI=m on powerpc
  * [Config] Enable CONFIG_MTD_NAND_PLATFORM=m on arm
  * [Config] Enable CONFIG_MTD_NAND_TMIO=m on arm
  * [Config] Enable CONFIG_MTD_SST25L=m on arm
  * [Config] Enable CONFIG_NET_CLS_CGROUP=y on arm
  * [Config] Enable CONFIG_NET_CLS_FLOW=m on arm
  * [Config] Enable CONFIG_NET_CLS_U32=m on arm
  * [Config] Enable CONFIG_NET_DCCPPROBE=m on arm
  * [Config] Enable CONFIG_NET_SCH_INGRESS=m on arm
  * [Config] Enable CONFIG_NET_TCPPROBE=m on arm
  * [Config] Enable...

Read more...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Eugene San (eugenesan) wrote :

Since there is no other solution, I am sending my patch with solution.
Patch enables usage of:
compcache for Linux < 2.6.35 (Lucid)
ramzswap for Linux < 2.6.38 (Maverick)
zram for Linux > 2.6.38 (Natty and Oneiric)

Changed in initramfs-tools (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.99ubuntu5

---------------
initramfs-tools (0.99ubuntu5) oneiric; urgency=low

  * hooks/compcache: udev RUN commands cannot include double quotes (")
    nor do they support shell syntax. Move to an external helper script
    to provision and add the memory swap partitions.
  * hooks/compcache: add support for the updated zram staging driver
    which requires the size to be pushed into sysfs and the partition be
    initialised before adding. (LP: #832694)
 -- Andy Whitcroft <email address hidden> Mon, 19 Sep 2011 15:40:32 +0100

Changed in initramfs-tools (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers