Crashes (caps lock blinking) when suspending/sleeping 2.6.38-11 kernel

Bug #830155 reported by Marius B. Kotsbak on 2011-08-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

This seems like a regression in the 2.6.38-11-generic kernel. It does not appear in 2.6.38-10-generic.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-11-generic 2.6.38-11.48
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: marius 2379 F.... pulseaudio
CRDA: Error: [Errno 2] Ingen slik fil eller filkatalog
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x98200000 irq 52'
   Mixer name : 'Realtek ALC269VB'
   Components : 'HDA:10ec0269,1458b100,00100100'
   Controls : 11
   Simple ctrls : 7
Date: Sat Aug 20 19:32:31 2011
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=49e028f9-7435-4850-8244-8523020782de
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: GIGABYTE T1005
ProcEnviron:
 LANGUAGE=nb_NO:en
 PATH=(custom, user)
 LANG=nb_NO.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-10-generic root=UUID=f1d0446d-3ea3-46a7-9842-8773acca78e6 ro crashkernel=384M-2G:64M,2G-:128M quiet splash i8042.noloop=1 vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-10-generic N/A
 linux-backports-modules-2.6.38-10-generic N/A
 linux-firmware 1.52.1
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to natty on 2011-04-24 (118 days ago)
dmi.bios.date: 08/30/2010
dmi.bios.vendor: GIGABYTE
dmi.bios.version: GSBF05
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: T1005
dmi.board.vendor: GIGABYTE
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnGIGABYTE:bvrGSBF05:bd08/30/2010:svnGIGABYTE:pnT1005:pvrGSBF05:rvnGIGABYTE:rnT1005:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: T1005
dmi.product.version: GSBF05
dmi.sys.vendor: GIGABYTE

Marius B. Kotsbak (mariusko) wrote :
tags: added: regression-update
Marius B. Kotsbak (mariusko) wrote :

I could not reproduce this in a 3.0 kernel.

summary: - Crashes (caps lock bllinking) when suspending/sleeping
+ Crashes (caps lock blinking) when suspending/sleeping 2.6.38-11 kernel
Brad Figg (brad-figg) on 2011-08-21
Changed in linux (Ubuntu):
status: New → Confirmed
Marius B. Kotsbak (mariusko) wrote :

I'm currently bisecting this. Reached halfway through, but takes time because I get an error if I don't run clean between each build. Is there a way to avoid that?

Changed in linux (Ubuntu):
assignee: nobody → Marius Kotsbak (mariusko)
Marius B. Kotsbak (mariusko) wrote :

Bisecting finished:

9335a6a2afb9512965e3f601b887fe00479d25f1 is the first bad commit
commit 9335a6a2afb9512965e3f601b887fe00479d25f1
Author: Martin K. Petersen <email address hidden>
Date: Wed May 18 10:37:35 2011 +0200

    block: Fix discard topology stacking and reporting

    BugLink: http://bugs.launchpad.net/bugs/793702

    commit a934a00a69e940b126b9bdbf83e630ef5fe43523 upstream.

    In some cases we would end up stacking discard_zeroes_data incorrectly.
    Fix this by enabling the feature by default for stacking drivers and
    clearing it for low-level drivers. Incorporating a device that does not
    support dzd will then cause the feature to be disabled in the stacking
    driver.

    Also ensure that the maximum discard value does not overflow when
    exported in sysfs and return 0 in the alignment and dzd fields for
    devices that don't support discard.

    Reported-by: Lukas Czerner <email address hidden>
    Signed-off-by: Martin K. Petersen <email address hidden>
    Acked-by: Mike Snitzer <email address hidden>
    Signed-off-by: Jens Axboe <email address hidden>
    Signed-off-by: Greg Kroah-Hartman <email address hidden>
    Signed-off-by: Tim Gardner <email address hidden>

:040000 040000 1742d8f1c7e3f4c93e7b91f8f8bfd13c72643524 ae17fc309373c5481a6a1e94c6adceda7db2a761 M block
:040000 040000 b664df5b84192064a75346880cdc04824f6c90be 80dc258ef4dd61a2f7bc16f4c9ee1527a6b1621e M include

I'm not sure yet if it is correct. I also noticed that the bug does not appear when doing sleep before logging in, which makes me suspect it has something to do with wlan or mobile broadband. But it might also be with ecryptfs, which I use (as this commit seems to be about storage).

Marius B. Kotsbak (mariusko) wrote :

I tried to build a kernel package with the patch reverted, but get:

EE: 1232 symbols changed hash and weren't ignored
make: *** [abi-check-generic] Error 1

even when I have run clean first. How to avoid this?

Changed in linux (Ubuntu):
assignee: Marius Kotsbak (mariusko) → nobody
Marius B. Kotsbak (mariusko) wrote :

My guess is that a stable backport was not complete, probably the commit above. Could someone build a version with that patch reverted?

I tried 3.0.0-9.14 package and there the problem does not exist.

Marius B. Kotsbak (mariusko) wrote :

I don't see this, but working / bug #879071 in Oneiric.

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
status: Fix Committed → In Progress
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers