Ubuntu

8086:0046 [Lenovo ThinkPad T510] Fuzzy and corrupted display after DPMS cycles

Reported by Marc Deslauriers on 2011-07-21
46
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
High
Unassigned
Natty
High
Unassigned
Oneiric
High
Unassigned
Precise
High
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
Saucy
High
Unassigned

Bug Description

Since updating to 2:2.14.0-4ubuntu7.2 in natty-proposed, screen comes up fuzzy and corrupted when coming out of the screensaver. I'm using the blank screen screensaver. Screen is flickery and graphics are corrupted and fuzzy. See attached screenshots.

This has now happened three times since I installed the version from -proposed, and had never happened before.

 it's happened 3 times in the last day and each time, I've rebooted, as I haven't figured out what else to do.
The screensaver probably has activated 30 times in the last day.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.2
ProcVersionSignature: Ubuntu 2.6.38-11.47-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Thu Jul 21 18:18:03 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21d9]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
MachineType: LENOVO 4313CTO
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-11-generic root=UUID=66b32bb3-1e18-436e-8f6e-62b8419ed48d ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/26/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6MET81WW (1.41 )
dmi.board.name: 4313CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6MET81WW(1.41):bd10/26/2010:svnLENOVO:pn4313CTO:pvrThinkPadT510:rvnLENOVO:rn4313CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4313CTO
dmi.product.version: ThinkPad T510
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu1~natty2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Marc Deslauriers (mdeslaur) wrote :
Marc Deslauriers (mdeslaur) wrote :
Marc Deslauriers (mdeslaur) wrote :
tags: added: regression-proposed
Bryce Harrington (bryce) on 2011-07-21
Changed in xserver-xorg-video-intel (Ubuntu Natty):
importance: Undecided → High
status: New → Triaged
summary: - fuzzy and corrupted display with update in -proposed
+ fuzzy and corrupted display with update in natty-proposed
description: updated
description: updated
Marc Deslauriers (mdeslaur) wrote :
Marc Deslauriers (mdeslaur) wrote :

More info: when the problem occurs, it also happens on virtual consoles. Ctrl-Alt-F1 shows me a corrupted console also.

Bryce Harrington (bryce) wrote :

The 7.2 -intel update adds patch 121_fdo-28798-fix.patch. This patch significantly changes rendering behavior with 2D graphics acceleration, thus is definitely a strong suspect for this issue (although it's quite strange that it affects the console too!) To prove it is the patch's fault, downgrade to 7.1; if it no longer reproduces within ~1 day, then the patch is at fault and we should not proceed with the SRU. If it still reproduces, then we should examine dpkg.log for other possible suspects.

Corruption that affects the console indicates either a kernel bug, or an X bug that somehow put the GPU into a really bad state. Booting and reproducing on an earlier kernel would rule out it being due to a kernel update.

If it *is* pinpointed to the patch, would you mind also booting an oneiric livecd and see whether you can reproduce it there. I ask because we're already including this patch in oneiric and if the same issue exists there, we ought to look into it more closely. If it doesn't occur on oneiric, then presumably we can just forgo the 7.2 SRU and leave it at that.

Bryce Harrington (bryce) wrote :

upgrade bluefish 2011-07-20 08:04:37 2.0.2-1 2.0.2-1ubuntu1
upgrade bzr 2011-07-20 08:04:42 2.3.3-0ubuntu1 2.3.4-0ubuntu1
install eglibc 2011-07-21 13:41:23 <none> 2.13-0ubuntu13
upgrade linux 2011-07-19 16:05:37 2.6.38-10.46 2.6.38-11.47
install linux-headers-2.6.38-11 2011-07-19 16:05:31 <none> 2.6.38-11.47
install linux-headers-2.6.38-11-generic 2011-07-19 16:05:34 <none> 2.6.38-11.47
install linux-image-2.6.38-11-generic 2011-07-19 16:05:17 <none> 2.6.38-11.47
upgrade linux-meta 2011-07-19 16:05:28 2.6.38.10.25 2.6.38.11.26
upgrade nfs-utils 2011-07-20 08:04:48 1:1.2.2-4ubuntu5 1:1.2.2-4ubuntu5.1
install valgrind 2011-07-21 13:41:25 <none> 1:3.6.1-0ubuntu1
upgrade xserver-xorg-video-intel 2011-07-20 08:04:50 2:2.14.0-4ubuntu7.1 2:2.14.0-4ubuntu7.2

Either linux or -intel could be a suspect at this point, looks like nothing else of relevance got updated within the timeframe.

Bryce Harrington (bryce) on 2011-07-21
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Marc Deslauriers (mdeslaur) wrote :

OK, looks like this isn't caused by the intel driver in proposed. I just had it happen with 2:2.14.0-4ubuntu7.1.
Next in line is the kernel update...

affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
Marc Deslauriers (mdeslaur) wrote :

I've been running with 2.6.38-10 for the past week, and this problem has not come back. This could definitely be a kernel regression.

Marc Deslauriers (mdeslaur) wrote :

3 hours after trying 2.6.38-11 again, I've been hit by the bug. I'm pretty convinced this is a regression in the kernel currently in -proposed.

Herton R. Krzesinski (herton) wrote :

It's likely a drm/i915 change which is causing the regression. Probably one of these four candidates that we got through stable update to 2.6.38.8:
drm/i915: Fix gen6 (SNB) missed BLT ring interrupts.
drm/i915: disable PCH ports if needed when disabling a CRTC
drm: Send pending vblank events before disabling vblank.
drm/i915: fix user irq miss in BSD ring on g4x

In a hunch, I reverted "drm: Send pending vblank events before disabling vblank.", built, and uploaded amd64 packages at http://people.canonical.com/~herton/lp814325/r1/

Marc, can you test it?

If it works, then try the 11.48 when it hits -proposed, just to double check. If it fails, then we got our change which introduced the issue.

Marc Deslauriers (mdeslaur) wrote :

Thanks Herton, I'll install them now and let you know...It will take a day or two as I can't reproduce this at will, but it usually happens a couple of times a day.

Marc Deslauriers (mdeslaur) wrote :

I've ran your test packages for the past day and a half and didn't get the issue.
I have now installed the 11.48 packages in -proposed, to see if it will come back.

Marc Deslauriers (mdeslaur) wrote :

I've now hit the problem again with the 11.48 packages in -proposed. Since it took two days for me to hit it, I'm now switching back to your test packages to see if the commit you reverted was the right one. I think I didn't wait long enough.

Marc Deslauriers (mdeslaur) wrote :

Unfortunately, I have hit the issue with the test packages from comment #12.

@Herton: do you have a second candidate I could test? Thanks!

Herton R. Krzesinski (herton) wrote :

Ok, lets see if some of other remaining drm/i915 changes is at fault. Marc, please try the kernel from http://people.canonical.com/~herton/lp814325/r2/

Marc Deslauriers (mdeslaur) wrote :

Thanks for the updated package Herton, I'm testing them now.

Marc Deslauriers (mdeslaur) wrote :

Herton, I've been running your updated packages for three days now with no sign of the regression. I'll continue running it, but I think you've located the problematic commits.

Herton R. Krzesinski (herton) wrote :

Thanks for testing, hopefully the regression really is gone reverting the 3 patches. If you could find an way to reproduce the problem more easily, may be come and go many times in sequence from screen saver/blank would be great, problem is I think you'll get bored easily always having to check the corrupted screen many times in a row :)

The three remaining reverted patches in r2 were:
drm/i915: Fix gen6 (SNB) missed BLT ring interrupts.
drm/i915: disable PCH ports if needed when disabling a CRTC
drm/i915: fix user irq miss in BSD ring on g4x

We should identify now which one is introducing the problem. I took a deep look again at them, and compared now against your reported hardware (lspci). You have an "ironlake" vga. The first and last patches touches code paths only related to sandybridge or gm45/g45 hardware, which shouldn't affect/change your case. Hoping this isn't a timing/code shuffle issue, now I strongly believe we could have a problem with the remaining patch:

drm/i915: disable PCH ports if needed when disabling a CRTC

This was a backport for hardware enablement, and also it is missing a following fix to this change which is upstream but wasn't backported to natty: "drm/i915: DP_PIPE_ENABLED must check transcoder on CPT".

First lets try to double check and really see if "drm/i915: disable PCH ports if needed when disabling a CRTC" introduces your regression, now I built a new kernel only with it reverted, please try the package http://people.canonical.com/~herton/lp814325/r3/

If this one works, then next step is including also "drm/i915: DP_PIPE_ENABLED must check transcoder on CPT" on natty, and doing another test to see if issue is gone.

Timo Aaltonen (tjaalton) wrote :

Yes, we really need that commit, so identifying additional ones to fix this bug would be most welcome.

Marc Deslauriers (mdeslaur) wrote :

OK, with the attached script, I can reproduce the issue reliably with the -proposed kernel.

Your r3 kernel does not have the issue, so that's the right commit.

Herton R. Krzesinski (herton) wrote :

Marc, please try now the kernel from http://people.canonical.com/~herton/lp814325/r4/

It reapplies the fix plus the change "drm/i915: DP_PIPE_ENABLED must check transcoder on CPT"

Marc Deslauriers (mdeslaur) wrote :

Herton, unfortunately the regression is in r4 :(

Herton R. Krzesinski (herton) wrote :

@Timo: any idea on this one? looks like we have to revert "drm/i915: disable PCH ports if needed when disabling a CRTC" for now :-/ The followup fix didn't worked.

Chris Halse Rogers (raof) wrote :

I'm wondering if this isn't a spread-spectrum bug - http://article.gmane.org/gmane.linux.kernel/1173193 sounds similar, although not identical. Maybe the connector is being turned back on with SSC enabled?

The patch starting that thread is not going to be applied upstream, as it just adds an option to work around a bug, but that means it could be used to test this SSC hypothesis.

Chris Halse Rogers (raof) wrote :

Oooh. Looks like the thread starting with http://<email address hidden> is likely to be the upstream fix for the spread-spectrum bit.

Robert Hooker (sarvatt) wrote :

Marc: Can you post the intel_reg_dumper output from before and after triggering this?

Marc Deslauriers (mdeslaur) wrote :

@Robert: unfortunately, they are the same.

Marc Deslauriers (mdeslaur) wrote :

What's interesting is once the problem occurs, I can do xset dpms force off; xset dpms force on to make it go away again.

Keng-Yu Lin (lexical) wrote :

The following models are tested with epilepsy.sh in the comment #22

Lenovo ZHAOYANG E47 with Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz)
Acer eMachine AS4739Z with Intel(R) Pentium(R) CPU P6200 @ 2.13GHz
Dell Inspiron N311z with Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz

but I cannot reproduce the bug.

Keng-Yu Lin (lexical) wrote :

BTW, the three models above were reported having bug 791752.

Keng-Yu Lin (lexical) wrote :

Dell Vostro V130 with Intel(R) Core(TM) i3 CPU U 380 @ 1.33GHz

is tested for comparison. not able to reproduce either.

Marc Deslauriers (mdeslaur) wrote :

I can't reproduce it either on a Dell Mini 9. That's the only other intel chipset machine I have.

Timo Aaltonen (tjaalton) wrote :

Herton, Marc: maybe test a newer mainline kernel (2.6.39, 3.0) to see that this really is fixed there, and if not, the patch that Chris pointed out could be another candidate to give a try.

Keng-Yu Lin (lexical) wrote :

Does this bug exist in Oneiric too?

Marc Deslauriers (mdeslaur) wrote :

Unfortunately, I just tried with the Oneiric alpha3 amd64 live cd, and I have the same regression. Here are a couple of screenshots.

Marc Deslauriers (mdeslaur) wrote :
Changed in linux (Ubuntu Oneiric):
status: Incomplete → Confirmed
importance: Undecided → High
Robert Hooker (sarvatt) on 2011-08-15
Changed in linux (Ubuntu Oneiric):
status: Confirmed → Incomplete
Changed in linux (Ubuntu Natty):
status: Triaged → Incomplete
44 comments hidden view all 117 comments

Created attachment 50311
Script to reproduce

Forwarding this for launchpad bug reporter Marc Deslauriers
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/814325

After f0575e92974d328e8816ed89704c985a7d7d90ac (drm/i915: DP_PIPE_ENABLED must check transcoder on CPT) was introduced in the kernel this person's Lenovo T510 machine started to come back from dpms fuzzy (see attached pictures) randomly, and another dpms cycle corrects it. This is still a problem on 3.1-rc2, and seems to be limited to this one machine with an optimus configuration (set to use only the integrated GPU) after testing on a wide variety of other machines including another T510 with an intel only config. He can reproduce the bug with the attached epilepsy.sh script which does rapid dpms off and on again easily.

System environment:
-- chipset: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046]
-- system architecture: amd64
-- xf86-video-intel/xserver/mesa/libdrm version: both ubuntu 11.04 and current 11.10 were tested. 11.04: libdrm 2.4.23, xf86-video-intel 2.14, mesa 7.10.2, xserver 1.10.1, kernel 2.6.38-11.48
11.10: libdrm 2.4.26, xf86-video-intel 2.15.901, mesa 7.11, xserver 1.10.2.902, kernel 3.0.1
-- kernel version: 2.6.38-11 (which has the above commit backported), 3.1-rc2, various other kernels in between those two
-- Linux distribution: Ubuntu 11.04, Ubuntu 11.10
-- Machine or mobo model: Lenovo T510 (4313CTO)
-- Display connector: LVDS

Created attachment 50312
Screenshot without the problem

Created attachment 50313
Screenshot with the problem

Created attachment 50314
Xorg.0.log

Created attachment 50315
dmesg with debug info (after reproducing the problem)

Created attachment 50316
dmesg with debug info (just before reproducing the problem)

Created attachment 50317
intel_reg_dumper output (before)

Created attachment 50318
intel_reg_dumper output (after)

Created attachment 50319
xrandr --verbose

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed

I can't make sense of this based on the commit... I'm afraid this might be timing related rather than an actual register change, since the register dumps before & after are identical.

Can you isolate which part of the patch causes problems?

(In reply to comment #9)
> I can't make sense of this based on the commit... I'm afraid this might be
> timing related rather than an actual register change, since the register dumps
> before & after are identical.
>
> Can you isolate which part of the patch causes problems?

Argh, I'm terribly sorry for this but the actual offending commit was

drm/i915: disable PCH ports if needed when disabling a CRTC

Which needed a bit of fixing to apply to .38, but has the same failure in both the backport and the upstream kernel

http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-natty.git;a=commit;h=bbeaf8811ba070fd186dfcabc957044c3a1149ac

Ah ok, that makes more sense. Does this patch change anything? We might be disabling LVDS incorrectly (i.e. without a corresponding panel power sequence):

diff --git a/drivers/gpu/drm/i915/intel_display.c b/drivers/gpu/drm/i915/intel_d
index 35364e6..ab8a36d 100644
--- a/drivers/gpu/drm/i915/intel_display.c
+++ b/drivers/gpu/drm/i915/intel_display.c
@@ -1394,7 +1394,7 @@ static void intel_disable_pch_ports(struct drm_i915_privat
        val = I915_READ(reg);
        if (ADPA_PIPE_ENABLED(val, pipe))
                I915_WRITE(reg, val & ~ADPA_DAC_ENABLE);
-
+#if 0
        reg = PCH_LVDS;
        val = I915_READ(reg);
        if (LVDS_PIPE_ENABLED(val, pipe)) {
@@ -1402,7 +1402,7 @@ static void intel_disable_pch_ports(struct drm_i915_privat
                POSTING_READ(reg);
                udelay(100);
        }
-
+#endif
        disable_pch_hdmi(dev_priv, pipe, HDMIB);
        disable_pch_hdmi(dev_priv, pipe, HDMIC);
        disable_pch_hdmi(dev_priv, pipe, HDMID);

@Jesse,

Unfortunately no, I can still reproduce with the patch in comment 11.

(In reply to comment #12)
> @Jesse,
>
> Unfortunately no, I can still reproduce with the patch in comment 11.

he tested on 3.0.1 there with this kernel

http://kernel.ubuntu.com/~sarvatt/fdo40172/

Can you try to isolate which part of the PCH port disable causes trouble? My other guess would be the panel register unlock, which might allow a clock change or something else to sneak in and cause LVDS problems...

Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking

I wonder if this relates to drm/i915: Enable dither whenever display bpc < frame buffer bpc?

summary: - fuzzy and corrupted display with update in natty-proposed
+ fuzzy and corrupted display after dpms cycles
tags: added: verification-done-natty
Changed in linux (Ubuntu Oneiric):
milestone: none → oneiric-updates
Changed in linux (Ubuntu Precise):
status: New → Incomplete
importance: Undecided → High
tags: added: rls-mgr-p-tracking
removed: rls-mgr-o-tracking
Changed in linux (Ubuntu Natty):
status: Incomplete → Fix Released
21 comments hidden view all 117 comments

Hmm, interesting. I've changed my monitor to D-sub instead of DVI connection and this problem seems to have gone. Have only turned off and turned on five times but it hasn't occured. It occured every time via DVI.

My monitor is a BenQ E2200HD 22" at 1920 by 1080.

Will keep testing in Lubuntu to see if it stays good.

Marc Deslauriers (mdeslaur) wrote :

@Orographic: If you can't reproduce it with the script in comment #22, you probably don't have the same issue...

Orographic (temp850) wrote :

Thanks for that, I'm not sure how to use that script in comment #22 but could easily learn, I'm sure. I have four drives in my system (Two Windows 7 drives, testing and production, and the same for Linux) that are all imaged via Clonezilla and Acronis, so its easy to restore my Linux distros.

I've just changed my DVI cable over to a new one and the monitor has turned on no problems, five times in a row thus far. So, it seems my situation is related to a faulty DVI cable.

Thanks for all the work you guys are doing, its always appreciated.

Marc Deslauriers (mdeslaur) wrote :

Unfortunately, the problem persists with: :(

linux-image-3.2.0-999-generic 3.2.0-999.201111140405

Ben (bhubu) wrote :

I am not sure whether this bug is related to my issue, but I am also not sure how I could figure it out.

Since today I get a white screen on the X display when using an external display and switching from screen mirroring to split screens. Switching to console shows a drm intel_disable_transcoder failure. After reboot the problem occurs reproducible each time screen properties are changed from mirror to split screen.

Ubuntu 11.10
Kernel 3.0.0-13-generic x86_64
Sony Z21

Marc Deslauriers (mdeslaur) wrote :

OK, I am now upgraded to Precise running 3.2.0-7-generic, and am still getting this issue, unfortunately.

Changed in linux (Ubuntu Oneiric):
status: Incomplete → Confirmed
Changed in linux (Ubuntu Precise):
status: Incomplete → Confirmed
17 comments hidden view all 117 comments

FYI, I still have this issue with 3.2.0.

summary: - fuzzy and corrupted display after dpms cycles
+ fuzzy and corrupted display after DPMS cycles
16 comments hidden view all 117 comments
Brian (rephorm) wrote :

I am also affected by this (or at least a very similar) bug on a Sony VAIO VPCEA laptop on kernel 3.0.0-14-generic (oneiric).

After the display blanks (e.g. if `xset s blank` is set), the laptop display is corrupted (pink and white vertical stripes) after resuming. An externally connected monitor turns back on correctly.

I can manually trigger by running `sleep 1 && xset dpms force off`
Running `xset dpms force off` (without the sleep) causes the display to cycle off and back on quickly, upon which it recovers correctly.

lspci lists the video card as:
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

lshw says:

 *-cpu
       description: CPU
       product: Intel(R) Core(TM) i5 CPU M 450 @ 2.40GHz
       vendor: Intel Corp.
       physical id: 4
       bus info: cpu@0
       version: Intel(R) Core(TM) i5 CPU M 450 @ 2.40GHz
       serial: N/A
       slot: N/A
       size: 1199MHz
       capacity: 1199MHz
       width: 64 bits
       clock: 133MHz
       capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp x86-64 constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm ida arat tpr_shadow vnmi flexpriority ept vpid cpufreq

  *-display
       description: VGA compatible controller
       product: Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:42 memory:f0000000-f03fffff memory:e0000000-efffffff ioport:e080(size=8)

17 comments hidden view all 117 comments

Created attachment 59984
manual revert of offending patch

Can you please try with the latest 3.3 kernel (or maybe even 3.4-rc) and check whether this patch still solves your issues?

Any update? I think this must have been fixed by one of the dither fixes...

Changed in linux:
status: Confirmed → Incomplete
1 comments hidden view all 117 comments

Sorry for the delay. I've just tried, and I can still reliably reproduce this with 3.4rc5.

Do you want me to try with 3.4rc5 and the patch in comment 17?

OK, unfortunately I can still reproduce the issue with 3.4rc5 and the patch in comment 17.

2 comments hidden view all 117 comments

I can still reproduce this reliably with 3.4rc5

Changed in linux:
status: Incomplete → In Progress
3 comments hidden view all 117 comments

Ok, so the manual revert doesn't help any longer. Which means something else changed, too.

just upgraded from oneric to precise

Screen now a DISASTER ZONE!
=========================
When exiting any application the 'old app.screen' blurrs and fails to close at all
Some LaunchPad Icons disappear, clicking in the right spot does activate task.

Log-off icon has vanished to right of top menu bar

Using WORKSPACE SWITCHER to refresh screen does work to remove old app.

Last month (early MAY), I tried a 12.04 beta CD (from Linux User) without any screen problems.

using LENOVO 4151 laptop

Marc Deslauriers (mdeslaur) wrote :

@Simon: your bug has _nothing_ to do with this bug. Please file a new one, thanks.

Can you please try the modeset-rework branch from my personal git repo at:

http://cgit.freedesktop.org/~danvet/drm

Among other things, this undoes the offending commit in a rather through-rough manner.

2 months have passed since the last request for patch feedback, and the modeset-rework has landed upstream... Presuming fixed.

Changed in linux:
status: In Progress → Fix Released
Changed in linux (Ubuntu Oneiric):
status: Confirmed → Invalid
Changed in linux (Ubuntu Precise):
status: Confirmed → Fix Released
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Marc Deslauriers (mdeslaur) wrote :

I still have this issue with Raring and kernel 3.8.0.

Changed in linux (Ubuntu Precise):
status: Fix Released → Triaged
Changed in linux (Ubuntu Quantal):
status: New → Triaged
Changed in linux (Ubuntu Raring):
status: New → Triaged
Changed in linux (Ubuntu Saucy):
status: Fix Released → Triaged

Sorry for the lack of feedback. I can still reproduce this reliably with 3.5.0 and 3.8.0.

dino99 (9d9) on 2013-05-23
tags: added: verification-done
removed: verification-done-natty
tags: added: precise raring saucy
removed: natty
tags: removed: regression-proposed
tags: added: bios-outdated-1.52
removed: needs-reassignment

FYI, I just upgraded to bios 1.52 and can still reproduce this this saucy.

 Version: 6MET92WW (1.52 )

tags: added: bisect-done latest-bios-1.52
removed: bios-outdated-1.52

Marc Deslauriers, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please just make a comment to this.

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

summary: - fuzzy and corrupted display after DPMS cycles
+ 8086:0046 [Lenovo ThinkPad T510] Fuzzy and corrupted display after DPMS
+ cycles
Changed in linux (Ubuntu):
milestone: oneiric-updates → none
status: Triaged → Incomplete
Displaying first 40 and last 40 comments. View all 117 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.