Ubuntu

Disks not recognized after upgrading to 2.6.38-10

Reported by Vincent Ladeuil on 2011-07-14
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

I upgraded to linux-image-2.6.38-10-generic (2.6.38-10.46) and two of my hard disks weren't recognized anymore.

Choosing the previous version, 2.6.38-8 at grub prompt brought them back.

Both hard disks are on a SAS host controller but not involved in a raid setup. Disk Utility reports the SAS Host Adapater as being from 'Marvell Technology Group Ltd.' with a '88SE6440 SAS/SATA PICe controller' model.

Any additional info I could provide to help debug the issue ?
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: vila 2158 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7ff8000 irq 74'
   Mixer name : 'Analog Devices AD1989B'
   Components : 'HDA:11d4989b,10438372,00100300'
   Controls : 44
   Simple ctrls : 25
DistroRelease: Ubuntu 11.04
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64+mac (20110427.1)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.

 eth1 no wireless extensions.
MachineType: System manufacturer System Product Name
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-11-generic root=UUID=9e03ea1c-298d-4b96-9870-4db1fe183774 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 2.6.38-11.47-generic 2.6.38.8
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-11-generic N/A
 linux-backports-modules-2.6.38-11-generic N/A
 linux-firmware 1.52
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
Tags: natty
Uname: Linux 2.6.38-11-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers
dmi.bios.date: 12/05/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1003
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P6T DELUXE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1003:bd12/05/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP6TDELUXE:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Brad Figg (brad-figg) on 2011-07-15
tags: added: natty
Brad Figg (brad-figg) on 2011-07-15
tags: removed: natty
Steve Conklin (sconklin) on 2011-07-18
tags: added: natty regression-release
Changed in linux (Ubuntu):
status: New → Invalid
Vincent Ladeuil (vila) wrote :

@Steve: invalid for linux (Ubuntu) ? Does that mean the problem doesn't exist in oneiric ?

I can't test oneiric on this machine (used in production), how can I help getting a fix for natty ?

Steve Conklin (sconklin) wrote :

Invalid just means that it hasn't been reported in Oneiric.

We need more system information - please run the following in a shell:

apport-collect 810400

- If you can do it after booting the problem kernel, then we'll get the system logs that include that. If not then do what you can and make a note in this bug please, after the new information is uploaded.

Thanks

Steve Conklin (sconklin) wrote :

Also, there's already another version of Natty in the -proposed pocket for testing. If you have the means to give this a test, it would be helpful to know whether the problem is resolved in that one.

Vincent Ladeuil (vila) wrote :

So, there are in fact *two* versions in the -proposed pocket: 2.6.38-9 in main and 2.6.38-11 in universe.

A bit surprising but I tested -11: same issue with the additional regression that I'm informed that I don't have the hardware required to run Unity.

Will run apport-collect 810400 nevertheless.

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Vincent Ladeuil (vila) wrote :

Let me know if you want me to run apport-collect 810400 for the working 2.6.38-8 version too.

Changed in linux (Ubuntu Natty):
status: New → Confirmed
Vincent Ladeuil (vila) wrote :

Re-tested with -11 now that it's available in main (just in case), the problem remains.

Vincent Ladeuil (vila) wrote :

Tested again with 2.6.38-11.49, the problem persists.

Vincent Ladeuil (vila) wrote :

Testing again with 2.6.38-11.50 (in case bug #777325 was related), no dice.

Again, is there something I can do to help debug this issue ?

Rickard Rosen (rickardrosen) wrote :

I have the same issue with the same chip and would really like to see a fix.
Please let me know if there is anything I can do.

Rickard Rosen (rickardrosen) wrote :

Still no progress?
Upgraded to 11.10 development with kernel 3.0.0-12 and I get a _lot_ of errors logged at boot:

READ CAPACITY failed
Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK
Sense not available
Truncating mode parameter data from 28273 to 512 bytes
Got wrong page
Assuming drive cache: write through

Mostly no disks are found, but some times after a reboot one or more disks are found.
Reverted back to 2.6.38-8 and all disks a found and my arrays are up and running again.
Should I report this as a new bug for 11.10?

Vincent Ladeuil (vila) wrote :

Things are different for me, the disks are back with oneiric.
I used the liveCD + disk utility to check and then upgraded.

dino99 (9d9) on 2013-05-18
Changed in linux (Ubuntu Natty):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers