Cannot change LED-Illuminated LCD brightness [LG R590-5700]

Bug #803051 reported by Hélio Nunes on 2011-06-28
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

The LED-Illuminated LCD brightness cannot be changed neither
1) using hot keys, Fn+Up and Fn+Down (both are detected by acpi_listen, but dbus does not detect Fn+Up -- if needed I file another bug on this issue only)
or 2) echo 1 > /sys/class/backlight/acpi_video0/brightness (no changes on display)
or 3) using /proc/acpi/video ... (which do not exist).

The only way is calling 'nvidia-settings -a brightness=xxx'. I don't know if this hardware accepts real brightness changes, if not (so it is not a bug in linux), I would be glad if you can help me tweak acpi and dbus to call nvidia-settings (nvclock does not work).

$ acpi_listen
video LCD 00000086 00000000 [Fn+Up]
video LCD 00000087 00000000 [Fn+Down]

$ dbus-monitor interface="org.gnome.PowerManager.Backlight"
signal sender=org.freedesktop.DBus -> dest=:1.143 serial=2 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameAcquired
   string ":1.143"
[Fn+Up does nothing, but Fn+Down:]
signal sender=:1.16 -> dest=(null destination) serial=62 path=/org/gnome/PowerManager/Backlight; interface=org.gnome.PowerManager.Backlight; member=BrightnessChanged
   uint32 87

Thank you in advance.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic 2.6.38-8.42
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dedalu 1982 F.... pulseaudio
CRDA: Error: [Errno 2] Arquivo ou diretório não encontrado
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd9100000 irq 46'
   Mixer name : 'Realtek ALC272'
   Components : 'HDA:10ec0272,18540832,00100001'
   Controls : 16
   Simple ctrls : 9
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xd3000000 irq 17'
   Mixer name : 'Nvidia GPU 0d HDMI/DP'
   Components : 'HDA:10de000d,10de0101,00100100'
   Controls : 16
   Simple ctrls : 4
Date: Tue Jun 28 12:49:39 2011
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=15b1a0e3-8294-45bf-8b75-b407aa6cde60
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: LG Electronics R590-P.BN58P1
ProcEnviron:
 LANGUAGE=pt_BR:en
 PATH=(custom, user)
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=d885c9b0-0614-41b8-a984-45d7fea64afc ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.52
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/06/2010
dmi.bios.vendor: INSYDE
dmi.bios.version: QL4L3I51
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Base Board Product Name
dmi.board.vendor: Intel Corp.
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrQL4L3I51:bd01/06/2010:svnLGElectronics:pnR590-P.BN58P1:pvrTBD:rvnIntelCorp.:rnBaseBoardProductName:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: R590-P.BN58P1
dmi.product.version: TBD
dmi.sys.vendor: LG Electronics
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0-0ubuntu2
Architecture: amd64
CheckboxSubmission: 7801270bed73bf50fdc0170f4c4dffa4
CheckboxSystem: c69722ecac764861be52925fa50b4dcc
DistroRelease: Ubuntu 12.04
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=e5f51dcb-c174-4cc1-b10c-aa3397abaddf
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
MachineType: LG Electronics R590-P.BN58P1
NonfreeKernelModules: nvidia
Package: linux (not installed)
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-21-generic root=UUID=69291abc-7421-440f-aa9d-a3d19611f6bc ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic 3.2.13
SourcePackage: linux
Tags: precise precise
Uname: Linux 3.2.0-21-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
WifiSyslog:

dmi.bios.date: 05/11/2011
dmi.bios.vendor: INSYDE
dmi.bios.version: QL4L3I81
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Base Board Product Name
dmi.board.vendor: Intel Corp.
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrQL4L3I81:bd05/11/2011:svnLGElectronics:pnR590-P.BN58P1:pvrTBD:rvnIntelCorp.:rnBaseBoardProductName:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: R590-P.BN58P1
dmi.product.version: TBD
dmi.sys.vendor: LG Electronics

Hélio Nunes (dedalu-dedalu) wrote :
Brad Figg (brad-figg) on 2011-06-28
Changed in linux (Ubuntu):
status: New → Confirmed
Andre Ferreira (andre-amtsec) wrote :

I have the same problem with an LG R590-5500. I think this is the same problem with LG R580 reported in another bug:
https://bugs.launchpad.net/ubuntu/+source/udev-extras/+bug/514855

As the BIOS updates from LG for R580 and R590 usually are the same, I believe the hardware are very similar.

Hélio Nunes (dedalu-dedalu) wrote :

Workaround:
1) install the nvidiabl module from https://github.com/guillaumezin/nvidiabl (Downloads > nvidiabl-dkms_0.69_all.deb);
2) add a line with 'nvidiabl' in /etc/modules;
3) add 'acpi_backlight=vendor' to the GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub;
4) run update-grub.

Reboot.

Hélio Nunes (dedalu-dedalu) wrote :

If you have problems with the workaround after reboot, read this issue: https://github.com/guillaumezin/nvidiabl/issues/14

I have the same probrem with an Positivo Sim+ 1321 (1A229RH2J).

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/803051

tags: added: laptop-testing

Hélio Nunes, thank you for reporting this and helping make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-upstream-testing

apport information

tags: added: apport-collected precise
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Hélio Nunes (dedalu-dedalu) wrote :

I found a workaround, nvidiabl (#3), but it stills an issue on Precise 12.04 (beta 2).

Should this bug be moved to nvidia-graphics-drivers package?

Changed in linux (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers