Reboot hangs on Dell Optiplex 390

Bug #800660 reported by Jonathan Davies on 2011-06-22
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Leann Ogasawara
Precise
Medium
Unassigned
Quantal
Medium
Unassigned
Raring
Medium
Leann Ogasawara

Bug Description

Reboot on Dell Optiplex 390s hangs at "Restarting system." on Natty.

Using the reboot=pci kernel option works around this but reboot=bios doesn't help.

Similar to bug #488319.

Jonathan Davies (jpds) wrote :

System Information
 Manufacturer: Dell Inc.
 Product Name: OptiPlex 390

Base Board Information
 Manufacturer: Dell Inc.
 Product Name: 0F6X5P
 Version: A00

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in linux (Ubuntu):
assignee: nobody → Leann Ogasawara (leannogasawara)
status: Triaged → In Progress

Hi Jonathan,

I've created a quirk patch for the OptiPlex 390 and built a test kernel which can be found at:

http://people.canonical.com/~ogasawara/dell-reboot-quirks/

If you could please test and confirm you no longer need to use the reboot=pci work around that would be great. Thanks in advance.

anil (anil-kumar) wrote :

Hi Leann,

I have optiplex 390 & running xenserver 5.6 or 6.0 & have same issue, it freezes at restart but shutdown is prefect.., is there any fix for this issue.

Waiting for you reply.

Thanks,
Anil

Daniel van Vugt (vanvugt) wrote :

Confirmed on Dell Optiplex 990 running 11.04 and 11.10beta2, and confirmed on Apple Macbook Air 3,1 running 10.10 and 11.04. Though I don't have the Macbook any more.

I notice Leann posted a patch for the Optiplex 990 in dell-reboot-quirks. Are we handling all affected Dell models in this one bug? If so, the bug title should be updated.

Daniel van Vugt (vanvugt) wrote :

Ignore my previous comment. I just found bug 768039.

Jonathan Davies (jpds) wrote :

Leann: I can confirm that the quirk works on my machine.

tags: added: raring
tags: added: precise quantal
Joseph Salisbury (jsalisbury) wrote :

Submitted SRU request to kernel team mailing list for Precise, Quantal and Raring.

Changed in linux (Ubuntu Precise):
status: New → In Progress
Changed in linux (Ubuntu Quantal):
status: New → In Progress
Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Changed in linux (Ubuntu Quantal):
importance: Undecided → Medium
Tim Gardner (timg-tpi) on 2013-04-16
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Raring):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (7.6 KiB)

This bug was fixed in the package linux - 3.8.0-19.29

---------------
linux (3.8.0-19.29) raring; urgency=low

  [ Paolo Pisati ]

  * UBUNTU: [Config] disable PL330_DMA
    - LP: #1168039

  [ Rob Herring ]

  * UBUNTU: SAUCE: (no-up) ARM: highbank: fix cache flush ordering for cpu hotplug
    - LP: #1169956

  [ <email address hidden> ]

  * SAUCE: (no-up) x86: reboot: Make Dell Optiplex 390 use reboot=pci
    - LP: #800660

  [ Kamal Mostafa ]

  * SAUCE: [media] uvcvideo: quirk PROBE_DEF for Dell Studio / OmniVision
    webcam
    - LP: #1168430

  [ Upstream Kernel Changes ]

  * Revert "drivers/rtc/rtc-at91rm9200.c: use a variable for storing IMR"
    - LP: #1168506
  * Revert "PCI/ACPI: Request _OSC control before scanning PCI root bus"
    - LP: #1168506
  * Revert "tty/8250_pnp: serial port detection regression since v3.7"
    - LP: #1168506
  * ALSA: hda - fixup D3 pin and right channel mute on Haswell HDMI audio
    - LP: #1167270
  * ASoC: imx-ssi: Fix occasional AC97 reset failure
    - LP: #1168506
  * ASoC: dma-sh7760: Fix compile error
    - LP: #1168506
  * ASoC: spear_pcm: Update to new pcm_new() API
    - LP: #1168506
  * regmap: Initialize `map->debugfs' before regcache
    - LP: #1168506
  * regmap: cache Fix regcache-rbtree sync
    - LP: #1168506
  * MIPS: Fix logic errors in bitops.c
    - LP: #1168506
  * HID: magicmouse: fix race between input_register() and probe()
    - LP: #1168506
  * spi/s3c64xx: modified error interrupt handling and init
    - LP: #1168506
  * spi/mpc512x-psc: optionally keep PSC SS asserted across xfer segmensts
    - LP: #1168506
  * gpio: stmpe: pass DT node to irqdomain
    - LP: #1168506
  * UBIFS: make space fixup work in the remount case
    - LP: #1168506
  * reiserfs: Fix warning and inode leak when deleting inode with xattrs
    - LP: #1168506
  * ALSA: hda - bug fix on return value when getting HDMI ELD info
    - LP: #1168506
  * ALSA: hda - Enabling Realtek ALC 671 codec
    - LP: #1168506
  * ALSA: hda - fix typo in proc output
    - LP: #1168506
  * drm/nouveau: fix handling empty channel list in ioctl's
    - LP: #1168506
  * drm/i915: Be sure to turn hsync/vsync back on at crt enable (v2)
    - LP: #1168506
  * drm: correctly restore mappings if drm_open fails
    - LP: #1168506
  * mm: prevent mmap_cache race in find_vma()
    - LP: #1168506
  * EISA/PCI: Init EISA early, before PNP
    - LP: #1168506
  * EISA/PCI: Fix bus res reference
    - LP: #1168506
  * ixgbe: fix registration order of driver and DCA nofitication
    - LP: #1168506
  * libata: Use integer return value for atapi_command_packet_set
    - LP: #1168506
  * libata: Set max sector to 65535 for Slimtype DVD A DS8A8SH drive
    - LP: #1168506
  * MIPS: Unbreak function tracer for 64-bit kernel.
    - LP: #1168506
  * alpha: Add irongate_io to PCI bus resources
    - LP: #1168506
  * PCI/ACPI: Always resume devices on ACPI wakeup notifications
    - LP: #1168506
  * PCI/PM: Disable runtime PM of PCIe ports
    - LP: #1168506
  * ata_piix: Fix DVD not dectected at some Haswell platforms
    - LP: #1168506
  * ftrace: Consistently restore trace function on sysctl enabling
    - LP: #1168506
  * powerpc: pS...

Read more...

Changed in linux (Ubuntu Raring):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
tags: added: verification-needed-quantal
Jonathan Davies (jpds) on 2013-05-08
tags: added: verification-done-precise verification-done-quantal
removed: verification-needed-precise verification-needed-quantal

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Julian Wiedmann (jwiedmann) wrote :

Released with 3.2.0-44.69 and 3.5.0-31.52.

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers