Ubuntu

[Dell Studio 16 XPS 1645] Internal Microphone not Working

Reported by Jack Nash on 2011-06-11
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
David Henningsson
Natty
Undecided
Unassigned

Bug Description

Dell Studio XPS 1645
Ubuntu 11.04 64bit
Audio device [0403]: ATI Technologies Inc Redwood HDMI Audio [Radeon HD 5600 Series]
Audio device [0403]: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: alsa-base 1.0.24+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jnash 1890 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf1000000 irq 47'
   Mixer name : 'IDT 92HD73C1X5'
   Components : 'HDA:111d7675,102802fe,00100103'
   Controls : 21
   Simple ctrls : 14
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xcfedc000 irq 49'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Fri Jun 10 23:10:50 2011
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/11/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.name: 0VV228
dmi.board.vendor: Dell Inc.
dmi.board.version: A09
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A09
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd05/11/2010:svnDellInc.:pnStudioXPS1645:pvrA09:rvnDellInc.:rn0VV228:rvrA09:cvnDellInc.:ct8:cvrA09:
dmi.product.name: Studio XPS 1645
dmi.product.version: A09
dmi.sys.vendor: Dell Inc.

Jack Nash (jack-nash) wrote :
Luke Yelavich (themuso) wrote :

Thanks for your report. Please check that you have the appropriate capture device selected, and that the recording level is turned up. TO do so, click on the speaker icon in the top right hand corner of your screen, and choose "Sound Preferences". Select the Input tab, and select the audio input device, the input connector, and adjust the input volume. You can test to see whether your microphone is working by watching the graphical signal meter, located just below the volume control. If the computer is receiving audio as per your settings, then those bars should light up green.

Hope this helps.

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Jack Nash (jack-nash) wrote :

Luke,

Yes, we tried all connectors, alsamixer, and installing the ppa:ubuntu-audio-dev/ppa, but were unsuccessful.

Thanks,

Jack

Ian Harris (teasel) wrote :

I had the same problem (also running on a Dell Studio 16 XPS - 1645). I fixed it by adding the following line to /etc/modprobe.d/alsa-base.conf, then rebooting

options snd-hda-intel model=dell-m6-dmic

People with other Dell Studio models, eg 1435, reported success with:

options snd-hda-intel model=6stack-dell

(see http://linuxforums.org.uk/ubuntu/internal-mic-not-working-in-my-ubuntu-10-10-%2864bit%29-in-my-dell-studio-14/)

Jonathan Davies (jpds) wrote :

I can confirm that the fix above (model=dell-m6-dmic) for a Dell Studio 16 XPS 1645 works.

Changed in alsa-driver (Ubuntu):
status: Incomplete → Opinion
status: Opinion → Triaged
Andy Whitcroft (apw) on 2011-08-18
summary: - Dell Studio XPS - Internal Microphone not Working
+ [Dell Studio 16 XPS 1645] Internal Microphone not Working
David Henningsson (diwic) wrote :

Hello, to verify that model=dell-m6-dmic is the solution to go upstream, could you please post an alsa-info https://wiki.ubuntu.com/Audio/AlsaInfo ? Thanks!

Changed in alsa-driver (Ubuntu):
status: Triaged → Incomplete

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 795823

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu Natty):
status: New → Incomplete
Martin Ling (martin-launchpad) wrote :

I can confirm this bug is still current on oneiric and that setting model=dell-m6-mic fixes it.

I am attaching alsa-info outputs from before and after making this change.

Martin Ling (martin-launchpad) wrote :
Changed in alsa-driver (Ubuntu):
status: Incomplete → Confirmed
Changed in alsa-driver (Ubuntu Natty):
status: New → Confirmed
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu Natty):
status: Incomplete → Confirmed
David Henningsson (diwic) wrote :

Patch sent to upstream. Sorry for the delay.

Changed in linux (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → David Henningsson (diwic)
affects: alsa-driver (Ubuntu) → ubuntu
David Henningsson (diwic) wrote :

(Hmm, wasn't there a way to remove additional packages from a bug?)

affects: ubuntu → alsa-driver (Ubuntu)
Changed in alsa-driver (Ubuntu):
status: Confirmed → Invalid
no longer affects: alsa-driver (Ubuntu)
no longer affects: alsa-driver (Ubuntu Natty)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.2.0-12.20

---------------
linux (3.2.0-12.20) precise; urgency=low

  [ Andy Whitcroft ]

  * switch to new style rebase marker with bug number

  [ Leann Ogasawara ]

  * Add CONFIG_GPIO_TWL4030=y for arm[el|hf] to the config enforcer
    - LP: #921934

  [ Paolo Pisati ]

  * [Config] Switch CONFIG_GPIO_TWL4030=y back on arm[el|hf].
    - LP: #921934

  [ Tim Gardner ]

  * Rebase to v3.2.2, CONFIG_SND_KCTL_JACK=y
  * [Config] Add Hyper-V modules to virtual inclusion list
    - LP: #922063

  [ Upstream Kernel Changes ]

  * Revert "CHROMIUM: enable CONFIG_SECCOMP_FILTER and
    CONFIG_HAVE_SECCOMP_FILTER"
  * Revert "CHROMIUM: Fix kref usage"
  * Revert "CHROMIUM: Fix seccomp_t compile error"
  * Revert "CHROMIUM: seccomp_filter: make inherited filters composable"
  * Revert "CHROMIUM: seccomp_filter: inheritance documentation"
  * Revert "CHROMIUM: seccomp_filter: allow CAP_SYS_ADMIN management of
    execve"
  * Revert "CHROMIUM: seccomp_filter: remove "skip" from copy and add drop
    helper"
  * Revert "CHROMIUM: seccomp_filters: clean up warnings; kref mistake"
  * Revert "CHROMIUM: seccomp_filters: guard all ftrace wrapper code"
  * Revert "CHROMIUM: seccomp_filter: kill NR_syscall references"
  * Revert "CHROMIUM: enable CONFIG_BTREE"
  * Revert "CHROMIUM: seccomp_filters: move to btrees"
  * Revert "CHROMIUM: arm: select HAVE_SECCOMP_FILTER"
  * Revert "CHROMIUM: x86: add HAVE_SECCOMP_FILTER and seccomp_execve"
  * Revert "CHROMIUM: seccomp_filter: Document what seccomp_filter is and
    how it works."
  * Revert "CHROMIUM: seccomp_filter: add process state reporting"
  * Revert "CHROMIUM: seccomp_filter: new mode with configurable syscall
    filters"
  * rebase to v3.2.2
    - LP: #795823
    - LP: #909419
    - LP: #724831
 -- Tim Gardner <email address hidden> Thu, 26 Jan 2012 02:54:56 +0000

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Herton R. Krzesinski (herton) wrote :

The fix for this on Lucid came through 2.6.32.55 upstream stable update, thus is not subject to the standard verification process.

tags: added: verification-done-lucid
Herton R. Krzesinski (herton) wrote :

The fix for this on Oneiric came through 3.0.18 upstream stable update, thus is not subject to the standard verification process.

tags: added: verification-done-oneiric

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).

dino99 (9d9) on 2013-05-18
Changed in linux (Ubuntu Natty):
status: Confirmed → Invalid
To post a comment you must log in.