Ubuntu

Regression: 147 second boot delay waiting for BIOS to hand off EHCI

Reported by EliCoten on 2011-05-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

During bootup there is an unacceptably long delay. After looking through the dmesg log it turns out that the delay seems to have been at a line that says
[ 149.596033] pci 0000:00:13.5: EHCI: BIOS handoff failed (BIOS bug?) 01010001

I did not notice this problem with Ubuntu 10.10 - it's new since I upgraded. It may be related that in the previous version the fan (and FN+F6/F6 brightness keys) wasn't working on initial bootup. If I did suspend and then resume, the fan and brightness keys worked as they do in Windows. Now in Natty, the fan seems to increase in speed gradually but then when the temperature cools down the fan doesn't slow down. Also in Maverick, hibernate usually worked fine whereas in this version hibernate just seems to do the equivalent of 'lock screen'.

Am new at reporting bugs so please advise on what other logs/attachments I should post.

EliCoten (launchpad-elicoten) wrote :
EliCoten (launchpad-elicoten) wrote :
EliCoten (launchpad-elicoten) wrote :
EliCoten (launchpad-elicoten) wrote :
EliCoten (launchpad-elicoten) wrote :
IKT (ikt) on 2011-05-12
affects: ubuntu → linux (Ubuntu)
EliCoten (launchpad-elicoten) wrote :

I tried selecting kernel version 2.6.35-28-generic on on bootup and the long delay went away.
I looked through the dmesg log and found that the same message comes up, but after 2 seconds instead of after 147 seconds. That's much more bearable!
[ 4.368031] pci 0000:00:13.5: EHCI: BIOS handoff failed (BIOS bug?) 01010001

papukaija (papukaija) on 2011-05-13
tags: added: natty
EliCoten (launchpad-elicoten) wrote :

The newer 2.6.38-10 kernel seems to have reverted and now works as 2.6.35-28. I believe the message still shows in logs but doesn't delay the computer so much when starting up.

This bug is missing log files that will aid in dianosing the problem. From a terminal window please run:

apport-collect 781591

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Dmitri (lamukra) wrote :

I had problem with login and boot time also, reason was in xorg.conf file configuration
And I also have problem with fans control, but it is another bug, Had it in 10.10 and still have in 11.04
in dmesg I also have line saying "...EHCI: BIOS handoff failed...", but it turned out that that is not a problem

Problem was coming from synaptics touchpad, where the special .conf file was created to make a scrolling work.

Below is outtake from launchpad bug report my comment, how I made scrolling work
[url]https://bugs.launchpad.net/ubuntu/+source/linux/+bug/565543[/url]

***************************************

It was annoying to be without scrolling, so created a file with name psmouse.conf in:

/etc/modprobe.d

with text inside:

options psmouse proto=imps

Saved and run through commands:
------------------------------------
sudo modprobe -r psmouse
sudo modprobe psmouse
------------------------------------
After this my ALPS is detected as ImPS/2 Generic Wheel Mouse, but scrolling is working

***************************************

After making this, I totally forgot about xorg.conf, that I had a Section InputDevice with assigning a driver to my touchpad, what was creating and error, because after making scrolling to work my touchpad was recognized as imPS2 mouse, but not as Synaptics Touchpad... so it was causing the long LOGIN time and partly a boot time

X was trying to find Synaptics Touchpad but there was imPS assigned Physically, so this so to speak searching time made an interface to stuck...

Solution

Simply comment out Section InputDevice and InputeDevice in Server Layout in xorg.conf

It solved the problem in my case, hope it will help someone

If you have configured xorg.conf check out its right functionality and Sections

run through commands after startup

cat /vat/log/Xorg.0.log | grep EE
cat /vat/log/Xorg.0.log | grep WW

Read what is said there and maybe it will help also, that is about long boot and login problem

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers