Ubuntu

[Lenovo T420s] Brightness keys make the indicator work, but don't actually dim or brighten the screen

Reported by Jeff Lane on 2011-04-29
72
This bug affects 13 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Robert Hooker
Natty
Undecided
Unassigned
Precise
Medium
Robert Hooker
nvidia-common (Ubuntu)
Medium
Alberto Milone
Precise
Medium
Alberto Milone

Bug Description

This is weird... I'm running the nvidia-current to get 3d and Unity on a Thinkpad T420s and doing Natty certification testing in this config.

When I hit Fn-Home/End (the brightness Function keys) the brightness indicator appears in the upper right corner, and the bar actually changes as it should, but the screen never brightens or dims. Even when the indicator says that the brightness is at the lowest level, the screen is stuck at the same brightness level.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic-pae 2.6.38-8.42
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1454 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf4320000 irq 48'
   Mixer name : 'Conexant CX20590'
   Components : 'HDA:14f1506e,17aa21d2,00100000'
   Controls : 8
   Simple ctrls : 5
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xf3000000 irq 17'
   Mixer name : 'Nvidia GPU 1c HDMI/DP'
   Components : 'HDA:10de001c,17aa21d2,00100100'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Fri Apr 29 18:58:25 2011
HibernationDevice: RESUME=UUID=ad4d224c-e172-4c16-84dc-e18307e39b77
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MachineType: LENOVO 417024U
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic-pae root=UUID=a02b58a2-f382-4f56-bc8e-3360ff8d9c82 ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic-pae N/A
 linux-backports-modules-2.6.38-8-generic-pae N/A
 linux-firmware 1.52
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/04/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8CET30WW (1.07 )
dmi.board.asset.tag: Not Available
dmi.board.name: 417024U
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8CET30WW(1.07):bd03/04/2011:svnLENOVO:pn417024U:pvrThinkPadT420s:rvnLENOVO:rn417024U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 417024U
dmi.product.version: ThinkPad T420s
dmi.sys.vendor: LENOVO

Jeff Lane (bladernr) wrote :
Jeff Lane (bladernr) on 2011-04-30
tags: added: blocks-hwcert
Ara Pulido (apulido) wrote :

Chris, can you have a look, please?

Changed in linux (Ubuntu):
assignee: nobody → Chris Van Hoof (vanhoof)
importance: Undecided → Medium
Vitaly Mygal (xmig) wrote :

I confirm this bug on a laptop Dell Vostro 3700.

Brad Figg (brad-figg) on 2011-05-03
Changed in linux (Ubuntu Natty):
status: New → Confirmed
Brad Figg (brad-figg) on 2011-05-03
Changed in linux (Ubuntu):
status: New → Confirmed
Mumineq (mumin66) wrote :

I confirm his on lenovo T510

Chris Van Hoof (vanhoof) on 2011-05-04
Changed in linux (Ubuntu):
assignee: Chris Van Hoof (vanhoof) → Robert Hooker (sarvatt)
tags: added: hwe-blocker
Robert Hooker (sarvatt) wrote :

Jeff: Does adding

Option "RegistryDwords" "EnableBrightnessControl=1"

to the device section in your /etc/X11/xorg.conf fix it?

Osama I. Al-Dosary (dosary) wrote :

I confirm the same issue with a Lenovo W510.
A similar problem exists with Mavrick 10.10. But with Mavrick I can switch to a console (using Ctrl+Alt+f5) and reduce the brightness using the function keys then. Whereas this trick doesn't work with Natty.

Osama I. Al-Dosary (dosary) wrote :

Just tried the suggestion in note #5, and so far it works, but can't be sure as the problem is inconsistent.
(Of course had the create the xorg.conf file, as it doesn't exist.)

Osama I. Al-Dosary (dosary) wrote :

CORRECTION: Suggestion in note#5 does NOT work after I suspend then awake my laptop.

Mumineq (mumin66) wrote :

Ok, I have found temporary solution.

In grub i have the following line:

...
linux /boot/vmlinuz-2.6.38-9-generic-pae root=UUID=b0da63e6-8a8d-4671-bb75-cd25c00f6585 ro vga=792 quiet splash nomodeset video=uvesafb:mode_option=1440x900-24,mtrr=3,scroll=ywrap vt.handoff=7
....

If I change it to:

linux /boot/vmlinuz-2.6.38-9-generic-pae root=UUID=b0da63e6-8a8d-4671-bb75-cd25c00f6585 ro vga=792

the brightness control works. One boot ago I reinstalled nvidia-current. I will try to reboot and check if it still works.

Jeff Lane (bladernr) wrote :

> Jeff: Does adding
> Option "RegistryDwords" "EnableBrightnessControl=1"
> to the device section in your /etc/X11/xorg.conf fix it?

Robert, I'm no longer up in the Lexington lab so I can't get hands on the machine. I'm adding Marc Legris to this as he is The Man for the lab up there.

Marc, when you get time, can you look into this for Robert?

tags: removed: blocks-hwcert
Edwin Grubbs (edwin-grubbs) wrote :

The solution from comment #5 works for me.
> Option "RegistryDwords" "EnableBrightnessControl=1"

Ershaad (ershaad-a) wrote :

I have the identical problem on the Dell Vostro 3300 with Geforce 310M. It used to work fine in 10.10.

Karl Trygve Kalleberg (karltk) wrote :

On a Lenovo 420s, running Natty (2.6.38-8-generic (64bit), xorg-server 2:1.10.1-1ubuntu1.1, NVIDIA dlloader X Driver 270.41.06 Mon Apr 18 14:55:25 PDT 2011), I can switch to a console (Ctrl-Shift-F1) and change the brightness there.

Using Fn+Home/End (brightness up/down) changes the brightness indicator in the top, right corner when running X11. The values of /sys/devices/virtual/backlight/acpi_video0/{brightness,actual_brightness} changes as one would expect. However, the builtin LCD remains at a fixed brightness level when in X.

I noticed these error messages in /var/log/Xorg.0.log which might or might not be related:

[ 5.073] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)

[ 6.423] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[ 6.423] (II) NVIDIA(0): may not be running or the "AcpidSocketPath" X
[ 6.423] (II) NVIDIA(0): configuration option may not be set correctly. When the
[ 6.423] (II) NVIDIA(0): ACPI event daemon is available, the NVIDIA X driver will
[ 6.423] (II) NVIDIA(0): try to use it to receive ACPI event notifications. For
[ 6.423] (II) NVIDIA(0): details, please see the "ConnectToAcpid" and
[ 6.423] (II) NVIDIA(0): "AcpidSocketPath" X configuration options in Appendix B: X
[ 6.423] (II) NVIDIA(0): Config Options in the README.

However, the acpid.socket file exists and is readable

# file /var/run/acpid.socket
/var/run/acpid.socket: socket

# ls -la /var/run/acpid.socket
srw-rw-rw- 1 root root 0 2011-06-24 23:15 /var/run/acpid.socket

Spencer Gibb (spencer-gibb) wrote :

I have the same issue on a lenovo W510 and I can confirm that comment #5 works for my laptop

Luigi R. (xluigi84) wrote :

Hi this bug affects also my HP DV6-6030el after a bios update 2 days ago. The previous one was F.06 version, the new one is F.1A. Can you check your bios version please?

There is no way to control the backlight, it is set at maximum level. I 'm running with ubuntu 11.04 and kernel 2.6.38-11-generic. I tried also with 2.6.39 rc4 without improvements. The same result with option acpi-backlight=vendor.

If I try to change the backlight in the kernel log I fing this message:

Aug 8 01:32:08 Houston kernel: [ 1640.031413] atkbd serio0: Unknown key pressed (translated set 2, code 0xab on isa0060/serio0).
Aug 8 01:32:08 Houston kernel: [ 1640.031416] atkbd serio0: Use 'setkeycodes e02b <keycode>' to make it known.

Let me know if you need more information.

Luigi R. (xluigi84) wrote :
Download full text (11.6 KiB)

Ps: solution #5 doesn't work for me. I create the xorg.conf file using sudo Xorg -configure in recovery mode. It give me a long xorg file and I add the line Option "RegistryDwords" "EnableBrightnessControl=1" under intel device section.

What is wrong? this my xorg:

Section "ServerLayout"
 Identifier "X.org Configured"
 Screen 0 "Screen0" 0 0
 Screen 1 "Screen1" RightOf "Screen0"
 Screen 2 "Screen2" RightOf "Screen1"
 Screen 3 "Screen3" RightOf "Screen2"
 Screen 4 "Screen4" RightOf "Screen3"
 Screen 5 "Screen5" RightOf "Screen4"
 InputDevice "Mouse0" "CorePointer"
 InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
 ModulePath "/usr/lib/xorg/modules"
 FontPath "/usr/share/fonts/X11/misc"
 FontPath "/usr/share/fonts/X11/cyrillic"
 FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
 FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
 FontPath "/usr/share/fonts/X11/Type1"
 FontPath "/usr/share/fonts/X11/100dpi"
 FontPath "/usr/share/fonts/X11/75dpi"
 FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
 FontPath "built-ins"
EndSection

Section "Module"
 Load "dbe"
 Load "extmod"
 Load "record"
 Load "glx"
 Load "dri2"
 Load "dri"
EndSection

Section "InputDevice"
 Identifier "Keyboard0"
 Driver "kbd"
EndSection

Section "InputDevice"
 Identifier "Mouse0"
 Driver "mouse"
 Option "Protocol" "auto"
 Option "Device" "/dev/input/mice"
 Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
 Identifier "Monitor0"
 VendorName "Monitor Vendor"
 ModelName "Monitor Model"
EndSection

Section "Monitor"
 Identifier "Monitor1"
 VendorName "Monitor Vendor"
 ModelName "Monitor Model"
EndSection

Section "Monitor"
 Identifier "Monitor2"
 VendorName "Monitor Vendor"
 ModelName "Monitor Model"
EndSection

Section "Monitor"
 Identifier "Monitor3"
 VendorName "Monitor Vendor"
 ModelName "Monitor Model"
EndSection

Section "Monitor"
 Identifier "Monitor4"
 VendorName "Monitor Vendor"
 ModelName "Monitor Model"
EndSection

Section "Monitor"
 Identifier "Monitor5"
 VendorName "Monitor Vendor"
 ModelName "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option "NoAccel" # [<bool>]
        #Option "SWcursor" # [<bool>]
        #Option "Dac6Bit" # [<bool>]
        #Option "Dac8Bit" # [<bool>]
        #Option "BusType" # [<str>]
        #Option "CPPIOMode" # [<bool>]
        #Option "CPusecTimeout" # <i>
        #Option "AGPMode" # <i>
        #Option "AGPFastWrite" # [<bool>]
        #Option "AGPSize" # <i>
        #Option "GARTSize" # <i>
        #Option "RingSize" # <i>
        #Option "BufferSize" # <i>
        #Option "EnableDepthMoves" # [<bool>]
        ...

Ayan George (ayan) on 2011-08-31
tags: added: blocks-hwcert-enablement
Changed in nvidia-common (Ubuntu):
status: New → Triaged
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → Medium
no longer affects: nvidia-common (Ubuntu Natty)
Changed in nvidia-common (Ubuntu Precise):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-common - 1:0.2.40

---------------
nvidia-common (1:0.2.40) precise; urgency=low

  * Add quirks to get brightness keys to work on Lenovo T420s
    (LP: #773710) and on Dell Latitude E6530 (LP: #914069)
    when using NVIDIA's proprietary driver.
 -- Alberto Milone <email address hidden> Thu, 08 Mar 2012 11:30:56 +0100

Changed in nvidia-common (Ubuntu Precise):
status: In Progress → Fix Released
Søren Holm (sgh) wrote :

It is not fixed for me.

krab1k (racek-t) wrote :

Same problem in precise with nvidia-current 295.40 on Thinkpad R61.

VS (storvann) wrote :

I'm seeing the exact same issue on my T61. Adding the EnableBrightnessControl=1 line to the Screen section of xorg.conf appears to fix it.

Is it possible to enable the T420-quirks for T61 and R61 as well?

I confirm this bug on a laptop Samsung RV520.

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
Changed in linux (Ubuntu Precise):
status: Confirmed → Invalid
Changed in linux (Ubuntu Natty):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers