Ubuntu

X120e crashes randomly (wireless?)

Reported by Samantha April Davis on 2011-04-24
174
This bug affects 32 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

My Lenovo X120e randomly crashes. The computer simply becomes non-responsive. Everything on the screen freezes: mouse does not move, can not switch to TTYs ect... If sound is playing sometimes loops last second or two of sound a couple of times before stopping.

I suspect bug has something to do with the wireless as the crashes are fairly regular and I have yet to replicate the bug when connected to the network via ethernet. Furthermore, I seem to have far less stability on my school network, which is known to be temperamental, than my home network which is very stable (although it crashes on both from time-to-time).

Bug report filed on affected computer immediately after crash.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic 2.6.38-8.42
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
AcpiTables:
 Error: command ['gksu', '-D', 'Apport', '--', '/usr/share/apport/dump_acpi_tables.py'] failed with exit code 1: Sorry, try again.
 GNOME_SUDO_PASS
 Sorry, try again.
 sudo: 3 incorrect password attempts
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: SB [HDA ATI SB], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: samantha 1445 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Generic'/'HD-Audio Generic at 0x90244000 irq 45'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card1.Amixer.info:
 Card hw:1 'SB'/'HDA ATI SB at 0x90240000 irq 16'
   Mixer name : 'Conexant CX20582 (Pebble)'
   Components : 'HDA:14f15066,17aa21df,00100302'
   Controls : 8
   Simple ctrls : 5
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Sun Apr 24 02:38:52 2011
HibernationDevice: RESUME=UUID=959bdbcd-6144-490a-92ad-56f9ba37cd5d
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: LENOVO 0596CTO
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=5d027e2c-4e61-4c50-900d-2111dc9de0cb ro crashkernel=384M-2G:64M,2G-:128M quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.52
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to natty on 2011-04-21 (2 days ago)
dmi.bios.date: 03/24/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8FET27WW (1.11 )
dmi.board.asset.tag: Not Available
dmi.board.name: 0596CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8FET27WW(1.11):bd03/24/2011:svnLENOVO:pn0596CTO:pvrThinkPadX120e:rvnLENOVO:rn0596CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 0596CTO
dmi.product.version: ThinkPad X120e
dmi.sys.vendor: LENOVO

Jason Wm. Doll (jwdoll) wrote :

I believe the issue is related to how the rtl8192ce driver handles wireless n. I haven't experienced the freezes on my home b/g router but have them too frequently to practically use wifi on my school's n network.

@Jason Wm. Doll: I disagree. I've never even used my network card on a wireless-n network and it crashed all the time. Maybe wireless-n is even worse, though.

Robert Lee (idiotmagoo) wrote :

I'm getting the same issues as Jason. Kubuntu seems to kernel panic while I use my school's wireless N, but it doesn't crash on my home network which used wireless g.

Jason Wm. Doll (jwdoll) wrote :

Seems like if it's not g vs n then there's gotta be something with big networks that's causing the issue that isn't present with a smaller one.

Brad Figg (brad-figg) on 2011-05-04
Changed in linux (Ubuntu):
status: New → Confirmed
Robert Lee (idiotmagoo) wrote :

Could it be that our wireless causes a kernel panic when using ad-hoc networks? I noticed someone was having similar issues with their x100e, arch and the realtek drivers.

Gregory Fong (gvfong) wrote :

@Robert: That might be a problem as well, but all of the issues I've had have been with infrastructure networks.

Ryan Porter (gimmelinux) wrote :

I'm running 11.04 on an X120E. It seemed like the wireless driver was causing random crashes (I'm using a wireless N home network). I tried installing the driver from the realtek website. This caused Ubuntu to consistently crash on startup. So I uninstalled the driver and replaced it with the rtl8192ce-dkms package from Keng-Yu Lin's hwe-wireless PPA (version 2.6.0005.1116.2010-1ubuntu1~maverick2). It hasn't crashed since.

KA12MA (knaablind-07) wrote :

i installed Keng-Tu's hew-wireless PPA 2.6.0005.1116.2010-1ubuntu1~maverick2 and i notice less crashes but i notice i experience crashes in my school's network and sometimes when waking up from sleep it just becomes a black screen and nothing is responsive, even using function key to turn brightness up and down doesn't affect the screen's brightness.

I'm also still getting crashes after installing rtl8192ce-dkms_2.6.0005.1116.2010-1ubuntu1~maverick2 from Keng-Tu's PPA. Running 11.04 on an x120e.

The computer will just freeze while I am using it. It will continue to display the screen as it was when the crash occurred, but the computer is completely unresponsive and I need to restart.

 The crashes sometimes (but not always) occur after waking up from sleep, seemingly when it is reconnecting to the wireless network.

Ryan Porter (gimmelinux) wrote :

My X120E still hasn't crashed since installing rtl8192ce-dkms_2.6.0005.1116.2010-1ubuntu1~maverick2.
Perhaps this has something to do with first trying to install the driver from source: http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=21&PFid=48&Level=5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true

Then completely uninstalling it before installing the driver from Keng-Tu's PPA.

Warning: The source driver caused the computer to crash during startup. I had to start up in safe mode to remove the driver.

Robert Lee (idiotmagoo) wrote :

@Ryan Porter: I tried compiling the driver from source using checkinstall rather than "make install" and received an error that the driver conflicted with the kernel module for the wireless card. This may be the reason you were experiencing crashes on startup. I wish I knew how to resolve the issue, but my kernel/driver knowledge hits a wall at this point.

Anyone know how we can resolve this conflict so we can test the newer wireless driver on the realtek website?

Jorge O. Castro (jorge) wrote :

We had this problem with X120e's at UDS. rtg think this is multiplied by wireless noise, so the busier a network is the greater chance of triggering it with RTL8192CE.

- I tried both the Oneiric kernel and the mainline kernel and it still crashes regularly.

Bill Coron (bcoron) wrote :

@Ben Lafreniere: You may be on to something.

My crashes are only once a day or every other day and it usually, but not always, happens on resume. May be coincidence but iirc, the last two times happened when I suspended at work and resumed at home (both g infrastructure networks). Also, home has more going on than work.

I was having slightly more frequent crashes when I had an openGL screen saver enabled.

Jason Wm. Doll (jwdoll) wrote :

@Jorge

I do think that network size/noise must be a big factor. That would explain those of us who don't or rarely experience crashes at home but do on our schools' networks.

Shane Reustle (sreustle) wrote :

@Jason

I frequently have this issue on a home network with 0 to 1 other user.

John Johansen (jjohansen) wrote :

Please note that there are multiple different crash bugs, not all of them are going to be related to the wireless driver. I know of at least one fix for crashes that has gone into the fglrx driver (if you are running the proprietary ati driver) and some fixes to the fusion radeon driver that went in late to the 2.6.39 kernel.

I am going to build a natty test kernel with the latest bug fixes for rtl8192ce and the radeon driver and will post here when I get it done

Robert Lee (idiotmagoo) wrote :

@John, I agree. It seems as though the waking up from sleep crashes are different from what this bug is addressing.

@Jorge, that actually makes a lot of sense with regards to signal/noise ratios causing the crashes. I generally get them only when either there are a lot of wifi users or when I am in a wifi deadspot in my house.

KA12MA (knaablind-07) wrote :

I installed Elementary OS which is base of 10.10 ubuntu http://elementaryos.org/
The Drivers i installed to get the wireless working is Keng-Tu's hew-wireless PPA 2.6.0005.1116.2010-1ubuntu1~maverick2
Elementary Os is a really gutted(slim version) of ubuntu 10.10 to make it run faster on slower hardware and after running/testing the OS for 5 days i have notice only 1 experience of frozen screen lock up, compared to 3-4 lock ups a day with ubuntu 11.04

Another thing i notice is that sometimes when i keep my lid open for it to sleep by itself it will lock up the computer. The screen will be black and the keys will be unresponsive to anything, the sleep and power buttons seems to be flashing rather then have a sold green color and the only way for me to get it working again is to do a hard reset. I have only experience this twice and have not be able to experience this problem when closing my lid to put it into sleep(sleeps fine with closing the lid).

In conclusion the OS is a lot more stable compared to running 11.04. I think that their must of been some type of upgrade ubuntu did that interferes with the wireless driver to cause the system to hard lock or maybe it some program/software/drivers ect that elementary removed (since elementary is a gutted out version of ubuntu 10.10) that help fix majority of the problems we are having. If anyone has an installed version of ubuntu 10.10 Maverick with the same wireless drivers installed and post their experience on here and compare it with Elementary OS and see what results you get, we might be able to find out what is causing the hard lock ups. Because if we come up with the same results it might just be some upgrade ubuntu did and if it different and still getting the same crashes it might just be some program/sofware/drivers ect that affecting the crashes that Elementary OS removed.

William Ward (wwward) wrote :

There is a stark contrast between using the x120e with the wireless on and off. When the wireless is enabled, even if my primary network traffic is over the wired Ethernet adapter, the device will freeze. With the wireless disabled, the machine can go all day without a freeze.

Alejandro Mery (amery) wrote :

with hwe-wireless driver I haven't get freezes, but I have the same problem of intermitently loosing wired and wireless connectivetity (I ping -W1 x120e continiuosly from another computer) unless I disable the wifi... smells like some sort of power saving "feature".

@William Yes! This is exactly my experience as well.

This past weekend I spent several hours programming with wireless disabled. The system was solid, no crashes. I enabled wireless to push some commits, it froze while connecting to the network.

Alejandro Mery (amery) wrote :

FYI, I've filed a ticket about the freezes when resuming, this time I was lucky enough to get it resurrected after 2 minutes. https://bugs.launchpad.net/ubuntu/+source/linux/+bug/787980,

Engwan (hleeyu) wrote :

I can confirm that installing the driver from Keng-Tu's PPA fixed the problem with random crashing.

Im not sure if this is related but after installing the driver, I also haven't experienced the black screen problem after waking up from suspend. It used to hang most of the time when i wake from suspend. Just a black screen stuck forever.

flandolt (landolt-f) wrote :

Using Ubuntu 11.04, I had the very same problem with my Thinkpad X120e.
Everytime I turned on the Thinkpad's WiFi adapter (a Realtek RTL8188CE in my case) the system randomly froze.

Installing a newer kernel version (3.0.0-rc7) fixed this issue. Haven't skimmed the kernel changelogs yet, so I can't confirm any changes associated to the Realtek driver, but as a matter of fact, I haven't had a single freeze up since updating to 3.0.0-rc7.

Nevertheless there is one drawback. It looks like the current fglrx package won't build with 3.0 kernels.
In my case that didn't matter, as I prefer functional WiFi over accelerated graphics any time.

You don't have to compile the kernel sources , Ubuntu provides 3.0.0-rc7 kernel images with Ubuntu patches here:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0-rc7-oneiric/
They can be simply installed by employing dpkg with the -i flag.

mr_tron (tr0n) wrote :

I think this is related to the activity hdd. When I was actively reading data from disk crashes frequently.
Sorry for bad english.

To post a comment you must log in.