Computer is not turned off at shutdown

Bug #762203 reported by Ernst on 2011-04-15
404
This bug affects 84 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I upgraded Maverick to Natty about two weeks ago. Since then, my computer does not turn off itself. So, I click in the upper right corner (I'm running Gnome2) and click Shut Down. All programs are closed, I see the Ubuntu logo (and I can click Esc to see the terminal during shutdown).
At some point, I notthing seems to happen anymore and the computer stays on. I press CTRL-SysReq REISUB. The computer restarts and I press the power button to power off the computer.

I would love to help solving this bug, so which log files do you need?

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic 2.6.38-8.42
Regression: Yes
Reproducible: No
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ernstblaauw 2133 F.... pulseaudio
 /dev/snd/controlC3: ernstblaauw 2133 F.... pulseaudio
 /dev/snd/controlC2: ernstblaauw 2133 F.... pulseaudio
 /dev/snd/controlC1: ernstblaauw 2133 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe7f8000 irq 45'
   Mixer name : 'Realtek ALC888'
   Components : 'HDA:10ec0888,14627512,00100001'
   Controls : 34
   Simple ctrls : 20
Card1.Amixer.info:
 Card hw:1 'Camera'/'Camera at usb-0000:00:1a.0-1, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:08f0'
   Controls : 3
   Simple ctrls : 2
Card2.Amixer.info:
 Card hw:2 'U8501'/'LG-Nortel Co. Ltd USB Phone 8501 at usb-0000:00:1d.7-4.1, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB1be1:0030'
   Controls : 1
   Simple ctrls : 1
Card2.Amixer.values:
 Simple mixer control 'Headset',0
   Capabilities: cswitch cswitch-joined penum
   Capture channels: Mono
   Mono: Capture [on]
Card3.Amixer.info:
 Card hw:3 'CMI8768'/'C-Media CMI8768 at 0xe800, irq 16'
   Mixer name : 'CMedia PCI'
   Components : ''
   Controls : 41
   Simple ctrls : 22
Card4.Amixer.info:
 Card hw:4 'HDMI'/'HDA ATI HDMI at 0xfe8ec000 irq 46'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100100'
   Controls : 4
   Simple ctrls : 1
Card4.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Fri Apr 15 23:19:26 2011
Frequency: Once a day.
HibernationDevice: RESUME=UUID=27cac63b-5a29-4c3f-a9f2-8218a51be4d4
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100122)
MachineType: MICRO-STAR INTERNATIONAL CO.,LTD MS-7512
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=0f104604-00b2-4b97-962f-b48f8c29db01 ro quiet splash acpi_osi=Linux vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.50
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to natty on 2011-03-26 (20 days ago)
dmi.bios.date: 03/09/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V3.4
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P45 Neo2-FR (MS-7512)
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV3.4:bd03/09/2009:svnMICRO-STARINTERNATIONALCO.,LTD:pnMS-7512:pvr1.0:rvnMICRO-STARINTERNATIONALCO.,LTD:rnP45Neo2-FR(MS-7512):rvr1.0:cvnMICRO-STARINTERNATIONALCO.,LTD:ct3:cvr1.0:
dmi.product.name: MS-7512
dmi.product.version: 1.0
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO.,LTD

Ernst (ernst-blaauw) wrote :
Patrick Scott (patrickscott52) wrote :

I'm seeing [what appears to be] ]the same issue on 11.04. I'm using the Unity desktop, shut down seems to halt right after the running applications and DE are killed. For me, this happens 50% of the time, the rest of the time it shuts down cleanly. Its seems to be fairly random also since I'm not doing anything special in the sessions where it fails to shut down. I'm also using proprietary nVidia drivers and I'm running 64 bit ubuntu.

Marcsalvat (marcsalvat) wrote :

I have exactly the same problem. SInce i updated to 11.04 restart and shutdown do not work correctly.
I'm using 32bits and ATI graphic card

If a log or any other info is needed please tell me and i will upload it.

fpattyn (filip-pattyn) wrote :

I have the same problem too. I'm running 64 bit Ubuntu using a HD radeon video card.

dino99 (9d9) wrote :

this issue is an old story on my end since karmic:

p5wdh+8500gt ich7r i386 install

- shutdown seems to be ok, but next boot always fail, need a cold boot then
- restart never works

On first try to boot (gnome2 without compiz/unity/splash) the grub menu appear and the timer delay works but boot fail. So on next cold boot, the grub menu dont show the starting timer, so need to hit Enter key, usually it boot on that second try.

Azyl (dj-azyl) wrote :

i have dell ispiron 1545 and after the latest updates on ubuntu 11.04 64bits after pressing shutdown it closes applications i see the screen with the dots for shutdown with the Ubuntu logo, and computer just remains at that point never powering down

Changed in linux (Ubuntu):
status: New → Confirmed
Ernst (ernst-blaauw) wrote :

I discovered the computer is turned off, but it takes 5 minutes instead of the 5 seconds it took before. I will open another bug report for this behavior.

Changed in linux (Ubuntu):
status: Confirmed → Invalid
navalio (naval) wrote :

Yes, I have the same issue. Nothing in google in this matter.

Appeared after upgrade to 11.04. Before shut down/restart was like it should be with the 10.10.

I'm having nvidia graphic card.

5 minutes of waiting does not solve shutting down or restart issue

Jörg Schumann (mainbrain36) wrote :

Same issue, using nvidia card on my hp probook 4520s and ubuntu 11.04 (upgrade from 10.10).
Let me know if I can help with logs or more informations.

Reny (reny1977) wrote :

same problem on Hp Pavillon DV6000 with NVIDIA GeForce 8400M.
If I start in normal mode I can't restart/reboot beacuse PC freeze.... I must press for some seconds the power button.
In normal mode I can't also access to text console tih CTRL+ALT+F1, the pc freeze again.....

I upgraded from 10.10.....in 10.10 my pc was very very very well......

Reny (reny1977) wrote :

ehm....sorry...I forgot to specify that if I run the recovery mode, start netroot console, start gdm, I can login in graphical environment, with unity3d, and I can shutdown correctly my pc.

Let me know if I can help with logs or more informations.

Marcsalvat (marcsalvat) on 2011-05-02
Changed in linux (Ubuntu):
status: Invalid → New
Reny (reny1977) wrote :
Download full text (3.3 KiB)

I have tried also kernel 2.6.39-0 from kernel/ppa without result: the problem persist.

I found in /var/log/kern.log

May 1 01:26:35 anakin kernel: [ 2946.045391] show_signal_msg: 15 callbacks suppressed
May 1 01:26:35 anakin kernel: [ 2946.045395] compiz[5781]: segfault at 4a00014 ip b714f33d sp bfcc8104 error 4 in libpthread-2.13.so[b7147000+15000]
May 1 01:27:49 anakin kernel: [ 3019.650984] compiz[6272]: segfault at 4800014 ip b71c533d sp bfdfa6e4 error 4 in libpthread-2.13.so[b71bd000+15000]
May 1 01:28:34 anakin kernel: [ 3064.848808] kernel tried to execute NX-protected page - exploit attempt? (uid: 0)
May 1 01:28:34 anakin kernel: [ 3064.848811] BUG: unable to handle kernel paging request at c00cb813
May 1 01:28:34 anakin kernel: [ 3064.848813] IP: [<c00cb813>] 0xc00cb813
May 1 01:28:34 anakin kernel: [ 3064.848823] *pdpt = 000000000187d001 *pde = 0000000001958067 *pte = 80000000000cb163
May 1 01:28:34 anakin kernel: [ 3064.848827] Oops: 0011 [#1] SMP
May 1 01:28:34 anakin kernel: [ 3064.848829] last sysfs file: /sys/devices/virtual/hwmon/hwmon0/temp1_input

Some time I had this crash (I have just submitted to Bug Report) on shutdown from Indicator Applet, saved in polkit-gnome-authentication-agent-1-bugreport.txt

System: Linux 2.6.38-8-generic-pae #42-Ubuntu SMP Mon Apr 11 05:17:09 UTC 2011 i686
X Vendor: The X.Org Foundation
X Vendor Release: 11001000
Selinux: No
Accessibility: Disabled
GTK+ Theme: Clearlooks
Icon Theme: ubuntu-mono-light
GTK+ Modules: gnomesegvhandler, canberra-gtk-module

Memory status: size: 112394240 vsize: 112394240 resident: 12398592 share: 9891840 rss: 12398592 rss_rlim: 18446744073709551615
CPU usage: start_time: 1304202894 rtime: 19 utime: 16 stime: 3 cutime:1 cstime: 0 timeout: 0 it_real_value: 0 frequency: 100

----------- .xsession-errors ---------------------
** (gnome-session:2008): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2008): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2008): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2008): DEBUG: GsmAutostartApp: (pid:2080) done (status:0)
** (gnome-session:2008): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2008): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2008): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2008): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
** (gnome-session:2008): DEBUG: GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
Could not attach to process. If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user. For more details, see /etc/sysctl.d/10...

Read more...

Reny (reny1977) wrote :

Found in /var/log/boot.log

Begin: Loading essential drivers ... FATAL: Error inserting uvesafb (/lib/modules/2.6.38-8-generic-pae/kernel/drivers/video/uvesafb.ko): Unknown symbol in module, or unknown parameter (see dmesg)
done.
Begin: Running /scripts/init-premount ... done.
Begin: Mounting root file system ... Begin: Running /scripts/local-top ... done.
Begin: Running /scripts/local-premount ... done.
Begin: Running /scripts/local-bottom ... done.
done.
Begin: Running /scripts/init-bottom ... done.
fsck from util-linux-ng 2.17.2
fsck from util-linux-ng 2.17.2
fsck from util-linux-ng 2.17.2
fsck from util-linux-ng 2.17.2
/dev/sda5: recovering journal
/dev/mapper/VolGroup00-root: clean, 403966/3276800 files, 6071424/13107200 blocks
/dev/sda5: clean, 253/60240 files, 94920/240940 blocks (check after next mount)
init: ureadahead-other main process (860) terminated with status 4
/dev/mapper/VolGroup00-home: recovering journal
/dev/mapper/VolGroup00-var: recovering journal
/dev/mapper/VolGroup00-home: clean, 194096/1310720 files, 3851613/5242880 blocks
init: ureadahead-other main process (876) terminated with status 4
/dev/mapper/VolGroup00-var: clean, 18198/1310720 files, 1207840/5242880 blocks

dino99 (9d9) on 2011-05-03
Changed in linux (Ubuntu):
status: New → Confirmed
Bob Harvey (bobharvey) wrote :

I have been observering something similar with 10.10 & 10.04, but on an intermittent basis.

professordes (d-a-johnston-hw) wrote :

There was a plymouth update today (6/5/11), but that has not fixed the problem (hang at logout/shutdown/restart) for me on a machine with fglrx graphics.

plopesc (plopesc) wrote :

 I have the same problem in my Dell Studio after upgrade from 10.10 to 11.04.
 In 10.10 it worked well, but after the upgrade, my laptiop hangs on shutdown/reboot.
It has an ATI Radeon HD4570 video card.

Conrad (conrad-barthelmes) wrote :

Just installed 11.04 on a fresh Dell Latitude E6420 and have the same problem as Azyl.. also in the live version from usb stic..

Stewy (brian-stewart6) wrote :

I'm having same the same problem since move from 10.10 to 11.04 about 3 weeks ago It did work OK for a while with early April version of 11.04 beta then went this way after an upgrade. Have re-installed twice - no luck. Though it was a Unity problem at first and raised a query but no response.
https://answers.launchpad.net/ubuntu/+source/unity/+question/153784

 Using Sony Laptop VGN-A617S with ATI RADEON X700.
Thought it was Unity at first but have removed that (which sometimes worked OK). Does not shut down properly even after 2 hours!. Have also noticed during startup that screen shows white vertical bars on black background for about 1 second. During shut-down the Ubuntu screen with 5 dots does not appear. About 1 in 10 - 1 in 20 times everything works OK just once.
Again like many others if any further info would help please let me know (but I need simple instructions being a novice).

Vid (davidzecha) on 2011-05-11
summary: - Computer is not turned off at sutdown
+ Computer is not turned off at shutdown
professordes (d-a-johnston-hw) wrote :

This behaviour may be aresult of earlier tinkerings to fix an ugly bootsplash in 10.10 or earlier. See comments by
mia1dolfan, #18 in bug #767927.

I ran the revert changes script at their suggestion for this at:

  http://www.kyleabaker.com/downloads/ubuntu/scripts/plymouth-resolution-fix-revert-back.sh.zip

and can now logout/shutdown again on an fglrx machine.

Stewy (brian-stewart6) wrote :

Hi,
Tried the plymouth revert script but had no effect. Terminal reported no changes.
I had not run any special scripts in 10.10 because I never had any problems with that so there shouldn't have been any hang-overs.
Anyway I had performed a complete re-installation of 11.04 to ensure I had no remnants of 10.10.

What I have noticed is that during normal boot (about 3/4 way through) I get a black screen with white vertical bars with what looks like some effort of text in the middle. This last for about a second. I will try to get a photo of it.
During shut down I get a single pixel line of dots and dashes across the centre of the screen for a few seconds, then the screen goes blank and system hangs.

I have also noticed that if I boot up in recovery mode I get white text on a black background (as you would expect) but the white text is in the form of white rectangular blocks - not characters. I will try to get a photo of this too. After a few minutes in recovery mode I do get the normal menu screen OK.

Sometimes - but not always (even in 10.10) at startup I get multiple images, although alternate lines are shifted a few inches (a bit like interleaved video) I have always been able to resolve this by "System - Preferences - Monitors" and selecting a different screen resolution - which I can then change back. I don't think this is related to the freezing on shutdown which only occurs in 11.04.

In summary - Still having problems. Sony VGN-A617S RADEON X700.

Stewy (brian-stewart6) wrote :

I've managed to get some screen photos. This one appears during normal startup for about 1 second about 20 secs after selection normal grub start.

Stewy (brian-stewart6) wrote :

This is what I get during a recovery start-up - obviously text in there somewhere - it scrolls up the screen.
I do get a normal grub boot selection screen first - which is clearly legible.

I was unable to get a photo of the shutdown screen which shows a line of 1 pixel high dots and dashes across the middle of the screen for about 5 secs just before hang-up.
I hope this helps someone identify what may be happening - or if they have something similar.
cheers.
Brian

Colin (tekash) wrote :

I can confirm this bug on my HP notebook 11.04 w/ Unity and ATI video. If I do a sudo halt from the terminal it shuts down properly. However, reboot from the menu or terminal still do not work. Shutting down from the menu or either reboot will hang on the Ubuntu splash screen with the dots. A couple of the dots animate and then nothing - hung.

Toni Alfaro (toni-alfaro) wrote :

In my Dell XPS420 with Unity and ATI video, i have the same situation that Colin describes:

- If i do a shutdown or reboot from the menu, the computers hung on
- If i do a shutdown from the terminal, it works property
- If i do a reboot from the terminal, it do not work

The final line in the log is different each time i try to shutdown:

- Sometimes "Cheking for running unattended-upgrades"
- Other times "Caught signal 15, shutting down." (only one final dot)
- Sometimes "Asking all remaining processes to terminate..."
- Finally, at other times, the display have different number of animated dots

If i try to reboot from the menu, the log seems a memory trace

Ubfan (ubfan1) wrote :

Running off a 4G usb stick, I get a hang at shutdown (Checking for unattended upgrades) on an MSI 135 (Micro Star International) netbook, but not on an Compaq Presario V3000 laptop. First time I have seen such a problem, going back to Jaunty.

Stewy (brian-stewart6) wrote :

Sorry, but sometimes in the heat of trying things we/I are not sure exactly what we've done.
I looke
I have a windows XP recovery partition (sony), a windows XP OS C: partition, an XP D: partition, then Ubuntu 11.04.
Out of frustration I tried Fedora (sorry) installed alongside and that really messed things up. Boot options only gave me Fedora14 and the XP recovery boot. No XP OS or Ubuntu.
Loaded my Ubuntu 10.10 LiveCD, Deleted the Fedora partition and loaded 10.10 there.
Boot options now gave me XP recovery, XP OS, Ubuntu 10.10 and 11.04.
All worked correctly except 11.04 which started up OK but had no gnome-panel. Would consistently start-up and close down OK.
Added gnome-panel to start-up applications and 11.04 works fine and shuts down fine every time.
Removed 10.10 partition and had to re-install grub.
Result... All boot options work fine, no white blocky screen with either 11.04 normal boot or Ubuntu recovery boot.
The boot options screen is different, smaller font and a white border around.
All my start-up and shut-down operations work fine now consistently.
The problem is that all seems OK but I have no real idea why.

pcanham (paulcanham) wrote :

Having issues with my Sony Vaio VPCM11M1E tried the following with no joys

1. tried removing "splash" from kernel line - shutdown hangs on wallpaper
2. "splash" and "quiet" from kernel line - shutdown hangs on wallpaper
3. added "acpi=off" and removed "splash" and "quiet" from kernel line - system doesnt boot
4. added "acpi=ht" and removed "splash" and "quiet" from kernel line - system boots but doesnt shutdown
5. added "pci=noacpi" and removed "splash" and "quiet" from kernel line - system doesnt boot
6. added "acpi=noirq" and removed "splash" and "quiet" from kernel line - system doesnt boot
7. added "pnpacpi=off" and removed "splash" and "quiet" from kernel line - shutdown hangs on wallpaper
8. added "noapic" and removed "splash" and "quiet" from kernel line - shutdown hangs on wallpaper
9. added "nolapic" and removed "splash" and "quiet" from kernel line - shutdown hangs on wallpaper

root@flippy:~# uname -a
Linux flippy 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Tarball of /proc/acpi directory attached

and also output of lspci -vvnn

pcanham (paulcanham) wrote :

sorry about multiple comments

demicode ouput

pcanham (paulcanham) wrote :

lastly kern.log.1

pcanham (paulcanham) wrote :

forgot to add /proc/acpi output

pcanham (paulcanham) wrote :

Following work around also didn't work

sudo modprobe -rf rt2860sta
sudo modprobe rt2860sta
echo blacklist rt2800pci | sudotee -a /etc/modprobe.d/blacklist.conf

Ubfan (ubfan1) wrote :

Further testing with a fresh Maverick install to an 8G stick and updated, displayed the improper shutdown problem -- it's as if the usb gets turned off before the filesystem is dismounted, leaving it dirty and in need of checking next boot. Looks like Lucid is the last release that worked properly on the MSI 135 netbook.

Petr Blatný (blatny) wrote :

AMD Phenom 8650, Nvidia 260, upgraded from 10.10 32-bit to 11.04 - also affected. Every log out, reboot or shutdown ends with black screen. Only option to reset or CTRL-SysReq REISUB.
No such problems with 10.10.

pcanham (paulcanham) wrote :

upgraded kernel to 2.6.38-9-generic #43pre201105250907 and found that shutdown/reboot and halt work from the command line and also from the menu options.

pcanham@flippy:~$ uname -a
Linux flippy 2.6.38-9-generic #43pre201105250907-Ubuntu SMP Wed May 25 10:21:18 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Reny (reny1977) wrote :

in which way I can upgrade kernel to 2.6.38-9-generic #43pre201105250907 ?
 I have tried to install 2.6.39 from ppa/kernel but the bug persist.

Kevin Munnelly (kevinmunnelly) wrote :

I was having the same issue on 11.04 with shut down and also suspend/hibernate. When shutting down everything would disappear except for my wallpaper and I would have to force a shutdown by holding the power button down. When hibernating/suspending the screen would go black but computer would not actually suspend/hibernate and I had no choice but to force a shutdown.

For me it was due to my Ralink RT3090 wireless adapter. I blacklisted the driver in /etc/modprobe.d/blacklist.conf and everything works fine now. Well except my wireless adapter obviously.

jcwinnie (jcwinnie) wrote :

This initial bug report (kudos to the bug reporter for bothering) is about an upgrade. I can report the problem is the same with a new Natty install. I have removed "quiet splash" and run 'update-grub'. Still have the problem.

Used the solution for past versions. Added 'acpi=force' , updated grub and that works. Would prefer a better solution.

Love that 90 days after validating the importance is undecided and it remains unassigned. And, yet when this problem appears many times in forum the standard response is: "Have you filed a bug report?"

dino99 (9d9) wrote :

The first step to understand that problem is already known:

http://www.phoronix.com/scan.php?page=news_item&px=OTUwOA
http://mjg59.livejournal.com/137313.html

now i hope the next kernel will take advantage of this know how, and maybe acpi be tweated, or initscripts be changed if we need to wait for a better kernel fix.

Lars (larsmednosen) wrote :

It would be a nice feature, to be able to shut the computer down. ;)

Petr Blatný (blatny) wrote :

Shutting computer is a piece of cake - you can always press a button. (Irritating - yes. User friendly - no.)
But guess what happens when my wife logs in and then tries to log out while my session is active. Not a nice thing at all. :-(

25 comments hidden view all 105 comments
Bruce Hohl (brucehohl) wrote :

rajeshkunnoth, this is your post:
http://ubuntuforums.org/showthread.php?t=1754383

I have been collecting my various attempts to solve this problem in this post:
http://ubuntuforums.org/showthread.php?t=1838460&highlight=poweroff

A variety of different solutions have worked for many yet many others can find no solution. Is there no way other than trial & error to trouble shoot this problem? It seems like there should be some way to determine what blocks a computer from carrying out a power off command! For many of us this also makes it impossible to use Suspend and Hibernate. This is a significant annoyance for laptop users.

Bruce Hohl (brucehohl) wrote :

For the Lenova B575 this problem also occurs with Ubuntu 11.10 beta 2 using kernel 3.0.0-11-generic x86_64. Booting with live CD is OK except that grub menu is unreadable (like with 11.04). Upon shutdown the computer continues apparently without error until the message: "Please remove installation media and close the try then press ENTER:"

At this point it is possible to switch among the virtual terminals but no virtual terminal is responsive. Once enter is pressed the system becomes totally unresponsive and does NOT poweroff.

Hans Deragon (deragon) wrote :

Same problem with Lenovo t61p laptop running 11.04. Upgraded regularly with the latest packages.

Same problem with Dell Latitude E5520 running 11.04.

Bruce Hohl (brucehohl) wrote :

Update regarding Lenovo B575 AND Ubuntu 11.10 beta 2 using kernel 3.0.0-11
With x86_64 (64 bit) version shutdown fails.
With i686 (32 bit) version shutdown and suspend WORKS !!!

So the problem (at least on the B575) is related to some difference between the 64 and 32 bit Ubuntu versions. (I would just use the 64 bit version but I also want to use KVM.)

Perhaps a few others can check the 64 bit versus 32 bit versions on their systems and report back. I checked the 32 bit version by using a bootable USB prepared with the "Startup Disk Creator".

Well I have the same problem with 64 bit, no problem with boot cds or live cds, usually 32 bit. Not yet tested with full 32 bit installation but with debian I have also no problem

Nils Braden (nils.nils) wrote :

Don't want to spoil the anticipation but I'am still getting this with a fresh Installation of 11.10 beta 2...

well I discovered that OS hangs during boot and services are not started from system V
So it was not possible to shut down the computer as well
after deinstallation of plymouth everything was working
plymouth is just the fancy boot screen, so no function problem.
be aware mountall is depending on the plymouth, which might be not correct as well

Solution for me was:

dpkg --force-depends -P plymouth

I did this after upgrading to 11.10. (beta), tried to solve the problem with the upgrade unsuccessfully

dino99 (9d9) wrote :

hm, #73 workaround only give broken packages (mountall & cant remove plymouth* because synaptic wants to remove a bunch of other packages), but agree that depending on plymouth does not seem justified.

Toni Alfaro (toni-alfaro) wrote :

It seems to be solved in Ubuntu 11.10 (kernel 3.0.0-12-generic). At least on my computer shutdown/reboot works properly

Hi Toni (#75), not with my motherboard, just after deinstalling plymouth :-O

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the release candidate kernel versus the daily build. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

Petr Blatný (blatny) wrote :

So the problem persists even after upgrade to 11.10. :-(

Recap:
AMD Phenom 8650, Nvidia 260, upgraded from 10.10 32-bit to 11.04 - also affected. Every log out, reboot or shutdown ends with black screen. Only option to reset or CTRL-SysReq REISUB. Later upgraded further to 11.10. Problem still persists.
No such problems with 10.10.

Filip Vařecha (xaralis) wrote :

I have finally resolved this issue after update to 11.10. This is Dell e6410.

The update via Update Manager didn't work for me as mentioned before so I tried a clean reinstall. Fortunately, Ubuntu installer is able to keep all configuration from home dir a also to reinstall most of previously installed packages so the reinstallation was really not that painful.

After this process, everything works as it should. Turn on/turn off and even suspend in memory and hibernation.

After coming through this I suppose that shutdown error has to do something with configuration in /etc not updating correctly when system was updated from 10.10 to 11.04.

I suggest everyone suffering from this issue to try clean reinstall and see if that works for you.

Jwednesday (jwednesday) wrote :

I am still having the issue with shutdown/reboot/logout. I upgraded from 11.04 to 11.10 and the menu buttons still do not work. I am able to use init/shutdown -r or -h now from the console. I am using a Dell 1545 N and I loaded the KDE desktop on top of Lubuntu and changed from LXDE to KDM. Any other suggestions or is there a specific file in /etc that anyone has found to be the issue?

Toni Alfaro (toni-alfaro) wrote :

In my case (#75), as in the case of Filip (#79), the problem was solved with a clean installation of Ubuntu 11.10 (not upgrade, clean installation)

Petr Blatný (blatny) wrote :

I feel like in Windows world again ... to fix "something" wrong in /etc we will reinstall the whole system? Really??

Don't get me wrong #79 & #81 - I really appreciate you information and giving us hope!

But could someone from developers after 6+ month finally look at the issue and tell us how to fix it moreover if it is just some messed up config file?

Jwednesday (jwednesday) wrote :

I totally agree with #82 that someone should be looking at this issue since it has been going on for so long. After, searching I decided to look at an online lesson on Linux servers. In that video, I found the "tasksel" command and found that the KDE desktop was not fully installed on top of Lubuntu. So whatever package was missing from the previous install, had cause my issue. I can now shutdown/reboot/logout. I could not tell you what was missing but it now works without having to "reinstall". I filed a bug report earlier but the developers really should look at this in order to make this version better.

Jwednesday (jwednesday) wrote :

side note ... the above only works with KDM

Reny (reny1977) wrote :

My system is fully configured from 8.04 for my work (script, db, ide, workspace, packages....) and think to reinstall everything from scratch is a scary thought!!!!!!
I'm agree with #82!!!!!!

Filip Vařecha (xaralis) wrote :

#82, #85: For me, the reinstallation was quite an easy-go. Nothing messed up, most of the settings remained to work as they did previously. The only things I had to install again were Opera (internet browser), Nvidia drivers and there were some minor tweaks for the UI itself - I am now using Unity instead of Gnome 2. But I don't use Unity's dash a lot and I stick to using Synapse launcher which is much faster and usable - at least for me.

funkatron (conrad-bebbington) wrote :

Seen after upgrade from 11.04 to 11.10. In an effort to get some movement I'm attaching a screenshot of the console seen on failed shutdown.

Hi Joseph (#77),

can you be more precise what I have to do for upsteam testing?
Currently I have the kernel:

Linux server 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

so do you want me to install kernel 3.1-rc10-oneiric (http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1-rc10-oneiric/)
so I need probably install the following two packages:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1-rc10-oneiric/linux-headers-3.1.0-030100rc10-generic_3.1.0-030100rc10.201110200610_amd64.deb

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1-rc10-oneiric/linux-image-3.1.0-030100rc10-generic_3.1.0-030100rc10.201110200610_amd64.deb

And adjust grub?

Is that your plan?

Roger Kay (lunarockets) wrote :

Ubuntu 11.10 I have to manually turn off my computer each time.

Mark P (mpupilli) wrote :

Since doing a regular system update today Ubuntu 11.10 has started hanging on shutdown in 'checking for unattended upgrades'. Ctrl-alt-del causes it to skip this but then it still does not shutdown. Very annoying as it was working fine before. I don't know what got updated today, is there a way to look at the update history?

Please try the patch below to see if it can help the issue.
http://marc.info/?l=linux-pm&m=132123391726374&w=2

thanks,
--
Ming Lei

Reny (reny1977) wrote :

I have formatted and installed 11.10...this bug not affect me now...

But I tried to follow this guid to fix ugly and big plymouth resolution

http://news.softpedia.com/news/How-to-Fix-the-Big-and-Ugly-Plymouth-Logo-in-Ubuntu-10-04-140810.shtml

and when I shutdown, pc freeze!!!!! so I turn back pc and now I can shutdown, reboot, ecc...

So, I suggest to investigate in this direction....I think that the problem is near uvesafb/v86d module!!!!!!

philinux (philcb) wrote :

11.10 clean install.

Sporadically takes ages to shutdown and sometimes never. Plymouth just displays progress dots.

Tried this and it seem to make shutdown much faster. Add this line, stop on runlevel [06], to this file.
gksu gedit /etc/init/network-manager.conf

# network-manager - network connection manager
#
# The Network Manager daemon manages the system's network connections,
# automatically switching between the best available.

description "network connection manager"

start on (local-filesystems
and started dbus)
stop on stopping dbus
stop on runlevel [06]
expect fork
respawn

exec NetworkManager

dino99 (9d9) wrote :

On Precise i386:

- 3.1 kernel seems to work without trouble: shutdown/restart process are clean
- 3.2 kernel dont shutdown, need to switch power off manually, restart of course always fails

this is with nvidia-current driver. (seems related to IgnoreAbi)

Benn Kovco (bennkovco) wrote :

I have an ASUS Pro50N, the issue (restart and shutdown hang, standby was OK for me) was present for me in Ubuntu 11.04 and also after clean install of 11.10, resolved in both cases by doing the following:

1. Open Terminal

2. Edit grub menu

 sudo gedit /etc/default/grub

3. Edit the line "GRUB_CMDLINE_LINUX_DEFAULT=" to be:

 GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi=force"

4. Close and save the file and run:

 sudo update-grub

This issue detailed at http://ubuntuforums.org/showthread.php?t=1466589&page=6 - along with links to resolving this issue by blacklisting bad Nvidia drivers which worked for some users.
I know this fix does not work for all instances of this issue but hope it helps some users while the bug is worked out.

Jacob T (jthpriv) wrote :

I am also having this issue. My box is running Ubuntu 11.04 and is a dedicated MythTV box, so failing to shut down properly is a huge issue. I have other machines with 11.04 is shutting done fine so it must be related to specific hardware configurations.
It hangs in the shutdown screen with the words "waiting...". I have looked in boot.log, dmesg and syslog but no suspicious messages.

I have tried the workaround in #95, but no sucess. I dont have any wireless networking so the suggestion in #31 wouldnt apply ( i guess)

uname -a gives:
Linux edoras 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux

I have nvidia drivers installed, which seem to be causing problems(?). I will also try a kernel update to 3.1 as this seem to have been succesful for some. Should i post my lsmod output?

Pedro Souza (phsbr) wrote :

Hi guys, any news on this?

I'm running a clean install of Ubuntu 11.10 with all possible updates done, and the computer still hangs on shutdown screen!

Thanks

dino99 (9d9) wrote :

post #94 follow up:
- on Precise i386, no ppa, nvidia, no compiz, no unity : dont get this issue (shutdown/restart are normal) now.

Petr Blatný (blatny) wrote :

lots of updates later ... problem still persists

Daniel Hahler (blueyed) wrote :

Comment #93 fixed it for me; adding "stop on runlevel [06]" to /etc/init/network-manager.conf.
Since this is specific to network-manager / dbus / upstart, I have filed a new bug about it: bug 937866.

Also comment #91 seems to make sense, but I have not checked if it's applied to Ubuntu's kernel already.

I am using Ubuntu Precise (development release).

dino99 (9d9) wrote :

it has been fixed with Precise by MTL: some sendid added and resolvconf fixed too.

Ernst, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
dino99 (9d9) wrote :

Sadly this issue persist with all the kernel versions up to the trunk one on one of my system, so its related to hardware/chipset (here asus p5wdh):

- first cold boot: either panic after getting the grub menu choice loading or it self kill
- second cold boot most of the time kill itself before getting the grub menu
- thirs cold boot works but the grub menu does not activate its countdown timer.

- shutdown seems working normally
- reboot never works: need to cut power, then get the 3 first cold boot issue

tags: added: i386kernel-bug-exists-upstream
removed: needs-upstream-testing
tags: added: i386 kernel-bug-exists-upstream
removed: i386kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

dino99, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette . If you do file a new report, please feel free to subscribe me to it.

tags: added: needs-upstream-testing
removed: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Displaying first 40 and last 40 comments. View all 105 comments or add a comment.