Ubuntu

Can't connect to hidden network automaticaly

Reported by Michal Predotka on 2011-04-13
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

I have hidden network at home and I have its parameters added to network manager wireless connection. Unfortunately automatic connection does not work. I have to go to "connect to hidden network", select my network, enter my password and then I can connect to that network.

I found the bug #295796, but it's about Ubuntu Intrepid and in the comment #44 someone is asking to open new bug report.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: network-manager 0.8.4~git.20110319t175609.d14809b-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
CRDA: Error: [Errno 2] Nie ma takiego pliku ani katalogu
Date: Wed Apr 13 17:57:33 2011
Gconf:

IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
IpRoute:
 192.168.2.0/24 dev wlan0 proto kernel scope link src 192.168.2.3 metric 2
 169.254.0.0/16 dev wlan0 scope link metric 1000
 default via 192.168.2.1 dev wlan0 proto static
Keyfiles: Error: [Errno 2] Nie ma takiego pliku ani katalogu
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
ProcEnviron:
 LANGUAGE=pl:en_GB:en
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)

Michal Predotka (mpredotka) wrote :

Hidden SSID auto-connect fine here, as soon as I remove the usual non-hidden one they'd connect to normally ;)

Reassigning to 'linux', since it's probably an issue with how iwl3945 deals with hidden SSIDs.

affects: network-manager (Ubuntu) → linux (Ubuntu)
naturewise (naturewise13) wrote :

I have the same problem in Ubuntu 11.04 64-bit. Network manager does not automatically connect to my hidden network, although "automatically connect" is checked in the settings. I have to go to "connect to hidden network", select my network, enter my password and then I can connect to that network. This is kind of annoying...

naturewise (naturewise13) wrote :

Several people having same problem. Pls see

http://ubuntuforums.org/showthread.php?t=1751740

Thanks for fixing the problem!

Jordi (jorval-terra) wrote :

I have the same problem after upgrading my Ubuntu Netbook Edition from 10.10 to 11.04 on an Asus eeepc1005ha.

AnGus (ozsolarwind) wrote :

I have 11.04 on a Dell Inspiron.
Initially, wireless was working fine (autoconnect, ...)
I then cable connected for a while
Now I need to "connect to hidden network" as described above.

SPARX (nospam-sparx) wrote :

I encountered the same problem, after upgrading and deleting the (working) entry in the manager, and adding it again. The problem is not searching for the hidden ssid and thus not auto connecting (after reboot).

For me the solution was something like (not sure though, not repeatable, it now stays working):
(Maybe these steps (* ) where unnecessary)
-delete the entries of this ssid
*switch on the ssid visibility on the router
*add the network
*switch off the ssid visibility on the router
-add the hidden network
-switch on available to all users

after rebooting it now automatically connects with the hidden ssid.!

Michal Predotka (mpredotka) wrote :

SPARX, thanks for workaround.
Unfortunately it's possible only if someone has access to router settings.

This bug is missing log files that will aid in dianosing the problem. From a terminal window please run:

apport-collect 760015

and then change the status of the bug back to 'New'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
naturewise (naturewise13) wrote :

Recently, there was a kernel update to 2.6.38-10. Now, it's working fine...
Thanks to those who fixed it!
Cheers!

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers