Comment 38 for bug 754711

Daniel Manrique (roadmr) wrote :

Hi,

Here's an update on this bug. I finally got around to trying systemtap on kernel 3.0 with Oneiric. If I run the systemtap diagnostics as referenced here:

https://wiki.ubuntu.com/Kernel/Reference/S3SystemTapDebug

the system begins suspend preparations, flickers the screen as if trying to suspend, and then *doesn't* suspend, returning me to the OS with this message on the terminal:

Suspending machine..
PM-INFO: Ready to run S3 test
PM-TEST: 255 tasks frozen successfully.
PM-TEST: __device_suspend(): device platform () failed to suspend.
PM-TEST: __device_suspend(): device platform () failed to suspend.
PM-TEST: dpm_suspend(): failed to suspend all devices.
PM-TEST: 2 of 554 devices failed to suspend.
PM-INFO: Devices that failed to suspend: 0000:02:00.0.
PM-TEST: dpm_suspend_start(): dpm_prepare() or dom_suspend() failed, cannot prepare devices for PM transistion and suspend.
PM-TEST: 544 devices resumed correctly.
PM-TEST: suspend_devices_and_enter(): failed to suspend devices and enter the desired system sleep state.
PM-TEST: enter_state(): failed because either suspend_prepare() or suspend_devices_and_enter() failed.
PM-TEST: state_store(): Expecting a return value of 3, got -12 instead.
PM-INFO: 32 functions entered, 30 functions returned.
PM-INFO: 255 tasks frozen and 255 tasks thawed.
PM-INFO: S3 test completed.

It indicates 2 devices failed to suspend, the indicated one (02:00.0) is the "VGA compatible controller [0300]: nVidia Corporation G98 [GeForce 9200M GS] [10de:06e8] (rev a1)".

If I run just pm-suspend, without systemtap debugging, the system behaves as originally reported, apparently entering suspend mode, but when I press the power button it fails to resume and just becomes unresponsive.

I also tried the latest mainline, 3.2.0-rc2 kernel from Ubuntu's mainline repository. Behavior is the same as originally reported. So this bug is still an issue.

I'm attaching all the systemtap-produced logfiles.