Ubuntu

Lenovo Ideapad U350: Internal mic stopped working with natty kernel

Reported by Ivanka Majic on 2011-04-05
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
David Henningsson

Bug Description

Upgraded kernel and my internal mic stopped working.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-7-generic 2.6.38-7.39
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
NonfreeKernelModules: wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ivanka 1331 F.... pulseaudio
 /dev/snd/pcmC0D0c: ivanka 1331 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf4600000 irq 48'
   Mixer name : 'Intel Cantiga HDMI'
   Components : 'HDA:14f15066,17aa4001,00100300 HDA:80862802,80860101,00100000'
   Controls : 12
   Simple ctrls : 6
Date: Tue Apr 5 18:03:24 2011
HibernationDevice: RESUME=/dev/sda5
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110404)
MachineType: LENOVO IdeaPad U350
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=82374323-8ebe-4fdc-8ef2-625867ca29a5 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-7-generic N/A
 linux-backports-modules-2.6.38-7-generic N/A
 linux-firmware 1.49
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/06/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 1CCN16WW
dmi.board.name: LL1
dmi.board.vendor: Lenovo
dmi.board.version: Rev 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Lenovo
dmi.chassis.version: Rev 1.0
dmi.modalias: dmi:bvnLENOVO:bvr1CCN16WW:bd06/06/2009:svnLENOVO:pnIdeaPadU350:pvrRev1.0:rvnLenovo:rnLL1:rvrRev1.0:cvnLenovo:ct10:cvrRev1.0:
dmi.product.name: IdeaPad U350
dmi.product.version: Rev 1.0
dmi.sys.vendor: LENOVO

Ivanka Majic (ivanka) wrote :
Brad Figg (brad-figg) on 2011-04-07
Changed in linux (Ubuntu):
status: New → Confirmed
Ivanka Majic (ivanka) wrote :

Have since wiped reinstalled natty from scratch and the problem is still there.

David Henningsson (diwic) wrote :

Hi Ivanka and thanks for your bug report. Could you please try to add the following row to /etc/modprobe.d/alsa-base.conf:

options snd-hda-intel model=asus

Then reboot and try again. If it does not work now, please attach an alsa-info with this configuration (see https://wiki.ubuntu.com/Audio/AlsaInfo )

Notes:
1) Yes, it's the asus model even though you have a Lenovo
2) You need root access to edit the file (start editing e g with this terminal command: "gksudo gedit /etc/modprobe.d/alsa-base.conf").

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Kent Baxley (kentb) wrote :

I also have a u350 Ideapad and the above suggestion got my internal mic working again.

Thanks, David!

David Henningsson (diwic) wrote :

Hi Kent,

As Ivanka did not respond, could you supply an alsa-info to verify you have the same hardware? ( wiki.ubuntu.com/Audio/AlsaInfo ) If so we can supply a quirk upstream.

Kent Baxley (kentb) wrote :

Hi David,

Here's the requested alsainfo. I had the "model=asus" workaround in place when I ran this.

Let me know if you need anything else.

Christopher Zehner (zarlan) wrote :

Hi David,

I was also affected by this bug and your workaround straightened it out for me right away. Launchpad is awesome like that.

Not sure if it's necessary but here's my alsa info as well.

Changed in linux (Ubuntu):
assignee: nobody → David Henningsson (diwic)
status: Incomplete → In Progress
David Henningsson (diwic) wrote :

Hi,

Upstream has asked for testing the new autoparser on this hardware. Could you please try the following:
1) Upgrade to latest alsa drivers: https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules
2) Change /etc/modprobe.d/alsa-base.conf so the line now says "options snd-hda-intel model=auto" instead
3) Reboot, test that everything works the way it should, and report back here.

Thanks!

http://mailman.alsa-project.org/pipermail/alsa-devel/2011-May/040050.html

Changed in linux (Ubuntu):
status: In Progress → Incomplete
Kent Baxley (kentb) wrote :

Hi David,

With this alsa package:

linux-alsa-driver-modules-2.6.38-8-generic 2.6.38-8.201105041657

and the following line set to:

options snd-hda-intel model=auto

...The internal mic stops working again.

I'll set it back to asus and see what happens.

Kent Baxley (kentb) wrote :

So, setting the model back to "asus" seems to be the only way to get the internal mic to work on this system at the moment.

David Henningsson (diwic) wrote :

Hmm, it seems the daily builds for Natty isn't up and running the way I thought it was. Could you uninstall this package and instead install the dkms-hda package from ppa:diwic/dkms, then retry model=auto?

Sorry for the inconvenience.

Kent Baxley (kentb) wrote :

Hi David,

I installed your alsa-hda-dkms package from your PPA and set model=auto. This time, the internal mic works.

Let me know if there's anything else I can provide.

Thanks!

David Henningsson's suggestion solved the problem for my Asus UL20FT. Thanks a lot.

Herton R. Krzesinski (herton) wrote :

The commit for this issue came in via a stable upstream release. As such it is not subject to the standard bug verification process.

tags: added: verification-done-natty
Launchpad Janitor (janitor) wrote :
Download full text (13.4 KiB)

This bug was fixed in the package linux - 2.6.38-11.48

---------------
linux (2.6.38-11.48) natty-proposed; urgency=low

  [Herton R. Krzesinski]

  * Release Tracking Bug
    - LP: #818175

  [ Upstream Kernel Changes ]

  * Revert "HID: magicmouse: ignore 'ivalid report id' while switching
    modes"
    - LP: #814250

linux (2.6.38-11.47) natty-proposed; urgency=low

  [Steve Conklin]

  * Release Tracking Bug
    - LP: #811180

  [ Keng-Yu Lin ]

  * SAUCE: Revert: "dell-laptop: Toggle the unsupported hardware
    killswitch"
    - LP: #775281

  [ Ming Lei ]

  * SAUCE: fix yama_ptracer_del lockdep warning
    - LP: #791019

  [ Stefan Bader ]

  * SAUCE: Re-enable RODATA for i386 virtual
    - LP: #809838

  [ Tim Gardner ]

  * [Config] Add grub-efi as a recommended bootloader for server and
    generic
    - LP: #800910
  * SAUCE: rtl8192se: Force a build for a 2.6/3.0 kernel
    - LP: #805494

  [ Upstream Kernel Changes ]

  * Revert "bridge: Forward reserved group addresses if !STP"
    - LP: #793702
  * Fix up ABI directory
  * bonding: Incorrect TX queue offset, CVE-2011-1581
    - LP: #792312
    - CVE-2011-1581
  * fs/partitions/efi.c: corrupted GUID partition tables can cause kernel
    oops
    - LP: #795418
    - CVE-2011-1577
  * usbnet/cdc_ncm: add missing .reset_resume hook
    - LP: #793892
  * ath5k: Disable fast channel switching by default
    - LP: #767192
  * mm: vmscan: correctly check if reclaimer should schedule during
    shrink_slab
    - LP: #755066
  * mm: vmscan: correct use of pgdat_balanced in sleeping_prematurely
    - LP: #755066
  * ALSA: hda - Use LPIB for ATI/AMD chipsets as default
    - LP: #741825
  * ALSA: hda - Enable snoop bit for AMD controllers
    - LP: #741825
  * ALSA: hda - Enable sync_write workaround for AMD generically
    - LP: #741825
  * cpuidle: menu: fixed wrapping timers at 4.294 seconds
    - LP: #774947
  * drm/i915: Fix gen6 (SNB) missed BLT ring interrupts.
    - LP: #761065
  * USB: ehci: remove structure packing from ehci_def
    - LP: #791552
  * drm/i915: disable PCH ports if needed when disabling a CRTC
    - LP: #791752
  * kmemleak: Do not return a pointer to an object that kmemleak did not
    get
    - LP: #793702
  * kmemleak: Initialise kmemleak after debug_objects_mem_init()
    - LP: #793702
  * Fix _OSC UUID in pcc-cpufreq
    - LP: #793702
  * CPU hotplug, re-create sysfs directory and symlinks
    - LP: #793702
  * Fix memory leak in cpufreq_stat
    - LP: #793702
  * net: recvmmsg: Strip MSG_WAITFORONE when calling recvmsg
    - LP: #793702
  * ftrace: Only update the function code on write to filter files
    - LP: #793702
  * qla2xxx: Fix hang during driver unload when vport is active.
    - LP: #793702
  * qla2xxx: Fix virtual port failing to login after chip reset.
    - LP: #793702
  * qla2xxx: Fix vport delete hang when logins are outstanding.
    - LP: #793702
  * powerpc/kdump64: Don't reference freed memory as pacas
    - LP: #793702
  * powerpc/kexec: Fix memory corruption from unallocated slaves
    - LP: #793702
  * x86, cpufeature: Fix cpuid leaf 7 feature detection
    - LP: #793702
  * ath9k_hw: do noise floor calibration only on required chain...

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.