Attempt to Use Realtek RTL8192CE Wireless Causes Computer to Freeze

Bug #749871 reported by William Haddon on 2011-04-04
170
This bug affects 43 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I have a Toshiba Satellite C655D-S5133 laptop with a Realtek RTL8192CE wireless card and Ubuntu 11.04 Beta. Network Manager successfully detects the wireless networks in the area, however when I attempt to connect to one, the computer freezes completely (can't move mouse, can't use Ctrl+Alt+F1 to switch to a terminal, etc.). Using the upstream 2.6.38 kernel in Ubuntu 10.10 (I haven't tried in 11.04) causes the same behavior, as does compiling the kernel module on the Realtek website for the 2.6.35 kernel that comes with Ubuntu 10.10.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-7-generic 2.6.38-7.39
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices:
 Failed to stat runtime directory /home/whaddon/.pulse/7798453df197cfe0743339dd0000000c-runtime: Invalid argument
 **** List of PLAYBACK Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: amd64
ArecordDevices:
 Failed to stat runtime directory /home/whaddon/.pulse/7798453df197cfe0743339dd0000000c-runtime: Invalid argument
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', '/dev/snd/controlC0', '/dev/snd/hwC0D0', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0x90340000 irq 16'
   Mixer name : 'Conexant CX20585'
   Components : 'HDA:14f15069,1179fde8,00100302'
   Controls : 8
   Simple ctrls : 5
Date: Sun Apr 3 22:00:31 2011
HibernationDevice: RESUME=UUID=557ff502-1a7a-43c2-a166-132dd6dc9728
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: TOSHIBA Satellite C655D
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=86a54951-f261-4d69-ab52-7650ec3dae9c ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-7-generic N/A
 linux-backports-modules-2.6.38-7-generic N/A
 linux-firmware 1.49
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to natty on 2011-04-04 (0 days ago)
dmi.bios.date: 12/07/2010
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: 1.30
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: AMD
dmi.chassis.version: None
dmi.modalias: dmi:bvnInsydeCorp.:bvr1.30:bd12/07/2010:svnTOSHIBA:pnSatelliteC655D:pvrPSC0YU-00H002:rvnTOSHIBA:rnPortablePC:rvrBaseBoardVersion:cvnAMD:ct10:cvrNone:
dmi.product.name: Satellite C655D
dmi.product.version: PSC0YU-00H002
dmi.sys.vendor: TOSHIBA

William Haddon (whaddon) wrote :
Brad Figg (brad-figg) on 2011-05-04
Changed in linux (Ubuntu):
status: New → Confirmed
Simon Brooks (burtnoir-gmail) wrote :

I have the same experience on the Toshiba C650D-007 laptop. It has the Realtek RTL8188CE card and uses the RTL8192 driver.

I have confirmed the same thing in Suse 11.4 and Fedora 15 Beta as well. The common thread appears to be the 2.6.38 version of the kernel.

chad billman (cabillman) wrote :

I was having problems with the 8188ce in my x120e. I didn't notice the crashing but it would constantly stop passing traffic after a few minutes.

After playing with lots of different combinations I seem to have a stable system and wireless connection with the drivers from the realtek website. What is strange is that I used the drivers marked for pre 2.6.34 kernels on my 2.6.38-8-generic kernel. The drivers installed fine and have been very stable.

The drivers I used had the following version version number: 2.6.0006.0321.2011

dreamon (dreamon) wrote :

I can confirm what Chad Billman said in post #4. The Realtek 8192CE driver which is currently included in the Natty kernel is very unstable. I also experience situations where no traffic is sent or received for a period of a few seconds up to a few minutes. This happens 2 to 3 times a day. Sometimes the connection also drops completely, forcing me to reconnect. Installing the official Realtek driver improves stability a bit. Ironically, compiling the version for >= 2.6.35 kernels (version 0003.0401.2011) breaks the system, but the version for <= 2.6.34 kernels (2.6.0006.0321.2011) works fine. I still experience random connection freezes and dropouts, however, albeit on a less frequent basis. More information can be found here: http://www.thinkwiki.org/wiki/ThinkPad_11b/g/n_Wireless_LAN_Mini-PCI_Express_Adapter_II and here: http://www.linlap.com/wiki/lenovo+thinkpad+edge+13+-+intel+core+i3.

Hardware: ThinkPad Edge 13, Intel Core i5, 4 GB RAM
uname -a: Linux thinkpad 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
lspci -v: 03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
 Subsystem: Realtek Semiconductor Co., Ltd. Device 8195
 Flags: bus master, fast devsel, latency 0, IRQ 17
 I/O ports at 2000 [size=256]
 Memory at f0400000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: rtl8192ce
 Kernel modules: rtl8192ce

Please let me know if you need any further information. Any suggestions or ideas would be welcome.

Alejandro Mery (amery) wrote :

compat-wireless is supposed to be linux-backports-modules-wireless-natty-generic, but it doesn't exist :(

Ben Lafreniere (ben-lafreniere) wrote :

I've tried Chad Billman's suggestion from post #4, using the pre 2.6.34 driver (2.6.0006.0321.2011) for my 2.6.38 natty kernel, and I'm still getting full system lock-ups.

They do seem less frequent than with the stock driver included with my kernel, but this might just be my imagination.

Linuxslate (johnapf) wrote :

Just posting a "Me too".

Toshiba Satellite C655D-S5133 laptop with a Realtek RTL8192CE wireless card.

10.04, with the Realtek "official" driver. Hard lock-up upon connection to the AP.

Stephan Diestelhorst (syon) wrote :

BTW: I successfully compiled compat-wireless and it works so far.

kozimodo (forums-theo) wrote :

@Stephan,

Are you running the 64 bit version? I tried the compat-wireless a few weeks ago and they didn't work on my install.

Stephan Diestelhorst (syon) wrote :

64bit, yes. Working, too.

kozimodo (forums-theo) wrote :

So -- still not working for me. I tried both the 3.0 rc and the 2.6.39 release drivers and in both cases, they do not connect to the AP whereas the included driver connects but has trouble maintaining a clean connection. Any ideas? Are the backported drivers going to be released for natty any time soon?

Simon Brooks (burtnoir-gmail) wrote :

I have now successfully compiled the compat wireless drivers and have them working in Fedora 15. I used the 2.6.38.2-2-ns version and am running 64 bit.

It's early days as I haven't rebooted and still have the ones direct from Realtek blacklisted but there seems to be light at the end of this tunnel.

kozimodo (forums-theo) wrote :

@Simon -- Many thanks. So far working better but connection still not as quick as 70/70 signal strength would suggest.

regards,
I hope this bug can be eliminated soon so I can install Linux in my laptop

This bug locked up my x120e on Natty while I was typing this comment. Oh, the irony!

Seriously though, PLEASE get this fixed.

I haven't had any problems after switching to linux-image-3.0.0-0300rc7-generic. (Had to remove fglrx to install kernel v3.)

Dear Andrew Janssen
Could you please tell us how can we fix this bug step by step?

Or should we wait more?

Stephan Diestelhorst (syon) wrote :

Just a quick update: After the most recent stable kernel update, I was forced to rebuild compat wireless and found that it was flaky, once again (version of Aug 01st, 2011). Installing Linux 3.0 as per https://wiki.ubuntu.com/Kernel/MainlineBuilds things are funcitoning again. Note that if you use fglrx, version 11.7 has support for that kernel, so no hassle.

Hi Christopher. I saw flandolt's comment at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/769812/comments/25 and tried to install kernel 3. Here's what I did, if I remember correctly:

# The following _didn't_ work, because I don't know how to use PPA correctly.
sudo add-apt-repository ppa:kernel-ppa/ppa #also tried ppa:kernel, ppa:kernel-ppa, etc.
sudo apt-get update
sudo apt-get install linux-headers-3
sudo apt-get install linux-headers
sudo apt-get update

# So instead I downloaded the debs from here: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0-rc7-oneiric/
# Looks like this kernel was released yesterday, you might try it: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.1-oneiric/
sudo apt-get remove fglrx
sudo dpkg -i ~/Downloads/linux-headers-3.0.0-0300rc7_3.0.0-0300rc7.201107120911_all.deb
sudo dpkg -i ~/Downloads/linux-headers-3.0.0-0300rc7-generic_3.0.0-0300rc7.201107120911_i386.deb
sudo dpkg -i ~/Downloads/linux-image-3.0.0-0300rc7-generic_3.0.0-0300rc7.201107120911_i386.deb
sudo reboot

During the installation I got a variety of errors as the the installer tried to recompile various modules with the v3 kernel. These failing modules included virtualbox and fglrx. There were two others I can't remember.

I still see fglrx in my pagkage list (version 2:8.840-0ubuntu4), I don't know how that happened. When I tried to boot into kernel-3 with fglrx installed, I kept getting a flashing black screen until I hard-rebooted into kernel 2.6 and removed it.

Stephan Diestelhorst (syon) wrote :

You cannot install from the mainline-ppa through the existing PPA mechanisms, you are not doing anything wrong. (See the Wiki site in my previous post with the official instructions.)

Secondly, the "-rc" versions are older than the same version numbers without "-rc". So the most recent stable version is always one without "-rc".

Finally, for fglrx install errors on newer kernels: Use fglrx >=11.7, it has support for Linux 3.0.0. (From www.amd.com)

Stephan Diestelhorst (syon) wrote :

Since #769812 is a duplicate... with PPAs for kernel 3.1 from the mainline-ppa, I seem to be hit more frequently by sudden system hangs (as in #769812), which were really rare before. Not obviously related to wireless, though.

I have also done a little "disk whacker" script:

while true; do for i in $(seq 1 10; do dd if=/dev/zero of=zeroes${i} bs=65536 count=16 oflag=direct&; done; wait; done

But that didn't affect suspend-to-ram performance, as was speculated in #769812.

It affects me too!!! I have over a year wanted to install ubuntu

Martin Spacek (mspacek) wrote :

Another me too. Seeing this on 11.04 with stock kernel on a Thinkpad X120e. Wireless works fine, but the machine freezes every few hours or so.

Darian Ryder (lifusion) wrote :

Same here 02:02.0 Network controller: Ralink corp. RT2561/RT61 802.11g PC on 11.10 3.0.0-16-generic #29-Ubuntu SMP Tue Feb 14 12:48:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Freezes without prior notice. Sometimes freezes immediately. Sometimes mouse is still working, keyboard does not. System Monitor runs for a few seconds and then stops. Occurs also every time when operating my kitchen microwave for more than 60 seconds. Have a PCMCIA 8192 (edmiax) on a laptop, save 11.10 but 32bit which does not freeze, and a nearby windows machine with the same PCI card which does not freeze either. Seems to relate to the 64bit-ness.

William Haddon, thank you for reporting this bug and helping make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please capture the oops following https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Capturing_OOPs ? As well, can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Jeffery von Ronne (vonronne) wrote :

As an additional data point:

My x120e used to crash when I used the standard realtex drivers in Natty kernels (and also IIRC, with the standard Oneiric kernels). After upgrading the kernel (to 3.0 if I remember correctly) and switching to the driver from the Realtek web site (0005.1230.2011)--I believe both upgrades were required--I was able to eliminate the system crashing. I am now running 3.2.0-15.24 kernel with the driver's from the Realtek web site, and my machine hasn't crashed for some time.

Unfortunately, however, the machine still drops the wireless connections frequently on certain wireless networks (usually ones with multiple access points and enterprise level security).

Dmitry Ershov (edvice) wrote :

No more freezes in Ubuntu 11.10 and 12.04 with 3.0 and 3.2 kernels. Fixed?

Dmitry Ershov, please do not post attachments to this report. If you are having a problem in Ubuntu, please execute the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

Easynote (pcousin) wrote :

I had this screen freeze on my Notebook Packard Bell ENLK11BZAMD E-300 APU with Radeon(tm) HD Graphics with Ubuntu 11.10 kernel 3,0,0,0-20.
I have installed Realtek rtl_92ce_92se_92de_linux_mac80211_0005.1230.2011 published 02/01/2012 to drive the 8192C/8188C 802.11n PCI wireless embelled.
The screen freeze each time within 10 min while accessing browser or so.
After many seaches, I found current discussion on http://forum.ubuntu-fr.org/viewtopic.php?id=814111 (french). Solution was to declare network first on bios boot sequence.
And so it works from this time.

Easynote, if you are having a problem in Ubuntu, please execute the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

Easynote (pcousin) on 2012-06-18
Changed in linux (Ubuntu):
status: Incomplete → Fix Committed

Easynote, please do not toggle this report. If you are having a problem in Ubuntu, please follow the instructions already posted to you in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/749871/comments/34 .

Changed in linux (Ubuntu):
status: Fix Committed → Incomplete
Easynote (pcousin) wrote :

I have changed bug status to "Fix Committed" because I never have any more freeze for 30 h of work with my computer since I have modified bios sequence as mentionned in my first message (declare network first on bios boot sequence).
I upgrated today with kernel 3.0.0.0-21 without any trouble. And lan throughput never fall.
But thanks to apologize if this change worried.

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers