Comment 8 for bug 740893

Gary Liddle (gary-liddle) wrote :

Hey

I have the same laptop and have the same problem when i updated the Kernel.

I've been running 2.6.35.22 which has no problems.

I initially updated to 2.6.38-8 which i thought at first had failed, but noticed the screen was only usable (and i use that word very lightly) in direct sunlight.

I've now updated to 2.6.38-10 which has the same problem as 2.6.38-8, no back light on the monitor.

I'm currently viewing the laptop on 2.6.38-10 through an external monitor so i can try to resolve the problem and can run any diagnostic commands you require.

My onboard graphics card is the same and as follows with [sudo lshw -c display]

*-display:0
       description: VGA compatible controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:46 memory:d0000000-d03fffff memory:c0000000-cfffffff ioport:50f0(size=8)
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:d3400000-d34fffff

Thanks,
Gary