Ubuntu

WiFi not working (Broadcom BCM4311 )

Reported by chaghaboo on 2011-03-09
130
This bug affects 26 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

After installing Natty from scratch I also installed Broadcom STA driver offered through Additional drivers but WiFi is not working. Network manager is not showing any wifi networks, and wifi light on my laptop is off. I tried to repeat procedure (stop/start Broadcome STA driver) but nothing happens. Tried also WiFi switch on laptop but still nothing. WiFi was working just fine on previous Ubuntu versions just after installing additional driver.

Natty Alpha3, Broadcom BCM4311.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: firefox 4.0~b12+build1+nobinonly-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Wed Mar 9 15:56:54 2011
FirefoxPackages:
 firefox 4.0~b12+build1+nobinonly-0ubuntu3
 flashplugin-installer 10.2.152.27ubuntu1
 adobe-flashplugin N/A
 icedtea-plugin 1.0~20110122-0ubuntu1
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox
UpgradeStatus: Upgraded to natty on 2011-03-09 (0 days ago)

chaghaboo (marko.niketic) wrote :
Tom Dison (fretinator) wrote :

I have the same problem on an Aspire 3680. It offered to install the driver, which I did (plugging in ethernet port so it would download driver) and rebooted. No go, lspci shows BCM4311, but nothing with ifconfig -a.

Richard Johnson (nixternal) wrote :

I am experiencing the same issue. One thing I noted though in /var/log/syslog is that it notices my pushes to the external wifi button.

NetworkManager[727]: <info> found WiFi radio killswitch rfkill0 (at /sys/devices/platform/hp-wmi/rfkill/rfkill0) (driver hp-wmi)
NetworkManager[727]: <info> WiFi now disabled by radio killswitch
NetworkManager[727]: <info> WiFi now enabled by radio killswitch

Laptop is a Compaq Presario C300

affects: ubuntu → linux (Ubuntu)
jejbarr (jejbarr) wrote :

When I first installed alpha3 my wifi was working -- though I think I installed the B43 driver since I've had (completely different) issues with the STA driver in the past.

I've recently done a fresh install on the same hardware, B43 install doesn't seem to work, and although "additional drivers" had no problem installing the STA driver and telling me its working, it's definitely not. Just like OP, no wifi, no light.

jejbarr (jejbarr) wrote :

Well, B43 is now working for me again -- I have no explanation as to why it wasn't working before -- just thought I'd give it one more try.

I know many prefer the STA driver, but something is better than nothing -- and in my case have a history of kernel panics using STA on this hardware.

I just removed the STA driver using the "Additional Drivers" gui, then did sudo apt-get install firmware-b43-installer. That was that...

chaghaboo (marko.niketic) wrote :

My guess is that eventually STA driver (the one from Additional drivers) will start working after some update. Most probably Broadcom still didn't provide valid proprietary driver for Ubuntu 11.04 or they did but it still have to pass Ubuntu control before it becomes available. Currently it is installed but is black listed.

Bernd Laser (bernd-laser) wrote :

Well, the fact currently is: users get a driver recommended as only available option to get their wifi working. And it doesn't. My guess is users will blame ubuntu and just remove it. Understandably.

Jeremy Foshee (jeremyfoshee) wrote :

Hi chaghaboo,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
chaghaboo (marko.niketic) wrote :

Hi Jeremy, just have tried but no luck. From terminal I got my kernel version (uname -r) - 2.6.38 - 7 - generic, and following instructions on site you gave me I have downloaded and installed related mainline kernel version - v2.6.38-natty. I have only downloaded and installed one file - linux-image-2.6.38-020638-generic_2.6.38-020638.201103151303_i386.deb, but after finished installation and reboot I couldn't log in as log in screen was a mess. Log in screen was showing funny, I couldn't see anything, just like something is wrong with graphics so I could only recognize mouse cursor I was moving. Now I have reinstalled Ubuntu from scratch as I didn't know how to fix it. I'm just a regular user so probably I don't know how to do this. If there is anything I can do just let me know.

drs305 (drs305) wrote :

Exactly the same experience as #5, on a Lenovo N100 with new Natty ALPHA3, 32-bit installation.

STA driver recognized and installed driver for B4311 but no light and no wireless signals detected.

Removed the STA driver, installed firmware-b43-installer and b43-fwcutter via synaptic. Rebooted and wireless working fine.

sticks (orawas) wrote :

Same here. STA driver not working. Going to install b43 and see if that works.

BTW, I'm on a Dell Inspiron 1501

Marius Vasilescu (vegancorr) wrote :

Here is my syslog with the error when trying "sudo modprobe wl"

Marius Vasilescu (vegancorr) wrote :

The same issue with the latest kernel. I should mentioned that I still have the b43 mod along with wl. b43 works, wl doesn't.

0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
 Subsystem: Dell Wireless 1390 WLAN Mini-Card
 Flags: bus master, fast devsel, latency 0, IRQ 17
 Memory at f9ffc000 (32-bit, non-prefetchable) [size=16K]
 Capabilities: [40] Power Management version 2
 Capabilities: [58] MSI: Enable- Count=1/1 Maskable- 64bit-
 Capabilities: [d0] Express Legacy Endpoint, MSI 00
 Capabilities: [100] Advanced Error Reporting
 Capabilities: [13c] Virtual Channel
 Kernel driver in use: b43-pci-bridge
 Kernel modules: wl, ssb

tags: removed: needs-upstream-testing
Marius Vasilescu (vegancorr) wrote :

@chaghaboo: The nvidia proprietary drived failed when I installed the latest kernel. I chose a previous kernel version from GRUB, removed nvidia driver and the booted with the latest kernel.

BTW, my tests were done on amd64 now (including the latest kernel test), but I had exactly the same issue on i386.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
chaghaboo (marko.niketic) wrote :

@Marius
In my case it is ATI graphics, but also problem was I didn't get GRUB at startup, so I couldn't choose different kernel in order to bypass graphics problems.

Marius Vasilescu (vegancorr) wrote :

Oh, wait, you installed just one deb file. Maybe that's why :) You have to install 3 files.

http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/

linux-headers-2.6.38-999_2.6.38-999.201103291240_all.deb
And for i386 (for amd64 the other 2 instead of those):
linux-headers-2.6.38-999-generic_2.6.38-999.201103291240_i386.deb
linux-image-2.6.38-999-generic_2.6.38-999.201103291240_i386.deb

sudo dpkg -i *.deb

Anyway, I did the test so I don't think it's still necessary to do it too.

chaghaboo (marko.niketic) wrote :

Yes, I installed just one, thought all three are only necessary for specific builds... Thanks for clarification, and it would be great not to do it again as I just tuned my fresh installed system ;)

DrPaulaner (dr-paulaner) wrote :

same here, no wlan with broadcom sta driver, did try to install the firmware, but does not help

Morris Cavestro (fly82) wrote :

I have thi bug on my pc. The broadcom driver don't work.

Anjang (syah) wrote :

For me, sudo apt-get install firmware-b43-installer solve my problem.... Thanx jejjbar.

Rej (boissonr) wrote :

Hello there,

sudo apt-get install firmware-b43-installer command did it for me as well I have a Dell Inspiron 1501 and could not have the WiFi logo lit despite I installed and re installed using additional driver ...

I could not have done it myself, ****** Thanks jejbarr ****** You're a king

I would like to understand though !

Where did you get this command and where does it go to get the firmware and what happen ?

I'm glad it helped, but have no sage wisdom on why it works -- it was
some poster's experience and google that got me to it. This was on a
laptop that was a long term loan after mine died, and I'm no longer
using it. I had just noticed that the STA driver didn't like that
hardware at least one release earlier (kernel panics) and had gotten
used to using B43. The restricted drivers dialogue used to offer to
install/activate B43 **OR** STA. 11.04 stopped offering B43 at some
point during the beta/release cycle, so I had to find another way to
get it when STA still wouldn't work.

Someone else who understands these things better than I do will have
to explain it -- I think it gets the actual proprietary broadcom
firmware from broadcom via wget or such, as opposed to the STA driver
which is open source and independently developed, but I could have
that all wrong. :-)

On Mon, May 23, 2011 at 1:02 AM, Rej <email address hidden> wrote:
> *** This bug is a duplicate of bug 732677 ***
>    https://bugs.launchpad.net/bugs/732677
>
> Hello there,
>
> sudo apt-get install firmware-b43-installer command did it for me as
> well I have a Dell Inspiron 1501 and could not have the WiFi  logo lit
> despite I installed and re installed using additional driver ...
>
> I could not have done it myself,                       ****** Thanks
> jejbarr ****** You're a king
>
> I would like to understand though !
>
> Where did you get this command and where does it go to get the firmware
> and what happen ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers