Ubuntu

black screen on boot on radeon 9200

Reported by Sergey "Shnatsel" Davidoff on 2011-02-26
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
Quantal
Medium
Unassigned

Bug Description

=== RELEASE NOTE TEXT ===

On systems with an ATI Radeon 9200 graphics card the system will boot to a black screen. As a work around edit the kernel command line in the boot loader and add "nomodeset". (Bug:725580)

===
Binary package hint: xserver-xorg-video-ati

Black screen on boot on radeon 9200, "nomodeset" option fixes it. Info from ubuntu-bug (booted without modesetting) and GPU info from lshw are attached.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-radeon 1:6.14.0-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
Architecture: i386
Date: Sat Feb 26 14:39:39 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GdmLog1:

GdmLog2:

GraphicsCard:
 ATI Technologies Inc RV280 [Radeon 9200] [1002:5962] (rev 01) (prog-if 00 [VGA controller])
   Subsystem: PC Partner Limited Device [174b:0192]
   Subsystem: PC Partner Limited Device [174b:0193]
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110226)
ProcEnviron:
 LANGUAGE=ru_RU:en
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz -- acpi=off nodmraid nomodeset debian-installer/language=ru console-setup/layoutcode?=ru
SourcePackage: xserver-xorg-video-ati
dmi.bios.date: 08/30/2005
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: 760GXK8MC
dmi.board.vendor: WinFast
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd08/30/2005:svn:pn:pvr:rvnWinFast:rn760GXK8MC:rvr:cvn:ct3:cvr:
version.compiz: compiz 1:0.9.4-0ubuntu1
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1~git20110215.cc1636b6-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu8
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu11
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5

bugbot (bugbot) on 2011-02-27
tags: added: black-screen
tags: added: radeon xorg
Bryce Harrington (bryce) wrote :

Hi Sergey "Shnatsel" Davidoff,
radeontool can be used to assist in debugging this issue. To install it from the command line, use this command:

    sudo apt-get install radeontool

After installing it, you run it like this:

    radeontool regmatch '*' > regdump_good.txt
    radeontool regmatch '*' > regdump_broke.txt

Run it two times. Once when you have a working screen (for any driver), and once in the broken case (either from the tty console or logged into the sick box remotely). Attach both of those to this bug report, and we can then forward this issue upstream. Thanks ahead of time!

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Incomplete

Radeontool is preinstalled in the current daily build. Here's the "good" dump from radeon driver with "nomodeset" option. However, I can't obtain the "broken" one now because I can run the system only as LiveCD on that PC so I can't set up ssh, and switching to ttys doesn't work because the display is screwed on the kernel level. I'll try to install ssh-server on LiveUSB and boot from there; however, it will take time.

Sorry, I can't ssh into the affected machine because it doesn't seem to have networking up when trying to use kernel modesetting. I get "host unreachable" error.

Is there any chance that the bug will be fixed without that dump?

I forgot to add that I have successfully ssh'ed to that machine when kernel modesetting was turned off.

Bryce Harrington (bryce) wrote :

No, unfortunately in order to troubleshoot this bug we need to have logs and register dumps from when the system is frozen.
(I guess it is possible the bug will get independently fixed elsewhere, but this bug report is not actionable itself without this info.)

If you haven't already, you could try connecting via ethernet or setting your wireless to share across all users. There are some other tips for debugging these kinds of issues here:

https://wiki.ubuntu.com/X/Troubleshooting/BlankScreen#Analysis%20Techniques
https://wiki.ubuntu.com/X/NonGraphicalBoot

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → New
status: New → Incomplete

Thanks, I'll try to invent something. Maybe I'll add the dump command as an Upstart job.

Bryce Harrington (bryce) on 2011-03-04
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → New
status: New → Incomplete

I'm afraid the "broken" dump is unobtainable because the kernel itself hangs when modesetting enabled (at least it doesn't respond to any SysRq combinations when booting to text mode). I'm gathering all other info I can get.

Robert Hooker (sarvatt) wrote :

Can you please create an /etc/X11/xorg.conf with these contents and see if it works around the problem?

Section "Device"
        Identifier "Default Device"
        Driver "radeon"
        Option "EnablePageFlip" "False"
EndSection

Robert,

I tried it but nothing changed. Also, as I said earlier, the kernel seems to hang before X is started, that's why I can't boot even in text mode. Maybe there's a way to disable pageflipping from a kernel parameter or something like that?

Bryce Harrington (bryce) wrote :

Seems pretty clear at this point it's a bug in the kernel's radeon drm driver rather than the X driver.

Maybe try removing vesafb from the kernel, or try apw's purple ppa, which has a proposed fix for the vesafb conflict.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed

Thanks to Ubiquity fixes that landed today, I've installed the complete OS on a USB flash disk, but it did some really weird things; "nomodeset" option didn't fix the installed system, though it did fix the LiveCD boot. The problem is in GDM now; even with nomodeset option I get Compiz crashes (bug #725569), nux crash (bug #725570), and now GDM is not working too!

And when I tried to install stuff from apw's purple PPA, I got "read-only filesystem" dpkg-configure error. Now when I boot the system, fsck fixes a number of errors which seem to be the same every time and reboots the system.

Bryce Harrington (bryce) wrote :

Alright, well black screen on boot issues that occur with kernel modesetting but not userspace modesetting are kernel bugs. Too a more actionable set of logs weren't collectable, else I could have at least forwarded it upstream.

But now it sounds like a lot worse problems are at play, but they're earlier on / deeper down than X anyway.

affects: xserver-xorg-video-ati (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → New
tags: added: kernel-bug

This issue is not present in packages from xorg-edgers ppa.

tags: added: regression regression-release

Or wait, looks like it's still present... I have probably booted with nomodeset that time.

tags: added: iso-testing
Brad Figg (brad-figg) on 2011-04-07
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium

I hear that kernel modesetting is dependent on ACPI, I tried to boot without "acpi=off" parameter that's listed in the bug description but it's all the same. ACPI seems to be enabled in BIOS.

seuffert (oliver-seuffert) wrote :

same problem here (Acer Laptop, Radeon Mobility 9200), 11.04 Beta2
starting with "nomodeset acpi=off" works. otherwise just a black screen during kernel start and system freeze.
also having this issue when starting the alternate installer CD

Adding Ubuntu Release Notes because similar issues with Intel drivers were documented in release notes in Lucid and Maverick.

Sam Smith (sam-smith-gmx) wrote :

Great, latest kernel (2.6.38.10) solved this problem for me!

Sam, where did you get it? I can see only 2.6.38.8.22 in Natty repos :(

And 2.6.39-3.10 in xorg-edgers ppa.

Doesn't work for me - hangs up even earlier than it used to. However, it might be a different bug. Too bad it doesn't support my keyboard at boot time.

Joseph Salisbury (jsalisbury) wrote :

Is this still an issue? Comment #24 suggests this may be resolved?

Still screwed in Oneiric release.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the release candidate kernel versus the daily build. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: needs-upstream-testing

Boots with "acpi=off nomodeset", though.

tags: added: oneiric
removed: needs-upstream-testing

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20

Yes, dear bot, it still happens in Oneiric release.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Triaged

Same issues in 3.1 rc10
without nomodeset, regardless of "acpi=off", it hangs when spins up the CD (I had plop boot in the drive this time).

tags: removed: xorg
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

sge (shazmosushi) wrote :

Hi, I just thought I'd chime in. I use an ATI Radeon Mobility 9200. I get a blank screen (with cursor present) on 11.10 live CD. I've been running an older version of Ubuntu and subsequently updated and IIRC had no problems.

Anyway, the newly released (early-December 2011) Alpha 1 version of 12.04 Precise Pangolin (tested Xubuntu and Lubuntu) do not have this problem, where as the 11.10 versions (tested Ubuntu, Xubuntu and Lubuntu) do have the problem.

The users who encounter this issue may want to test the 12.04 Alpha versions - the problem may be fixed upstream now.

Andy Whitcroft (apw) on 2012-04-26
Changed in ubuntu-release-notes:
status: New → In Progress
assignee: nobody → Andy Whitcroft (apw)
Andy Whitcroft (apw) on 2012-04-26
description: updated
Andy Whitcroft (apw) on 2012-04-26
Changed in ubuntu-release-notes:
assignee: Andy Whitcroft (apw) → nobody
status: In Progress → Fix Committed
Andy Whitcroft (apw) on 2012-04-26
Changed in ubuntu-release-notes:
status: Fix Committed → Fix Released
Kate Stewart (kate.stewart) wrote :

Update state so this gets considered for precise, state was ambiguous.

Changed in linux (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
milestone: none → precise-updates
Changed in linux (Ubuntu Quantal):
milestone: none → ubuntu-12.10
madbiologist (me-again) on 2012-06-10
tags: removed: kernel-request-3.0.0-12.20
madbiologist (me-again) wrote :

Is this still occurring on Ubuntu 12.10 "Quantal Quetzal" alpha 1? The following patch was queued up for inclusion in the 3.4 kernel:

http://lists.freedesktop.org/archives/dri-devel/2012-March/020070.html

If it is still occurring on Ubuntu 12.10 "Quantal Quetzal" alpha 1, does changing the video aperture setting in the BIOS from 128MB to 256MB help?

tags: added: precise quantal
Changed in linux (Ubuntu Quantal):
milestone: ubuntu-12.10 → ubuntu-12.10-beta-1
Kate Stewart (kate.stewart) wrote :

Is this actively being worked on by anyone, or do we need to make it explicit its not getting fixed in quantal?

Changed in linux (Ubuntu Quantal):
milestone: ubuntu-12.10-beta-1 → ubuntu-12.10-beta-2
madbiologist (me-again) wrote :

I should have marked the Quantal task as Incomplete in June.

Changed in linux (Ubuntu Quantal):
status: Triaged → Incomplete
Joseph Salisbury (jsalisbury) wrote :

Has anyone affected by this bug had a chance to test Quantal? As @madbiologist posted, the fix for this bug should be in the following commit:

c4353016dac10133fa5d8535af83f0c4845a2915 drm/radeon: Restrict offset for legacy hardware cursor.

globalkeith (keithsalisbury) wrote :

Just installed Quantal (*quantal-desktop-amd64.iso md5 7ad57cadae955bd04019389d4b9c1dcb) and yes I am experiencing this problem.

I dont understand this "As a work around edit the kernel command line in the boot loader and add "nomodeset". "

Can anyone explain in a touch more detail what file should be edited and how.

thanks

madbiologist (me-again) on 2012-10-23
Changed in linux (Ubuntu Quantal):
status: Incomplete → Confirmed
To post a comment you must log in.