Comment 27 for bug 721896

User Unknown (user-unknown) wrote :

Thanks @Follow-Me and @Anthony, the hint with the kernel update really seems to work. :-) I didn't know this was even possible in such an easy manner with an active 10.04 installation.

Inspired by Anthony's descriptions, I found out yesterday that even the Lucid-Updates repository[1] features 2.6.38-10-generic (even if this newer kernel is available, it won't get offered automatically to install by normal updates, it needs to be selected explicitly – or maybe 'dist-upgrade' would do, I didn't try that). So, for me, no PPA for the kernel was necessary.

I installed the following packages:

linux-headers-2.6.38-10 (2.6.38-10.46~lucid1)
linux-headers-2.6.38-10-generic (2.6.38-10.46~lucid1)
linux-image-2.6.38-10-generic (2.6.38-10.46~lucid1)

After installation and reboot into the new linux-image, I, too, had to fiddle around with my graphics drivers (NVidia) as the nvidia-current package wouldn't compile against 2.6.38. I had to add Ubuntu-X team's 'X Updates' PPA[2],[3], which provides version 275.19 of the NVidia drivers, to solve this problem for me.

To anyone else trying this: You might wanna add this PPA and upgrade your NVidia drivers *before* you boot with the linux-image-2.6.38. That might already compile the NVidia driver against 2.6.38, which could save you some low-res pain-in-the-eye after booting with 2.6.38. :-)

Anyway, everything runs fine so far. My usual suspects applications have been running ever since yesterday, I hibernated/resumed over night, and even did a test run of two VirtualBox VMs running at the same time. With the two VMs the system sure got a bit laggy from time to time, but it was usable all the time. IO Wait load occurred only for a few seconds every once in a while, with kswapd0 showing up as idle process every now and then (top -i) but disappearing shortly after and without any hassle.

Also, fullscreen flash video still works, so do fullscreen 3D games and, of course, my compiz effects. So, the NVidia driver appears to be fine. Also everything else, all other application I run thus far, worked as expected (I hope I won't hit rock buttom at some point, though...).

If everything should continue to run as it did ever since yesterday, this issue would finally be solved for me. :-) Oh, what a treat! Thank you again, guys!!

I hope this might help others affected.

Regards,
uu

[1]: [in Synaptic: menu 'Settings' ›] Software Sources › tab 'Updates' › check 'Recommended updates (lucid-updates)' and reload package index
[2]: https://launchpad.net/~ubuntu-x-swat/+archive/x-updates
[3]: Thanks go to 'BicyclerBoy' who suggested this PPA here: http://ubuntuforums.org/showthread.php?t=1691764