Ubuntu

[vostro 130] Dell Wireless 1702 dual wifi/bluetooth: bluetooth not detected

Reported by Mathieu Trudel-Lapierre on 2011-02-17
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
AceLan Kao
Natty
High
AceLan Kao
linux-ti-omap4 (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

On a Dell Vostro V130: seems like the Dell Wireless 1702 device, which is in fact an Atheros AR9285, does not load the necessary kernel bits for bluetooth coexistance. My uneducated guess says it's because the subsystem ID for the device is not in the list of valid subsys ids for bluetooth coex.

$ cat subsystem_device subsystem_vendor
0x0205
0x1028

Note sure what else to add here, but basing my research on the documentation on http://wireless.kernel.org/en/users/Drivers/ath9k/btcoex and code in http://git.kernel.org/?p=linux/kernel/git/mcgrof/atheros-next-2.6.git

ProblemType: Bug
DistroRelease: Ubuntu 11.01
Package: linux-image-2.6.38-3-generic 2.6.38-3.30
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Uname: Linux 2.6.38-3-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mtrudel 1959 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe500000 irq 47'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:111d7605,1028049c,00100105 HDA:80862804,80860101,00100000'
   Controls : 18
   Simple ctrls : 10
Date: Thu Feb 17 15:33:14 2011
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=b7ea33e4-59e3-4a3b-b91f-3c78757b0fd0
MachineType: Dell Inc. Vostro V130
ProcEnviron:
 LANGUAGE=fr_CA:fr_CA.UTF-8:fr:en_GB:en
 PATH=(custom, user)
 LANG=fr_CA.UTF-8
 LC_MESSAGES=fr_CA.UTF-8
 SHELL=/bin/zsh
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-3-generic root=UUID=8336ba63-9921-4049-af4d-5ffe1c22aaa4 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-3-generic N/A
 linux-backports-modules-2.6.38-3-generic N/A
 linux-firmware 1.47
SourcePackage: linux
dmi.bios.date: 12/13/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.name: 0GD7D0
dmi.board.vendor: Dell Inc.
dmi.board.version: A03
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A03
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd12/13/2010:svnDellInc.:pnVostroV130:pvrA03:rvnDellInc.:rn0GD7D0:rvrA03:cvnDellInc.:ct8:cvrA03:
dmi.product.name: Vostro V130
dmi.product.version: A03
dmi.sys.vendor: Dell Inc.

FWIW, I tried to manually start btcoex by removing the ath9k driver and starting it again with "modprobe ath9k btcoex_enable=1" but without success.

Jeremy Foshee (jeremyfoshee) wrote :

Hi Mathieu,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
tags: removed: running-unity

Tested with the mainline kernel 2.6.38-rc6 (linux-image-2.6.38-020638rc6-generic_2.6.38-020638rc6.201102220910_amd64.deb), but it's still not working.

tags: removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Herton R. Krzesinski (herton) wrote :

I think this is related to ath3k, not ath9k btcoex.

The bluetooth device should be this from attached lsusb:
Bus 002 Device 005: ID 0cf3:3002 Atheros Communications, Inc.

Which is currently handled by ath3k module.

But on provided CurrentDmesg we have this error:
[ 33.195005] ath3k_load_firmware: Can't change to loading configuration err
[ 33.195073] ath3k: probe of 2-1.5:1.0 failed with error -5

For some reason it was unable to load the firmware into the device, and so bluetooth fails.

I found a bug report opened upstream that looks like the same problem (https://bugzilla.kernel.org/show_bug.cgi?id=27402), which suggests that this is currently fixed with latest Linus tree. I found it suspicious, but there were changes to bluetooth subsystem post 2.6.38-rc6 which may have fixed it.

When rc7 comes out or next natty kernel is available (already rebased to commit cited at upstream bug), is good to test again, otherwise we have another problem here.

Chris Van Hoof (vanhoof) on 2011-03-24
tags: added: hwe-blocker
AceLan Kao (acelankao) wrote :

% cat /proc/version_signature
Ubuntu 2.6.38-7.38-generic 2.6.38

Still not works.

Chris Van Hoof (vanhoof) on 2011-04-04
Changed in linux (Ubuntu):
assignee: nobody → AceLan Kao (acelankao)
importance: Undecided → High
Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Natty):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.38-8.42

---------------
linux (2.6.38-8.42) natty; urgency=low

  [ David Henningsson ]

  * SAUCE: (drop after 2.6.38) ALSA: HDA: Fix dock mic for Lenovo
    X220-tablet
    - LP: #751033

  [ Gustavo F. Padovan ]

  * SAUCE: Revert "Bluetooth: Add new PID for Atheros 3011"
    - LP: #720949

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: (drop after 2.6.39) v4l: make sure drivers supply a zeroed
    struct v4l2_subdev
    - LP: #745213

  [ John Johansen ]

  * AppArmor: Fix masking of capabilities in complain mode
    - LP: #748656

  [ Leann Ogasawara ]

  * [Config] Disable CONFIG_RTS_PSTOR for armel, powerpc

  [ Manoj Iyer ]

  * SAUCE: (drop after 2.6.38) add support for Lenovo tablet ID (0xE6)
    - LP: #746652

  [ Steve Langasek ]

  * [Config] Make linux-libc-dev coinstallable under multiarch
    - LP: #750585

  [ Tim Gardner ]

  * [Config] CONFIG_RTS_PSTOR=m
    - LP: #698006

  [ Upstream Kernel Changes ]

  * Revert "tcp: disallow bind() to reuse addr/port"
    - LP: #731878
  * ALSA: HDA: Add dock mic quirk for Lenovo Thinkpad X220
    - LP: #746259
  * ALSA: HDA: New AD1984A model for Dell Precision R5500
    - LP: #741516
  * Input: sparse-keymap - report scancodes with key events
  * Input: sparse-keymap - report KEY_UNKNOWN for unknown scan codes
  * KVM: SVM: Load %gs earlier if CONFIG_X86_32_LAZY_GS=n
    - LP: #729085
  * watchdog: sp5100_tco.c: Check if firmware has set correct value in
    tcobase.
    - LP: #740011
  * staging: add rts_pstor for Realtek PCIE cardreader
    - LP: #698006
  * staging: fix rts_pstor build errors
    - LP: #698006
  * Staging: rts_pstor: fixed some brace code styling issues
    - LP: #698006
  * staging: rts_pstor: potential NULL dereference
    - LP: #698006
  * Staging: rts_pstor: fix read past end of buffer
    - LP: #698006
  * staging: rts_pstor: delete a function
    - LP: #698006
  * staging: rts_pstor: fix sparse warning
    - LP: #698006
  * staging: rts_pstor: fix a bug that a greenhouse sd card can't be
    recognized
    - LP: #698006
  * staging: rts_pstor: optimize kmalloc to kzalloc
    - LP: #698006
  * staging: rts_pstor: MSXC card power class
    - LP: #698006
  * staging: rts_pstor: modify initial card clock
    - LP: #698006
  * staging: rts_pstor: set lun_mode in a different place
    - LP: #698006
  * x86, hibernate: Initialize mmu_cr4_features during boot
    - LP: #752870
 -- Leann Ogasawara <email address hidden> Fri, 08 Apr 2011 09:24:59 -0700

Changed in linux (Ubuntu Natty):
status: Fix Committed → Fix Released

I think there's been a misunderstanding, this is not fixed, bluetooth remains disabled in gnome-bluetooth, devices don't appear in hcitool.

I've been able to make this work only by installing the DKMS driver package from bug 714862.

Changed in linux (Ubuntu Natty):
status: Fix Released → Confirmed
summary: - Dell Wireless 1702 dual wifi/bluetooth: bluetooth not detected
+ [vostro 130] Dell Wireless 1702 dual wifi/bluetooth: bluetooth not
+ detected
AceLan Kao (acelankao) wrote :

Mathieu,

Yes, this problem still exists, I'm still working on it when I available.
You can use that dkms package before we have find out a solution.

Launchpad Janitor (janitor) wrote :
Download full text (38.0 KiB)

This bug was fixed in the package linux-ti-omap4 - 2.6.38-1209.15

---------------
linux-ti-omap4 (2.6.38-1209.15) natty-proposed; urgency=low

  * Release tracking bug
    - LP: #837761

  [ Paolo Pisati ]

  * [Config] Turn on CONFIG_USER_NS and DEVPTS_MULTIPLE_INSTANCES.
    - LP: #787749

  [ Tim Gardner ]

  * [Config] Add enic/fnic to nic-modules udeb, CVE-2011-1020
    - LP: #801610

  [ Upstream Kernel Changes ]

  * mpt2sas: prevent heap overflows and unchecked reads
    - LP: #780546
  * agp: fix arbitrary kernel memory writes
    - LP: #775809
  * can: add missing socket check in can/raw release
    - LP: #780546
  * agp: fix OOM and buffer overflow
    - LP: #775809
  * bonding: Incorrect TX queue offset, CVE-2011-1581
    - LP: #792312
    - CVE-2011-1581
  * fs/partitions/efi.c: corrupted GUID partition tables can cause kernel
    oops
    - LP: #795418
    - CVE-2011-1577
  * can: Add missing socket check in can/bcm release.
    - LP: #796502
    - CVE-2011-1598
  * USB: ehci: remove structure packing from ehci_def
    - LP: #791552
  * taskstats: don't allow duplicate entries in listener mode,
    CVE-2011-2484
    - LP: #806390
    - CVE-2011-2484
  * ext4: init timer earlier to avoid a kernel panic in __save_error_info,
    CVE-2011-2493
    - LP: #806929
    - CVE-2011-2493
  * dccp: handle invalid feature options length, CVE-2011-1770
    - LP: #806375
    - CVE-2011-1770
  * pagemap: close races with suid execve, CVE-2011-1020
    - LP: #813026
    - CVE-2011-1020
  * report errors in /proc/*/*map* sanely, CVE-2011-1020
    - LP: #813026
    - CVE-2011-1020
  * close race in /proc/*/environ, CVE-2011-1020
    - LP: #813026
    - CVE-2011-1020
  * auxv: require the target to be tracable (or yourself), CVE-2011-1020
    - LP: #813026
    - CVE-2011-1020
  * deal with races in /proc/*/{syscall, stack, personality}, CVE-2011-1020
    - LP: #813026
    - CVE-2011-1020
  * rose: Add length checks to CALL_REQUEST parsing, CVE-2011-1493
    - LP: #816550
    - CVE-2011-1493
  * GFS2: make sure fallocate bytes is a multiple of blksize, CVE-2011-2689
    - LP: #819572
    - CVE-2011-2689
  * Bluetooth: l2cap and rfcomm: fix 1 byte infoleak to userspace.
    - LP: #819569
    - CVE-2011-2492
  * Add mount option to check uid of device being mounted = expect uid,
    CVE-2011-1833
    - LP: #732628
    - CVE-2011-1833
  * ipv6: make fragment identifications less predictable, CVE-2011-2699
    - LP: #827685
    - CVE-2011-2699
  * perf: Fix software event overflow, CVE-2011-2918
    - LP: #834121
    - CVE-2011-2918
  * proc: fix oops on invalid /proc/<pid>/maps access, CVE-2011-1020
    - LP: #813026
    - CVE-2011-1020

linux-ti-omap4 (2.6.38-1209.13) natty; urgency=low

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #772381

  [ Brad Figg ]

  * Ubuntu-2.6.38-9.43

  [ Bryan Wu ]

  * merge Ubuntu-2.6.38-9.43
  * cherry-pick 6 patches from u2 of 'for-ubuntu' branch
  * [Config] Sync up configs for 2.6.38.4

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: Revert "x86, hibernate: Initialize mmu_cr4_features during boot"
    - LP: #764758

  [ Leann Ogasawara ]

  * [Config] updateconfigs for 2.6.38.4

  [ Paolo Pisati ]

  * [Conf...

Changed in linux-ti-omap4 (Ubuntu Natty):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-ti-omap4 (Ubuntu):
status: New → Confirmed
Chris Van Hoof (vanhoof) on 2011-12-06
tags: added: blocks-hwcert-enablement
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.