Ubuntu

[Realtek ALC892] Recording problem

Reported by Kjell L. on 2011-02-13
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)

Mic does not work on Maverick.

Fix:
Add "options snd-hda-intel position_fix=1 enable=yes" to the file
/etc/modprobe.d/alsa-base.conf

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: alsa-base 1.0.23+dfsg-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-25.44-generic 2.6.35.10
Uname: Linux 2.6.35-25-generic x86_64
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC892 Analog [ALC892 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: kl 1581 F.... pulseaudio
 /dev/snd/pcmC0D0p: kl 1581 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfe4f8000 irq 16'
   Mixer name : 'Realtek ALC892'
   Components : 'HDA:10ec0892,104383c0,00100302'
   Controls : 32
   Simple ctrls : 18
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xfe5bc000 irq 46'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Sun Feb 13 22:17:54 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SelectedCard: 0 SB HDA-Intel - HDA ATI SB
SourcePackage: alsa-driver
Symptom: audio
Title: [Realtek ALC892] Recording problem
dmi.bios.date: 03/08/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1005
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M4A89GTD-PRO/USB3
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1005:bd03/08/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM4A89GTD-PRO/USB3:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Kjell L. (lkjell) wrote :
David Henningsson (diwic) wrote :

Hi Kjell and thanks for your bug report!

There have been a few changes upstream since Maverick, would it be possible for you to test the latest snapshot and see if position_fix=1 is still needed on the daily snapshot: https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules

Thanks!

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Kjell L. (lkjell) wrote :

You still need the position_fix=1

Changed in alsa-driver (Ubuntu):
status: Incomplete → New
David Henningsson (diwic) wrote :

Thanks. I've sent a patch to upstream and stable, so that it'll work out of the box in Natty and hopefully in Maverick as well, although that make take some time depending on the stable maintainers.

Changed in alsa-driver (Ubuntu):
status: New → In Progress
David Henningsson (diwic) wrote :

Upstream accepted patch.

Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
Andy Whitcroft (apw) wrote :

linux (2.6.38-5.32) natty; urgency=low

  [ Andy Whitcroft ]

  * rebase to mainline 6f576d57f1fa0d6026b495d8746d56d949989161
  * [Config] updateconfigs following rebase to v2.6.38-rc6
  * [Config] enable CONFIG_DMAR
    - LP: #552311

  [ Upstream Kernel Changes ]

  * drm/i915: skip FDI & PCH enabling for DP_A
    - LP: #561802, #600453, #681877

  [ Major Kernel Changes ]

  * rebase from v2.6.38-rc5 to v2.6.38-rc6
    - LP: #718402
    - LP: #719524
    - LP: #721126
    - LP: #719691
    - LP: #722689
    - LP: #722310
 -- Andy Whitcroft <email address hidden> Tue, 22 Feb 2011 13:28:39 +0000

Changed in alsa-driver (Ubuntu):
status: Fix Committed → Fix Released

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu Lucid):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted linux-ec2 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-lucid
Kjell L. (lkjell) wrote :

Make one for maverick and I am gladly to test it. Do not have a spare partition to install lucid on.

Kjell L. (lkjell) wrote :

Verified failure on maverick with linux-ec2 package

Steve Conklin (sconklin) wrote :

This patch came in through an upstream stable update, and therefore will be accepted whether is actually solves this bug or not. I'm therefore setting verification tags to complete to indicate this.

tags: added: verification-done-lucid
removed: verification-needed-lucid

Accepted linux-ec2 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted linux into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Launchpad Janitor (janitor) wrote :
Download full text (7.2 KiB)

This bug was fixed in the package linux - 2.6.32-31.61

---------------
linux (2.6.32-31.61) lucid-proposed; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #754842

  [ Upstream Kernel Changes ]

  * x86, quirk: Fix SB600 revision check
    - LP: #742056

linux (2.6.32-31.60) lucid-proposed; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #734950

  [ Paolo Pisati ]

  * SAUCE: Clear new_profile in error path
    - LP: #732700

  [ Tim Gardner ]

  * [Config] CONFIG_BOOT_PRINTK_DELAY=y
    - LP: #733191

  [ Upstream Kernel Changes ]

  * Revert "drm/radeon/bo: add some fallback placements for VRAM only
    objects."
    - LP: #652934
  * drm/radeon: fall back to GTT if bo creation/validation in VRAM fails.
    - LP: #652934
  * drm/radeon/kms: Fix retrying ttm_bo_init() after it failed once.
    - LP: #652934
  * xfs: always use iget in bulkstat
    - LP: #692848
  * drm/radeon/kms: make the mac rv630 quirk generic
    - LP: #728687
  * drm/radeon/kms: add pll debugging output
    - LP: #728687
  * drm/radeon: remove 0x4243 pci id
    - LP: #728687
  * drm/radeon/kms: fix s/r issues with bios scratch regs
    - LP: #728687
  * drm/i915/lvds: Add AOpen i915GMm-HFS to the list of false-positive LVDS
    - LP: #728687
  * drm/i915: Add dependency on CONFIG_TMPFS
    - LP: #728687
  * Linux 2.6.32.29+drm33.14
    - LP: #728687
  * NFSD: memory corruption due to writing beyond the stat array
    - LP: #728687
  * mptfusion: mptctl_release is required in mptctl.c
    - LP: #728687
  * mptfusion: Fix Incorrect return value in mptscsih_dev_reset
    - LP: #728687
  * ocfs2_connection_find() returns pointer to bad structure
    - LP: #728687
  * x25: decrement netdev reference counts on unload
    - LP: #728687
  * x86, hpet: Disable per-cpu hpet timer if ARAT is supported
    - LP: #728687
  * OHCI: work around for nVidia shutdown problem
    - LP: #728687
  * x86/pvclock: Zero last_value on resume
    - LP: #728687
  * av7110: check for negative array offset
    - LP: #728687
  * CRED: Fix get_task_cred() and task_state() to not resurrect dead
    credentials
    - LP: #728687
  * bonding/vlan: Avoid mangled NAs on slaves without VLAN tag insertion
    - LP: #728687
  * CRED: Fix kernel panic upon security_file_alloc() failure.
    - LP: #728687
  * CRED: Fix BUG() upon security_cred_alloc_blank() failure
    - LP: #728687
  * CRED: Fix memory and refcount leaks upon security_prepare_creds()
    failure
    - LP: #728687
  * sendfile(): check f_op.splice_write() rather than f_op.sendpage()
    - LP: #728687
  * isdn: hisax: Replace the bogus access to irq stats
    - LP: #728687
  * ixgbe: add support for 82599 based Express Module X520-P2
    - LP: #728687
  * ixgbe: prevent speculative processing of descriptors before ready
    - LP: #728687
  * scsi_dh_alua: add netapp to dev list
    - LP: #728687
  * scsi_dh_alua: Add IBM Power Virtual SCSI ALUA device to dev list
    - LP: #728687
  * dm raid1: fail writes if errors are not handled and log fails
    - LP: #728687
  * GFS2: Fix bmap allocation corner-case bug
    - LP: #728687
  * dm raid1: fix null pointer dereference in suspend
    - LP: #728687
  * sunrpc/...

Read more...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Accepted linux into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-maverick
Brad Figg (brad-figg) wrote :

This patch cam in via upstream as part of the 2.6.38 (natty) development cycle. It does not require verification.

tags: added: verification-done-natty
removed: verification-needed-maverick
Brad Figg (brad-figg) wrote :

This patch came into Maverick via stable upstream release and is not subject to the verification process.

tags: added: verification-done-maverick
removed: verification-done-natty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers