iphone usb internet tethering gives no ip, while bluetooth does

Bug #717914 reported by Andreas Nilsson on 2011-02-12
This bug affects 13 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

Connecting the iphone 4.2.1 device with usb the system fails to get an ip-address. Tethering over bluetooth works just fine.

Both usb and bluetooth tethering used to work on Maverick.

Attached is a tcpdump of all the trafic on the ipheth interface.

$ lsb_release -rd
Description: Ubuntu natty (development branch)
Release: 11.04

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-3-generic 2.6.38-3.30
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Uname: Linux 2.6.38-3-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
 /dev/snd/controlC0: andrnils 1632 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
 Card hw:0 'Intel'/'HDA Intel at 0xf2420000 irq 44'
   Mixer name : 'Conexant CX20585'
   Components : 'HDA:14f15069,17aa218b,00100302'
   Controls : 8
   Simple ctrls : 5
 Card hw:1 'NVidia'/'HDA NVidia at 0xcdefc000 irq 16'
   Mixer name : 'Nvidia GPU 0b HDMI/DP'
   Components : 'HDA:10de000b,10de0101,00100100'
   Controls : 16
   Simple ctrls : 4
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 6MHT43WW-1.18'
   Mixer name : 'ThinkPad EC 6MHT43WW-1.18'
   Components : ''
   Controls : 1
   Simple ctrls : 1
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Sat Feb 12 22:33:29 2011
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=3dec6f16-5685-49c5-a3f3-03999c25bd4d
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110202)
MachineType: LENOVO 43494JG
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-3-generic root=UUID=c2072261-01b1-425c-a0b2-6a557f552c15 ro quiet splash vt.handoff=7
 linux-restricted-modules-2.6.38-3-generic N/A
 linux-backports-modules-2.6.38-3-generic N/A
 linux-firmware 1.47
SourcePackage: linux
dmi.bios.date: 10/26/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6MET81WW (1.41 )
dmi.board.name: 43494JG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6MET81WW(1.41):bd10/26/2010:svnLENOVO:pn43494JG:pvrThinkPadT510:rvnLENOVO:rn43494JG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 43494JG
dmi.product.version: ThinkPad T510
dmi.sys.vendor: LENOVO

Andreas Nilsson (andrnils) wrote :
Changed in linux (Ubuntu):
importance: Undecided → High
Andreas Nilsson (andrnils) wrote :

Problem is present on 2.6.38-4-generic as well.

Andrew Sam (mailandrewsam) wrote :

Any updates on when this will be resolved? Or any patches?

Jiehan Zheng (jiehanzheng) wrote :

Seems that this person fixed the problem:

But is there any easier ways to fix this?

Brad Figg (brad-figg) on 2011-04-06
Changed in linux (Ubuntu):
status: New → Confirmed
taylorc209 (taylorc209) wrote :

problem may be more widespread than just the iphone. Since updating to 11.04 xubuntu I can no longer tether with my n900. Still works fine the wifes laptop....

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Sigmun (sigmun84) wrote :

This is fixed by installing teh last version of ipheth from https://github.com/dgiagio/ipheth

Andreas Nilsson, thank you for reporting this and helping make Ubuntu better. Natty reached EOL on October 2012.
Please see this document for currently supported Ubuntu releases:

We were wondering if this is still an issue in a supported release? If so, could you please plug the USB iphone in, unplug all other USB devices, execute the following at a terminal and post the results to this report:

As well, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the tag:

This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the text:

If this bug is fixed in the mainline kernel, please add the following tags:

where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the following tags:

where VERSION-NUMBER is the version number of the kernel you tested.

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:

where VERSION-NUMBER is the version number of the kernel you tested.

Please let us know your results. Thank you for your understanding.

Helpful Bug Reporting Tips:

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.