Random kernel panic during boot on a Dell Inspiron 1520

Bug #712082 reported by Paolo Sammicheli on 2011-02-02
76
This bug affects 13 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

Binary package hint: casper

While ISO Testing Ubuntu Desktop i386 I got random kernel panic. Because persistence doesn't works I can't attach dmesg when panic. Attaching a screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: casper 1.255
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
Architecture: i386
Date: Wed Feb 2 19:48:50 2011
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
ProcEnviron:
 LANGUAGE=it_IT.UTF-8:it:en_GB:en
 LANG=it_IT.UTF-8
 LC_MESSAGES=it_IT.utf8
 SHELL=/bin/bash
SourcePackage: casper
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AlsaVersion_: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', '/dev/snd/controlC0', '/dev/snd/hwC0D0', '/dev/snd/hwC0D1', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/pcmC0D1p', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code -11:
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfebfc000 irq 45'
   Mixer name : 'SigmaTel STAC9205'
   Components : 'HDA:838476a0,102801f1,00100204 HDA:14f12c06,14f1000f,00100000'
   Controls : 18
   Simple ctrls : 11
DistroRelease: Ubuntu 11.04
Frequency: Once a day.
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
LiveMediaBuild_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
MachineType: Dell Inc. Inspiron 1520
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=it_IT.UTF-8:it:en_GB:en
 LANG=it_IT.UTF-8
 LC_MESSAGES=it_IT.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcKernelCmdLine_: BOOT_IMAGE=/casper/vmlinuz noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
ProcVersionSignature_: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Regression: Yes
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-1-generic N/A
 linux-backports-modules-2.6.38-1-generic N/A
 linux-firmware 1.46
Reproducible: No
Tags: natty kernel-config regression-release needs-upstream-testing natty kernel-config regression-release needs-upstream-testing
Uname: Linux 2.6.38-1-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 11/05/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.name: 0KY768
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd11/05/2007:svnDellInc.:pnInspiron1520:pvr:rvnDellInc.:rn0KY768:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Inspiron 1520
dmi.sys.vendor: Dell Inc.

Paolo Sammicheli (xdatap1) wrote :
Paolo Sammicheli (xdatap1) wrote :
Paolo Sammicheli (xdatap1) wrote :
tags: added: iso-testing
Colin Watson (cjwatson) on 2011-02-02
affects: casper (Ubuntu) → linux (Ubuntu)
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:

apport-collect 712082

This will help us to find and resolve the problem. Bear in mind that you may need to install the python-launchpadlib package from the universe repository. Thanks in advance!

Changed in linux (Ubuntu):
importance: Undecided → High
status: New → Incomplete

apport information

tags: added: apport-collected kernel-config needs-upstream-testing regression-release
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Hello Brian,

I just uploaded the requested info. While reporting thing with apport-collect I got another kernel issue, maybe related to this kernel panic. The screen changed to terminal and it showed the message you can find at the end of the syslog attached to this report. I used ctrl F7 to come back to graphical console and complete the apport-collect report.

Also, take into consideration that this problem comes up with Desktop i386 Alpha 2 [20110202] and I haven't got it with Alpha 2 [20110201.1]

Changed in linux (Ubuntu Natty):
status: Incomplete → New
Alberto Russo (valix) on 2011-02-03
Changed in linux (Ubuntu Natty):
status: New → Confirmed
Paolo Rotolo (paolorotolo) wrote :

I can confirm this bug in Alpha2 of Natty...

Paolo Rotolo (paolorotolo) wrote :

I had already found this bug in daily relase after Alpha1: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/697631

Joel Pickett (jpickett) wrote :

Yeah, this bug is annoying. Been getting it for about a week and a half. Any sort of workaround or do we just have to wait for a patch? Boots fine in a VM, just not on bare metal.

jolo (joop-loep) wrote :

I also can confirm this bug in Ubuntu Alpha2 of Natty. And I had reported this before https://bugs.launchpad.net/ubuntu/+source/linux/+bug/694993

summary: - Random kernel panic during boot
+ Random kernel panic during boot on a Dell Inspiron 1520
John Bryant (johnmbryant) wrote :

Also occurs on a Toshiba L40-17M

Joel Pickett (jpickett) wrote :

Also occurs on a HP dv6-3006tx

Yachar (yach) wrote :

Also occurs from time to time (less than 1/4) on a selfmade config. See attached lshw output.
The bug occured before alpha 2, using nightlies, using live USB or Virtualbox.

Yachar (yach) wrote :
Paolo Rotolo (paolorotolo) wrote :

Also occurs on Asus F7Se.

Scott Lavender (slavender) wrote :

I have had almost consistent kernel panics during boot, probably four out of five boots results in kernel panic.

It was difficult trying to ascertain when the panic occurred because from the visual cues. Sometimes it would result in text on the screen and sometimes not, but always with a hard locked system and flashing caps/scroll lock. Sometimes it would panic before the grub menu, sometimes directly after the grub menu. Sometimes grub would go to the menu, other times it would skip the menu.

However, I focused on the kernel.

persia suggested that I start with a Maverick install, replace natty for maverick in my /etc/apt/sources.list, and selectively upgrade using aptitude excluding the kernel. Then I could download from Launchpad and install each kernel available for Natty in order to find the offending kernel.

Unfortunately, even excluding the linux kernel update I found that my new Natty install still suffered from kernel panic at the same rate. I attempted updating using aptitude twice with the same results.

For my third attempt I decided to exclude grub packages in addition to the kernel packages. These are the packages that I did NOT update/add to an updated Maverick installation:
 * linux-headers-2.6.38-1
 * linux-headers-2.6.38-1-generic
 * linux-image-2.6.38-1-generic
 * grub-common
 * grub-pc
 * linux-firmware
 * linux-generic
 * linux-headers-generic
 * linux-image-generic

As noted above, everything list was previously excluded from my two hand updates, with the except of the two grub packages, which resulted in continued kernel panics.

After the third update my computer experienced a single panic directly after rebooting from the update but hasn't panicked since. I now have almost ten reboots without problems.

Therefore I wonder if grub could be at least partially responsible for the intermittent kernel panics.

If anyone would like me to attach any logs or reports to this bug report please let me know. I'll keep the machine as is for several days and continue to test the reboots for panic problems.

Herton R. Krzesinski (herton) wrote :

This issue was discussed/reported in linux-hotplug ML too: http://marc.info/?l=linux-hotplug&m=129435174818955&w=2

Herton R. Krzesinski (herton) wrote :

Patch posted by upstream maintainer which handles this issue:
http://marc.info/?l=linux-hotplug&m=129552836031425&q=raw

Herton R. Krzesinski (herton) wrote :

The upstream fix was included on latest update/rebase, in version 2.6.38-2.29
(commit 729a6a3 "libata: set queue DMA alignment to sector size for ATAPI too")

Changed in linux (Ubuntu Natty):
status: Confirmed → Fix Released
Joel Pickett (jpickett) wrote :

Seems to be working fine now, as of Ubuntu daily images dated 18th Feb and later.

To post a comment you must log in.