Ubuntu

Microphone not working on Lenovo Edge 13

Reported by David Henningsson on 2011-01-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
David Henningsson

Bug Description

Microphone not working on Lenovo Edge 13. This bug is for tracking purposes - please do not triage.

Changed in linux (Ubuntu):
status: New → In Progress
assignee: nobody → David Henningsson (diwic)
Andy Whitcroft (apw) wrote :

This bug was fixed in the package linux - 2.6.38-3.30

---------------
linux (2.6.38-3.30) natty; urgency=low

  [ Andy Whitcroft ]

  * rebase to v2.6.38-rc4
  * ppc64 -- add basic architecture
  * ubuntu: AUFS -- update to 65835da20b77c98fb538c9114fc31f5de1328230

  [ Colin Ian King ]

  * SAUCE: Add WMI hotkeys support for Dell All-In-One series
    - LP: #676997
  * SAUCE: Add WMI hotkeys support for another Dell All-In-One series
    - LP: #701530
  * SAUCE: Dell WMI: Use sparse keymaps and tidy up code.
    - LP: #701530

  [ Dan Rosenberg ]

  * SAUCE: (drop after 2.6.38) Convert net %p usage %pK

  [ Kees Cook ]

  * Revert "SAUCE: kernel: make /proc/kallsyms mode 400 to reduce ease of
    attacking"
  * SAUCE: (drop after 2.6.38) use %pK for /proc/kallsyms and /proc/modules

  [ Tim Gardner ]

  * [Config] CONFIG_BLK_CGROUP=y
    - LP: #706394
  * [Config] CONFIG_DELL_WMI_AIO=m

  [ Upstream Kernel Changes ]

  * drm/i915/lvds: Restore dithering on native modes for gen2/3
    - LP: #711568

  [ Upstream Kernel Changes ]

  * rebase from v2.6.38-rc3 to v2.6.38-rc4.
 -- Andy Whitcroft <email address hidden> Tue, 08 Feb 2011 02:07:18 +0000

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Chris Van Hoof (vanhoof) on 2011-02-18
tags: added: hwe-blocker
Mal (mal-gamble) wrote :

I have two Thinkpad Edge 13 notebooks in the family and neither of them have working microphones, even with kernel 2.6.38-8 in Natty.

I tried setting the "model" parameter in snd-hda-intel to all the alternatives that are available and still no luck. When I ran "alsa-info.sh" it indicated that these machines use the Conexant 5066 chip with vendor ID: 17aa:21b3.

I had a look in the kernel source and found a file "sound/pci/hda/patch_conexant.c". This lists the machines that use the 5066 chip, but the only vendor IDs listed for the Edge 13 are 17aa:21c5 and 17aa:21c6. This suggests to me that Lenovo have produced another variant of the Edge 13 that does not work with the fix discussed above.

Maybe this bug should be reopened?

David Henningsson (diwic) wrote :

Mal, you're probably having different hardware than the Edge 13 that we certify. Could you please file a separate bug using "ubuntu-bug audio"? Thanks!

Mal (mal-gamble) wrote :

David, thanks for taking the time to respond. I have filed a bug at https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/789718.
Regards,
Mal

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers