Ubuntu

[Conexant CX20585] Headphone jack doesn't work

Reported by Martin Eve on 2010-11-24
52
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Toshiba Satellite C650D. Headphone Jack has no playback and doesn't mute speaker.

Solution is to add options snd-hda-intel model=ideapad to /etc/modprobe.d/alsa-base.conf

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: alsa-base 1.0.23+dfsg-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-23.40-generic 2.6.35.7
Uname: Linux 2.6.35-23-generic i686
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: martin 2070 F.... pulseaudio
 /dev/snd/pcmC0D0p: martin 2070 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xd2300000 irq 16'
   Mixer name : 'Conexant CX20585'
   Components : 'HDA:14f15069,1179fde4,00100302'
   Controls : 6
   Simple ctrls : 4
Date: Wed Nov 24 10:05:15 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100831.2)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SelectedCard: 0 SB HDA-Intel - HDA ATI SB
SourcePackage: alsa-driver
Symptom: audio
Title: [Conexant CX20585] Playback problem
dmi.bios.date: 05/19/2010
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: 1.40
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: AMD
dmi.chassis.version: None
dmi.modalias: dmi:bvnInsydeCorp.:bvr1.40:bd05/19/2010:svnTOSHIBA:pnSatelliteC650D:pvrPSC16E-01Q007EN:rvnTOSHIBA:rnPortablePC:rvrBaseBoardVersion:cvnAMD:ct10:cvrNone:
dmi.product.name: Satellite C650D
dmi.product.version: PSC16E-01Q007EN
dmi.sys.vendor: TOSHIBA

Martin Eve (martineve) wrote :
Daniel T Chen (crimsun) wrote :

Do playback and capture work completely when you use the model quirk? I.e., do speakers automute when headphones are inserted, and do the mics capture successfully?

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Martin Eve (martineve) wrote :

Hi Daniel,

When using the model quirk the speakers mute and the headphones play. I haven't been able to test Microphone recording.

Martin

Daniel T Chen (crimsun) wrote :

This is already resolved in Natty. Furthermore, you can use a daily build of the sound driver; please see https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules.

affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
canucked (canucked) wrote :

I configured Ubuntu 10.10 Maverick 64-bit on a Toshiba Satellite L655-S5115 laptop with Conexant CX20585 audio for a friend. In addition to the headphone jack not working, the built-in microphone and microphone jack did not work. Upgrading to the alsa daily build did not fix everything. I tried the Natty 64-bit alpha1 and the same problems persist. Using the model=ideapad work-around fixed the headphone jack and built-in mic, but not the microphone jack.

Fortunately, I was able to get all the audio issues fixed by adding "options snd-hda-intel model=thinkpad" to /etc/modprobe.d/alsa-base.conf
http://ubuntuforums.org/showthread.php?t=1641931
http://translate.google.com/translate?hl=en&sl=de&u=http://forum.ubuntuusers.de/post/2698401/

(Apparently someone with an L650 successfully used model=dell-vostro, but I did not confirm this on the L655.)
http://ubuntuforums.org/showthread.php?t=1533015&page=2

I hope this helps!

canucked (canucked) wrote :

I configured Ubuntu 10.10 Maverick 64-bit on a Toshiba Satellite L655-S5115 laptop with Conexant CX20585 audio for a friend. In addition to the headphone jack not working, the built-in microphone and microphone jack did not work. Upgrading to the alsa daily build did not fix everything. I tried the Natty 64-bit alpha1 and the same problems persist. Using the model=ideapad work-around fixed the headphone jack and built-in mic, but not the microphone jack.

Fortunately, I was able to get all the audio issues fixed by adding "options snd-hda-intel model=thinkpad" to /etc/modprobe.d/alsa-base.conf

I also posted this here:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/680844

Klaus (klaus-krtschil) wrote :

My solution was to add

options snd-hda-intel model=ideapad

to alsa-base.conf

I have an Acer TravelMate 8572T with Conexant CX20585.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions