HP / LG blu-ray drive gets softreset failed errors on 64 bit but not 32 bit

Bug #668392 reported by timothymowens on 2010-10-29
98
This bug affects 14 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Dmesg reports the following, and the blue-ray drive attached to that port does not function:

[ 11.810854] ata3: softreset failed (device not ready)
[ 21.820854] ata3: softreset failed (device not ready)
[ 32.430018] ata3: link is slow to respond, please be patient (ready=0)
[ 56.850018] ata3: softreset failed (device not ready)
[ 56.850022] ata3: limiting SATA link speed to 1.5 Gbps
[ 62.080018] ata3: softreset failed (device not ready)
[ 62.080020] ata3: reset failed, giving up

timothymowens (timothymowens) wrote :
Phillip Susi (psusi) wrote :

Rather than paste massive amounts of information into the description, you should attach log files. You mention seeing soft resets failing, but they are not there in the attached dmesg output, I assume because you have the port disabled. Please attach /var/log/dmesg when you boot with the port enabled. Also this has nothing to do with not having a driver; you appear to have a hardware problem.

Changed in linux (Ubuntu):
status: New → Incomplete
summary: - Missing blu-ray drive support causes restart/shutdown problems and
- delays
+ blu-ray drive causes restart/shutdown problems and delays

I apologize, this was the first time I tried to report a bug for Ubuntu. I attached the requested dmesg file.

Phillip Susi (psusi) on 2010-11-02
summary: - blu-ray drive causes restart/shutdown problems and delays
+ blu-ray drive gets softreset failed errors
description: updated

What make and model of drive is this?

timothymowens (timothymowens) wrote :

HP BDDVDRW CH20L. For the record, I tried booting more than one recent Linux distro with the BIOS set to IDE, AHCI, and RAID. The issue occurs with all three scenarios. This drive is SATA and has no jumpers. If you google, "CH20L Linux", you will see this is becoming a growing issue as of late. The issue only occurs with newer Linux x64 kernels it seems. The drive works perfectly in Windows. Any help in getting this blu-ray drive working in Ubuntu 64 bit is greatly appreciated.

Phillip Susi (psusi) wrote :

Have you tried the 10.10 32 bit livecd? Also you want to keep the bios set to ACHI mode or RAID mode, depending on whether you are making use of the fake hardware raid.

Phillip Susi (psusi) wrote :

I had a guess to what the problem might be. It appears that the kernel resets the link at 3 gbps, and retries a few times with longer and longer timeouts for the drive to reset, then reduces the speed to 1.5 gbps and retries only one more time to soft reset it before giving up. I wonder if the drive only is capable of 1.5 gbps and also requires an long time to reset, but my attempt at googling for hps specifications on this drive failed miserably. I hate HP, I hate HP, I hate HP, oh my god I hate HP.

If you can find specifications for this drive it would sure make me feel a little better, and if it turns out that it only supports 1.5 gbps, then I could possibly be on the right track.

timothymowens (timothymowens) wrote :

I will try the 32 bit Ubuntu live disc in the morning and let you know. Yeah, I hate HP also, especially when it comes to finding product specs and information or their response time on firmware updates when they are obviously needed.

timothymowens (timothymowens) wrote :

OK. I can confirm that this issue is related to 64 bit Linux distros only. I tried a few different 32 bit Linux distros via LiveCD, including 32 bit Ubuntu 10.10 and all of them detected the blu-ray drive and started up almost instantly. I checked dmesg on all of them and not one showed the soft reset issue that the 64 bit distros show. What does this mean? Is there a way to incorporate the 32 bit SATA handling in the 64 bit kernels? What's different with the 64 bit handling of SATA vs the 32 bit? I really need the 64 bit OS as I commonly perform tasks that require more than 4GB of RAM, but it would be nice if my blu-ray drive worked as well.

Phillip Susi (psusi) wrote :

That is very strange, there should be no difference between 32 abd 64 bit. Can you test the mainline kernel builds? See https://wiki.ubuntu.com/Kernel/MainlineBuilds.

summary: - blu-ray drive gets softreset failed errors
+ HP blu-ray drive gets softreset failed errors on 64 bit but not 32 bit
Changed in linux (Ubuntu):
status: Incomplete → New

OK. The issue still occurs with v2.6.35.8-maverick. I downloaded the following packages, installed and tested with SATA port 3 enabled:

linux-headers-2.6.35-02063508-generic_2.6.35-02063508.201010291110_amd64.deb 29-Oct-2010 12:20 728K
linux-headers-2.6.35-02063508_2.6.35-02063508.201010291110_all.deb 29-Oct-2010 11:13 9.8M
linux-image-2.6.35-02063508-generic_2.6.35-02063508.201010291110_amd64.deb 29-Oct-2010 12:20 32M

I attached the dmesg log after booting with this kernel.

timothymowens (timothymowens) wrote :

I just attempted booting up kernel 2.6.37-999 as well (daily build Nov. 3rd 2011) using the following packages and SATA port 3 enabled:

linux-image-2.6.37-999-generic_2.6.37-999.201011031118_amd64.deb 03-Nov-2010 12:25 32M
linux-headers-2.6.37-999_2.6.37-999.201011031118_all.deb 03-Nov-2010 11:21 10M
linux-headers-2.6.37-999-generic_2.6.37-999.201011031118_amd64.deb 03-Nov-2010 12:25 777K

(Again, SATA port 3 being the blu-ray drive). Still had soft reset issues. This kernel was different though. X didn't load, so I generated a new dmesg log file from command line and attached it. What I noticed though is that as I was attempting to log in, more soft resets were being performed, even though they failed before and displayed the "giving up" message. Then I see in the dmesg that a hard reset was being performed. The last line states "EH complete". Not sure what that means though. Any thoughts?

timothymowens (timothymowens) wrote :

Apparently, this is not the first time this bug has been reported. Please see the following link:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/285392?comments=all

It seems to be a bug in SATA PMP (Port Multiplier).

timothymowens (timothymowens) wrote :

I attempted to rebuild the amd64 2.6.35 kernel that comes with Maverick with CONFIG_SATA_PMP = n, but I the build failed with errors. I've never compiled a kernel before, so it's very likely I missed something or didn't do something correctly. If someone could build the current amd64 kernel that comes stock with Maverick with CONFIG_SATA_PMP = n and post it, I'd be happy to test.

timothymowens (timothymowens) wrote :

OK. I managed to compile the 2.6.35 kernel following this guide: http://duopetalflower.blogspot.com/2010/10/ubuntu-maverick-64bit-kernel.html I only set CONFIG_SATA_PMP = n and compiled a kernel aptly called 2.6.35-22-nopmp. Yet, it seems that this did not fix the issue. It did provide some different information regarding the softreset issue though; more specifically, note the "COMRESET failed (errno=-16)". I attached the entire dmesg log from booting this custom kernel for reference.

[ 7.244210] ata3: link is slow to respond, please be patient (ready=0)
[ 11.860040] ata3: COMRESET failed (errno=-16)
[ 17.254207] ata3: link is slow to respond, please be patient (ready=0)
[ 21.874210] ata3: COMRESET failed (errno=-16)
[ 27.264210] ata3: link is slow to respond, please be patient (ready=0)
[ 56.930042] ata3: COMRESET failed (errno=-16)
[ 56.930053] ata3: limiting SATA link speed to 1.5 Gbps
[ 61.970044] ata3: COMRESET failed (errno=-16)
[ 61.970053] ata3: reset failed, giving up

I'm out of ideas now. If anyone has any ideas to try, my machine will be your guinea pig.

Phillip Susi (psusi) wrote :

Can you post the dmesg with the working 32bit kernel?

timothymowens (timothymowens) wrote :

Sure. I attached it here. Sorry for the delay in response. I was away from my machine over the weekend. Hope it helps!

timothymowens (timothymowens) wrote :

Just a bump on this bug. I installed the new 2.6.35-23-generic kernel via software update in Ubuntu today and tried the Blu-Ray drive, but still no success. The dmesg is attached.

Jeremy Foshee (jeremyfoshee) wrote :

Hi timothymowens,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
timothymowens (timothymowens) wrote :

I couldn't find the image file for the current build, so I installed and tested the next best thing and attached the dmesg output to this comment. No change in the bug/issue. This kernel took even longer to boot than the others. If you know of the links to the current kernel image and headers that will install in Maverick AMD64, please post the link here and I will test.

Hope this helps. Incidentally, this kernel also breaks my ATI drivers, but I was able to fix this easily myself.

I got the same problem with another drive. It is a LG CH10LS blueray combodrive. I attach my dmesg (but the problem looks the same). I tried the latest mainline kernel. The problem stays the same (but with additional output like also said before). I also will attach this dmesg in the next message.
The drive works fine with Ubuntu 32 bit, Fedora 14 64 bit and Windows 7. Sadly I can't switch to 32 bit because the machine has 8 gb of ram (and i don't like to switch to fedora because all other systems I use are running with Ubuntu).
I hope someone finds soon the problem, because this drive is also in build sugestions for a quiet and fast desktop pc from the german pc magazin c't. (They tested linux compatibility but with Fedora.)

T. Bass (hornito) wrote :

Yes, my problems are continuing (with booting and recognition of LG CH10LS drive), and makes no difference if it's 32 or 64 bit (happens with all Ubuntu 10.10 based distros). The distro is simply not recognizing the LG as a live drive, and then takes forever to boot up while it tries.

One trick I have found though, is that if I put a disk in the LG, and close the door during boot of U-10.10, it will recognize the drive, and work perfectly. Go figure. Once I got the drive recognized, I did all the program updates, and now, more often than not the drive will be recognized, and boot up work correctly. Not perfect, but at least I can use the OS until a bug fix is found, without having to wait though a painfully slow boot up process, and non-recognition of the LG drive. I'll report back later today as I am still working with it.

T. Bass (hornito) wrote :

Note, that the HP BDDVDRW CH20L drive is made by LG, and corresponds with their LG CH10LS20 model drive. Also note, that owners of the LG CH10LS20 drive are having the same problems as owners of the HP BDDVDRW CH20L drive with Ubuntu 10.10 based distros.

T. Bass (hornito) wrote :

UPDATE: As an addendum to my above comment about closing the drive door during boot to make U-10.10 based distros recognize the drive;

I am now able to boot just fine into either 32 bit or 64 bit Ubuntu 10.10 based distros. I am no longer having to keep a disk in the drive, or having to close the drive door during boot, to facilitate drive recognition and proper boot function.

Apparently, booting several times with a disk (I used an DVD movie) in the drive, closing the drive door during boot, and then updating the program, fixes whatever was causing the problem. All now works flawlessly and like it should.

So, until a fix is found for this bug, once again here are the steps you can try that worked for me. Note, that I have a dual boot setup with Win7, but it should work the same for any setup:

1. With computer on and booted, insert a CD or DVD (movie, songs, etc.) into the drive. Reboot computer.

2. As computer is rebooting, and just before the GRUB2 menu appears asking you to select which OS you want, open the CD/DVD drive door. Then, select the Ubuntu 10.10 distro in GRUB2, and hit enter. As you do this, close the CD/DVD drive door. Booting should now proceed normally.

3. Once into the program, check to make sure the drive is recognized and operates properly. If so, proceed to download and install all program updates.

That's all there is to it. I noticed I had to do the above procedure (with the exception of the updating) a couple of times, before all worked properly. I now no longer have to insert a disk, etc., and all works as it should. Yay!

I can confirm, that if you insert a CD or DVD while you boot at the right time the drive works with Ubuntu 64bit. But with more ten tries only three times, the drive only worked three times. It seems my system boots too fast so i have only a short time to insert the disk.
My system is also uptodate. (And I can't think of something that could repair this problem with just boot some times. LG also offers no firmwareupdate or something like this.)
The Fedora Live CD 64bit works out of the box. But in the kernel configuration and in the patches I haven't found anything.

I found the difference between Fedora and Ubuntu. The controller (an AMD 890GX so a SB850 Southbridge) is managed in Fedora by the kernel modul ata_generic in Ubuntu by ahci.
While searching how to switch the module I found, that kernel parameter libata.force.
With "libata.force=5:nohrst" as kernel parameter my drive was working (5 is the ata link of my drive). The drive seems to have problems with the hard reset while booting. I will use this as tempory workaround since the problem is solved.
(You can add kernel parameters in /etc/default/grub in GRUB_CMDLINE_LINUX and calling sudo update-grub2.)
Only one problem for the workaround is left (for me) I have two sata/ide controllers on the motherboard most times the pata_jmicron ist first sometimes ahci, so ata5 is somtimes ata3.

Phillip Susi (psusi) wrote :

I wonder if it is the controller or the drive that is broken, and why the 32bit kernel works? Or did the 32 bit kernel work for you Markus? Also do you have a bios setting for AHCI/IDE Compatibility mode? AFAIK, that setting should allow ata_generic to work, and not ahci, or vice versa.

Phillip Susi (psusi) wrote :

By the way, do you have other drives attached to this controller that work? Is it just the LG optical drive that fails to come up after the hard reset?

the_voice (the-voice-gmx) wrote :

hi,

i have the very same problem with the above mentioned LG drive CH10LS20 only on 64bit ubuntu.
my bios supports ahci/ide setting but neither of the settings make the drive recognized under 64bit.
i also have 2 harddisks connected to the controller which work perfectly on both settings in 32 and 64bit

the kernel parameter marcus mentioned in his post makes the drive get recognized in 64bit.

my mainboard is a: ASUS M4A78 PRO
the onboard sata controller is: ATI Technologies Inc SB700/SB800 SATA Controller

Have similar issues. ASUS notebook, Aspire 4180T, kernel 2.6.35-24-generic (maverick 64bit), optical drive DVDRAM GU10N by HL-DT-ST (at least that's what the device manager says).
The kernel parameter Markus describes doesn't work for me.
What does work is simply putting any disc in to the drive and booting while the disc remains in the drive.
Haven't tried 32 bit distributions yet.

Sorry, sent this too quickly. Update:

If I eject the disc and put in another one, the issues re-appears. So for now I always have to put the disc I want to use in and restart :(

update2:
I changed the bios paremeter EHCI to ATA and now all works fine.

@Philip:
I retried with the 32 bit version, it failed also. It seems for the first tests with the new pc i accidentally fetched not Ubuntu 10.10 32 bit. (I have several live linux versions here. Maybe I fetched one which uses also ata_generic like fedora. I only used the commandline for the first tests.) I'm sorry for the wrong info in the first post.
In the bios i tried all three settings IDE, RAID and AHCI, nothing changed (Ubuntu was also loading the kernel module ahci with all settings.)
Another optical drive a Plextor PX-L890SA was connected to the same controller all the time. It worked all the time (with every setting) perfectly. So it seems to be just the LG drive that fails when it gets the hard reset (i have not other sata controller at hand to test it, the other one in the system has only an internal pata port).
I would guess it is a bug in the drives firmware (that doesn't show up in Windows 7) or (with less probability) it is bug in the ahci kernel module.
Does someone know if ata_generic is hard ressetting the link?

Phillip Susi (psusi) wrote :

ata_generic is the old IDE driver, so it does not know how to issue a SATA hard reset.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: removed: needs-upstream-testing
Matthias Schmidt (mschmidt) wrote :

Can confirm the bug with latest 10.10 64bit and a HL-DT-ST BDDVDRW CH10LS20. Setting libata.force to norst in grub solves the problem. Using 32bit Ubuntu 10.10 also, but thats not an option.

timothymowens (timothymowens) wrote :

I tried the GRUB_CMDLINE_LINUX="libata.force=5:nohrst" in my /etc/default/grub file and rebuilding grub with update-grub2, but saw no change. dmesg still reported the exact same softreset issues. This was with me putting a disc in the drive at boot and having tried under IDE, ACHI and RAID. Still nothing. Wish this was a solution for my issue.

It's frustrating because this CH20L drive works perfectly in Windows 7 64 bit for burning DVD/CD, blu-ray read, etc., just not in 64 bit Linux. I've tried Ubuntu, Fedora, Mint, Mandriva, Sabayon, etc. Nothing. No power to the drive even. Once Ubuntu boots fully, the drive has no power and the button does not eject the tray. It doesn't seem that it's being addressed upstream at all either. I keep trying newer and newer kernel builds and the issue persists. No issues with 32 bit Linux though. Drive works great in 32 bit Ubuntu 10.10 as well as other distros.

Any other suggestions?

timothymowens (timothymowens) wrote :

Nevermind. Please disregard my last comment. Markus Feist, you are AWESOME! It was my fault that your grub mod wasn't working for me as I forgot that on my board, there is no sata-0 and that it starts at 1, once I adjusted, my CH20L blu-ray drive started working and Ubuntu booted just as fast as it did with the drive disabled.

THANK YOU!

Now if only this could be the default action on a clean install in future Ubuntu AMD64 releases...

timothymowens (timothymowens) wrote :

BTW, my SATA controller is set to RAID mode and the grub modifier worked. My blu-ray drive is set on the 3rd port now, so the grub mod I used is:

GRUB_CMDLINE_LINUX="libata.force=3:nohrst"

On my board, the port numbers start with 1 and not 0 like most boards do. I added this line to my /etc/default/grub (actually /etc/default/burg in my case), ran a sudo update-burg (sudo update-grub or sudo update-grub2 if you are not using BURG) and rebooted.

Voila! Markus's magic is working.

Phillip Susi (psusi) wrote :

So it is looking like an incomatability between this particular chipset and drive. Do you have spread spectrum clocking enabled in the bios? If so, try disabling it.

timothymowens (timothymowens) wrote :

Unfortunately, this is a locked-down OEM BIOS. About the only thing I can change is the date.

CPU and PCIE spread spectrum were both turned to auto in my bios. I disabled both.
But the problem (the failing soft-resets) still occurs.

Phillip Susi (psusi) wrote :

It is SATA spread spectrum that is/could be the issue, not other things like the pcie bus.

Something is causing the drive and SATA controller to fail to communicate after a reset.

In my bios there is no setting SATA spread spectrum. Also there is nothing mentioned in documentation about SATA spread spectrum. I also tried to limit the SATA III to 1.5Gbps in the bios. I doesn't helped. After the hard reset the drive is still dead until power down.

0xnate (0xnate) wrote :

I am having the same issue and also have an OEM locked down bios. There is no option to change the spectrum spread. What is 64bit grub/boot process doing differently then 32 bit? The fact that the drive is recognized just fine in 32bit and not 64bit points to a distro issue and not a bios one.

Phillip Susi (psusi) wrote :

Is anyone having issues with this drive NOT using the ATI Technologies Inc SB700/SB800 SATA Controller?

It seems like this is a hardware issue between this particular drive and this particular controller. Does the nohrst workaround NOT resolve the issue for anyone?

Gareth Clay (gareth-clay) wrote :

Hi guys,

I've just unknowlingly bought one of these LG drives and have found the same issue (64-bit Maverick, ATI SB700/SB800 controller). Thanks to this thread I'm up and running with the nohrst workaround. I share Markus's problem with shifting ata numbers though, so it doesn't work on every boot. Since I have no PATA drives I'll take a look at disabling the controller in the BIOS and see if that stabilises the ata link numbering.

Thanks for investigating this - I'll try to help out if I can. It does seem very odd that it works with the 32-bit kernel and not 64-bit.

Hallo Gareth,

one tip. If you load the driver for your PATA controller in /etc/modules it is loaded after the initial boot phase.
(On my motherboard the second controller handles one internal PATA port and one ESATA port.)
It doesn't work with 32 bit kernel on my system. It was a fault, I must have grabed a wrong live cd. This one used ata_generic instead of ahci. Ata_generic doesn't have the problem (because it didn't hard reset any sata link).

Phillip Susi (psusi) wrote :

Does anyone have this drive and NOT the ATI SB700/800? Or maybe can try testing it in a different system that doesn't use that controller? I just got an LG blue ray drive myself and have not had any issues, but I don't have an AMD chipset any more, and I got the WH10LS30 OEM model.

Gareth Clay (gareth-clay) wrote :

Markus, thanks for the tip - I'll give that a try :)

Phillip, just checked the controller in my other box with a view to testing the drive in it, but unfortunately it's an SB700 too.

Hallo,

one interesting find. (Sorry I can't test it with another SATA controller.) I found it in a forum. The ATI sb has 6 sata ports. You can turn all to ide and only port 5 and 6 to ide. I turned to test the ide access all to ide (because i attached the drive to port 4 because of the wiring in my case). Someone in the heise forum had the drive working attached to port 6 and port 5 and 6 turned to ide. So i also tried it.
The drive is than controlled via a module pata_atiixp and worked fine without any other work around.
I will attach my new dmesg with the new setting.
I wouldn't expected any difference between turning all ports to ide and only turning port 5 and 6 to ide, so I haven't tried.
But switching port an turning port 5 and 6 in BIOS to IDE solves also the issue with this drive.
Because both optical drives are running now with ide, but this isn't a problem for me. I would guess with the ide mode the drive will not get a hard-reset and therefor doesn't hang. I can simply turn on AHCI for port 5 and 6 so i will test again with every new kernel version or suggested patch.

Jon Farz (jfarza1) wrote :

Mine can be seen in BIOS after a shutdown and startup but if only restarted linux doesnt detect it even in BIOS so i think this also has to do with this bug

Alecks Gates (alecks-g) wrote :

I was having this problem with both 32-bit and 64-bit linux kernels, and just now I recompiled a 64-bit kernel with "CONFIG_SATA_PMP=n" as suggested earlier and that fixed it for me.

I have an LG UH10LS20, which is likely very similar to what many of you have.
My south bridge is an AMD SB850 (on an M4A88TD-M/USB3 motherboard).

It's such a huge relief to finally have it fixed. Prior to this I would have to completely shut off the system and unplug the power cable in order to get it to work again. It was to the point where I couldn't install linux from a CD/DVD because, after booting up into the installation process, it wouldn't be able to find the drive.

Kimiko Koopman (kimiko) on 2011-05-26
summary: - HP blu-ray drive gets softreset failed errors on 64 bit but not 32 bit
+ HP / LG blu-ray drive gets softreset failed errors on 64 bit but not 32
+ bit
Kimiko Koopman (kimiko) wrote :

I also have an ASUS M4A88TD-M EVO motherboard (AMD SB800) and LG CH10LS20 bluray drive combination. Booting Ubuntu (Maverick) is very slow due to the "softreset failed" errors. They cause the drive to lock up so hard that (after a warm reboot) even the BIOS doesn't detect it anymore and the tray won't open or close. Only a cold reboot remedies that.

The suggested fix of adding "libata.force=#:nohrst" to the boot options worked for me too. The drive is now detected and working properly.

I've edited the bug's title to make it easier for LG owners to find it.

On 5/26/2011 5:31 PM, Kimiko Koopman wrote:
> I also have an ASUS M4A88TD-M EVO motherboard (AMD SB800) and LG
> CH10LS20 bluray drive combination. Booting Ubuntu (Maverick) is very
> slow due to the "softreset failed" errors. They cause the drive to lock
> up so hard that (after a warm reboot) even the BIOS doesn't detect it
> anymore and the tray won't open or close. Only a cold reboot remedies
> that.

This supports my theory that the drive is just badly broken after the
hard reset. Do others find this to be the case as well?

timothymowens, thank you for reporting this and helping make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you report on the results following https://help.ubuntu.com/community/DebuggingIRQProblems ? As well, can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-upstream-testing
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.